16:19:03 <dims> #startmeeting oslo
16:19:04 <openstack> Meeting started Mon Sep 14 16:19:03 2015 UTC and is due to finish in 60 minutes.  The chair is dims. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:19:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:19:08 <openstack> The meeting name has been set to 'oslo'
16:19:16 <dims> anyone still here? :)
16:19:18 <dims> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dougwig, e0ne, flaper87, garyk, harlowja, haypo,
16:19:18 <rpodolyaka1> o/
16:19:18 <dims> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka,
16:19:18 <dims> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:19:20 <ozamiatin> o/
16:19:20 <harlowja_at_home> supppp
16:19:22 <dhellmann> o/
16:19:25 <amrith> ./
16:19:28 <kgiusti> o/
16:19:29 <johnsom> o/
16:19:37 <bknudson> hi
16:19:42 <dims> #topic Releases for Liberty
16:19:44 <jecarey> o/
16:19:58 <kzaitsev_mb> o/
16:20:01 <dims> stable/liberty branches are cut for all oslo projects. yay
16:20:10 <rpodolyaka1> \o/
16:20:24 <dims> so go on and +2/+A things in review please
16:20:39 <harlowja_at_home> yaaa
16:20:42 <harlowja_at_home> cool
16:20:54 <dims> if we need something from master to stable/liberty, please ping me
16:21:00 <dims> #topic Red flags for/from liaisons
16:21:15 <dims> any liaisons still around? :)
16:21:22 <amrith> yes and nothing to report.
16:21:33 <amrith> the gate ...
16:21:34 <bknudson> nothing for keystone.
16:21:35 <toabctl> hi
16:21:42 <dims> we've been only doing g-r and translations for some time now...so hoping all's well
16:21:57 <dims> thanks amrith bknudson
16:22:23 <jungleboyj1> Sorry, I am kind-of here.
16:22:29 <dims> hi jungleboyj1
16:22:30 <jungleboyj1> No red flags from Cinder.
16:22:43 <dims> thanks!
16:22:43 <jungleboyj1> We are just in bug fix mode now.
16:23:11 <jungleboyj1> Thank you dims... Sorry for being distracted tdoday.
16:23:41 <harlowja_at_home> fix all the bugs!
16:23:42 <dims> no worries jungleboyj1, i reached here late as well
16:23:50 <dims> #topic virtual doc sprint
16:24:01 <dims> totally got the timing wrong on the sprint
16:24:16 <dims> does anyone have time next thu and friday?
16:24:24 <harlowja_at_home> me
16:24:43 <harlowja_at_home> next thu, not this one right?
16:24:44 <dims> 24 and 25th sept
16:24:46 <harlowja_at_home> k
16:24:47 <dims> y
16:25:09 <bknudson> I've got nothing going on next week.
16:25:18 <dims> bknudson: awesome
16:25:19 <dims> :)
16:25:33 <bknudson> and the gate is definitely not going to be broken
16:25:37 <dims> right
16:25:50 <jecarey> I can help
16:25:55 <harlowja_at_home> the gate is never broken, idk what u guys are talking about
16:25:58 <harlowja_at_home> lol
16:26:09 <dims> jecarey: awesome, do you want to coordinate?
16:26:53 <bknudson> someone needs to supply chips and dip.
16:27:09 <jecarey> sure ... do we have specific libraries we want to focus on?
16:27:10 * dims volunteers for chips and dip
16:27:17 <harlowja_at_home> virtual chips and dip?
16:27:54 <dims> jecarey: don't know yet, we can use the etherpad to figure out
16:27:57 <dims> #link https://etherpad.openstack.org/p/oslo-liberty-virtual-doc-sprint
16:28:26 <dims> jecarey: need to send an email out with the date too
16:28:59 <dims> #topic bugs, bugs, bugs
16:29:14 <dims> have to ask, do we have things we really need for liberty?
16:29:33 <dims> i saw some oslo.db stuff for logging tracebacks
16:29:37 <dims> in review
16:29:45 <harlowja_at_home> https://review.openstack.org/#/c/221606/ would be sorta nice, idk
16:29:50 <dims> there was a review for hiding tokens in logging
16:29:51 <harlowja_at_home> but idk if its 'really need'
16:29:55 <dims> right
16:30:07 <dims> not doing sorta-nice :)
16:30:12 <harlowja_at_home> :-P
16:30:48 <rpodolyaka1> dims:  I missed the oslo.db one, will take a look
16:31:02 <dims> #action jecarey to send out email for virtual sprint :)
16:31:11 <dims> ok jecarey? :)
16:31:28 <dims> thanks rpodolyaka1
16:31:33 <jecarey> yes
16:31:56 <dims> #topic Summit planning
16:32:17 <dims> harlowja_at_home: can you take point on this please? https://etherpad.openstack.org/p/mitaka-oslo-summit-planning
16:32:34 <dims> what new libraries we need? drivers?
16:32:36 <harlowja_at_home> sureeee
16:32:50 <dims> i saw a blueprint for kafka with oslo.messaging for example
16:32:54 <harlowja_at_home> right
16:33:04 <harlowja_at_home> kafka def requires a session i  think
16:33:08 <dims> we'll need a blueprint to nuke oslo-incubator
16:33:35 <dims> rpodolyaka1: any new stuff in oslo.db?
16:33:57 <dims> amrith: kzaitsev_mb: any new fun stuff we can do in oslo?
16:34:22 <amrith> dims, none that I have right now from the trove team
16:34:37 <ozamiatin> dims: I've filed one https://blueprints.launchpad.net/oslo.messaging/+spec/messaging-api-ext but spec is in progress
16:34:39 <amrith> we're looking into encryption of amqp traffic with o.m
16:34:40 <dims> oh, over the weekend found this fun looking middlware thingy - https://github.com/racker/eom/pulse
16:34:46 <amrith> haven't enabled that by default yet
16:34:55 <amrith> but are trying to make sure those things all work as expected.
16:35:05 <amrith> you may get some requests out of that.
16:35:09 <dims> amrith: transport level or payload level amrith?
16:35:12 <rpodolyaka1> dims: probably just additional work based on the EngineFacade merged in Liberty (like automatic retries on deadlocks, etc)
16:35:19 <dims> ozamiatin: cool
16:35:25 <rpodolyaka1> dims: not sure it's big enough to have a bp/spec
16:35:55 <amrith> dims, transport level.
16:35:56 * rpodolyaka1 needs to a write a blog post to 'advertise' EngineFacade
16:36:10 <dims> kgiusti: johnsom: bknudson: anything you can think ok?
16:36:14 <dims> rpodolyaka1: ++
16:36:39 <dims> rpodolyaka1: reminds me, haven't seen zzzeeek in a while
16:36:39 <johnsom> I don't have anything
16:36:41 <harlowja_at_home> amrith, i added something to https://etherpad.openstack.org/p/mitaka-oslo-summit-planning (it'd be really nice to finally get something going/finished for trusted messaging stuff in o.m)
16:36:42 <bknudson> are you running bandit?
16:37:00 <harlowja_at_home> amrith,  maybe at summit we can really figure that out (finally)
16:37:10 <bknudson> could talk about obfuscating / encrypting config options
16:37:30 <amrith> harlowja_at_home, sure
16:37:31 <bknudson> also could talk about supporting replacements
16:37:36 <rpodolyaka1> dims: yeah, me neither, he must have been busy working on something else
16:38:00 <dims> harlowja_at_home: the privsep spec will need a session
16:38:03 <dims> rpodolyaka1: ack
16:38:11 <harlowja_at_home> dims, def
16:38:23 <dims> bknudson: ++ to safe password storage
16:39:03 <johnsom> Yeah, I like that one
16:39:12 <dims> bknudson: need a session to advertize the new oslo.policy stuff?
16:39:16 <harlowja_at_home> bknudson, ok i added '* safe config password storage (aka, the whattt my passwords are in clear-text, woah), keeping somethings in a vault... (or better name)'
16:39:23 <harlowja_at_home> feel free to rename, seems like a useful session
16:39:51 <bknudson> dims: I'm sure there will be a keystone session on policy (aka dynamic policies)
16:39:58 <dims> big ticket...is there anything we can do to help python3 adoption?
16:40:03 <dims> bknudson: ++
16:40:26 * dims invokes haypo
16:41:31 <dims> ozamiatin: you need one session for zmq right?
16:41:45 <ozamiatin> dims: right
16:41:58 <dims> ozamiatin: please update https://etherpad.openstack.org/p/mitaka-oslo-summit-planning
16:42:13 <ozamiatin> dims: ok, will do
16:42:18 <dims> thanks
16:42:58 <amrith> sorry, tuned out for a second reading what bandit was. Why is OSLO storing passwords? is this something new?
16:43:14 <dims> amrith: oslo.config files have passwords right now
16:43:21 <amrith> yes
16:43:34 <harlowja_at_home> i don't think oslo is, oslo.config is (sadly imho) and it'd be nicer to have some kind of let's call it oslo.config.vault or something
16:43:38 <dims> we need to figure out how to take them out of there
16:43:39 <amrith> and the passwords are easy to read now ;)
16:43:49 <dims> exactly :)
16:43:50 <amrith> isn't that something to push into barbican?
16:43:55 <harlowja_at_home> something like a oslo.config.vault would fix that (maybe?)
16:44:02 <dhellmann> harlowja_at_home: if we put them in a vault, where would we store the pass phrase to open the vault?
16:44:12 * amrith runs off to look at oslo.config.vault
16:44:22 <dims> amrith: there isn't one :)
16:44:23 <dhellmann> amrith: if we put them in barbican, where do we put the credentials to get into barbican?
16:44:24 <harlowja_at_home> :-P
16:44:30 <dims> haha
16:45:06 <dims> what do other frameworks, services do for their passwords is a better leading question i think
16:45:08 <harlowja_at_home> so knowing what yahoo has done for this, i believe there is an easily rotatable key that is used to get into the 'vault'
16:45:24 <harlowja_at_home> but i can try to find people to comment on the yahoo internal solution for just this problem..
16:45:51 <dhellmann> harlowja_at_home: that would be good
16:45:55 <harlowja_at_home> def
16:45:58 <dims> dhellmann: i was asking before, is there anything in oslo we can do around python3 to help other projects
16:46:09 <dhellmann> dims: sorry, distracted by release work today
16:46:16 <dims> no worries dhellmann
16:46:32 <dhellmann> I'm not sure there's anything in oslo to do, but if someone wanted to take over my devstack patch next cycle that might be useful
16:46:40 <dhellmann> https://review.openstack.org/181165
16:46:51 <dhellmann> I'm going to try again, but time...
16:47:04 <dims> dhellmann: ack. i can take that over
16:47:11 <amrith> dhellmann, this is a catch-22
16:47:58 <dhellmann> amrith: right. We've always viewed oslo.config as the lowest-level for managing this sort of info.
16:48:33 <dhellmann> it's the same reason we don't create a service for distributing oslo.config content instead of using files -- we would need a config file to tell an app where to talk to the config service
16:48:55 <bknudson> there's already services for distributing config files
16:49:03 <dhellmann> right
16:49:40 <dhellmann> from time to time we get folks suggesting that oslo.config accept a URL instead of a filename, so it can hit a remote service. But how do you tell an app what the URL is?
16:50:40 * dims peeks at openstack-specs to see if there's things we can do from there - https://review.openstack.org/#/q/status:open+project:openstack/openstack-specs,n,z
16:50:42 <harlowja_at_home> metaconfig :-P
16:50:46 <harlowja_at_home> oslo.metaconfig, ha
16:50:59 <dhellmann> I'm not saying it's a bad idea, just that none of the solutions proposed so far have made things "simpler" in any appreciable way.
16:51:30 <dims> "asynchronous user event support to OpenStack"
16:52:36 <dims> quota's - everyone needs them and everyone has something right now
16:53:14 <dhellmann> dims: the conclusion we reached on a centralized quota thing was it needed to be a service, since it needs a database schema
16:53:17 <harlowja_at_home> dims, i agree to that, i have some coworkers working on that, i'm not sure about oslo.quotas yet
16:53:30 <harlowja_at_home> oslo.quotas or something maybe someday
16:53:35 <bknudson> that service is not keystone
16:53:38 <dhellmann> I can't remember if that was paris or vancouver where that discussion happened
16:53:40 <harlowja_at_home> could be useful to brainstorm though, idk
16:53:41 <dims> looks like amrith had to drop off, i remember he was talking about hiding things in nova that are started by trove from end user
16:53:50 <dhellmann> no, there's an existing thing that starts with B that needs to be fixed up and hardened, I think
16:54:09 <harlowja_at_home> boson, meh, idk
16:54:27 <dhellmann> harlowja_at_home: yeah, that's the one
16:54:44 <dhellmann> I haven't looked at the code or anything, so I don't know if it's what we'd want or if we'd want to build something else
16:55:02 <harlowja_at_home> to me quotas really require a much larger initiative across all projects to get fully resolved, folks i know are working on pieces of it, but ya, time, people, cross-projects need to all really agree...
16:55:24 <dhellmann> right
16:55:29 <harlowja_at_home> so i'm really thinking, ummm, maybe in a couple of years, idk
16:55:47 <dims> k that's all the ideas i had in my head :)
16:55:54 <harlowja_at_home> unless some TC group wants to help out really push this :-P
16:55:58 <dhellmann> dims: it would be interesting to see if there's some work in the WSGI app level that could be pulled into oslo. Some of the flask/pecan setup stuff, for example.
16:56:16 <dims> dhellmann: interesting
16:56:51 <dhellmann> dims: an oslo.rest lib maybe? with different parts for a flask app and a pecan app
16:56:57 <dims> dhellmann: there was something that the docs group (annegentle) was trying/thinking in terms of documenting services as well
16:57:02 <dims> related to that
16:57:10 <bknudson> let's spend the time getting stuff done
16:57:22 <dhellmann> yeah, I've had pretty good luck with adding sphinxext modules to a couple of libraries for doc work
16:57:44 <dims> k. we can talk more next meeting
16:57:50 <dims> i have one more topic
16:57:57 <dhellmann> bknudson: ++ -- it would be good to work on the lib docs, if we don't sprint before then
16:58:06 <dims> #topic next ptl
16:58:08 <bknudson> we're sprinting next week
16:58:11 * dhellmann realizes ++ with -- is confusing
16:58:13 <dhellmann> oh!
16:58:22 <harlowja_at_home> bknudson, for quotas, i think its getting stuff done + a crap-ton of getting projects to agree, both need to happen (and probably at the same time)
16:58:24 * dhellmann checks his calendar
16:58:27 <dims> dhellmann: y picked next thu/fri
16:58:44 <dhellmann> ++
16:59:58 <dims> so, i have fuel in the tank for one more round (M) as ptl. but would be great to see a vote so would encourage anyone else who wishes to run as well
17:00:15 <harlowja_at_home> so are u half full or half empty?
17:00:16 <harlowja_at_home> lol
17:00:25 <dims> i believe we have this week to file nominations
17:00:28 <dims> harlowja_at_home: haha
17:00:33 <dhellmann> it would also be good for anyone who thinks they want to do it to shadow dims this cycle (assuming he is re-elected) to learn the ropes
17:00:34 <dims> harlowja_at_home: half full
17:00:39 <dims> 1000++
17:00:59 <dims> so please think about it
17:01:10 <dims> almost out of time
17:01:33 <dims> thanks everyone. talk to you next week. apologies for the delayed start
17:01:49 <dims> #endmeeting