16:00:06 <harlowja_at_home> #startmeeting oslo
16:00:07 <openstack> Meeting started Mon Sep 21 16:00:06 2015 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <openstack> The meeting name has been set to 'oslo'
16:00:14 <harlowja_at_home> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dougwig, e0ne, flaper87, garyk, dims, haypo,
16:00:17 <harlowja_at_home> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka,
16:00:20 <harlowja_at_home> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:00:21 <ozamiatin> o/
16:00:22 <e0ne> hi
16:00:22 <johnsom> o/
16:00:23 <bknudson> hi
16:00:24 <kzaitsev_mb> o/
16:00:24 <dims__> o/
16:00:25 <harlowja_at_home> yo yo
16:00:25 <zzzeek> o/
16:00:26 <jecarey> o/
16:00:27 <kgiusti> o/
16:00:39 <bknudson> looks like there's been a coup already.
16:00:44 <sileht> o/
16:00:45 <harlowja_at_home> so your previous meeting host, dims__ will be busy today, i have taken his spot (not his body)
16:00:48 <harlowja_at_home> haha
16:01:30 <harlowja_at_home> let's get the show on the road!
16:01:31 <harlowja_at_home> #topic Action items from last week
16:01:32 <harlowja_at_home> sooo
16:01:40 <harlowja_at_home> http://eavesdrop.openstack.org/meetings/oslo/2015/oslo.2015-09-14-16.19.html
16:01:44 <harlowja_at_home> #link http://eavesdrop.openstack.org/meetings/oslo/2015/oslo.2015-09-14-16.19.html
16:01:55 <harlowja_at_home> so i think the virtual sprint email was done
16:02:03 <harlowja_at_home> #link https://etherpad.openstack.org/p/oslo-liberty-virtual-doc-sprint
16:02:18 <harlowja_at_home> jecarey, good to go right?
16:02:31 <harlowja_at_home> 'Kick-off:14:00 UTC on Sept 24th' (from etherpad)
16:02:37 <jecarey> harlowja_at_home, yes ... though due to a family thing, I can't participate anymore.
16:03:09 <harlowja_at_home> okies, we will have a honorary kickoff in your name then, someone else can kick i suppose?
16:03:17 * harlowja_at_home does not do so well at kicking (balls or other)
16:04:19 <harlowja_at_home> anyways, we'll make it work (kick or not)
16:04:23 <jungleboyj> o/
16:04:52 <harlowja_at_home> #topic Red flags for/from liaisons
16:05:04 <harlowja_at_home> any red flags that anyones seeing?
16:05:12 <bknudson> nothing for keystone
16:05:17 <jungleboyj> noting for Cinder.
16:05:22 <jungleboyj> *nothing
16:05:37 <johnsom> Nothing on the Octavia front
16:05:50 <harlowja_at_home> good good
16:07:03 <harlowja_at_home> #topic Specs specs specs
16:07:23 <harlowja_at_home> soo we have a few specs that are nearly ready to get merged, just wanted to see if anyone has any issues with them (or other)
16:07:31 <dhellmann> o/
16:07:41 <harlowja_at_home> https://review.openstack.org/#/c/204073/ (new privsep work)
16:07:54 <harlowja_at_home> seems like people are eager(?) to get that one going
16:08:16 <harlowja_at_home> i've requested a y! security folk also look at it (but doesn't seem like that has happened yet)
16:08:37 <harlowja_at_home> anyone else that wants to look that one over, please do
16:09:06 <harlowja_at_home> it seems to be about a micron away from merging, so this week it will probably move that far
16:09:47 <bknudson> this is proposing a library or server?
16:09:54 * bknudson wonders why this isn't part of OSSG
16:10:26 <harlowja_at_home> gus, yt (pretty sure this is the right gus)
16:11:26 <harlowja_at_home> bknudson, +1 to it being connected into  OSSG
16:11:33 <bnemec> I believe this is actually what OSSG wanted us to do in the first place.
16:11:40 <dims__> ++ bnemec
16:11:41 <dhellmann> bknudson: privsep is a new feature in rootwrap, is that not made clear in the spec? (I haven't read it)
16:11:51 <bnemec> I don't like my odds of finding the ML post where they said that though. :-)
16:12:07 <bknudson> I haven't read the spec.
16:12:35 <bknudson> I know this was discussed by the OSSG and we came up with the same solution
16:12:38 <dhellmann> this is the thing we discussed in vancouver
16:12:55 <bknudson> now I'm wondering why this work is proposed to oslo program and not ossg program
16:13:02 <bknudson> although if oslo owns rootwrap that makes sense
16:13:06 <dhellmann> because the code is going into rootwrap -- right
16:13:20 <dims__> and a eventual replacement for rootwrap
16:13:40 <bknudson> I noticed that changing rootwrap is kind of a mess, since nova doesn't actually use "just rootwrap"
16:13:47 <bknudson> you can also configure nova to not use rootwrap
16:14:35 <bknudson> maybe switching to privsep can clean that up too.
16:14:48 <bknudson> (as in, always use privsep rather than rootwrap/direct commands)
16:14:57 <harlowja_at_home> ya, i hope that's how this works out :)
16:15:56 <harlowja_at_home> so that's spec #1 thats about to go in, please check it out before it merges (soon)
16:16:24 <bknudson> I don't see in the spec an obvious place where it says this is part of rootwrap
16:17:14 <harlowja_at_home> spec #2 behind door #2 is https://review.openstack.org/#/c/219468/
16:17:14 <harlowja_at_home> 'Spec for pbr changes for pip'
16:17:14 <harlowja_at_home> this one should get pbr a wider audience and help overall (afaik)
16:17:14 <harlowja_at_home> making pbr and pip more BFF
16:18:10 <dhellmann> bknudson: I didn't either, and it would be good to clarify that. now that I think of it, we also discussed making this a brand new library
16:18:31 <bknudson> if it's a new library why not put it in ossg
16:18:52 <dhellmann> dunno
16:18:56 * harlowja_at_home has no objections to this, if its the best thing to do :)
16:19:06 <harlowja_at_home> or we can transfer ownership as needed...
16:21:13 <harlowja_at_home> #action harlowja_at_home start a ML email thread about privsep and ossg and repo/code ownership
16:21:22 <harlowja_at_home> i'll start something on that, it seems like an ok question imho
16:21:31 <harlowja_at_home> and one that i'm not sure the answer to :-P
16:22:01 <harlowja_at_home> sound ok to folks?
16:22:30 <bknudson> you can ask gus if he's willing to do it first
16:22:33 <harlowja_at_home> k
16:22:37 <harlowja_at_home> will do
16:23:15 <harlowja_at_home> any other specs folks want to bring up that need some attention
16:23:17 <harlowja_at_home> https://review.openstack.org/#/q/project:openstack/oslo-specs,n,z
16:24:21 <harlowja_at_home> #topic Summit planning
16:24:26 <harlowja_at_home> alright, onto the next bigger topic
16:24:36 <harlowja_at_home> mitaka is fastly approaching
16:24:52 <harlowja_at_home> and https://etherpad.openstack.org/p/mitaka-oslo-summit-planning is fastly forming
16:24:59 <bknudson> how many slots does oslo have?
16:25:10 <harlowja_at_home> dims__, you have any idea on ^ ?
16:25:40 <dims__> bknudson: we haven't been told yet
16:26:04 <harlowja_at_home> that's probably decided soon right?
16:26:26 <harlowja_at_home> i say take over all the slots, lol
16:26:29 <harlowja_at_home> :-P
16:26:55 <bknudson> let's make this the "oslo summit"
16:27:12 <harlowja_at_home> or maybe wait a little for the 'O' summit
16:27:18 <harlowja_at_home> which will be in oslo, lol
16:27:29 <harlowja_at_home> anndd that one will def be all oslo, all the time
16:27:44 * harlowja_at_home can not confirm any of the above ^
16:28:19 <harlowja_at_home> anyway, please add ideas, drivers, interested to https://etherpad.openstack.org/p/mitaka-oslo-summit-planning
16:28:31 <harlowja_at_home> anything and everything accepted (ideas, people, drivers...)
16:28:36 <bknudson> oslo is taking over everything, e.g., "Policy, roles, and finally killing Bug 968696" was a keystone session last time.
16:28:37 <openstack> bug 968696 in OpenStack Compute (nova) ""admin"-ness not properly scoped" [High,Confirmed] https://launchpad.net/bugs/968696
16:29:07 <bknudson> "finally pulling off encryption with oslo.messaging (trusted messaging?), how to get from 0 to 60 (aka, how to make it happen)" -- was also done in keystone for a while
16:29:19 <harlowja_at_home> :)
16:29:32 <harlowja_at_home> if it doesn't work, we'll pass it back to keystone
16:29:33 <harlowja_at_home> the cycle of life, lol
16:30:05 <harlowja_at_home> *circle of life
16:30:12 <harlowja_at_home> https://i.ytimg.com/vi/8zLx_JtcQVI/maxresdefault.jpg (or other circle of life reference)
16:30:12 <harlowja_at_home> lol
16:30:21 <harlowja_at_home> ^ keystone and oslo (all happy)
16:30:47 <bknudson> I thought circle of life was when the lion ate the monkey
16:30:52 <harlowja_at_home> lol
16:30:55 <harlowja_at_home> that is the other circle
16:31:10 <harlowja_at_home> they didn't show those scenes in the movi
16:32:22 <harlowja_at_home> i know there are a few other things that could be talked about for taskflow, and possibly a few other libraries, so i'll poke some folks on that
16:32:34 <harlowja_at_home> and get those ideas listed on there
16:32:55 <harlowja_at_home> #action harlowja_at_home poke folks for taskflow and automaton ideas to get on etherpad for mitaka
16:33:39 <harlowja_at_home> #topic Open discussion
16:33:52 <harlowja_at_home> anything else folks want to chit-chat about?
16:34:02 <harlowja_at_home> vote as well!
16:34:12 <harlowja_at_home> dims__, or me, you decide the future
16:34:27 * harlowja_at_home will not build a wall around mexico this time
16:34:35 <bknudson> canada?
16:34:44 <harlowja_at_home> maybe canada, to much maple syrup
16:35:37 * harlowja_at_home hasn't had maple syrup in a while, mmm
16:36:36 <harlowja_at_home> okie dokie then, speak now or forever hold your peace
16:36:44 <harlowja_at_home> *where forever == until next week
16:37:47 <harlowja_at_home> exit stage left, lol
16:37:55 <harlowja_at_home> thx for showing up folks
16:37:58 <jungleboyj> :-)  Later.
16:38:02 <harlowja_at_home> #endmeeting