16:00:21 <harlowja_at_home> #startmeeting oslo
16:00:21 <openstack> Meeting started Mon Nov 23 16:00:21 2015 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:24 <openstack> The meeting name has been set to 'oslo'
16:00:33 <harlowja_at_home> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims, dougwig, e0ne, flaper87, garyk, haypo,
16:00:33 <harlowja_at_home> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka, spamaps
16:00:33 <harlowja_at_home> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek, gcb
16:00:35 <rpodolyaka> o/
16:00:36 <bogdando> o/
16:00:38 <harlowja_at_home> yo yo all
16:00:39 <e0ne> hi!
16:00:39 <gcb> o/
16:00:40 <ozamiatin> o/
16:00:40 <bknudson> hi
16:00:41 <sileht> o/
16:00:44 <harlowja_at_home> i will be your pilot for today :-P
16:00:48 <dhellmann> o/
16:00:48 <toabctl> hi
16:00:54 <harlowja_at_home> dims is afaik out busy
16:00:58 <stevemar> i'll tune in this week!
16:01:22 <harlowja_at_home> stevemar, thanks, i will play your top 10 requests at the end of the show, ha
16:01:24 <kgiusti> o/
16:01:52 <haypo> hi
16:01:55 <stevemar> harlowja_at_home: give me anything from dims' greatest hits
16:02:03 <harlowja_at_home> stevemar, lol, def
16:02:11 <harlowja_at_home> soooo let's get started with the awesomeness
16:02:17 <harlowja_at_home> #topic Red flags for/from liaisons
16:02:33 <bknudson> nothing from keystone that I know of
16:02:50 <bknudson> I guess we'll have to change the libs to drop support for py26
16:02:54 <harlowja_at_home> :-P
16:03:01 <harlowja_at_home> drop py26 from all the things, ha
16:03:18 <haypo> is it ok to drop python 2.6 support from stevedore or not?
16:03:28 <harlowja_at_home> dhellmann, ^ any thoughts on that?
16:03:40 <dhellmann> if we're not going to have a way to test it, then I think it's ok
16:03:58 <ihrachys> we had liberty neutron broken by some internal renames in oslo.messaging
16:04:00 <dhellmann> do we have someone who wants to maintain it?
16:04:03 <harlowja_at_home> haypo dhellmann , let's wait for further discussion actually i got a topic for that
16:04:18 <ihrachys> there was a backport: https://review.openstack.org/#/c/247276/ but it's abandoned and I assume it will be (is?) fixed oslo.messaging side.
16:04:19 <dhellmann> ihrachys : were they private symbols?
16:04:22 <haypo> harlowja_at_home: ok
16:04:24 <ihrachys> dhellmann: yes
16:04:32 <harlowja_at_home> haypo, thx
16:04:35 <dhellmann> harlowja_at_home : ack
16:04:42 <ihrachys> dhellmann: since in liberty gate we don't rely on constraints, it broke.
16:05:19 <dhellmann> ihrachys : I'm not sure why this would be fixed "on the oslo.messaging side"? do you mean with a requirements change in the liberty branch?
16:05:44 <ihrachys> dhellmann: not sure but I quote comment in the backport "We're going to create an alias to the old name in oslo.messaging and release that, then blacklist oslo.messaging 2.6.0->the release that has the alias in stable/liberty g-r."
16:06:12 <dhellmann> ok, I guess mriedeman and dims worked that out
16:06:20 <ihrachys> dhellmann: I believe the best path would be applying constraints. if not, fixing neutron. if not, oslo.messaging. Not sure why we start in reverse order
16:06:52 <dhellmann> ihrachys : the constraints work is going to take a lot of time, I think. I agree it might have been faster to fix neutron.
16:07:04 <dhellmann> ihrachys : and I hope someone is fixing the master branch of neutron
16:07:07 <ihrachys> dhellmann: actually the patch to enable constraints for neutron in L is up for review
16:07:14 <ihrachys> dhellmann: master is fixed, yes
16:08:03 <harlowja_at_home> is it just a fix in neutron to not use a private symbol of oslo.messaging?
16:08:05 <dhellmann> good
16:08:35 <dhellmann> harlowja_at_home : yeah, although in the stable branch it becomes a question of what name *should* be used because different versions of the lib have that private symbol in different places
16:09:02 <ihrachys> harlowja_at_home: not really: https://review.openstack.org/#/c/247276/1/setup.cfg
16:09:10 <dhellmann> ihrachys : those old names in neutron's setup.cfg should be deprecated and removed asap
16:09:20 <ihrachys> dhellmann: ack
16:09:30 <ihrachys> I will put up a deprecation patch for M
16:09:38 <dhellmann> ihrachys : ty
16:09:39 <ihrachys> we won't be able to drop before N
16:09:46 <dhellmann> right
16:09:57 <harlowja_at_home> dhellmann, ihrachys thx, i get it now i think
16:10:25 <ihrachys> should have been dropped a lot earlier, mea culpa
16:10:38 <dhellmann> yeah, we should probably audit all the projects for these old names
16:11:11 <ihrachys> dhellmann: yeah, I once copied that from glance
16:11:39 * harlowja_at_home just thinking but could https://github.com/openstack/debtcollector/blob/master/debtcollector/moves.py#L111 or other of its moved API(s) be used here...
16:11:51 <harlowja_at_home> * in oslo.messaging
16:12:30 <ihrachys> nothing more from my side, sorry for taking too much time on that one
16:12:52 <harlowja_at_home> np ihrachys
16:13:35 <harlowja_at_home> any other red flags from folks?
16:13:41 <harlowja_at_home> yellow flags are ok to
16:14:08 <harlowja_at_home> ok, assuming not :-P
16:14:11 <harlowja_at_home> #topic Releases for Mitaka
16:14:12 * haypo only has white flags
16:14:25 <harlowja_at_home> haypo, u should order some red or yellow flags from amazon, lol
16:14:30 <haypo> ;)
16:14:47 <harlowja_at_home> sooo https://review.openstack.org/#/c/248391/ is out from dims
16:14:58 <harlowja_at_home> 'All Libraries that have dropped py2.6 support have had a major version bump specified.'
16:15:16 <harlowja_at_home> ^ so please check that out
16:15:21 <harlowja_at_home> there are alot of releases in it :)
16:15:39 <haypo> harlowja_at_home: it's huge. is there an etherpad with the list somewhere maybe?
16:15:57 <dhellmann> haypo : the list?
16:15:59 <dhellmann> of changes?
16:16:09 <dhellmann> #link http://logs.openstack.org/91/248391/4/check/gate-releases-tox-list-changes/c76116b/console.html
16:16:29 <harlowja_at_home> oh nice, i didn't know that job exists
16:17:02 <harlowja_at_home> haypo, is that what u were thinking?
16:17:05 <dhellmann> I asked on the review, but before we cut all of those we should make sure the trove classifiers are updated in all the libs. Was that done?
16:17:39 <harlowja_at_home> #action harlowja check all the trove classifiers
16:17:43 <harlowja_at_home> dhellmann, i'll verify
16:18:03 <harlowja_at_home> i guess this is where stevedore question comes into play
16:18:15 <haypo> yes
16:18:26 <dhellmann> yeah, I think it's fine to drop 2.6 support there
16:18:41 <dhellmann> did we have someone who wanted to keep it and was willing to do that work?
16:19:04 <haypo> dhellmann: i don't think that linux distro care of python 2.6 anymore
16:19:05 * harlowja_at_home not it
16:19:06 <dhellmann> infra is going to remove 2.6 from the test images, so we won't be able to run the tests on our CI system
16:19:12 <gcb> drop python 2.6 support in https://review.openstack.org/#/c/246257/
16:19:28 <haypo> dhellmann: i mean, distro using python 2.6 for "python" are no more upgraded, only backport fixes
16:19:30 <harlowja_at_home> thx gcb
16:20:11 <dhellmann> gcb, were you suggesting that we need to keep it, or not sure why haypo had submitted that patch?
16:20:21 <harlowja_at_home> in that review i see 'gate-stevedore-python26'
16:20:36 <harlowja_at_home> dhellmann, do u know if infra will chop off all those jobs or should we
16:20:49 <gcb> dhellmann, I'm not sure if we need to keep it
16:21:16 <harlowja_at_home> anyone want to do a simple audit to see if other 'gate-stevedore-python26' jobs are alive that probably should not be anymore...
16:21:29 <dhellmann> harlowja_at_home : we should go ahead and drop them. I think that will let infra remove the job definitions entirely.
16:21:33 <harlowja_at_home> k
16:21:47 <gcb> I will check that
16:21:53 <dhellmann> gcb : we are going to stop supporting 2.6, so we do not want to advertise that stevedore supports 2.6 any more
16:22:02 <gcb> agree
16:22:26 <harlowja_at_home> #action harlowja figure out / remove any jobs for 2.6 that are still in infra yaml files
16:22:42 <harlowja_at_home> ^ others feel free to do this also (i'm just keeping a note that this needs to happen)
16:23:33 <harlowja_at_home> if anyone feels like parsing and looking at the infra yaml files before I do, feel free ;)
16:23:51 <harlowja_at_home> its a super-fun activity
16:24:30 <harlowja_at_home> ok next topic i suppose
16:24:42 <harlowja_at_home> #topic Moment of silence for python 2.6
16:24:57 <harlowja_at_home> ok, a 10 second moment of silence for the farewell of 2.6
16:24:59 <harlowja_at_home> haha
16:25:26 <haypo> for new releases, we may have some issues in oslo.config docstrings using versionadded/versionchanged
16:25:32 <haypo> but it's not a big deal, it can be fixed later
16:25:35 <dhellmann> harlowja : I'll do the project-config update if you like
16:25:45 <haypo> i'm still supposed to write a tool to detect that ;)
16:25:49 <harlowja_at_home> dhellmann, thats fine with me
16:25:59 <harlowja_at_home> haypo, tool to detect that ftw
16:26:00 <haypo> otherwise, https://review.openstack.org/#/c/248391/ looks good to me
16:26:38 <haypo> major versions is increased for all released projects, except of pylockfile
16:26:58 <haypo> i guess that pylockfile still supports python 2.6, or at least didn't drop py 2.6 support explicitly
16:28:12 <harlowja_at_home> cool, i also noted that major version bump for taskflow, which hasn't had 2.6 support for a while now, so i'll write a comment on that review
16:28:23 <dhellmann> harlowja_at_home : https://review.openstack.org/248802
16:29:17 <gcb> we don't  say pylockfile support python 2.6 in setup.cfg
16:29:22 <gcb> now
16:30:21 <dhellmann> haypo : since pylockfile has a version < 1.0, semver doesn't require a major version update for this change
16:30:28 <harlowja_at_home> dhellmann, thx that was quick
16:31:02 <haypo> gcb: now, but python 2.6 was in setup.cfg a few weeks ago :)
16:31:16 <haypo> gcb: https://review.openstack.org/#/c/246240/
16:31:52 <haypo> dhellmann: ok
16:31:58 <gcb> haypo, my mistake, I just my local copy
16:32:05 <haypo> dhellmann: would it be possible to switch to 1.0?
16:32:09 <gcb> just saw my local copy
16:32:12 <haypo> dhellmann: pylockfile is stable enough, no?
16:32:35 <harlowja_at_home> good ole pylockfile
16:32:43 <dhellmann> haypo : sure. talk to dims?
16:32:50 <harlowja_at_home> haypo, do u want to be the primary owner of pylockfile ;)
16:32:59 <harlowja_at_home> it needs a owner :-/
16:33:05 <haypo> harlowja_at_home: sorry, no
16:33:18 <haypo> dhellmann: i don't think that it's worth to delay releases just for that
16:33:19 <harlowja_at_home> ya, so i wonder if that why dims doesn't want to bump to 1.0
16:33:23 <haypo> dhellmann: i will just add a comment
16:33:32 <dhellmann> haypo : sure, and we can re-tag it as 1.0 later, too
16:35:17 <harlowja_at_home> cool, so seems like we got all that under control
16:35:31 <haypo> harlowja_at_home: are we done with the release change?
16:35:48 <harlowja_at_home> haypo, well i added my comments on https://review.openstack.org/#/c/248391/
16:35:58 <harlowja_at_home> need dims to check them, not sure why taskflow and tooz are being bumped major version
16:36:04 <harlowja_at_home> they havent support 2.6 for a while now :-P
16:36:21 <haypo> harlowja_at_home: yeah, i just read your comment. but dims is not here, so there is no need to wait, no?
16:36:41 <harlowja_at_home> right, we can chat on the review
16:36:50 <harlowja_at_home> and/or after the meeting when dims comes back
16:37:07 <harlowja_at_home> haypo, any other 2.6 items on your mind?
16:37:39 <haypo> harlowja_at_home: sorry, i didn't follow the topic. i just put +2 blindly on random changes :)
16:37:46 <harlowja_at_home> thats cool
16:37:47 <harlowja_at_home> lol
16:37:48 <harlowja_at_home> haha
16:37:49 <haypo> lol
16:38:02 <gcb> trivial  python 2.6 clean up ?
16:38:26 <gcb> we just remove the python 2.6 classifier , and need some clean up
16:38:58 <harlowja_at_home> gcb,  in pylockfile? or cleanup elsewhere?
16:39:07 <haypo> as i wrote to gcb, i don't think that it matters if gcb changes to "drop" python 2.6 support are incomplete. if someone find other code which can be simplified later, it's fine
16:39:17 <haypo> so i don't spend too much time on reviewing these changes
16:39:32 <haypo> (they all looked good to me, except of some minor comments)
16:39:44 <dhellmann> haypo : yeah, this is about communicating support rather than actually making "breaking" changes
16:40:15 <gcb> I'm working on all libs , just summit a few commits
16:40:29 <harlowja_at_home> gcb, cool, thanks
16:41:06 <haypo> dhellmann: yep
16:41:07 <harlowja_at_home> alright let's switch to open disccusion for anything else
16:41:14 <harlowja_at_home> #topic Open discussion
16:41:24 <harlowja_at_home> oh also, don't forget https://review.openstack.org/#/q/status:open+project:openstack/oslo-specs,n,z
16:41:35 <haypo> harlowja_at_home: ok, i would like to find fresh blood, find new core reviewers
16:41:41 <harlowja_at_home> lol
16:41:48 <harlowja_at_home> haypo, +1 from me
16:41:57 <haypo> as we started to discuss privately, it would help to have some tools to detect them
16:42:01 <harlowja_at_home> yup
16:42:10 <haypo> is there a process to "elect" someone?
16:42:28 <harlowja_at_home> crappy code @ https://review.openstack.org/#/c/246682/ haypo can be improved to find new blood
16:42:46 <gcb> how to reduce oslo bugs ?  I found some bugs were fixed , but still open or in progress
16:43:03 <haypo> harlowja_at_home: can we put all info on the core reviewer process somewhere?
16:43:15 <haypo> harlowja_at_home: i would prefer to have a transparent and public process
16:43:44 <harlowja_at_home> haypo, it might all be documented somewhere already, i'm not to sure
16:43:51 <harlowja_at_home> but yes, +1 for public stuff
16:44:39 <harlowja_at_home> haypo, process i think is probably documented somewhere, but the process i follow is, 1, find person that might be interested, 2, ask them (just to be sure they are really interested), use https://github.com/openstack/oslo-incubator/blob/master/tools/new_core.py to make email, send email to openstack-dev, wait, then see if ok or not, then add or not add as new core
16:44:59 <harlowja_at_home> if no wiki or something exists already we should make one
16:45:20 <harlowja_at_home> there has to be something someone has made somewhere :-P
16:45:23 <dhellmann> some of the other teams have developer references in their repo. Since we didn't have "a" repo, we started adding some of that info to our specs repo under policies.
16:45:30 <dhellmann> #link http://specs.openstack.org/openstack/oslo-specs/#team-policies
16:45:55 <haypo> harlowja_at_home: i take the action of documenting the process, or complete the existing doc
16:46:11 <harlowja_at_home> #action haypo document new core reviewer process(es)
16:46:14 <harlowja_at_home> thx
16:46:47 <harlowja_at_home> boris-42, yt
16:46:49 <haypo> dhellmann: do you mean that i should write a spec to describe the process?
16:47:11 <dhellmann> haypo : we put them in the specs repo, but we didn't really call them "specs"
16:47:23 <dhellmann> IIRC, there was a separate template for policies
16:47:41 <haypo> dhellmann: but technically, i have to write a review to add a new "spec"?
16:47:59 <dhellmann> haypo : right, that's how you get things into that repo
16:48:00 <harlowja_at_home> boris-42, since https://review.openstack.org/#/c/103825/ appears to be picking up momentum agian, just wanted to see if u wanted to discuss anything about it
16:48:11 <haypo> dhellmann: ok, thanks
16:48:40 <harlowja_at_home> nobody has made a auto-writing-spec program yet? :-P
16:48:42 <dhellmann> haypo : I would expect a lot less discussion, and more follow-up patches, on a policy review
16:49:01 <haypo> dhellmann: yeah :)
16:49:06 <dhellmann> haypo : the ones I wrote were almost all just better documentation of things we were already doing
16:49:16 <dhellmann> they were easy to review, and then we could add to them over time
16:49:38 <haypo> " don't forget https://review.openstack.org/#/q/status:open+project:openstack/oslo-specs,n,z " i just completly forgot that :-/
16:49:56 <harlowja_at_home> haypo, don't forget it
16:49:58 <harlowja_at_home> lol
16:50:19 <haypo> harlowja_at_home: forget what? sorry, i already forgot
16:50:26 <harlowja_at_home> lol
16:50:29 <gcb> haha
16:50:44 * harlowja_at_home sets up hourly reminder email to haypo about oslo-specs
16:50:50 <haypo> harlowja_at_home: haha
16:51:45 <harlowja_at_home> haypo, feel free to also document https://github.com/openstack/oslo-incubator/blob/master/tools/new_core_recruit.py in your little writeup
16:51:55 <haypo> harlowja_at_home: hum ok
16:51:57 <harlowja_at_home> that was going to be my new recruit/blood template
16:52:13 <harlowja_at_home> ^ with mission impossible theme in it, lol
16:52:37 <haypo> ok, next week i hope that we will have 100 more core reviewers
16:52:40 <haypo> :-D
16:52:43 <haypo> (at least)
16:52:47 <harlowja_at_home> obviously
16:52:49 <harlowja_at_home> why stop at 100
16:52:52 <harlowja_at_home> why not 1000
16:52:56 <harlowja_at_home> ha
16:53:04 <harlowja_at_home> 1million
16:53:29 <haypo> ok, more seriously 1 or 2 at least would be great
16:53:32 <harlowja_at_home> :)
16:53:47 <harlowja_at_home> guess we are wondering outside of meeting area, lol
16:54:07 <harlowja_at_home> anything else from folks or we can end it and move to #openstack-oslo
16:54:48 * harlowja_at_home rings end of meeting bell
16:54:52 <harlowja_at_home> ding
16:54:53 <harlowja_at_home> lol
16:55:00 * dhellmann has nothing else
16:55:01 <haypo> harlowja_at_home: thanks to replacing dims ;)
16:55:15 <harlowja_at_home> np :)
16:55:26 <harlowja_at_home> #endmeeting