16:00:19 <harlowja_at_home> #startmeeting oslo
16:00:20 <openstack> Meeting started Mon Feb 22 16:00:19 2016 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:22 <ihrachys> o/
16:00:23 <openstack> The meeting name has been set to 'oslo'
16:00:26 <harlowja_at_home> howday folks
16:00:26 <johnsom> o/
16:00:33 <jimbobhickville> ahoy
16:00:33 <kgiusti> \o
16:00:33 <bknudson_> hi
16:00:37 <rpodolyaka> o/
16:00:44 <jecarey_> o/
16:00:45 <harlowja_at_home> dims i think out (on a plane?) so i'm taking the battleship over for now, lol
16:00:57 <harlowja_at_home> *and no sinking my battleship* lol
16:00:59 <amrith> aye aye captain
16:01:07 <harlowja_at_home> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims, dougwig, e0ne, flaper87, garyk, haypo,
16:01:07 <harlowja_at_home> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka, spamaps
16:01:07 <harlowja_at_home> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek, gcb, Nakato
16:01:25 <harlowja_at_home> ok, let's see who else shows up :-P
16:01:36 <rbradfor> o/
16:01:45 <jungleboyj> o/
16:02:01 <harlowja_at_home> \o
16:02:04 <dukhlov_> o/
16:02:04 <harlowja_at_home> o/
16:02:19 <amrith> ./
16:02:19 <rbradfor> \o o/
16:02:27 <harlowja_at_home> \0/
16:02:30 <harlowja_at_home> #topic Red flags for/from liaisons
16:02:35 <amrith> Oh, there are two Ron's?
16:02:39 <harlowja_at_home> ha
16:02:48 <amrith> the man and the legend ;)
16:02:49 <johnsom> We are seeing an exception in cliff 1.16.0+ in python-neutronclient
16:02:53 <johnsom> https://bugs.launchpad.net/python-cliff/+bug/1547707
16:02:53 <openstack> Launchpad bug 1547707 in cliff "cliff 1.16-17.0 breaks neutron lbaas-loadbalancer-list when no load balancers are present" [Undecided,New]
16:03:01 <harlowja_at_home> uh ohes
16:03:04 <bknudson_> no so-called "red flags" for keystone that I know of
16:03:10 <jungleboyj> harlowja_at_home: Nothing from Cinder.  I need to try to finish pulling out the incubator code.
16:03:13 <amrith> no red flags from Trove at this time.
16:03:22 <johnsom> #link https://bugs.launchpad.net/python-cliff/+bug/1547707
16:03:27 <johnsom> Should have done link...
16:03:30 <johnsom> That is all I have
16:03:41 <amrith> just a question about this oslo.log writeable logger change that is percolating its way through the system. Is that required for Mitaka
16:03:46 <harlowja_at_home> anyone looking into the cliff stuff?
16:04:01 <ihrachys> I think neutron is good, nothing to raise that I am aware of
16:04:55 <harlowja_at_home> amrith, hmmmm, i'll have to followup with dims on that one, i don't think its required
16:05:16 <amrith> thanks, I'll look for your response on #openstack-oslo
16:06:02 <harlowja_at_home> johnsom, as for your's i'll poke dims on that one to, unsure who the current cliff person is (i think dhellmann might know)
16:06:35 <johnsom> Ok, thanks
16:06:47 <harlowja_at_home> cool, seems like a not-so-hard-bug-to-address
16:06:58 <harlowja_at_home> *with extra dashes, ha
16:07:04 <johnsom> Yeah, we just started getting reports from users
16:07:14 <harlowja_at_home> kk
16:08:04 <harlowja_at_home> #topic Releases for Mitaka
16:08:12 <harlowja_at_home> so let's see if dims put up a release for the week review
16:08:23 <harlowja_at_home> yup, seems so, ha
16:08:24 <harlowja_at_home> https://review.openstack.org/#/c/282730/
16:08:27 <harlowja_at_home> #link https://review.openstack.org/#/c/282730/
16:08:56 <harlowja_at_home> so that looks like a subset, if anyone wants to add more please either comment on the review or file a separate one
16:09:08 <harlowja_at_home> (or if u object to those being released please comment on the review to)
16:09:08 <bknudson_> this is supposedly the last week for oslo lib releases for M
16:09:27 * rbradfor so that's how releasenotes are seen in releases (oslo.log.yaml)
16:09:55 <harlowja_at_home> bknudson_, good to know, so if u want a release in M, get it added :-P
16:11:38 <harlowja_at_home> bogdando, yt
16:12:29 <harlowja_at_home> #topic Ongoing-specs
16:12:34 <harlowja_at_home> #link https://review.openstack.org/#/q/status:open+project:openstack/oslo-specs,n,z
16:12:53 <harlowja_at_home> so the only one, if people are interested (me and jd__ i think are, ha) is https://review.openstack.org/#/c/256342/
16:13:17 <harlowja_at_home> tldr; about having workers, some kind of work/job queue in tooz that taskflow, mistral (others?) can share
16:13:25 <harlowja_at_home> jimbobhickville ^
16:13:29 <harlowja_at_home> u might also be interested
16:14:06 <harlowja_at_home> but maybe can find bogdando (i think that name is bogdan dobrelya from the review) for a chat next week
16:14:24 <jimbobhickville> looking...
16:14:32 <harlowja_at_home> rakhmerov, yt
16:15:30 <harlowja_at_home> anyways, seeing as nobody is around for that one to talk about it let's skip that (maybe another time)
16:16:13 <harlowja_at_home> there's a few other specs that would be good to have looked at (if people get time)
16:16:39 <harlowja_at_home> but probably to late for mitaka for accomplishing them
16:17:17 <harlowja_at_home> #topic Stuck reviews
16:17:30 <harlowja_at_home> soooo anyone have any reviews that i can help prioritize or get eyes on
16:17:38 <harlowja_at_home> i know jimbobhickville and me want some taskflow ones :-P
16:18:01 <jimbobhickville> yeah, pretty big backlog there
16:18:02 <harlowja_at_home> but besides those (which i can post a bunch on if people want) anyone have any others?
16:18:49 <dukhlov_> If neutron guys are here I would ask to take a look at https://review.openstack.org/#/c/276842/
16:19:09 <dukhlov_> it is not oslo review but related to it
16:19:22 <rbradfor> lxsli has a olso.log review that I'm sure we should get into M, but it's got a cross dependency on oslo.config (in current release) https://review.openstack.org/#/c/254821/
16:19:23 <harlowja_at_home> #link bit.ly/1oDpFQ5
16:19:26 <harlowja_at_home> ^ review dashboard
16:20:44 <harlowja_at_home> rbradfor, k, 254821 looks like its getting worked on, guess we will see how that goes (especially if this week is the last oslo-release-in-M)
16:21:25 <harlowja_at_home> dukhlov_, have u poked some of the neutron folks for that one?
16:21:30 <rbradfor> harlowja_at_home,  agreed, it looks tough as it requires a release and its the last one
16:21:46 <harlowja_at_home> (unsure when that neutron weekly meeting is)
16:22:08 <dukhlov_> harlowja_at_home: just added a lot as reviewers, haven't poke in chat
16:22:14 <rbradfor> harlowja_at_home, https://review.openstack.org/#/c/281790/ is also pending a +2 and is holding up two other approved changes. also lxsli work for adding release notes to oslo.config (not critical I would assume)
16:22:16 <harlowja_at_home> dukhlov_,  or an email to the ML with [neutron] might help also
16:22:34 <dukhlov_> harlowja_at_home: ok, will try, thank you
16:23:02 <ihrachys> dukhlov_: it's in my review queue, sorry for not getting to it prev week, I was sick
16:23:13 <harlowja_at_home> rbradfor, cool i'll get that one looked over, seems like a releasenotes stuffs
16:23:29 <harlowja_at_home> i gotta learn more about reno
16:23:45 <dukhlov_> ihrachys: ah, np. get better
16:23:55 <rbradfor> harlowja_at_home, thanks. I'm learning about reno myself, had it successfully added to oslo.log last week.
16:24:00 <harlowja_at_home> :)
16:24:32 <harlowja_at_home> rbradfor,  does it just make a prettier http://docs-draft.openstack.org/90/281790/3/check/gate-oslo.config-docs/1dcabc1//doc/build/html/history.html ?
16:25:03 <rbradfor> harlowja_at_home, you can see it add a highlight to release yaml (which I didn't know) nice to help https://review.openstack.org/#/c/282730/2/deliverables/mitaka/oslo.log.yaml
16:25:07 <harlowja_at_home> or maybe that docs in that review is differnt
16:25:25 <rbradfor> harlowja_at_home, that does not seem to include release notes.
16:25:28 <harlowja_at_home> k
16:25:36 <harlowja_at_home> wonder how those 2 get inter-connected
16:25:42 <harlowja_at_home> since that's like i guess the old-style release notes
16:25:56 <harlowja_at_home> (which most oslo projects have)
16:26:00 <rbradfor> harlowja_at_home, see http://docs-draft.openstack.org/85/263785/7/gate/gate-oslo.log-releasenotes/f5724bb//releasenotes/build/html/
16:26:21 <harlowja_at_home> rbradfor,  cool
16:26:41 <harlowja_at_home> so i guess some work is for folks to remove the current release notes that show up in docs, with a link to that one ?
16:26:48 <rbradfor> harlowja_at_home, I assume as part of releases (dhellmann would confirm) they move unreleased.rst to mitaka.rst
16:27:10 <harlowja_at_home> for example the oslo.log one still has http://docs.openstack.org/developer/oslo.log/history.html
16:27:13 <rbradfor> harlowja_at_home, that's a good point, I'm not sure how you see it in developer docs.
16:27:18 <harlowja_at_home> which maybe should just point to the other one now ?
16:27:49 <harlowja_at_home> (pretty sure most oslo libraries have that same history.html file)
16:28:05 <harlowja_at_home> dhellmann,  yt
16:28:12 <rbradfor> harlowja_at_home, it's a different directory structure and tox directive, so not sure how it would get to docs.o.o
16:28:15 <harlowja_at_home> kk
16:28:29 <harlowja_at_home> maybe dhellmann , reno expert , can explain
16:28:31 <rbradfor> harlowja_at_home, dhellmann is out most of today to my knowledge
16:28:35 <harlowja_at_home> oh
16:28:41 <harlowja_at_home> well guess he won't explain then
16:28:42 <harlowja_at_home> ha
16:29:05 <rbradfor> harlowja_at_home, not here, we need to stumble across the reno uses and benefits!
16:29:19 <harlowja_at_home> #action harlowja_at_home find dhellmann and see what to do about the history.rst file now that reno exists
16:29:21 <bknudson_> release notes aren't developer docs
16:29:49 <harlowja_at_home> bknudson_, k, so i guess both will still exist?
16:30:06 <harlowja_at_home> if so, seems like the developer doc history should at least point to the release notes?
16:30:24 <harlowja_at_home> (where release notes from reno would have notes/more details about each review)
16:30:26 <bknudson_> If a developer wants to see the history they can git log
16:30:33 <harlowja_at_home> *about each release
16:30:41 <harlowja_at_home> bknudson_,  right, that's basically what the history.rst is, lol
16:30:53 <harlowja_at_home> *with a little more prettiness added
16:31:25 <rbradfor> history seems to be git commit messages, while reno is human generated. I suspect it's more for operators, highlighting changes, new features etc in releases.
16:31:48 <harlowja_at_home> rbradfor, agreed, seems like that
16:31:59 <harlowja_at_home> i'll figure out my own confusion around it :)
16:32:05 <harlowja_at_home> once i find dhellmann ha
16:32:12 <rbradfor> for those interested, here is the etherpad of notes for reno rollout https://etherpad.openstack.org/p/reno-rollout
16:32:39 <harlowja_at_home> #link  https://etherpad.openstack.org/p/reno-rollout
16:32:44 * dhellmann arrives late
16:32:53 <harlowja_at_home> dhellmann, well well, ha
16:32:59 <harlowja_at_home> u have been assigned all the work, ha
16:33:13 <rbradfor> dhellmann, we just blamed you for something, but alas you called our bluff
16:33:25 <dhellmann> harlowja_at_home : cliff is managed by the sdk team now. the fix for the bug has landed, it just needs to be released.
16:33:25 <harlowja_at_home> :)
16:33:30 <harlowja_at_home> johnsom, ^
16:33:37 <harlowja_at_home> thx dhellmann
16:34:28 <johnsom> Cool, thanks dhellmann
16:34:48 <dhellmann> harlowja_at_home , rbradfor : reno is meant to be used for release notes for deployers of openstack, the pbr-generator history file is useful for developers consuming the lib
16:35:05 <harlowja_at_home> dhellmann,  ok, so i guess cross-linking them is up to each project
16:35:12 <harlowja_at_home> like a for-detailed-developer-docs click here
16:35:13 <rbradfor> dhellmann, thanks, that is what we kinda got to
16:35:25 <dhellmann> johnsom : the release request is https://review.openstack.org/#/c/282905/ it just needs dtroyer to sign off on it
16:35:52 <dhellmann> rbradfor : ah, yeah, I'm caught up with scrollback and I see that now
16:36:39 <harlowja_at_home> #topic Open discussion
16:36:51 <harlowja_at_home> anything else that people want to talk about?
16:36:57 <bknudson_> I'd be interested in comments from oslo on https://review.openstack.org/#/c/281579/
16:37:04 <bknudson_> patchbot??
16:37:12 <bknudson_> "Stop using oslotest.BaseTestCase"
16:37:14 <bknudson_> in keystone
16:37:18 <harlowja_at_home> interesting
16:37:51 <dhellmann> bknudson_ : yeah, that follows with http://specs.openstack.org/openstack/oslo-specs/specs/policy/test-tools.html and http://specs.openstack.org/openstack/oslo-specs/specs/liberty/oslotest-refactor-test-base-class.html
16:38:00 <bknudson_> I'm not sure what the goal of oslotest's base test case is -- was it to bring some commonality to openstack tests?
16:38:17 <harlowja_at_home> bknudson_,  afaik yes
16:38:27 <bknudson_> I hadn't seen these specs
16:38:37 <dhellmann> bknudson_ : it was, but we've found a lot of issues with having multiple inheritance in test classes, so we thought fixtures would make a better way to compose things into tests
16:38:40 <harlowja_at_home> although i didn't know BaseTestCase was going bye bye
16:38:57 <dhellmann> harlowja_at_home : it probably won't actually be deleted, we just want people to move off of it
16:38:59 <harlowja_at_home> k
16:39:07 <dhellmann> at least not for a while
16:39:23 <harlowja_at_home> cool
16:39:49 <harlowja_at_home> ya, fixtures exist for all the stuff its doing anyway (afaik) so probably nicer to just use the fixtures u want as needed
16:41:08 <harlowja_at_home> bknudson_,  are u thinking in that review that there would be a oslotest mega-fixture?
16:41:30 <bknudson_> harlowja_at_home: yes, if we want to keep projects consistent
16:41:30 <harlowja_at_home> where the mega-fixture would activate all those other fixtures?
16:41:58 <harlowja_at_home> right, mega-fixture would help the consistency part
16:42:14 <bknudson_> the thing is that these fixtures are actually controlled by env vars that come from tox.ini for example
16:42:30 <harlowja_at_home> right, or testr.conf
16:42:34 <harlowja_at_home> (i think)
16:42:53 <dhellmann> I don't think we want a megafixture. I think we want projects to choose which of these fixtures to use in the base class(es) they define in their own test suites.
16:43:15 <bknudson_> ah, yes: http://git.openstack.org/cgit/openstack/keystone/tree/.testr.conf#n2
16:43:54 <bknudson_> so I don't know if infra is setting OS_STDOUT_CAPTURE OS_STDERR_CAPTURE OS_LOG_CAPTURE ?
16:44:08 <harlowja_at_home> i don't think so
16:44:18 <bknudson_> is infra depending on those being available? I don't know what affect it has if you actually change them.
16:44:19 <harlowja_at_home> (but i might be wrong)
16:44:30 <dhellmann> the defaults can be set in .testr.conf but they're really mean to be used for debugging tests locally I think
16:44:31 <bknudson_> the tests might not even pass if these are changed.
16:45:22 <bknudson_> maybe it's better to simplify and not use these env vars or fixtures
16:45:30 <harlowja_at_home> bknudson_, understood, i myself have been stumped by that log/stdout capturing one
16:45:37 <dhellmann> harlowja_at_home : did you cover the fact that this is our last week to release changes before the freeze?
16:45:45 <harlowja_at_home> dhellmann,  yup
16:46:32 <dhellmann> harlowja_at_home : https://review.openstack.org/282435 would be good to get in, if I can make it pass the test suite :-/
16:47:05 <harlowja_at_home> dhellmann,  cool, looks like a good one once it passes
16:47:11 <harlowja_at_home> recheck * 10, ha
16:47:13 <harlowja_at_home> lol
16:47:30 <dhellmann> there's something weird going on in neutron, I think one of their plugins has an old incubated oslo.config
16:47:41 <rbradfor> dhellmann, one of lxsli mutate changes to get released is dependent on a release first  https://review.openstack.org/#/c/254821/
16:47:59 <dhellmann> rbradfor : ack, is there a release request for that?
16:48:18 <dhellmann> I see https://review.openstack.org/282730 from dims
16:48:46 <dhellmann> yeah, that should cover it. dims is traveling today, but we can get that release done this afternoon.
16:48:50 <rbradfor> dhellmann, so https://review.openstack.org/#/c/280847/ the pre-requisite I believe is in release
16:49:07 <dhellmann> right
16:51:17 <harlowja_at_home> dhellmann, amrith had a question about oslo.log and the writeable option, wonder if u know much about that
16:51:30 * dhellmann scans scrollback again
16:52:06 <dhellmann> hmm, I'm not sure what change he means
16:52:12 <amrith> let me get a link
16:52:32 <harlowja_at_home> k
16:52:53 <amrith> https://bugs.launchpad.net/oslo.log/+bug/1440773
16:52:53 <openstack> Launchpad bug 1440773 in Trove "Remove WritableLogger as eventlet has a real logger interface in 0.17.2" [Undecided,In progress] - Assigned to Chaozhe Chen (chaozhe-chen)
16:52:53 <dhellmann> ah, WritableLogger is deprecated
16:53:02 <dhellmann> I think this was working around -- right, an issue in eventlet
16:53:13 <amrith> and the change in Trove, https://review.openstack.org/#/c/283021/
16:53:21 <dhellmann> the class is still present, and I don't expect us to remove it from the library this week
16:53:30 <amrith> I was wondering whether this is something critical that we should merge for Mitaka.
16:53:33 <dhellmann> it's likely to happen early next cycle, though, if we keep on top of it
16:55:28 <amrith> thanks dhellmann harlowja_at_home
16:55:42 <harlowja_at_home> np
16:55:53 <harlowja_at_home> ok, guess we running out of time
16:55:58 <rbradfor> amrith, I'll add it to my ongoing deprecation work I'm trying to do across oslo config
16:56:22 <harlowja_at_home> anything else from folks before time runs up? get it while its hot, lol
16:57:30 <harlowja_at_home> ok welllllll if more stuff people think about #openstack-oslo
16:57:44 <harlowja_at_home> dims should also be around later to
16:57:56 <harlowja_at_home> (or find me or dhellmann or others there)
16:58:03 <harlowja_at_home> #endmeeting