16:00:06 <dims_> #startmeeting oslo
16:00:07 <dims_> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dougwig, e0ne, flaper87, garyk, harlowja, haypo,
16:00:08 <dims_> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka, spamaps
16:00:08 <openstack> Meeting started Mon Mar 14 16:00:06 2016 UTC and is due to finish in 60 minutes.  The chair is dims_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <dims_> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek, gcb
16:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <dims_> courtesy ping for dukhlov, lxsli, rbradfor, mikal, nakato, tcammann1, browne,
16:00:12 <openstack> The meeting name has been set to 'oslo'
16:00:13 <johnsom> o/
16:00:15 <e0ne> hi
16:00:17 <bknudson> hi
16:00:19 <toabctl> hi
16:00:19 <kgiusti> yo!
16:00:19 <jecarey> o/
16:00:24 <dims_> Thanks haypo for running the meeting last week
16:00:25 <amrith> hello!
16:00:30 <redrobot> o/
16:00:41 <jungleboyj> o/
16:01:00 <rbradfor> Happy Pi Day!
16:01:13 <dims_> hi johnsom bknudson e0ne toabctl kgiusti jecarey amrith redrobot jungleboyj rbradfor
16:01:19 <rpodolyaka> o/
16:01:27 <harlowja_at_home> yo yo
16:01:27 <dims_> hi rpodolyaka
16:01:41 <harlowja_at_home> hi dims_
16:01:42 <dims_> rbradfor : happy pi day :)
16:01:53 <dims_> hi harlowja_at_home
16:01:55 <dims_> #topic Red flags for/from liaisons
16:01:56 <harlowja_at_home> hi hi dims_
16:02:03 <bknudson> none for keystone
16:02:11 <johnsom> Nothing to report from LBaaS land
16:02:12 <stevemar> damn dst
16:02:23 <dims_> thanks bknudson johnsom
16:02:25 <redrobot> Pi Day! \o/
16:02:26 <dims_> stevemar : hehe
16:02:49 <sileht> o/
16:02:56 <haypo> sileht: _o/
16:03:08 <dims_> hi sileht haypo
16:03:11 <dims_> #topic Any stop-ship Bugs needed to be fixed for Mitaka
16:03:12 <dims_> Oslo.messaging - https://review.openstack.org/#/q/status:open+project:openstack/oslo.messaging+branch:stable/mitaka
16:03:16 <jungleboyj> Nothing to report from Cinder.  Good news, we now have incubator fully removed.
16:03:40 <rpodolyaka> \o/
16:03:46 <dims_> i found a couple of things we could fix, so please review those 2 items and we can request a oslo.messaging release for Mitaka
16:03:46 <e0ne> jungleboyj: it's really good news!
16:03:51 <rbradfor> jungleboyj, great to hear, no more incubator
16:03:51 <dims_> jungleboyj : very cool
16:03:56 <jungleboyj> e0ne: Indeed!
16:04:17 * jungleboyj should have dug into it earlier.  Didn't take much work.
16:04:28 <dims_> jungleboyj : w00t
16:04:35 <amrith> none from trove.
16:05:04 <dims_> so stable/mitaka branches were cut from the last released library SHA
16:05:32 <harlowja_at_home> woot!
16:05:43 <dims_> if anyone has stuff that went in after the last release into master, we should consider backporting to stable/mitaka and asking for a release
16:06:20 <ozamiatin> o/
16:06:25 <dims_> one review above is to fix problems we see in grenade the other one is to not starve threads other than the notification listener
16:06:36 <dims_> both one-liners
16:06:45 <dims_> so please vote on those
16:07:05 <dims_> hey ozamiatin
16:07:19 <harlowja_at_home> ah, time.sleep(0)
16:07:27 <harlowja_at_home> how i hate such code, lol
16:07:28 <harlowja_at_home> ha
16:07:43 <dims_> ozamiatin dukhlov for the pika and zmq drivers and the simulator stuff, those can wait until we wrap up mitaka work
16:07:48 * harlowja_at_home looking at blocking code review, ha
16:08:05 <dims_> harlowja_at_home : tested in 2 different environments by different people,
16:08:06 <ozamiatin> dims_: ok
16:08:15 <harlowja_at_home> dims_,  i know, such code just makes me sad, lol
16:08:24 <harlowja_at_home> its like sprinkling fairy dust in various places
16:08:26 <harlowja_at_home> lol
16:08:37 <dims_> yep, hard to find them too
16:08:42 <harlowja_at_home> yup
16:09:01 <dims_> looks like no one else needs anything for Mitaka :) moving on
16:09:07 <dims_> #topic Gather session ideas for Austin
16:09:07 <dims_> #link https://etherpad.openstack.org/p/newton-oslo-summit-planning
16:09:30 <dims_> we need to help the next PTL :) ^^
16:10:37 <dims_> giving it a minute for people to look through
16:10:46 <harlowja_at_home> dims_, should we send that etherpad to ML?
16:10:51 <jungleboyj> dims_: Some good stuff in there.
16:11:01 <dims_> harlowja_at_home : +1 please do
16:11:04 <harlowja_at_home> kk
16:11:06 <harlowja_at_home> will do
16:11:23 <dims_> #action harlowja_at_home to send planning etherpad to mailing list
16:12:07 <dims_> so i keep getting asked what did we do in Mitaka :) so crowdsourcing it
16:12:08 <dims_> #topic Achievements for Mitaka - The good, the bad and the ugly
16:12:08 <dims_> #link https://etherpad.openstack.org/p/mitaka-oslo-achievements
16:12:19 <harlowja_at_home> nice
16:12:20 <harlowja_at_home> +\
16:12:21 <harlowja_at_home> +1
16:12:33 <dims_> please add even small achievements
16:12:53 <dims_> this will help figure out what we want to tell projects to adopt/use in the next cycle
16:13:15 <harlowja_at_home> cools
16:13:17 <harlowja_at_home> good idear
16:13:21 <dims_> liaison's please note the TODO's at the end :)
16:14:06 <dims_> harlowja_at_home : something about tooz ther?
16:14:08 * dhellmann ducks in late
16:14:29 <harlowja_at_home> dims_, hmmmm, let me think, jd__ yt
16:14:34 <dims_> dhellmann we need to advertise what we did in M - https://etherpad.openstack.org/p/mitaka-oslo-achievements
16:14:50 <harlowja_at_home> jungleboyj, did any tooz integration merge into cinder (finally?)
16:15:00 <dims_> harlowja_at_home : if we have to evangelize tooz+zookeeper stuff now's the time :)
16:15:07 <johnsom> I think we are good on both of those TODO's but I will double check
16:15:23 <jungleboyj> harlowja_at_home: I think some has gotten in.  I would need to check with Dulko on that.
16:15:27 <jungleboyj> e0ne: Do you know for sure?
16:15:49 <harlowja_at_home> dims_, did u say zookeeper
16:15:50 <harlowja_at_home> that's bad
16:15:52 <harlowja_at_home> haha
16:15:57 <harlowja_at_home> thou shall not say that word
16:15:58 <harlowja_at_home> lol
16:16:05 <harlowja_at_home> especially java
16:16:11 <harlowja_at_home> thou who can not be named
16:16:12 <dims_> lol
16:16:26 <harlowja_at_home> (or whatever it was from harry potter, i forget)
16:16:31 <dims_> dhellmann : did you get a chance to peek at the planning etherpad too? https://etherpad.openstack.org/p/newton-oslo-summit-planning
16:16:43 <dims_> #topic Open discussion
16:16:43 <dims_> Any stuck reviews? new specs?
16:17:00 <dhellmann> dims_ : yeah, I added one or two things to each of those
16:17:24 <amrith> I have one ... for open discussion.
16:17:29 <dims_> shoot amrith
16:17:33 <bknudson> I've got one for oslo.policy using yaml
16:17:39 <harlowja_at_home> oh dims_ should we have a followup topic in newton about all the reviewers and how to get more and more and more...
16:17:40 <harlowja_at_home> and more
16:17:48 <amrith> I'm wondering if there is some way we can have an extension to the current API's in oslo.messaging to provide credentials with which the underlying transport will connect.
16:18:01 <rbradfor> dims_, I've proposed a spec to standardize on context args https://review.openstack.org/#/c/290907/  Based on several reviews that just skim the surface
16:18:02 <bknudson> oslo.policy in yaml - https://review.openstack.org/#/c/279748/
16:18:06 <amrith> i.e. pass the moral equivalent of rabbitMQ credentials (or the appropriate ones for other transports) from the requestor
16:18:08 <bknudson> I put it in keystone-specs
16:18:10 <amrith> rather than configuration options.
16:18:12 <amrith> thoughts?
16:18:34 <dhellmann> amrith : so you want to send credentials over the message bus?
16:18:34 <dims_> amrith : you can programatically construct a transport url (and the url can have the creds)
16:18:41 <rbradfor> I am also writing a Deprecation management policy https://review.openstack.org/#/c/288720/ Would appreciate initial feedback while I'm still completing
16:18:44 <amrith> Logical extension to that (camel meet tent) is that I'd like the ability to create users through oslo.messaging.
16:18:49 <amrith> sorry dhellmann no.
16:19:08 <amrith> I'd like to be able to pass to oslo.messaging, the credentials that rabbitMQ under the covers should use to connect to the MQ server.
16:19:19 <bknudson> rbradfor: there's already a deprecation policy - https://review.openstack.org/#/c/226157/
16:19:22 <bknudson> in review
16:19:29 <dhellmann> amrith : as dims_ said, you can do that in the connection url
16:19:40 <dhellmann> and if not, that's a bug
16:19:56 <amrith> dhellmann, dims_ thanks. Let me see if that will do what I want.
16:19:57 <amrith> thanks
16:20:42 <dims_> bknudson : the oslo.policy spec.. want to move it to oslo-specs? should be a breeze since we already merged some reviews
16:20:42 <rbradfor> bknudson, that does not talk about the packages and features we use to deprecate.
16:21:14 <dims_> rbradfor : is yours a HOWTO?
16:21:16 <bknudson> dims_: I originally proposed it to oslo-specs, so i can move it back there.
16:21:26 <harlowja_at_home> e0ne, jungleboyj ya, seems like tooz something or other landed in cinder ( https://github.com/openstack/cinder/blob/master/requirements.txt#L59 )
16:21:58 <dims_> bknudson : ack
16:22:01 <harlowja_at_home> e0ne, any idea what merged, if u get some time
16:22:09 <rbradfor> dims_, you could say that.  Given what is available to use, this is how you should use it.
16:22:17 <harlowja_at_home> (or else i can find out by scanning git history)
16:22:44 <dims_> dhellmann : is there another spot we can use for a HOWTO deprecate?
16:22:56 <dims_> since it may be useful for other projects too?
16:22:57 <e0ne> harlowja_at_home: https://github.com/openstack/cinder/commit/d6fabaa6cf7700cfb957e37594d0da818afea806
16:23:02 <harlowja_at_home> e0ne, thx
16:23:28 <harlowja_at_home> johnsom, do u want to add a little piece about taskflow, how it made your life so much better in https://etherpad.openstack.org/p/mitaka-oslo-achievements
16:23:41 <jungleboyj> e0ne: Was just about to put that here.
16:23:43 <harlowja_at_home> johnsom, under new integrations
16:23:56 <dhellmann> dims_ : we could put it in the project-team-guide, but that's really mean to be processes used everywhere and different projects may have slight variations
16:23:59 <jungleboyj> harlowja_at_home: So, first round of work to get distributed locks for A/A HA support.
16:24:06 <harlowja_at_home> jungleboyj, e0ne coool, so starts with file-locks
16:24:11 <johnsom> Hmm, sure.  You should add the deciders too.  Big feature for us
16:24:19 <harlowja_at_home> johnsom, u want to add ;)
16:24:20 <harlowja_at_home> haha
16:24:26 <harlowja_at_home> u can say how awesome it is for u
16:24:28 <harlowja_at_home> lol
16:24:45 <johnsom> Ok.  Not sure if we fit in "new" integrations, as we were using taskflow in liberty too
16:24:54 <dims_> i threw in "Evangelize distributed locks (tooz + zookeeper?)"
16:25:14 <harlowja_at_home> johnsom, ok i fixed it :)
16:25:44 <harlowja_at_home> dims_, 'It-Who-Must-Not-Be-Named'
16:25:48 <harlowja_at_home> u must not say that word
16:25:48 <harlowja_at_home> lol
16:25:53 <dhellmann> dims_ : since rbradfor's is a howto as long as it doesn't conflict with lifeless' proposal maybe it can be a follow-up to that? we've been using the policy section of the specs repo for oslo team notes, but maybe we want to add a new dev-guide section?
16:26:05 <harlowja_at_home> * https://en.wikipedia.org/wiki/Lord_Voldemort (if u don't get the joke)
16:26:06 <harlowja_at_home> lol
16:26:50 <rbradfor> dhellmann, I welcome any feedback to adjust/rename accordingly.
16:27:32 <harlowja_at_home> johnsom, thx :)
16:27:43 <harlowja_at_home> johnsom, i can write how awesome things are, but it feels weird for me to write it, lol
16:27:56 <dhellmann> rbradfor : most project teams have a dev guide in their main repo, but we don't have a "main" repo any more now that the incubator isn't being used
16:28:04 <johnsom> Grin
16:29:05 <johnsom> harlowja_at_home Though you are probably better at wording some of this
16:29:13 <harlowja_at_home> johnsom, haha, perhaps
16:29:45 <harlowja_at_home> i mostly just write crap though
16:29:48 <harlowja_at_home> its an acquired skill
16:29:49 <harlowja_at_home> lol
16:29:52 <johnsom> You have full license to word smith anything I write
16:29:57 <harlowja_at_home> thx :)
16:30:13 <dims_> johnsom bknudson e0ne toabctl kgiusti jecarey amrith redrobot jungleboyj rbradfor harlowja_at_home rpodolyaka sileht haypo - anything else?
16:30:19 <bknudson> nope
16:30:25 <johnsom> nope
16:30:27 <rpodolyaka> no
16:30:29 <jecarey> no
16:30:33 <kgiusti> nope
16:30:36 <rbradfor> no
16:30:42 <harlowja_at_home> no no
16:30:43 <harlowja_at_home> yes
16:30:46 <harlowja_at_home> haha, just kidding on the yes
16:30:52 <dims_> Last but not the least :) Please throw your hat in the ring for PTL
16:30:54 <jungleboyj> Nope.
16:30:58 <rbradfor> dims_, good to meet you in person last monday!
16:31:01 <dims_> Thanks everyone
16:31:06 <jungleboyj> Thank you!
16:31:16 <dims_> rbradfor : likewise :) it was short but still fun
16:31:30 <dims_> talk to you all next week
16:31:32 <dims_> #endmeeting