16:00:35 <harlowja_at_home> #startmeeting oslo
16:00:36 <openstack> Meeting started Mon Mar 21 16:00:35 2016 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:40 <openstack> The meeting name has been set to 'oslo'
16:00:45 <rbradfor> o/ I'm only around for 15mins more
16:00:48 <harlowja_at_home> courtesy ping for GheRivero, amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims, dougwig, e0ne, flaper87, garyk, haypo,
16:00:48 <harlowja_at_home> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, ozamiatin, redrobot, rpodolyaka, spamaps
16:00:48 <harlowja_at_home> courtesy ping for sergmelikyan, sreshetnyak, sileht, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zzzeek, gcb, Nakato
16:00:50 <rpodolyaka> o/
16:00:52 <johnsom> o/
16:00:53 <harlowja_at_home> hi there folks!
16:00:53 <jungleboyj> o/
16:00:53 <dims_> o/
16:00:55 <redrobot> o/
16:00:55 <ozamiatin> o/
16:00:59 <bknudson> hi
16:01:06 <harlowja_at_home> welcome to oslo-next-generation, lol
16:01:09 <kgiusti> o/
16:01:18 <dims_> hello boss
16:01:36 <harlowja_at_home> lol
16:01:39 <harlowja_at_home> hi prior boss
16:01:46 <amrith> ./
16:01:49 <jecarey> o/
16:01:55 * kgiusti doesn't want to be Westley
16:01:58 <harlowja_at_home> lol
16:02:00 <rbradfor> harlowja_at_home, dims_ is this not a round table?
16:02:09 <harlowja_at_home> lol
16:02:17 <jungleboyj> :-)
16:02:20 * jungleboyj calls Riker
16:02:40 <harlowja_at_home> just don't be a temp actor, cause they always get killed, lol
16:02:50 <harlowja_at_home> or was that the original star-trek, idk
16:02:53 <browne> o/
16:03:18 <harlowja_at_home> #topic Red flags for/from liaisons
16:03:28 <harlowja_at_home> anything for people to report, as in stuff ain't working, or ...
16:03:28 <amrith> none that I know of from trove.
16:03:29 <johnsom> Nothing from LBaaS
16:03:43 <jungleboyj> Nothing from Cinder.
16:03:50 <bknudson> none for keystone that I know of
16:04:10 <harlowja_at_home> cool col
16:04:12 <harlowja_at_home> *cool
16:04:49 * harlowja_at_home needs to see about getting more projects in here to report anything wrong, ha
16:05:22 <lxsli> o/
16:05:24 <dims_> harlowja_at_home : good time to send a reminder to ML for CPL(s) https://wiki.openstack.org/wiki/CrossProjectLiaisons
16:05:30 <ihrachys> nothing from neutron I guess
16:05:36 <harlowja_at_home> dims_,  ya, +1
16:05:55 <harlowja_at_home> i'll try to send something today
16:05:58 <amrith> dims_, good idea.
16:06:00 * breton watches
16:06:12 <dims_> hey breton : welcome
16:06:23 <harlowja_at_home> #action harlowja_at_home  ML for CPL(s) https://wiki.openstack.org/wiki/CrossProjectLiaisons
16:06:51 <amrith> "They also serve who only stand and watch" (John Milton)
16:07:27 * harlowja_at_home imagines u singing that
16:07:42 <amrith> :)
16:08:13 <harlowja_at_home> #topic Mitaka achievements
16:08:21 <harlowja_at_home> soooo https://etherpad.openstack.org/p/mitaka-oslo-achievements is still looking for more goodness
16:08:45 <harlowja_at_home> i guess dims or maybe i will send something out from that (summing it up)
16:09:00 <harlowja_at_home> soooo keep on adding random things u think about
16:09:08 <amrith> harlowja_at_home, one suggestion I had abotu this is that maybe you could add accomplishments related to oslo from projects (your customers)
16:09:30 <harlowja_at_home> amrith, def
16:09:37 <harlowja_at_home> johnsom, did that a little in the taskflow section
16:09:43 <harlowja_at_home> but +1 for more of that
16:09:47 <amrith> that would help indicate adoption of the various things that the oslo team is producing
16:09:54 <amrith> if that's ok, I'll try and add some that trove did
16:09:59 <amrith> and plans to do for Newton
16:10:17 <harlowja_at_home> good idea, i can send out a ML email asking for more of that (since i don't think i can find/contact everyone via this IRC meeting)
16:10:28 <harlowja_at_home> but ya +1 from me, makes sense
16:10:56 <harlowja_at_home> then maybe i can work with thingee or ttx to get a offical openstack post or something
16:10:58 <harlowja_at_home> that'd be nice
16:11:03 <harlowja_at_home> *website post*
16:11:53 <harlowja_at_home> dims_, sound good to u? inline with your vision of that etherpad?
16:12:04 <dims_> sounds good
16:12:09 <rbradfor> +1 for blog post
16:12:47 <harlowja_at_home> +2
16:12:55 <harlowja_at_home> #topic Newton summit planning
16:13:02 <harlowja_at_home> #link https://etherpad.openstack.org/p/newton-oslo-summit-planning
16:13:12 <harlowja_at_home> sooo that's still accumulating things, keep adding items
16:13:29 <harlowja_at_home> i'm unsure when that has to stop accumulating ideas, but probably soonish
16:13:43 <harlowja_at_home> dims_, the whole planning should probably start soon (ie, no more accumulating ideas, ha)
16:14:21 <dims_> harlowja_at_home : we have to tell people to cleanup https://etherpad.openstack.org/p/oslo-incubator-remnants (from dhellmann)
16:14:44 <harlowja_at_home> k
16:14:56 <rbradfor> dims_, I've been doing a lot of this last week.
16:15:03 <harlowja_at_home> people clean ^ up!
16:15:04 <dims_> rbradfor : nice!
16:15:07 <amrith> thanks rbradfor for pushing up one of those to trove
16:15:26 <rbradfor> #link https://etherpad.openstack.org/p/oslo-libraries-adoption
16:15:38 <rbradfor> from the Newton meeting I proposed.
16:15:49 <dims_> ack rbradfor
16:15:57 <harlowja_at_home> rbradfor, nice
16:16:06 <rbradfor> amrith, actually I'm working on doing apiclient now, it's become a bit more of a challenge. I do a WIP and get feedback from the oslo team.
16:16:32 <harlowja_at_home> #topic Oslo libraries adoption
16:16:39 <amrith> rbradfor, lmk if I can help with any of the trove stuff.
16:16:40 * harlowja_at_home just so i can note this
16:16:49 <harlowja_at_home> #link  https://etherpad.openstack.org/p/oslo-incubator-remnants
16:16:52 <rbradfor> amrith, will do.
16:16:56 <harlowja_at_home> #link  https://etherpad.openstack.org/p/oslo-libraries-adoption
16:17:12 <amrith> On the subject of library adoption, do you want to also talk abut deprecation(s) now?
16:17:29 <amrith> I have one about deprecation (thanks cp16net for pointing me at this)
16:17:31 <rbradfor> amrith, deprecation of libraries?
16:17:37 <amrith> oslo_utils.timeutils.
16:17:45 <harlowja_at_home> sure, we can talk about it
16:17:51 <amrith> There's a change that has been proposed in Trove see https://review.openstack.org/#/c/257152/4
16:18:14 <amrith> there are some concerns abotu the approach and I wanted to ask the oslo team for their guidance.
16:18:30 <harlowja_at_home> ah, isotime stuff
16:18:34 <harlowja_at_home> jd__, yt ;)
16:18:58 <amrith> harlowja_at_home, I could follow up with someone outside the meeting if that is more appropriate
16:19:02 <harlowja_at_home> nah, its fine
16:19:05 <amrith> I don't mean to have the discussion here, just to get a pointer.
16:19:12 <amrith> if it is jd__ I'll follow up later
16:19:13 <amrith> thanks
16:19:18 <harlowja_at_home> just wondering if that's a copy of the code without the deprecation warnings ----> trove :-P
16:19:46 <harlowja_at_home> sorta looks like that, lol
16:19:50 <amrith> it may be, I found it odd to have a new file in 2016 with a 2011 copyright but your explanation would tell why it is the case.
16:19:51 <bknudson> in keystone we wound up copying the code.
16:19:57 <cp16net> yeah i think it is
16:20:00 <harlowja_at_home> :-/
16:20:13 <harlowja_at_home> ya, gotta be a better way then
16:20:16 * rbradfor have to bug out to make another appointment, will review meeting notes after.
16:20:24 <harlowja_at_home> rbradfor, okies
16:20:24 <amrith> so, wait. what I'm hearing is that you deprecated something and now there are >1 copies of that code in projects?
16:20:32 <amrith> that sounds like a bad thing to me.
16:20:33 <harlowja_at_home> :(
16:20:38 <harlowja_at_home> ya, sounds bad
16:20:45 <harlowja_at_home> anti-depreciation, lol
16:21:10 <bknudson> we copied the code because we needed the string format to be exactly what it was before otherwise we wouldn't be backwards compatible
16:21:17 <bknudson> that might not be the case for everybody
16:21:30 <bknudson> and is maybe a reason not to use a library that might change underneath us
16:21:59 <harlowja_at_home> :-/
16:22:17 <dims_> bknudson : same case with Nova
16:22:32 <amrith> bknudson, I will check whether we need the exact format but there seems to be a case for using the deprecated code in >1 projects which begs the question, why deprecate it in the first place.
16:22:35 <cp16net> bknudson: thats the same reason i approved this change for trove.
16:22:38 <amrith> but I must be missing something in that assessment.
16:23:01 <harlowja_at_home> so i'm thinking this might require a larger discussion, i know jd__ feels passionately about this
16:23:03 <cp16net> i was concerned about changing the format
16:23:17 <amrith> Philosophically, I think 3 projects wanting the same 'private' code is not a good thing. Let me follow up with bknudson and jd__ ... thanks harlowja_at_home
16:23:23 <harlowja_at_home> so maybe we can have a volunteer to summarize the current situation and do some analysis
16:23:31 <amrith> I will volunteer
16:23:35 <amrith> sign me up with the action
16:23:45 <harlowja_at_home> amrith, thx, i agree with u for the feeling on that (feels odd)
16:23:48 <dims_> amrith : cp16net : so we are raising awareness so folks understand the repercussions
16:24:17 <dims_> and choose whether to keep status quo or figure out a path forward
16:24:34 <amrith> dims_, I'm raising it because I want to know what this 'copy' of code is about. In raising it, I learned that others also have copies. which makes my copy "less valuable".
16:24:34 <dims_> so it's serving the purpose
16:24:37 <harlowja_at_home> #action amrith summarize and do a little analysis of the current timeutils issues and start some outward discussion on the current state of things and where to go
16:24:48 <amrith> I don't want "cheap copies of code", I'd rather use the "original" ;)
16:25:15 <harlowja_at_home> ya, counterfeit code is bad, lol
16:25:24 <dims_> amrith : do talk to jd__ please
16:25:29 <harlowja_at_home> buy french made code only
16:25:40 <amrith> dims_, wilco.
16:25:52 <amrith> #action amrith to chat with jd__ about timeutils stuff
16:26:11 * harlowja_at_home what other work can i give jd__ (hmmmm)
16:26:11 <harlowja_at_home> lol
16:26:54 <haypo> amrith: sorry, i missed the beginning of the meeting. what is your question about timeutils?
16:27:13 <haypo> amrith: i know that jd deprecated functions, then i proposed patches to update nova
16:27:14 <harlowja_at_home> amrith, maybe include haypo in this future analysis discussion ;)
16:27:16 <amrith> haypo, the question regards review https://review.openstack.org/#/c/257152 in trove
16:27:24 <amrith> I will follow up with you offline (of this meeting).
16:27:26 <haypo> amrith: but nobody reviewed my changes, and i was bored, so i abandonned it
16:27:29 <harlowja_at_home> lol
16:28:01 <haypo> amrith: copy code to avoid a deprecation. hum...
16:28:03 <amrith> haypo, I know that feeling. would you like hbase in Trove :)
16:28:17 <haypo> hbase?
16:28:33 <amrith> longer story, involves much alcohol and tears.
16:28:37 <harlowja_at_home> lol
16:28:38 <harlowja_at_home> #topic Releases for Mitaka
16:28:47 <harlowja_at_home> so afaik there aren't any releases for mitaka, so this is a trick topic
16:28:48 <harlowja_at_home> lol
16:28:58 <bknudson> I hope there's not
16:28:59 <harlowja_at_home> but just incase anyone missed any, maybe tag on to https://review.openstack.org/#/c/294594/
16:29:08 <harlowja_at_home> and/or find ttx ^
16:29:19 <haypo> amrith: i didn't understand everything, but ok for the alcohol
16:30:39 <harlowja_at_home> #topic Idears for newton (for getting more activity all around)
16:30:48 <harlowja_at_home> soooo this is a little different, something i am trying out
16:31:16 <haypo> harlowja_at_home: is there an home page for oslo listing all oslo projects?
16:31:40 <harlowja_at_home> https://wiki.openstack.org/wiki/Oslo ?
16:31:47 <harlowja_at_home> haypo, ^
16:32:09 <harlowja_at_home> along with this topic, what i am seeing if it works it to do a little outreach via the ML
16:32:10 <harlowja_at_home> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/thread.html#89895
16:32:26 <harlowja_at_home> getting peoples complaints, random ideas, (no hate mail, lol)
16:32:42 <harlowja_at_home> or not complaints and just complements are fine also
16:32:42 <haypo> harlowja_at_home: maybe we need a more shiny table of projects
16:33:00 <harlowja_at_home> haypo, sure!
16:33:20 <johnsom> How about a "consistent hash" library?
16:33:27 <haypo> harlowja_at_home: the wiki page is full of "Please file bugs ..." and there is no moose logo!?
16:33:42 <harlowja_at_home> and then i was thinking we can aggregate how that thread turns out and start to seek volunteers (new or old) for that work ;)
16:33:52 <harlowja_at_home> johnsom, sureee, seems like could be a useful thing
16:34:02 <harlowja_at_home> so that was/is my motivation for that thread :-P
16:34:04 <johnsom> I know one of the other projects is using consistent hashing (swift or cinder maybe) and we are probably going to need it as well.
16:34:11 <harlowja_at_home> johnsom, ya, ironic is also
16:34:21 <harlowja_at_home> there are a few impls of it around afaik
16:34:31 <harlowja_at_home> in various states with various algorithms
16:34:58 <dims_> harlowja_at_home : ayoung was mentioning a few things in oslo.messaging?
16:34:59 <harlowja_at_home> haypo, yes, we need more moose logos and moose pictures on that page, lol
16:35:04 <johnsom> My random idea for the day
16:35:17 <harlowja_at_home> dims_, yup, that's one thing
16:35:48 <harlowja_at_home> which may just turn into a deployment pattern (since it seems HMAC or other is not desireable)
16:36:29 <harlowja_at_home> johnsom,  do u want to reply to that thread with that idea :)
16:36:40 <harlowja_at_home> ML reaches a larger audience afaik
16:36:40 <johnsom> Sure
16:36:43 <harlowja_at_home> thx
16:36:55 <amrith> harlowja_at_home, I did have a request for oslo.messaging as well (to allow programmatically to specify the credentials for the underlying transport, rabbitMQ ...)
16:37:14 <harlowja_at_home> seems useful
16:37:24 <amrith> I'll file a bug for that but have so far held off to make sure that the oslo folks believe that this would be within scope for oslo.
16:37:33 <harlowja_at_home> sounds fair to me
16:37:36 <harlowja_at_home> thx
16:37:40 <amrith> the reason I ask that is because the next request right behind that is to provide an API to create users through oslo ;)
16:37:40 <harlowja_at_home> sileht, ^
16:37:57 <harlowja_at_home> hmmm
16:38:08 <amrith> since the choice of underlying transport is not known to Trove (consumer)
16:38:19 <amrith> hence an abstraciton like oslo_messaging.register_user()
16:38:25 <harlowja_at_home> i wonder what the cue folks have in mind for this
16:38:36 <harlowja_at_home> cause u would think they need something similarish (maybe)
16:38:40 <amrith> which would do the right thing for the underlying transport (OR say buzz-off-not-supported-for-this-transport).
16:39:14 <harlowja_at_home> #link https://wiki.openstack.org/wiki/Cue (for those who dont know)
16:39:15 <amrith> well, that (Cue) is a different level of abstraction, right? Cue under oslo.messaging is fine from my perspective.
16:39:28 <harlowja_at_home> ya, not totally sure
16:39:37 <harlowja_at_home> anyways, something to think about :-P
16:39:40 <amrith> does it make sense to discuss here before I open the bug?
16:40:09 <harlowja_at_home> well the 'programmatically to specify the credentials for the underlying transport' seems ok, the next step from that seems a little different (in my view)
16:40:23 <harlowja_at_home> next step might require a little discussion i think, first step i don't think does to much
16:40:31 <harlowja_at_home> but would like sileht thoughts there
16:41:56 <harlowja_at_home> #topic Open discussion
16:42:39 <harlowja_at_home> so i'd just like to personally thx dims_ for his oslo ptl for the last year(?) and dhellmann before that and all the others that came before
16:42:48 <harlowja_at_home> cause i forgot to do that at the start of the meeting, lol
16:42:55 <harlowja_at_home> (better late than never, ha)
16:43:11 <bknudson> I proposed a spec to oslo.policy for supporting YAML in addition to JSON -- https://review.openstack.org/#/c/279725/
16:43:14 <dims_> my pleasure harlowja_at_home - am not going anywhere :)
16:43:22 <lxsli> If anyone knows about the problems eventlet causes when reconfiguring logging, I'd like to chat to them
16:43:30 <amrith> thanks dims_ dhellmann, all the best harlowja_at_home
16:43:33 <johnsom> harlowja_at_home http://lists.openstack.org/pipermail/openstack-dev/2016-March/090032.html
16:44:02 <harlowja_at_home> bknudson, ya, yaml +1, just the ability to have comments in yaml makes me happy, lol
16:44:16 <harlowja_at_home> but i know there are anti-yaml-people (probably the same people who use emacs, lol)
16:44:29 <harlowja_at_home> johnsom, thx
16:44:55 <lxsli> I'm slightly confused that it's so much more popular to change policy to accept YAML than config + logconfig, but JSON is closer than INI
16:45:09 <lxsli> and I'm certainly not standing in the way
16:45:23 <harlowja_at_home> config + logconfig ?
16:45:41 <lxsli> there were a couple of patches to support YAML in oslo.config and oslo.log which got roundly -1d
16:45:56 <harlowja_at_home> oh, gotcha
16:46:18 <harlowja_at_home> ya, we need to work through some of those -1d
16:46:29 <harlowja_at_home> wasn't it around configuration tools working better with ini
16:46:33 <harlowja_at_home> or something
16:46:40 <lxsli> People didn't want to support two file formats
16:46:56 <bknudson> the nice thing about YAML is there is only 1 file format.
16:46:59 <bknudson> JSON is a subset of YAML
16:47:02 <dims_> lxsli : policy i haven't seen the push back
16:47:03 <lxsli> yes, that's helpful
16:47:10 <harlowja_at_home> lxsli, ya, maybe we just need to do a better job convincing of the benefits
16:47:39 <dims_> harlowja_at_home : biggest pain point it addresses is ability to add comments in the policy file
16:47:45 <harlowja_at_home> ya
16:47:50 <harlowja_at_home> comments ++
16:48:18 <lxsli> harlowja_at_home: could be, as an Ansible user YAML is everywhere and INI seems outdated
16:48:57 <harlowja_at_home> lxsli, i mean i get the 2 file formats are hard(er) to manage, and so on, but i feel that if we really believe yaml is better, then wellll i guess we just need to convince better on why
16:49:11 <harlowja_at_home> everytime i think ini i think windows still
16:49:13 <harlowja_at_home> lol
16:49:15 <lxsli> harlowja_at_home: +1
16:50:03 <dims_> harlowja_at_home : the idea that nova folks had was that default policy would be right near the code. then there's not policy file until someone needs to override it. so then yaml is just fine
16:50:41 <harlowja_at_home> as in a dict in the code dims_ ?
16:50:44 <bknudson> my understanding is they want to generate a sample policy file (like being able to generate a sample config file)
16:50:45 <dims_> alaski had a nova review
16:50:57 <dims_> bknudson : y that too
16:51:38 <harlowja_at_home> seems like we can resolve all these things anyway (imho)
16:51:40 <harlowja_at_home> we can do it!
16:51:40 <harlowja_at_home> lol
16:51:43 <dims_> harlowja_at_home : bknudson : https://review.openstack.org/#/c/289596/ and https://review.openstack.org/#/c/290155/
16:52:04 <harlowja_at_home> cool
16:53:04 <harlowja_at_home> will read that one more fully soonish
16:53:33 <harlowja_at_home> haypo, do u want to spice up the oslo page?
16:53:49 <harlowja_at_home> with moose pictures or whatever
16:53:50 <harlowja_at_home> lol
16:53:51 <bknudson> We could use a policy file generator in keystone, too.
16:54:10 <haypo> harlowja_at_home: i don't want a copy of the logo :-/
16:54:23 <harlowja_at_home> haypo,  https://github.com/openstack/oslo-incubator/blob/master/doc/source/_images/oslo-moose-color.svg ;)
16:54:41 <harlowja_at_home> now u want a copy i know it, lol
16:55:36 <harlowja_at_home> alright, time running out
16:55:43 * harlowja_at_home rolls credits
16:56:01 <harlowja_at_home> anything else from folks?
16:56:12 <lxsli> If anyone knows about the problems eventlet causes when reconfiguring logging, I'd like to chat to them
16:56:17 <harlowja_at_home> def
16:56:18 <dims_> all set from me harlowja_at_home
16:56:18 <lxsli> really very much
16:56:31 <harlowja_at_home> lxsli, haypo may know
16:56:34 <harlowja_at_home> he's mr.eventlet ;)
16:56:36 <lxsli> awesome thanks
16:56:53 <harlowja_at_home> dims_, thx
16:56:55 <harlowja_at_home> okie dokie
16:57:00 <harlowja_at_home> until the next episode
16:57:09 <harlowja_at_home> oslo-next-generation end show
16:57:14 <harlowja_at_home> #endmeeting