16:00:05 <harlowja_at_home> #startmeeting oslo
16:00:07 <openstack> Meeting started Mon May 23 16:00:05 2016 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <openstack> The meeting name has been set to 'oslo'
16:00:19 <harlowja_at_home> courtesy ping for amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims, dougwig
16:00:19 <harlowja_at_home> courtesy ping for e0ne, flaper87, garyk, gcb, GheRivero, haypo, ihrachyshka, jd__
16:00:19 <harlowja_at_home> courtesy ping for jecarey, johnsom, jungleboyj, kgiusti, kragniz, lifeless, lintan, lxsli
16:00:19 <harlowja_at_home> courtesy ping for Nakato, ozamiatin, rbradfor, redrobot, rpodolyaka, sergmelikyan, sileht, spamaps
16:00:19 <harlowja_at_home> courtesy ping for sreshetnyak, sreshetnyak, stevemar, therve, thinrichs, toabctl, viktors, zhiyan
16:00:21 <harlowja_at_home> courtesy ping for zzzeek
16:00:25 <rbradfor> o/
16:00:29 <kgiusti> o/
16:00:31 <johnsom> o/
16:00:31 <harlowja_at_home> o/
16:00:32 <dims> o/ (partially here :)
16:00:34 <bknudson> aloha
16:00:37 * dhellmann listens in partly
16:00:37 <sileht> o/
16:00:41 <harlowja_at_home> hi theres
16:01:03 <ihrachys> o/
16:01:42 <harlowja_at_home> cool, guess we can get started
16:01:48 <harlowja_at_home> #topic Red flags for/from liaisons
16:02:02 <bknudson> none for keystone that I'm aware of.
16:02:07 <johnsom> Nothing to report (I was traveling, so...)
16:02:17 <ihrachys> nothing on neutron side. we had a patch for the way we spin up rpc workers using oslo.messaging merged and reverted due to a breakage, but I guess we are following up on that revert with https://review.openstack.org/#/c/313277/
16:02:17 <harlowja_at_home> thx johnsom bknudson
16:02:38 <harlowja_at_home> ihrachys, are those possibly the cause of http://logs.openstack.org/periodic/periodic-neutron-py27-with-oslo-master/49f6434/console.html ?
16:02:56 * harlowja_at_home was going to jump into neutron channel and see if anyone knows what these are about
16:03:01 <harlowja_at_home> http://status.openstack.org/openstack-health/#/g/build_name/periodic-neutron-py27-with-oslo-master == sad
16:03:16 <ihrachys> not sure. but if you get it with latest master, probably no since we reverted it
16:03:25 <harlowja_at_home> hmmm, ok
16:03:33 <ihrachys> I will take a look right now on the failure logs.
16:03:52 <harlowja_at_home> thx
16:04:12 <harlowja_at_home> sort of seems like its testing oslo.messaging, but i'm not quite sure
16:04:35 <ihrachys> we have some code that messes with timeouts for clients
16:04:36 <lxsli> o/
16:04:50 <ihrachys> doing back-off procedure for clients on timeouts for scaling reasons
16:04:54 <ihrachys> merged in Newton
16:05:03 <harlowja_at_home> ihrachys, ya, i wonder if that might need tweaking due to newer oslo.messaging code
16:05:07 <harlowja_at_home> lxsli, hi there
16:05:10 <harlowja_at_home> #topic Releases for newton
16:05:15 <ihrachys> harlowja_at_home: I will definitely take a look
16:05:18 <harlowja_at_home> which segways into the releases i guess
16:05:25 <harlowja_at_home> #link https://review.openstack.org/#/c/317111/
16:05:38 <harlowja_at_home> i have that up, if people want newer versions of things to release let me know
16:06:03 <ihrachys> harlowja_at_home: I guess you will postpone oslo.messaging until we clear neutron thing
16:06:03 <harlowja_at_home> but ihrachys it'd be nice to have some look at the errors happening before that offically merges and releases happen (and then neutron will break?)
16:06:04 <jungleboyj> o/
16:06:24 <harlowja_at_home> ihrachys, i can do that, unless u think its a non-issue
16:06:30 <harlowja_at_home> jungleboyj, how's cinder
16:06:33 <ihrachys> harlowja_at_home: exactly, let's not break things. maybe split the releases patch into two
16:06:39 <harlowja_at_home> ihrachys, k, can do
16:06:47 <ihrachys> thanks
16:06:56 <jungleboyj> harlowja_at_home: Fine as far as I know.  :-)  No flags to raise.
16:07:02 <harlowja_at_home> #action harlowja_at_home split  https://review.openstack.org/#/c/317111/  into two (oslo.messaging and other)
16:07:09 <harlowja_at_home> jungleboyj, cool
16:07:17 <jungleboyj> :-)
16:07:27 <harlowja_at_home> http://status.openstack.org/openstack-health/#/g/build_name/periodic-cinder-py27-with-oslo-master?groupKey=build_name&resolutionKey=hour&end=2016-05-23T15:52:38.117Z looks good for cinder so i'm happy :-P
16:07:47 <harlowja_at_home> johnsom, i'd be nice to get a http://status.openstack.org/openstack-health/#/g/build_name/periodic-octavia-py27-with-oslo-master?groupKey=build_name&resolutionKey=hour&end=2016-05-23T15:52:38.117Z i think to
16:07:52 <harlowja_at_home> let me try to do that
16:08:45 <harlowja_at_home> anyways, if people need me to adjust https://review.openstack.org/#/c/317111/ let me know (comment on the review is fine)
16:09:07 <harlowja_at_home> #link https://review.openstack.org/#/c/318604/ (pbr release) is also happening
16:09:38 <ihrachys> dougwig: can we have someone take a look at octavia test failure with oslo master? ^
16:09:51 <harlowja_at_home> oh, is it octavia related
16:10:04 <ihrachys> harlowja_at_home: wait, where is failure
16:10:11 <ihrachys> or I miss context of the discussion :D
16:10:30 <harlowja_at_home> ihrachys, oh sorry, i was just saying that it'd be nice to have periodic jobs against oslo master for octavia :)
16:10:33 <harlowja_at_home> they don't exist yet ;)
16:10:37 <johnsom> I can look at Octavia issues.  is it the 318604?
16:10:43 <ihrachys> harlowja_at_home: aha. ok, sorry. false alarm.
16:10:48 <harlowja_at_home> np :)
16:10:52 <johnsom> Yeah, I didn't think we had them yet
16:11:14 <harlowja_at_home> #action harlowja_at_home setup octavia + oslo master jobs (or try to)
16:11:22 <harlowja_at_home> let's see if we can get them :-P
16:11:29 <johnsom> harlowja_at_home You know how to find me if there is something I can help with
16:11:41 <harlowja_at_home> i'll come get u if needed :-P
16:11:47 <harlowja_at_home> where u live again
16:11:48 <harlowja_at_home> lol
16:12:03 <johnsom> Oregon, it's a short drive....  grin
16:12:07 <harlowja_at_home> :-p
16:12:35 <harlowja_at_home> #topic Newton specs
16:12:49 <harlowja_at_home> #link https://review.openstack.org/#/q/status:open+project:openstack/oslo-specs,n,z
16:13:14 <harlowja_at_home> it would be super to have folks that are interested review more of those (myself included, ha)
16:13:19 <jungleboyj> harlowja_at_home: Oh sweet, who set up the periodic job for Cinder?
16:13:30 <harlowja_at_home> i think that would be dims
16:13:42 <harlowja_at_home> i'll setup an octavia one and then i'll know how to do it :-P (i don't think its hard)
16:14:00 <dims> y should be easy hopefully
16:14:48 <harlowja_at_home> jd__, u around
16:14:54 <harlowja_at_home> i guess http://status.openstack.org/openstack-health/#/g/build_name/periodic-ceilometer-py27-with-oslo-master might be something also
16:15:11 <harlowja_at_home> although i think that's the keystonemiddleware issue
16:15:12 <harlowja_at_home> anyways
16:15:20 <harlowja_at_home> #topic Stuck reviews
16:15:35 <harlowja_at_home> any stuck reviews that we can raise so folks can try to unstick them?
16:16:06 <harlowja_at_home> don't all speak up at once now, lol
16:16:43 <bknudson> I asked / was asked some questions on https://review.openstack.org/#/c/304923/
16:17:03 <rpodolyaka> bknudson: yeah, I'll respond to that one
16:17:03 <lxsli> https://review.openstack.org/#/c/293561/ needs reviews
16:17:05 <bknudson> "Fix db_version checking for sqlalchemy-migrate "
16:17:20 <harlowja_at_home> sqlalchemy-migrate  woah
16:17:36 <bknudson> keystone still uses sqlalchemy-migrate
16:17:54 <bknudson> haven't figured out how to switch to alembic... and haven't had a great reason to either.
16:18:03 <harlowja_at_home> cool cool, good to know
16:18:36 <rbradfor> if we are wanting to cleanup incubator code it may be good to get a +1 on reviews that are stuck in other projects.
16:19:00 <harlowja_at_home> rbradfor, where is the list of all those again
16:19:13 <rpodolyaka> bknudson: in oslo.db we have some utils to support both at the same time, so that you can eventually migrate to alembic, but it's not pretty  and I doubt anyone used it in the wild :(
16:19:21 <harlowja_at_home> rbradfor,  i'll +1 some stuff (or maybe liasons here can help)
16:19:46 <bknudson> rpodolyaka: can you point me to some docs for the tools?
16:19:47 <rpodolyaka> bknudson: IIRC, at some point zzzeek wanted to add support for sqlalchemy-migrate migrations to alembic
16:19:48 <rbradfor> unfortunately they fall under several topics, so not so easy to point to
16:20:19 <bknudson> any docs for switching from s-m to alembic would be handy.
16:20:45 <rbradfor> This is the link to the etherpad with more overview of adoption https://etherpad.openstack.org/p/oslo-libraries-adoption.  Reviews list per project may be dated, will look at it
16:21:02 <harlowja_at_home> also that reminded me https://github.com/openstack/oslo.tools is now up, so i think i can go through the final stages of moving oslo-incubator ---> openstack attic
16:21:06 <rpodolyaka> bknudson: let me take a look, but I'm afraid we don't have much, except for the API reference...
16:21:07 <bknudson> maybe just needs some kind of indicator that after this version, switch to alembic, which alembic would handle.
16:21:18 <harlowja_at_home> the tools repo there is just the tools from oslo-incubator
16:21:45 <harlowja_at_home> (the only part of the incubator that afaik was still used)
16:21:57 <harlowja_at_home> rbradfor, thx
16:22:19 <harlowja_at_home> #link https://etherpad.openstack.org/p/oslo-libraries-adoption
16:22:20 <rbradfor> harlowja_at_home, is there a fuel liason?
16:22:31 <harlowja_at_home> rbradfor, not that i am aware of
16:22:44 <harlowja_at_home> dims, do u know anyone at mirantis that might be a candiate for that
16:23:13 * harlowja_at_home doesn't see fuel @ https://wiki.openstack.org/wiki/CrossProjectLiaisons#Oslo
16:23:18 <bknudson> oslo.tools doesn't show up in http://git.openstack.org/cgit/openstack/openstack/tree/ ... wonder why that is?
16:23:25 <harlowja_at_home> bknudson, that's weird :-/
16:23:37 <bknudson> I'll ask on infra after the meeting.
16:23:40 <harlowja_at_home> kk
16:23:51 <harlowja_at_home> wonder how it can showup on github without being there, weird
16:23:55 <bknudson> I have a new process for keeping a local copy of the repos using http://git.openstack.org/cgit/openstack/openstack/tree/
16:24:37 <harlowja_at_home> cool
16:24:43 <harlowja_at_home> i should do that to
16:24:55 <harlowja_at_home> track all the openstack :-P
16:25:39 <harlowja_at_home> #topic Open discussion
16:25:48 <bknudson> remember to add oslo.tools to your watched projects: https://review.openstack.org/#/settings/projects
16:25:54 <harlowja_at_home> bknudson, thx
16:26:19 <harlowja_at_home> i gotta use that tree repo later (currently i just checkout repos individually)
16:26:52 <bknudson> it's just git clone the openstack/openstack , git submodule init oslo.*
16:27:07 <bknudson> then when you git pull it updates the ones that have changed.
16:27:15 <harlowja_at_home> cool
16:27:28 <harlowja_at_home> kgiusti, u are all set on https://review.openstack.org/#/c/319452/ right?
16:27:31 <rbradfor> bknudson, is this something new, or old and not clearly documented
16:27:55 <harlowja_at_home> rbradfor, also thx for the draft blog email, i'll check that out today (just wanted to let u know i got it)
16:27:58 <bknudson> rbradfor: openstack/openstack has existed forever as far as I know
16:28:08 <bknudson> I just didn't know how to use submodules
16:28:47 <rbradfor> harlowja_at_home, sure. generally one just blogs, but I'd like a second eye on it, as we could use it as a base point for talking about individual libraries
16:28:59 <harlowja_at_home> rbradfor, cools
16:29:17 <sileht> openstack/openstack is not really up2date
16:29:18 <harlowja_at_home> jroll, u are still thinking https://review.openstack.org/#/c/308398  might not be needed right? (if u are around)
16:29:36 <jroll> harlowja_at_home: it isn't on my priority list at the moment
16:29:47 <harlowja_at_home> lxsli, ^ that might affect the parser stuffs there
16:29:53 <harlowja_at_home> jroll, thx, that's fine with me :)
16:30:03 <jroll> np
16:30:15 * jroll wips for now
16:30:24 <harlowja_at_home> thx
16:31:24 <harlowja_at_home> alright anything else folks want to talk about, if not guess we can end early
16:31:36 <harlowja_at_home> i was thinking i'll send out a ML email to get https://wiki.openstack.org/wiki/CrossProjectLiaisons#Oslo updated
16:31:48 <harlowja_at_home> rbradfor, i'll poke about a fuel liason in that email as well
16:32:21 <rbradfor> harlowja_at_home, thanks. There were issues with a failing bandit test being required (seems it's not now), so I'll start with a recheck
16:32:22 <sileht> harlowja_at_home, why fuel liaison do they consume our libs ?
16:32:23 <harlowja_at_home> poke and/or mention
16:33:39 <harlowja_at_home> good question, and i shall investigate that before mentioning oslo liason in that email ;)
16:33:54 <harlowja_at_home> to many fueld repos, lol
16:34:12 <harlowja_at_home> https://github.com/openstack?page=1&query=fuel
16:34:22 <harlowja_at_home> page 1 of 5 :-/
16:34:59 <sileht> most of them are puppet stuff
16:35:58 <harlowja_at_home> ya, lots of plugins
16:36:12 <harlowja_at_home> anyways, i'll see if fuel wants/needs a liason
16:37:03 <harlowja_at_home> okie dokie, anything else from folks? otherwise 20 minutes of your time back :-P
16:37:51 <harlowja_at_home> see ya'll on #openstack-oslo then :)
16:37:53 <dougwig> ihrachys: aye, link?
16:38:05 <ihrachys> dougwig: that was false alarm, sorry.
16:38:09 <harlowja_at_home> dougwig, false alarm afaik :)
16:38:15 <dougwig> ihrachys: ok, no worries. :)
16:38:29 <harlowja_at_home> #endmeeting