16:00:18 <harlowja_at_home> #startmeeting oslo
16:00:19 <openstack> Meeting started Mon Jun  6 16:00:18 2016 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:24 <openstack> The meeting name has been set to 'oslo'
16:00:31 <rpodolyaka> o/
16:00:35 <harlowja_at_home> courtesy ping for amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims
16:00:36 <harlowja_at_home> courtesy ping for dougwig, e0ne, flaper87, garyk, gcb, GheRivero, haypo
16:00:36 <harlowja_at_home> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz
16:00:36 <harlowja_at_home> courtesy ping for lifeless, lintan, lxsli, Nakato, ozamiatin, rbradfor, redrobot
16:00:36 <harlowja_at_home> courtesy ping for rpodolyaka, sergmelikyan, sileht, spamaps, sreshetnyak, sreshetnyak, stevemar
16:00:38 <harlowja_at_home> courtesy ping for therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:00:45 <ozamiatin> o/
16:00:45 <harlowja_at_home> o/
16:00:47 <kgiusti> o/
16:00:48 <rbradfor> o/
16:00:54 * harlowja_at_home needs more coffee, lol
16:01:26 <ihrachys> o/
16:01:44 <amrith> ./
16:01:51 <harlowja_at_home> hi there, let's get started i suppose
16:02:07 <bknudson> hi
16:02:10 <harlowja_at_home> #topic Red flags for/from liaisons
16:02:19 <harlowja_at_home> anything folks need to bring up?
16:02:27 <bknudson> nothing for keystone that I know of.
16:02:28 <harlowja_at_home> (from a liason perspective)
16:02:34 <amrith> nothing from the world of trove
16:02:48 <ihrachys> nothing from neutron. we were broken in mitaka by config_dir option type change, but we handled it on our side.
16:03:03 <harlowja_at_home> cool, good to know
16:04:03 <harlowja_at_home> #topic Releases for newton
16:04:16 <harlowja_at_home> anyone need anything specifically released ?
16:04:27 <harlowja_at_home> otherwise i'll post a larger set of oslo things to get out today
16:04:51 <harlowja_at_home> (but let me know if any such thing should wait/or be prioritized sooner)
16:05:06 * ihrachys checks neutron periodic job trend. all clear, 0% failure rate.
16:05:20 <harlowja_at_home> ya, i'll look those over as well (need more coffee first, ha)
16:05:28 <harlowja_at_home> i do like 0% failure though
16:05:30 <harlowja_at_home> +2
16:05:31 <harlowja_at_home> ha
16:06:07 <ihrachys> :)
16:06:09 <bknudson> 0% failure means you're not taking enough risks
16:06:20 <harlowja_at_home> lol
16:06:25 <harlowja_at_home> true dat
16:06:31 <ihrachys> right. it becomes too boring, developers look at greener riskier pastures
16:06:56 <ihrachys> like importing from tempest :P
16:06:58 <harlowja_at_home> i'll break some stuff so that it isn't 0%
16:06:59 <harlowja_at_home> lol
16:07:07 <harlowja_at_home> #action harlowja_at_home break some things, lol
16:07:14 <ihrachys> attaboy
16:07:34 <harlowja_at_home> don't want people getting used to things working u know
16:07:35 <harlowja_at_home> lol
16:07:42 <harlowja_at_home> (managing expectations ...)
16:08:03 <harlowja_at_home> #topic Farewell oslo-incubator
16:08:12 <rbradfor> testing is not about showing that your software works, testing is about breaking software.
16:08:22 <bknudson> it's taken a long time to exorcise this.
16:08:30 <harlowja_at_home> so just fyi this is nearly done
16:08:36 <harlowja_at_home> #link https://review.openstack.org/#/c/320680/
16:08:40 <ihrachys> neutron just removed the last incubator bit the previous week. good timing!
16:08:46 <harlowja_at_home> thx gcb for helping there
16:09:05 <harlowja_at_home> ya, the repo is being blown up/torn down
16:09:15 <harlowja_at_home> nearly there
16:10:30 <harlowja_at_home> #topic Specs
16:10:56 <harlowja_at_home> so this week i'm gonna try to get all these specs cleaned up (at least my own)
16:11:01 <harlowja_at_home> #link https://review.openstack.org/#/q/project:openstack/oslo-specs
16:11:16 <harlowja_at_home> seems like other projects are also finalizing there newton specs this week
16:11:33 <bknudson> spec proposal freeze was last week for keystone
16:11:39 <harlowja_at_home> right
16:12:13 <harlowja_at_home> any specs there in that list people urgently need folks to look over (for some definition of urgent)
16:13:07 <harlowja_at_home> ok, assuming not then :-P
16:13:18 <rbradfor> hold a sec
16:13:18 <harlowja_at_home> i'll clean up all mine and get those in shape
16:13:19 <harlowja_at_home> k
16:13:45 <rbradfor> I'd like to see some more feedback on deprecation policy -- https://review.openstack.org/#/c/288720/
16:14:03 <harlowja_at_home> ya
16:14:04 <harlowja_at_home> +1
16:14:14 <rbradfor> there has been some other review about adding another attribute, and it would be good for us to standardize on.
16:14:18 * rbradfor looks for said review
16:14:53 <harlowja_at_home> https://review.openstack.org/#/c/288720/ has been a long time coming, so i'll also look over it again
16:15:03 <rbradfor> harlowja_at_home, I know you raised comments about versionedutils in comparison to debtcollector usage
16:15:04 <harlowja_at_home> see if i can find/think of anything new
16:15:15 <harlowja_at_home> ya, likely
16:15:40 <rbradfor> https://review.openstack.org/#/c/307671/
16:15:48 <bknudson> is this trying to set deprecation policy for other projects? That doesn't seem appropriate for an oslo spec.
16:15:57 <rbradfor> a proposal to add deprecated_version.
16:16:32 <rbradfor> bknudson, it's a policy to be used in all Oslo projects, and then for us to promote adoption of how to deprecate stuff in a consistent and reproducible manner.
16:16:38 <rbradfor> some of the goals of the Oslo project.
16:16:44 <harlowja_at_home> ah, https://review.openstack.org/#/c/307671/ seems nice, will look over that
16:17:00 <rbradfor> in order to use/enforce in all Oslo projects, I'd like to know we are in agreement
16:17:35 <rbradfor> https://review.openstack.org/#/c/307671/, only goes part of the way, I'd proposed to ML more detailed info, for example, a deprecated_version and a removal_version.
16:17:54 <harlowja_at_home> ya, seems fair to have that
16:18:09 <rbradfor> so it's clear which release stuff is to be removed, not just a +2 policy, by adding as an attribute, it gets into all docs, help text etc.
16:18:17 <harlowja_at_home> yup
16:18:22 <rbradfor> or in the case of some projects, something is deprecated but it's not expected to be removed.
16:19:00 <bknudson> we're looking to add a tool for keystone that will show when deprecated options are used.
16:19:07 <bknudson> rather than having to search the logs
16:19:21 <bknudson> so this might cause changes to oslo.config
16:19:26 <rbradfor> bknudson, there is a nice deprecated log file that dims added
16:19:33 <rbradfor> for devstack gates
16:19:51 <bknudson> this would be for operators not just devs.
16:20:06 <rbradfor> bknudson, e.g. http://logs.openstack.org/36/294136/1/gate/gate-tempest-dsvm-full/b34704d/logs/deprecations.txt.gz
16:20:13 <harlowja_at_home> ah, thats nice
16:20:23 <rbradfor> bknudson, I agree.
16:20:45 <harlowja_at_home> 'Its value may be silently ignored in the future' :-/
16:20:46 <harlowja_at_home> lol
16:21:00 <harlowja_at_home> (from that log)
16:22:23 <harlowja_at_home> ok, let's see if we (as a group) can look over that depreciation standardization work and come to some agreement
16:22:32 <harlowja_at_home> i'd like that, pretty sure rbradfor would to ;)
16:22:59 <harlowja_at_home> #topic Stuck reviews
16:23:13 <harlowja_at_home> any stuck reviews that people want to raise (so that they may get unstuck?)
16:23:21 <harlowja_at_home> (raise or discuss)
16:23:39 <rbradfor> yes
16:24:04 <rbradfor> Oslo Incubator cleanup, these reviews in other projects have been idle 4-8 weeks. Could some Oslo reviewers please +1 so hopefully the respective cores will pick up and get them approved -- https://review.openstack.org/#/c/312175/, https://review.openstack.org/#/c/312171/, https://review.openstack.org/#/c/297330/, https://review.openstack.org/#/c/297329/, https://review.openstack.org/#/c/294730/, https://review.openstack.org/#/c/294775/
16:24:26 <rbradfor> given we are deleting the project, this ongoing cleanup should still be a goal for Newton
16:24:45 <harlowja_at_home> yup
16:24:58 <harlowja_at_home> i'll give those a good look over today
16:24:59 <rbradfor> they have various different topics, so it's hard to provide a single link.
16:25:14 <harlowja_at_home> np
16:25:22 <rbradfor> harlowja_at_home, thanks. I think your a person that has +1 some already
16:25:41 <harlowja_at_home> yup yup, seems like i did find some of those, will look over the rest (that i must of missed or something, ha)
16:25:52 <harlowja_at_home> 'openstack/sticks-dashboard'
16:25:56 <rbradfor> let's get somebody else to help out to.
16:25:57 <harlowja_at_home> i wonder what that project is, lol
16:26:26 <rbradfor> some projects are very idle, and hence I was able to retire the entire kite project based on proposing incubator cleanup
16:26:39 <harlowja_at_home> ya
16:26:41 <rbradfor> happy to kill off a few more, so codesearch shows no incubator code
16:26:45 <harlowja_at_home> need a GC for projects
16:26:50 <harlowja_at_home> rbradfor,  the GC
16:26:51 <harlowja_at_home> lol
16:27:05 <rbradfor> GC?
16:27:12 <harlowja_at_home> garbage collector
16:27:42 <rbradfor> doh!
16:28:21 <amrith> He's from NYC/NJ. If I were you, I wouldn't make fun of the garbage collector. Otherwise you may 'become part of the landfill'.
16:28:26 <harlowja_at_home> :)
16:29:27 <harlowja_at_home> any other stuck reviews from folks?
16:30:26 <harlowja_at_home> #topic Open discussion
16:30:54 <kgiusti> got a general 'feature branch etiquette" question...
16:31:07 <harlowja_at_home> sileht, yt, if u are do u mind responding to http://lists.openstack.org/pipermail/openstack-dev/2016-June/096607.html
16:31:11 <amrith> I have a q re: 290907 (https://review.openstack.org/#/c/290907/)
16:31:23 <amrith> and a question about isotime() since everyone misses that ...
16:31:38 <harlowja_at_home> kgiusti, whats up (not sure i can answer, but maybe someone can, ha)
16:31:52 * amrith waits for harlowja_at_home to hand me a microphone
16:31:59 * harlowja_at_home hands amrith a mic
16:31:59 <harlowja_at_home> lol
16:32:01 <kgiusti> Do patches going onto the feature branch need multiple reviewers?
16:32:09 <amrith> so the first question is about https://review.openstack.org/#/c/290907/
16:32:30 <amrith> I'm hoping we can come to a quick decision on it (preferably in line with my review comments).
16:32:36 <rbradfor> amrith and I had a dicussion over beer about 290907
16:32:38 <amrith> I'd hate to see a change to this ...
16:32:49 * amrith nods; was good beer
16:32:49 <bknudson> I'd prefer the same review criteria for feature branches as for master.
16:33:20 <bknudson> unless there's a plan for another review step before the code is merged to master?
16:33:26 <amrith> my question about isotime(). Does anyone know of a project that actually took the recommended advice of using datetime.datetime.isoformat()?
16:33:28 <bknudson> I wouldn't want to work that way
16:33:44 <harlowja_at_home> ya, same here, what have people done that have used feature branches on gerrit previously (i haven't used one yet)
16:33:46 <amrith> as far as I can tell, everyone just took the code from timeutils and made it their own; warts and all.
16:33:53 * amrith hands microphone to harlowja_at_home
16:34:15 <rbradfor> to summarize our discussion, on one side (the spec), proposals standardizing names of arguments because multiple projects just effective duplicate _id versions, and then there is differing code duplicated.  So, in Oslo form, our goal should be to reduce, simplify and provide consistent code.
16:34:15 <kgiusti> bknudson: It's likely that further work will iteratively modify the code until the feature is finished
16:34:34 <rbradfor> on the other side as amrith correctly points out, it's doesn't add any real value.
16:34:58 <amrith> rbradfor, ironically it will have the same effect as attempting to deprecate isotime :)
16:35:16 <harlowja_at_home> so for isotime() some projects as u stated took the code themselves, i've used isoformat() in a library of mine without issue, but i think if a project felt they really needed it (for some reason) that it was ok (but not preferable imho) to just copy over isotime()
16:36:32 <harlowja_at_home> or at least i think that was the consensus for that isotime -> isoformat dilemma
16:36:36 <rbradfor> my concern in these two cases, when 3 new projects come onboard, do they simply copy said code also.  And when somebody modifies 'their' version, when/how do other projects know about it, or determine it's validity, and need to incorporate
16:37:41 <bknudson> if we have a v4 of the identity API I assume we'll go with isoformat for timestamps.
16:37:53 <harlowja_at_home> ya, i think that new projects should just use isoformat from the get-go
16:38:12 <bknudson> or maybe we can change it in a microversion
16:38:51 <kgiusti> seems silly to have 2x+2 on this: https://review.openstack.org/#/c/325916/
16:39:25 <bknudson> kgiusti: I don't think you need 2x+2 for administrative reviews like this one.
16:39:57 <kgiusti> bknudson: agreed!
16:40:01 <harlowja_at_home> kgiusti, i forget, but when that feature branch --> master; does the whole thing get reviewed at that point
16:40:23 <kgiusti> harlowja_at_home: I haven't the foggiest - that would be ideal
16:40:41 <harlowja_at_home> i thought something like that happened
16:41:31 <dhellmann> kgiusti, harlowja_at_home : I think there's a merge commit, but I don't think you want to wait that long to have strong review. It'd be a lot more code if you wait until the end.
16:41:44 <harlowja_at_home> right
16:41:47 <bknudson> reviewing large changes doesn't work well. Reviewers get burned out and don't do careful reviews.
16:42:12 <kgiusti> gotcha
16:42:16 <bknudson> and you don't want to have to rework everything.
16:42:20 <harlowja_at_home> agreed, so i guess kgiusti do your best if u can, for administrative ones, meh, i guess those are fine
16:42:32 <harlowja_at_home> bknudson, right
16:42:32 * kgiusti breaks out his 'need a review bat'
16:42:41 <harlowja_at_home> lol
16:42:41 <kgiusti> no problem
16:42:56 <kgiusti> thanks
16:43:03 <bknudson> review cookies might work better.
16:43:05 <harlowja_at_home> lol
16:43:18 <kgiusti> only if you come to the dark side...
16:43:33 <amrith> harlowja_at_home, thanks for the clarification re: isotime. I'm wondering which way to go for trove
16:43:51 <amrith> leaning towards the isoformat() route but unfortunately can't find someones footsteps to follow
16:43:55 <harlowja_at_home> amrith, i'd try isoformat first, if u really can't just use it, then we can figure out what u can do
16:44:11 <bknudson> if you're going the typical route you should just pick a new random format
16:44:12 <amrith> I think it should be fine for Trove
16:44:16 <bknudson> ;)
16:44:37 <amrith> bknudson, yes. I was thinking pope Gregory had something to say about that ...
16:44:59 <harlowja_at_home> the pope uses isotime() ?
16:45:00 <harlowja_at_home> lol
16:45:26 <bknudson> seconds since trove 1.0
16:45:31 <amrith> Since ~1582
16:45:53 <harlowja_at_home> ah, ya that gregorian time stuff ( i got the joke now, ha)
16:46:14 <amrith> but I much prefer bknudson's definition of the epoch
16:46:18 <amrith> BT and AT
16:46:22 <bknudson> isoformat looks like the way to go.
16:46:24 <harlowja_at_home> :)
16:46:41 <amrith> bknudson, yes. I think so
16:46:48 <amrith> it should work for Trove
16:47:18 <harlowja_at_home> cool
16:47:34 <harlowja_at_home> alright, guess we can continue with anything else in #openstack-oslo as needed
16:47:40 <harlowja_at_home> unless anything else people want to bring up?
16:47:55 <amrith> harlowja_at_home, at some point I'd love to have some decision on the review I brought up
16:48:00 <amrith> to put it to rest, hopefully
16:48:12 <amrith> it is (at this point) a concern for Trove
16:48:13 <harlowja_at_home> agreed
16:48:16 <amrith> as we use oslo.context
16:48:24 <amrith> and if the thing changes; then we have a verioning issue
16:48:27 <amrith> versioning
16:48:50 <amrith> and since for other reasons (bad ones) trove doesn't yet version it's RPC API (shame, shame) this would be a serious problem for us.
16:48:53 <harlowja_at_home> i thought u guys had a happy beer over it, lol
16:48:58 <rbradfor> amrith, any changes will always be backward compatible for 1+ versions, however your concern is need for that longer right?
16:49:11 <amrith> to drown my sorrows on this one would take more than beer
16:49:15 <harlowja_at_home> lol
16:49:22 <amrith> rbradfor, my issue is that we need versions first
16:49:26 <amrith> before you go make this change :)
16:49:37 <amrith> and currently that's a big hill
16:49:47 <rbradfor> harlowja_at_home, we had a happy discussion, and amrith points are totally valid, and I would agree.
16:50:24 <harlowja_at_home> gotcha
16:51:12 <rbradfor> I want to add some more specific details to the spec, a code example and also lists of projects duplicating code (in varying ways)
16:51:47 <harlowja_at_home> sounds good to me
16:52:50 <harlowja_at_home> okie dokie, amrith rbradfor we will come to some conclusion there, i just know it (and hopefully not in a few years, ha)
16:53:30 <rbradfor> as per my discussion with amrith,  what is the means to justify a change, if we take the true agile approach, we construct ALL functionality for new code to be a user story. i.e. how does it benefit the end user.
16:53:42 <amrith> well, some incentives would help. I think beer is a good start, don't you rbradfor?
16:53:46 <amrith> harlowja_at_home, could buy :)
16:53:51 <rbradfor> however, a lot of work done in OpenStack does not even start with the basic premise.
16:54:12 <amrith> the basic premise that beer helps decision making?
16:54:22 <amrith> :)
16:54:26 <harlowja_at_home> or 'how does it benefit the end-user' ?
16:54:30 <amrith> rbradfor, let's discuss some more
16:54:34 <harlowja_at_home> or how does beer benefit the end-user?
16:54:35 <harlowja_at_home> lol
16:54:36 <rbradfor> ok, beer wins, lets all finish up now and have a beer
16:55:02 <harlowja_at_home> ha, ok
16:55:08 <harlowja_at_home> until next time!
16:55:14 <rbradfor> harlowja_at_home, thanks
16:55:17 <amrith> toodle-doo
16:55:19 <harlowja_at_home> thanks those who  showed up for coming :)
16:55:29 <harlowja_at_home> #openstack-oslo for further things!
16:55:33 <harlowja_at_home> #endmeeting