16:00:06 <harlowja_at_home> #startmeeting oslo
16:00:10 <openstack> Meeting started Mon Jul 18 16:00:06 2016 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <openstack> The meeting name has been set to 'oslo'
16:00:23 <harlowja_at_home> courtesy ping for amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims
16:00:24 <harlowja_at_home> courtesy ping for dougwig, e0ne, flaper87, garyk, gcb, GheRivero, haypo
16:00:24 <harlowja_at_home> courtesy ping for ihrachyshka, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz
16:00:24 <harlowja_at_home> courtesy ping for lifeless, lintan, lxsli, Nakato, ozamiatin, rbradfor, redrobot
16:00:24 <harlowja_at_home> courtesy ping for rpodolyaka, sergmelikyan, sileht, spamaps, sreshetnyak, sreshetnyak, stevemar
16:00:25 <harlowja_at_home> courtesy ping for therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:00:30 <rpodolyaka> o/
16:00:34 <rbradfor> o/ o/ o/
16:00:42 <gcb> o/
16:00:42 <johnsom> o/
16:00:51 <harlowja_at_home> yo yo
16:01:51 <harlowja_at_home> alright, guess we'll get going and see who wonders in :-P
16:01:56 <harlowja_at_home> #topic Red flags for/from liaisons
16:02:05 <gcb> oslo.context 2.6 breaks Nova test, dims block this version in g-r
16:02:07 <harlowja_at_home> i guess nova had a red flag @ http://lists.openstack.org/pipermail/openstack-dev/2016-July/099467.html
16:02:12 <johnsom> Nothing to report in load balancing land
16:02:21 <harlowja_at_home> ya, thx gcb and dims_ for that
16:02:37 <ihrachys> nothing on neutron side
16:02:42 <osh> no red flags from murano
16:02:50 <SpamapS> o/
16:03:50 <harlowja_at_home> gcb,  any idea why that broke nova?
16:04:07 <harlowja_at_home> https://review.openstack.org/#/c/331916/4/oslo_context/context.py doesn't seem like it should have
16:04:18 <rbradfor> harlowja_at_home, gcb I know, see https://review.openstack.org/#/c/343694/
16:04:40 <rbradfor> nova (and other projects) are doing a dictionary comparison, and is_admin_project was added to dictionary
16:04:46 <harlowja_at_home> ah
16:04:56 <rbradfor> patch does a attribute comparison on "what we want to test in the project"
16:05:03 <harlowja_at_home> kk
16:05:05 <harlowja_at_home> ya, that makes sense
16:05:16 <rbradfor> i patched it in senlin also, seems a lot of other projects are unaffected
16:05:43 <harlowja_at_home> ya, i wouldn't call it a need for 3.0 for that, just more of nova needs to stop doing those kinds of equivalence tests
16:05:47 <rbradfor> however I'd like to ask, I thought periodic tests were running against oslo master, should we not know about these problems before a release.
16:06:38 <dims_> rbradfor : harlowja_at_home : right. are the tests green or red? :)
16:06:43 <gcb> http://status.openstack.org/openstack-health/#/job/periodic-nova-py34-with-oslo-master
16:06:51 <rbradfor> well, they have blacklisted it now, jamielennox is not on, but he had another patch in 2.6, as did 1. There was also something that missed 2.6
16:07:11 <harlowja_at_home> ya, its a good question, pretty sure i checked last week for the periodic tests
16:07:16 <dims_> the tests were failing and we still pushed out a release :(
16:07:39 <rbradfor> dims_, gcb could we take a moment now, or after meeting in -olso to understand/explain the periodic tests some more so we can pre-empt this next time
16:07:58 <harlowja_at_home> now is fine
16:08:03 <harlowja_at_home> usually i check http://status.openstack.org/openstack-health/#/?groupKey=build_name&resolutionKey=hour&searchProject=-with-oslo before releases
16:08:11 <dims_> #link https://etherpad.openstack.org/p/dims-periodic-jobs
16:09:00 <gcb> the jobs will tell us whether the master branch of oslo.* will break consuming projects
16:09:30 <rbradfor> status still trying to load for me?
16:10:01 <gcb> they're useful to avoid breaking projects when we release new version lib
16:10:21 <harlowja_at_home> rbradfor, it takes a while
16:10:42 <harlowja_at_home> so intersting for this one i think was that https://review.openstack.org/#/c/340578/ was merged on july 12th
16:10:58 <harlowja_at_home> which if we do a little analysis shows that nova was green then on july 11th
16:11:11 <harlowja_at_home> on http://status.openstack.org/openstack-health/#/g/build_name/periodic-nova-py27-with-oslo-master
16:11:18 <harlowja_at_home> it started failing july 13th
16:11:37 <harlowja_at_home> so dims_ i don't quite think it was a purposely done release of bad things
16:11:59 <harlowja_at_home> just more of a odd coincidence (there seems to be a periodic run on july 12th of nova that is missing, lol)
16:12:16 <dims_> harlowja_at_home : aha
16:12:52 <harlowja_at_home> ya, a little odd
16:12:55 <rbradfor> also, actually the nova tests check for warnings so even writing better tests still fail (and will with subsequent warning emitting, a present review) http://git.openstack.org/cgit/openstack/nova/tree/nova/tests/unit/test_context.py#n144
16:13:16 * jd__ votes for killing oslo.context anyway
16:13:32 * amrith sneaks in and hopes no one will notice; really, I was here all along
16:13:34 <harlowja_at_home> rbradfor, damn, tests against log output make me sad, lol
16:13:36 <rbradfor> jd__, good luck with that, it's used extensively in logging.
16:13:40 <dims_> i had another layer of protection. a set of jobs running against bot proposed updates. that failed as well
16:13:54 <jd__> rbradfor: let's kill logging too lol
16:14:05 <dims_> i'll request the new requirements cores to chase that
16:14:33 <harlowja_at_home> dims_, is that a new set of jobs?
16:15:12 <dims_> https://review.openstack.org/#/q/status:open+branch:master+topic:dims/test/constraints
16:15:20 <dims_> harlowja : ^
16:15:40 <harlowja_at_home> kk, gotcha
16:16:21 <harlowja_at_home> it'd be nice to somehow get that plugged in more offically somehow
16:16:53 <dims_> harlowja : i'll let you ping say coolsvap about it :)
16:17:11 <harlowja_at_home> kk
16:17:49 <harlowja_at_home> #topic Releases for newton
16:17:53 <rbradfor> should we discuss the "3.0.0" suggestion?
16:17:57 <harlowja_at_home> ya
16:18:09 <harlowja_at_home> and/or any other releases that people want/need
16:18:19 <harlowja_at_home> the 3.0 suggestion, feels a little weird
16:18:42 <harlowja_at_home> and perhaps should be better suited by better docs around what is public and what isn't
16:18:43 <rbradfor> harlowja_at_home, I don't see the justification, we augment api signatures to make them compatible.
16:18:50 <harlowja_at_home> right
16:19:05 <harlowja_at_home> and to_dict doesn't seem like it should be a thing projects are testing content of
16:19:23 <rbradfor> it's not the new argument that's the problem, it's that a method is now returning a dictionary with an additional attribute.
16:19:30 <dims_> we should check the jobs more often...........
16:19:42 <rbradfor> not something I feel warrants a major release.
16:19:42 <harlowja_at_home> dims_, ya, that to :-P
16:19:52 <gcb> dims_ +1
16:19:54 <harlowja_at_home> rbradfor, i agree
16:20:15 <dims_> it's just not just the 1 person(s) job :)
16:20:18 <harlowja_at_home> git.openstack.org/cgit/openstack/nova/tree/nova/tests/unit/test_context.py feels like it does alot of internal oslo.content checks
16:20:44 <harlowja_at_home> dims_, ya, agreed, i'm gonna make a little bot later that will watch those jobs and write them into irc
16:20:51 <rbradfor> harlowja_at_home, I had this discussion with dhellmann for another project, and I proposed reducing tests on his comments to sub-classed attributes only.
16:20:53 <harlowja_at_home> (assuming i can get at the data, ha)
16:21:28 <harlowja_at_home> rbradfor, that'd make sense i think
16:21:36 <rbradfor> having nova accept that oslo.context is doing the tests on its behalf will probably be a more complex task
16:21:42 <harlowja_at_home> http://git.openstack.org/cgit/openstack/nova/tree/nova/tests/unit/test_context.py#n83 feels weird imho
16:22:38 <harlowja_at_home> rbradfor, agreed
16:22:44 <harlowja_at_home> dims do u know if http://status.openstack.org/openstack-health/#/g/build_name/periodic-nova-py27-with-oslo-master comes in json form :-P
16:22:45 <rbradfor> each project takes on subclassing different, and some even have errors processing kwargs, you only detect any inconsistencies after you try to remove it.
16:24:21 <harlowja_at_home> right
16:24:32 <timothyb89> harlowja_at_home: depending on which part of the page you're looking for, http://health.openstack.org/runs/key/build_name/periodic-nova-py27-with-oslo-master
16:24:51 <harlowja_at_home> timothyb89, kk, i'll see what i can grab later
16:25:07 <harlowja_at_home> and make an IRC bot that at least sends that data (on failing) right into IRC periodically :-P
16:25:40 <timothyb89> harlowja_at_home: oh, for failures you'd want http://health.openstack.org/runs/key/build_name/periodic-nova-py27-with-oslo-master/recent (or rss at  http://health.openstack.org/runs/key/build_name/periodic-nova-py27-with-oslo-master/recent/rss )
16:25:42 <harlowja_at_home> #action harlowja make that IRC bot
16:25:54 <harlowja_at_home> ah, cool, thx timothyb89
16:25:59 <harlowja_at_home> that will likely work
16:26:25 <harlowja_at_home> so rbradfor do u want to send out a ML response to the nova one or shall i ;)
16:26:37 <harlowja_at_home> about 3.0 and how it sorta umm doesn't feel needed
16:26:40 <rbradfor> harlowja_at_home, I can tackle that.
16:27:33 <harlowja_at_home> k, i can send a little retrospective on how that got released (jobs being green on july 11th before release and ...) and how I'm going to make a more vocal periodic job 'emitter' thing
16:27:50 <harlowja_at_home> that'll hopefully be useful to someone, h
16:27:51 <harlowja_at_home> *ha
16:28:57 <harlowja_at_home> any other releases needed for folks of oslo libs?
16:29:12 <harlowja_at_home> i'll double check what there is to release when i get in (not thinking to much to get out anyway)
16:30:37 <harlowja_at_home> #topic Reviews needing review
16:31:00 <harlowja_at_home> any reviews that people want some more attention on that we can bring up here so that they (may) get more eyes on them :)
16:31:13 <harlowja_at_home> bring your reviews!
16:31:18 <harlowja_at_home> any reviews, lol
16:31:21 <harlowja_at_home> 2 for 1
16:31:49 <rbradfor> harlowja_at_home, well if your making that offer
16:31:58 * harlowja_at_home oh crap
16:31:58 <harlowja_at_home> lol
16:32:17 <harlowja_at_home> 0.5 for 1?
16:32:18 <harlowja_at_home> lol
16:33:04 <rbradfor> https://review.openstack.org/#/q/topic:context_refactor and https://review.openstack.org/#/q/topic:oslo_i18n_cleanup  are small tasks to bring projects closer to being consistent, one oslo.context related.
16:33:30 <harlowja_at_home> awesome
16:33:53 <harlowja_at_home> osh, ^ has one for murano
16:34:01 <harlowja_at_home> https://review.openstack.org/#/c/342912/
16:34:34 <rbradfor> there was also another project I tackled for oslo incubator cleanup https://review.openstack.org/#/q/status:open+project:openstack/gce-api+branch:master+topic:oslo_incubator_cleanup  but I may have missed something
16:34:41 <harlowja_at_home> man, alot of people went and subclasses the oslo.context stuff
16:34:48 <harlowja_at_home> *subclassed
16:35:04 <harlowja_at_home> i can see why people started testing to_dict themselves
16:35:32 <harlowja_at_home> gce-api project, is that still active?
16:35:36 <rbradfor> gce wasn't even subclassed, it was copied, but your point is valid for other projects
16:36:11 <rbradfor> harlowja_at_home, active (I don't know), but if inactive, than this serves as a measure to have this discussion
16:36:21 <rbradfor> it lead to me killing off kite.
16:36:35 <harlowja_at_home> agreed, seems a teeny bit active
16:36:50 <harlowja_at_home> but not exactly getting major work i can see from the review history
16:36:58 <rbradfor> I generally check commits before embarking on a project cleanup
16:37:01 <harlowja_at_home> ya
16:37:03 <osh> harlowja_at_home: got it
16:37:12 <harlowja_at_home> thx osh
16:38:11 * rbradfor thinks I should call myself the janitor, I cleanup a lot of stuff
16:38:19 <harlowja_at_home> the best janitor ever!
16:38:21 <harlowja_at_home> my hero
16:38:59 <rbradfor> definitely not a hero
16:39:16 <harlowja_at_home> :)
16:39:48 <harlowja_at_home> #topic Open discussion
16:40:25 <harlowja_at_home> rbradfor, anyway its much appreciated :)
16:40:28 <harlowja_at_home> at least i appreciate it :)
16:40:33 <harlowja_at_home> +1 appreciation
16:40:53 <harlowja_at_home> https://docs.google.com/document/d/1jdI8gkQKBE0G9koR0nLiW02d5rwyWv_-gAp7yavt4w8/ (tooz related) for those interested
16:40:57 <rbradfor> np, I consider them good Friday projects, something to knock off.
16:41:02 <harlowja_at_home> def
16:41:19 <harlowja_at_home> jd__, is that a guy from redhat?
16:41:28 <harlowja_at_home> <jschwarz> that is
16:41:31 <jd__> harlowja_at_home: yes
16:41:40 <harlowja_at_home> seems tested against RDO so was wondering about that
16:41:53 <harlowja_at_home> (in that canonical folks wouldn't test against RDO)
16:41:54 <harlowja_at_home> :-P
16:42:04 <jd__> you never know
16:42:07 <harlowja_at_home> ha
16:42:10 <harlowja_at_home> true dat
16:42:27 <gcb> harlowja_at_home,  it seems hacking does not belong to oslo any more, right ?
16:42:48 <harlowja_at_home> gcb, i believe that is correct, i think it got moved to QA ?
16:43:19 <gcb> yes,  so we need clean up oslo wiki page
16:43:28 <harlowja_at_home> https://review.openstack.org/#/admin/groups/153,members
16:43:35 <harlowja_at_home> guess infra-core and QA
16:43:53 <harlowja_at_home> gcb, good point, ya, we should probably have a link to new owners (at least)
16:44:03 <gcb> another one oslo.vesion was also retired , right
16:44:16 <harlowja_at_home> ya
16:44:42 <harlowja_at_home> thought we mentioned retired on it, guess not
16:44:50 <harlowja_at_home> another thing to update i suppose
16:45:28 <harlowja_at_home> gcb,  u want to do those updates or shall i?
16:45:31 <harlowja_at_home> (either is fine with me)
16:45:48 <gcb> ok, I will try to update the wiki :-)
16:46:01 <harlowja_at_home> k, let me know if u fail to :)
16:46:02 <harlowja_at_home> and i can try
16:46:08 <harlowja_at_home> tag-team to update the wiki, ha
16:46:29 <gcb> sure
16:46:45 <harlowja_at_home> so if i'm going to make an oslo-irc-bot
16:46:56 <harlowja_at_home> that will be able to give info about periodic jobs
16:47:00 <harlowja_at_home> anything else people want in it?
16:47:13 <harlowja_at_home> ability to +2 reviews excluded, lol
16:48:15 <gcb> Update about python3.5 support classifier , there  are still two oslo libs to fix before declaring.
16:48:27 <gcb> https://review.openstack.org/#/q/status:open+topic:py35+owner:%22ChangBo+Guo%28gcb%29+%253Ceric.guo%2540easystack.cn%253E%22
16:48:29 <harlowja_at_home> gcb, cool, which ones btw?
16:48:30 <harlowja_at_home> thx
16:48:57 <harlowja_at_home> 'It seems eventlet doesn't work well on Python 3.5'
16:48:59 <harlowja_at_home> :(
16:49:03 <harlowja_at_home> durn
16:49:23 <harlowja_at_home> eventlet, how i despise u, lol
16:49:47 * harlowja_at_home never did understand why openstack even needed it :(
16:50:12 <gcb> will find more details when I have time
16:50:23 <harlowja_at_home> cool, gcb i can see what i can gather also
16:50:27 <harlowja_at_home> maybe known eventlet issues
16:51:02 <gcb> harlowja_at_home, thanks
16:51:06 <harlowja_at_home> np
16:51:40 <harlowja_at_home> dims_, in your honor i might name the oslo bot 'dimsjr'
16:51:45 <harlowja_at_home> or maybe thats to weird, hahaha
16:52:06 <harlowja_at_home> 'dimsjr' has noticed the periodic jobs are failing
16:52:22 <rbradfor> it's a minidims
16:52:26 <harlowja_at_home> :)
16:52:51 <rbradfor> oh, I could think of some poor political references to how to name the bot!
16:53:07 <harlowja_at_home> i'll take any names u got
16:53:09 <harlowja_at_home> minidims, dimsjr
16:53:10 <harlowja_at_home> lol
16:53:19 <rbradfor> but being an international project we should leave the US/UK/EU and Australia out of it.
16:53:46 <harlowja_at_home> we just have to make the names global, UN based?
16:54:10 <harlowja_at_home> ha, anyway, guess we can figure that out later :-P
16:54:11 <dims_> haha
16:54:56 <harlowja_at_home> alright, bot names we can decide in #openstack-oslo (once i get some code together also, lol)
16:55:07 <harlowja_at_home> thanks all for coming :)
16:55:18 <harlowja_at_home> #endmeeting