16:00:06 <harlowja_at_home> #startmeeting oslo
16:00:06 <openstack> Meeting started Mon Sep 12 16:00:06 2016 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:09 <openstack> The meeting name has been set to 'oslo'
16:00:21 <harlowja_at_home> courtesy ping for amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims
16:00:22 <harlowja_at_home> courtesy ping for dougwig, e0ne, flaper87, garyk, gcb, GheRivero, haypo
16:00:22 <harlowja_at_home> courtesy ping for ihrachys, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz
16:00:22 <harlowja_at_home> courtesy ping for lifeless, lintan, lxsli, Nakato, ozamiatin, rbradfor, redrobot
16:00:22 <harlowja_at_home> courtesy ping for rpodolyaka, sergmelikyan, sileht, spamaps, sreshetnyak, sreshetnyak, stevemar
16:00:23 <harlowja_at_home> courtesy ping for therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:00:28 <johnsom> o/
16:00:30 <redrobot> o/
16:00:35 <harlowja_at_home> o/
16:00:46 <harlowja_at_home> \o/
16:00:50 <ihrachys> o/
16:00:50 <harlowja_at_home> \o
16:01:02 <rpodolyaka> o/
16:01:05 <bknudson> hi
16:01:10 <harlowja_at_home> yo yo
16:01:49 <harlowja_at_home> #topic Red flags for/from liaisons
16:02:00 <bknudson> haven't heard of any keystone issues
16:02:02 <harlowja_at_home> any issues for folks to report, looks like oslo.db release seems to be fine now :)
16:02:11 <johnsom> Nothing to report here
16:02:46 <harlowja_at_home> cool
16:02:49 <ihrachys> nothing from neutron I believe
16:02:51 <harlowja_at_home> #link https://releases.openstack.org/newton/schedule.html for folks also
16:02:59 <harlowja_at_home> RC1 I guess this week
16:03:27 <harlowja_at_home> ihrachys, great, good good
16:03:33 <harlowja_at_home> less issues the better ;)
16:03:58 <ihrachys> especially considering the mess I triggered the last time :P
16:04:01 <harlowja_at_home> lol
16:04:18 <harlowja_at_home> it all got worked through, no worries ;)
16:05:31 <harlowja_at_home> #topic Ongoing work and specs and reviews
16:05:49 <harlowja_at_home> so I think folks are mostly working on docs, examples and such right now :)
16:06:15 <harlowja_at_home> if people also want to look @ https://review.openstack.org/#/q/project:openstack/oslo-specs that'd be great to
16:06:46 <harlowja_at_home> if some of those are dead/outdated/need updating, getting around to adjusting those; sooner (rather than later) would be super
16:06:58 <harlowja_at_home> lxsli, some of the ones u have might need adjusting?
16:07:09 <harlowja_at_home> (as well as some of my own, ha)
16:08:00 <harlowja_at_home> any other reviews that people want to highlight so that we can get some eyes on them?
16:08:41 <kgiusti> some doc updates https://review.openstack.org/#/c/368513/  for the messaging peeps
16:08:57 <harlowja_at_home> thx kgiusti (i read that over a little while ago, looks good)
16:09:10 <lxsli> harlowja_at_home: yeah I'll take a look
16:09:26 <kgiusti> made some "intelligent" guesses - oversight is needed.
16:09:34 <harlowja_at_home> kgiusti, def makes me think we need some kind of 'capabilities table' or something for each driver
16:10:16 <kgiusti> def - where we know the "known unknowns" - stuff that's not implemented
16:10:25 <harlowja_at_home> ya
16:10:38 <harlowja_at_home> other one i'd also really like soonish is https://review.openstack.org/#/c/229194/
16:11:03 <harlowja_at_home> keep on finding various hacky exception transfer (serialize/unserialize) functions in various places
16:11:05 <harlowja_at_home> lol
16:11:47 <harlowja_at_home> nova cells has 1 variant, oslo.messaging has a similar variant, (i forget wherelse, ha)
16:12:31 <harlowja_at_home> https://github.com/openstack/nova/blob/master/nova/cells/messaging.py#L1869 (not kidding, ha)
16:13:20 <harlowja_at_home> maybe i'll throw something together for that this week
16:13:53 <harlowja_at_home> #topic Ocata summit planning
16:14:10 <harlowja_at_home> just a reminder for folks to add on to https://etherpad.openstack.org/p/ocata-oslo-summit-planning with ideas and such :)
16:14:21 <harlowja_at_home> (comes out of #link http://lists.openstack.org/pipermail/openstack-dev/2016-August/102553.html )
16:15:08 <harlowja_at_home> if folks want to discuss specs, new things, new ideas, ... please put them in that etherpad so we can schedule them :)
16:16:44 <harlowja_at_home> #topic Open discussion
16:16:53 <harlowja_at_home> guess it's a short meeting :-P
16:17:22 <harlowja_at_home> anything else people want to bring up (i'm guessing most everyone busy trying to get RC1 newton and ... going)
16:17:48 <harlowja_at_home> PTL nominations also!
16:18:12 <harlowja_at_home> if people want to run (i probably will do it again also) then don't forget to jump in :)
16:18:16 <harlowja_at_home> the more the merrier
16:18:35 <jungleboyj> o/  Sorry I am late.
16:18:40 <harlowja_at_home> o/
16:18:44 <harlowja_at_home> jungleboyj, how goes it?
16:18:53 <jungleboyj> Nothing to report from Cinder that I am aware of.
16:18:56 <harlowja_at_home> thx :)
16:19:06 <harlowja_at_home> glad that the ship is sailing smoothly
16:19:11 <harlowja_at_home> (at least for oslo, ha)
16:19:51 <harlowja_at_home> http://status.openstack.org/openstack-health/#/?groupKey=build_name&resolutionKey=hour&searchProject=-with-oslo also look ok
16:20:05 <harlowja_at_home> cue i need to talk to a person about (not sure its ever getting fixed...)
16:20:19 <bknudson> so we've released everything for newton
16:20:24 <bknudson> we've got stable branches
16:20:25 <harlowja_at_home> right
16:20:39 <bknudson> so we're good to be adding new features to master or still holding off?
16:21:00 <harlowja_at_home> i think features are fine, although i'd prefer spec time and docs and examples (but that's just me)
16:21:55 <harlowja_at_home> cause i think https://review.openstack.org/#/q/project:openstack/oslo-specs could use a refresh/cleanup/...
16:23:24 <harlowja_at_home> but sure, if people want to do super-features, that's ok, be nice to have a spec for those (if people are willing/able to)
16:24:24 <bknudson> ok, just wanted to make sure that we're ok to approve non-bugfixes.
16:24:53 <harlowja_at_home> ya, should be ok :)
16:25:11 <harlowja_at_home> the coast is clear (for now, ha)
16:25:34 <harlowja_at_home> #action harlowja_at_home see about basic periodic jobs for N-1 release
16:25:56 <harlowja_at_home> i notice that the periodic jobs we have don't really run on the last stable so i'd like to get those going
16:26:45 <bknudson> what's that testing?
16:26:49 <harlowja_at_home> master right now
16:26:59 <harlowja_at_home> dsvm + master
16:27:07 <harlowja_at_home> and then libs + each projects master
16:27:57 <harlowja_at_home> i'll see if i can get something for N-1, gotta chat with some folks as to why that's not done, or not useful or... (or maybe it already exists)
16:28:19 <bknudson> are there even enough changes in stable branches?
16:28:32 <harlowja_at_home> a few, not a ton
16:28:48 <harlowja_at_home> may not be worth it, or could be worth it to run it periodically (weekly, vs daily)
16:29:13 <harlowja_at_home> (a slower rate would be fine with me)
16:30:01 <harlowja_at_home> something like http://logs.openstack.org/periodic/periodic-tempest-dsvm-oslo-latest-full-master/ but N-1 stuff
16:30:07 <bknudson> https://review.openstack.org/#/q/branch:stable/mitaka+project:%255Eopenstack/oslo.*
16:30:32 <harlowja_at_home> right, perhaps not worth it
16:32:03 <bknudson> to me, doesn't seem worth it.
16:32:30 <harlowja_at_home> k, i'll see about maybe 20 minutes of asking around then, at least i'll come out a little more knowledgeable :-P
16:33:43 <harlowja_at_home> alright anything else from folks?
16:34:48 <harlowja_at_home> alrighty then, thanks for coming folks :)
16:34:56 <harlowja_at_home> until next week! :)
16:35:03 <harlowja_at_home> #endmeeting