16:00:50 <harlowja_at_home> #startmeeting oslo
16:00:51 <openstack> Meeting started Mon Sep 26 16:00:50 2016 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:54 <openstack> The meeting name has been set to 'oslo'
16:00:58 <harlowja_at_home> ding a ling
16:01:01 <gcb> o/
16:01:11 <osh> \o/
16:01:13 <kgiusti> \o
16:01:17 <harlowja_at_home> courtesy ping for amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims
16:01:17 <harlowja_at_home> courtesy ping for dougwig, e0ne, flaper87, garyk, gcb, GheRivero, haypo
16:01:17 <harlowja_at_home> courtesy ping for ihrachys, jd__, jecarey, johnsom, jungleboyj, kgiusti, kragniz
16:01:17 <harlowja_at_home> courtesy ping for lifeless, lintan, lxsli, Nakato, ozamiatin, rbradfor, redrobot
16:01:17 <harlowja_at_home> courtesy ping for rpodolyaka, sergmelikyan, sileht, spamaps, sreshetnyak, sreshetnyak, stevemar
16:01:18 <harlowja_at_home> courtesy ping for therve, thinrichs, toabctl, viktors, zhiyan, zzzeek
16:01:23 <harlowja_at_home> \o
16:01:26 <johnsom> o/
16:01:27 <rpodolyaka> o/
16:01:37 <harlowja_at_home> yo yo
16:01:38 <ihrachys> o/
16:01:56 <harlowja_at_home> ihrachys, how's the neutron upgrades :)
16:02:08 <harlowja_at_home> that meeting always seems exciting, lol
16:02:19 <dhellmann> o/
16:02:29 <ihrachys> :) it rolls, maybe not as quick as you would desire :)
16:02:59 <harlowja_at_home> :)
16:03:19 <harlowja_at_home> okie dokie, guess we can get this show on the road
16:03:27 <harlowja_at_home> #topic Red flags for/from liaisons
16:03:39 <johnsom> Nothing to report
16:03:40 <ihrachys> I have a question about https://review.openstack.org/#/c/370499/
16:03:41 <harlowja_at_home> not expecting any issues but anything happening out there?
16:03:48 <harlowja_at_home> uh oh, does that require me to login
16:03:49 <harlowja_at_home> lol
16:03:50 <ihrachys> that switches neutron to using to_policy_values()
16:04:13 <harlowja_at_home> k
16:04:15 <ihrachys> by doing it, the patch also drops some keys from the dict available for policy engine
16:04:30 <ihrachys> I was wondering, is it safe to do? should it be in scope of the patch?
16:05:55 <harlowja_at_home> hmmm, not totally sure, i do see where u are coming from though
16:06:25 <ihrachys> whatever you folks tell us to do! :)
16:06:41 <ihrachys> you are maintaining both sides of the pipe - receiving and producing
16:07:32 <harlowja_at_home> ihrachys, do u mind sending a ML email for that one, it seems like a useful question and i'm not sure anyone currently in the meeting has the best answer
16:07:51 <ihrachys> ack
16:07:54 <harlowja_at_home> basically the diff between https://github.com/openstack/oslo.context/blob/master/oslo_context/context.py#L119 and https://github.com/openstack/oslo.context/blob/master/oslo_context/context.py#L138
16:08:16 <harlowja_at_home> ihrachys, thanks
16:08:25 <harlowja_at_home> i think its a valid question :)
16:09:14 <ihrachys> I had one more, we were planning to adopt constraints for neutron-lib, but then armax asked why oslo.* does not do it
16:09:19 <ihrachys> and hence - should we?
16:09:25 <ihrachys> so it would be great to know why
16:09:41 <ihrachys> maybe we miss something and it's not good to do it for libs
16:09:58 <harlowja_at_home> requirement constraints right?
16:10:04 <ihrachys> yea
16:10:06 <harlowja_at_home> k
16:11:07 <ihrachys> ok I guess another topic for ML :))
16:11:11 <harlowja_at_home> dhellmann, is there a general policy on libraries and constraints, i haven't seen one that i can remember
16:11:24 <harlowja_at_home> ihrachys, i don't recall any specific reason for that one
16:11:41 <ihrachys> ok. I asked dhellmann before, he forwarded me to tonyb.
16:11:41 <dhellmann> I think we just never got around to it and didn't consider it a high priority.
16:12:15 <dhellmann> but there could be some reason we don't want to do it, so that's why I suggested consulting with tonyb before going ahead
16:12:22 <harlowja_at_home> k
16:12:33 <harlowja_at_home> ya, it feels like to me, just never got around to it
16:12:38 <ihrachys> kk, sorry for taking a lot of time of the meeting. I will keep silence.
16:12:41 <harlowja_at_home> np
16:12:54 <harlowja_at_home> its ok :-P
16:14:01 <harlowja_at_home> #topic Summit
16:14:10 <harlowja_at_home> so a couple reminders :)
16:14:13 <harlowja_at_home> #link https://etherpad.openstack.org/p/ocata-oslo-summit-planning
16:14:28 <harlowja_at_home> don't forget to add session ideas there :)
16:14:51 <harlowja_at_home> sometime soon that will have to be translated into an actual list
16:15:01 <harlowja_at_home> and
16:15:04 <harlowja_at_home> #link https://etherpad.openstack.org/p/ocata-live-from-oslo
16:17:00 <harlowja_at_home> #topic Newton
16:17:19 <harlowja_at_home> just a reminder, for those that haven't checked it out recently
16:17:22 <harlowja_at_home> #link https://releases.openstack.org/newton/schedule.html
16:17:31 <harlowja_at_home> Sep 26-30 	R-1 	Final RCs and intermediary releases
16:17:34 <harlowja_at_home> guess thats this week!
16:17:35 <harlowja_at_home> lol
16:18:02 <harlowja_at_home> man another release, jeez
16:18:08 <harlowja_at_home> i remember the D days
16:18:09 <harlowja_at_home> lol
16:18:28 <gcb> yeah, then after the release of Newton ,  we can release new oslo.* lib, right ?
16:18:35 <harlowja_at_home> yup
16:18:50 <harlowja_at_home> should be safe to do that than :)
16:19:46 <harlowja_at_home> #topic Reviews needing review
16:19:56 <harlowja_at_home> in the meantime any reviews people want eyes on?
16:20:07 <harlowja_at_home> (just don't make me login, cause i'm not sure if that's fixed yet)
16:20:08 <harlowja_at_home> lol
16:20:21 <harlowja_at_home> nm, seems fixed, ha
16:20:36 <gcb> fixed now :-)
16:20:51 <harlowja_at_home> :)
16:21:45 <harlowja_at_home> https://tinyurl.com/ze6k557 is still a good URL for folks, basically the oslo review dashboard from the dashboard generation git/project
16:21:54 <harlowja_at_home> *just incase people haven't seen that
16:22:25 <harlowja_at_home> #link https://github.com/openstack/gerrit-dash-creator
16:22:26 <kgiusti> "Server Error" - no reviews!!!
16:22:58 <harlowja_at_home> lol
16:23:04 <harlowja_at_home> odd
16:23:08 <harlowja_at_home> make sure u logged in
16:23:18 <harlowja_at_home> i gotta go create that file @ https://github.com/openstack/gerrit-dash-creator/tree/master/dashboards
16:23:22 <harlowja_at_home> i swear there was an oslo one in there
16:23:37 <harlowja_at_home> thats the little tool to make these
16:23:56 <kgiusti> +1 logged in before hitting url - works for me
16:24:08 <harlowja_at_home> :)
16:24:26 <harlowja_at_home> https://github.com/openstack/gerrit-dash-creator/blob/master/dashboards/tooz_taskflow.dash is an example if people are interested
16:24:38 * harlowja_at_home i swear there was an oslo one, pretty sure someone deleted it, lol
16:25:39 <harlowja_at_home> #topic Open discussion
16:25:52 <harlowja_at_home> guess we are in the <josh rambling> stage of the meeting
16:25:53 <harlowja_at_home> ha
16:26:11 <gcb> I got the URL from https://wiki.openstack.org/wiki/Oslo#Review_Links
16:26:14 <bknudson> sorry I missed the beginning. No keystone issues that I know of.
16:26:22 <harlowja_at_home> bknudson, thanks :)
16:26:37 <harlowja_at_home> gcb, right, oh ya, that's right
16:26:49 <dhellmann> harlowja_at_home : I moved the dashboard file to the incubator a while back because it let us manage the reviews
16:26:57 <dhellmann> it's probably in the tools repo now?
16:27:01 <harlowja_at_home> right, wondering if i transfered it over
16:27:01 <harlowja_at_home> lol
16:27:17 <harlowja_at_home> oh hey look at that
16:27:18 <harlowja_at_home> lol
16:27:56 <harlowja_at_home> wondering if the dashboards/ folder didn't get moved over
16:27:56 <harlowja_at_home> lol
16:28:12 <harlowja_at_home> #action harlowja_at_home fix the dashboards folder
16:31:12 <harlowja_at_home> alright since its getting quiet in here
16:31:19 <harlowja_at_home> just a reminder for anyone that has bigger features and such
16:31:22 <harlowja_at_home> #link https://review.openstack.org/#/q/project:openstack/oslo-specs
16:31:53 <harlowja_at_home> https://review.openstack.org/#/c/273468/ from lxsli1 may still be useful (if people are interested)
16:32:40 <harlowja_at_home> same with https://review.openstack.org/#/c/229194/ (if anyone wants to take that over)
16:34:00 <harlowja_at_home> okie dokie, guess we will call it a meeting, unless other folks have anything to bring up :)
16:34:08 <gcb> Do we need a spec review day or week ?
16:34:19 <harlowja_at_home> gcb, i think it could be useful :)
16:34:45 <harlowja_at_home> personally i'd like to discuss on how we can have less of them get abandoned and such
16:35:00 <harlowja_at_home> but its a tricky question, because sometimes people just don't have time
16:35:06 <gcb> haha , maybe we can try it
16:35:13 <harlowja_at_home> sure :)
16:35:38 <harlowja_at_home> gcb, want to start a email for that? maybe later this week or next?
16:35:46 <harlowja_at_home> it seems like a good idea to me :)
16:36:04 <gcb> ack, will send out a email about the idea
16:36:14 <harlowja_at_home> super :)
16:38:05 <harlowja_at_home> alright, until next week!
16:38:11 <harlowja_at_home> thanks all for showing up :)
16:38:37 <gcb> thanks harlowja_at_home
16:38:41 <harlowja_at_home> np :)
16:38:48 <harlowja_at_home> for more awesome good times
16:38:52 <harlowja_at_home> #openstack-oslo
16:38:54 <harlowja_at_home> lol
16:38:57 <harlowja_at_home> #endmeeting