15:00:08 <bnemec> #startmeeting oslo
15:00:12 <openstack> Meeting started Mon Mar 12 15:00:08 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <openstack> The meeting name has been set to 'oslo'
15:00:21 <bnemec> courtesy ping for amotoki, amrith, bknudson, bnemec, crushil, dansmith, dhellmann
15:00:21 <bnemec> courtesy ping for dims, dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb
15:00:21 <bnemec> courtesy ping for GheRivero, haypo, jd__, jecarey, johnsom, jungleboyj, kgiusti
15:00:21 <bnemec> courtesy ping for kragniz, lhx_, lifeless, lxsli, Nakato, ozamiatin, raildo
15:00:21 <bnemec> courtesy ping for rbradfor, redrobot, rpodolyaka, sergmelikyan, sileht, spamaps, sreshetnyak
15:00:22 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zxy
15:00:24 <bnemec> courtesy ping for zzzeek
15:00:36 <jungleboyj> o/
15:00:38 <kgiusti> o/
15:00:40 <ansmith> o/
15:00:58 <e0ne> hi
15:01:02 * zzzeek can watch but is OTP
15:01:04 <crushil> o/
15:02:05 <raildo> o/
15:02:23 <bnemec> Hi everyone
15:02:27 <bnemec> #topic Red flags for/from liaisons
15:02:44 <jungleboyj> No red flags here.  All is quiet.
15:02:49 <bnemec> I saw there was a mailing list message about Cinder and config generation.
15:03:41 <jungleboyj> bnemec:  Yes.  That is one of the things I need to work on in Rocky.
15:04:03 * jungleboyj is hoping to have the bandwidth to actually work on that.
15:04:34 <bnemec> jungleboyj: Okay, sounds good.  I see Doug replied to that already too.
15:04:50 <jungleboyj> bnemec:  Ok, I will have to take a look.
15:05:03 <bnemec> Anything else?
15:05:07 <jungleboyj> This is a problem we have been ignoring for a while.
15:06:31 <bnemec> #topic Releases
15:06:50 <bnemec> I still need to get up to speed on releases.  It's been a while since I've been involved in them.
15:07:06 <bnemec> #action bnemec to sync with gcb and/or dhellmann on Oslo releases
15:07:45 <bnemec> Otherwise I don't think there's much going on release-wise right now.
15:08:09 <bnemec> #topic Agenda cleanup
15:08:27 <bnemec> I think the first two bullets on the agenda have been addressed and I will remove them before next meeting.
15:08:43 <bnemec> Specifically, they are
15:08:43 <bnemec> Improving Logging debugging spec and patch series - https://review.openstack.org/460112 and https://review.openstack.org/#/q/topic:improve-logging-debugging
15:08:43 <bnemec> Oslo.config to protect plain text secrets in configuration files - Updates and general schedule - https://review.openstack.org/#/c/513844/
15:09:09 <bnemec> If anyone objects let me know, but otherwise I'm going to move on.
15:09:25 <bnemec> #topic oslo.config changes to let an app detect whether a user has changed a config value (dhellmann)
15:09:35 <bnemec> #link https://review.openstack.org/#/c/537397/
15:10:06 <bnemec> dhellmann: Around?
15:10:53 <bnemec> I see the first three patches in that series have merged.  Maybe it's just a question of getting reviews on the last couple.
15:11:31 <bnemec> #link https://review.openstack.org/#/c/537400
15:11:42 <bnemec> is the next one in the series if anyone is looking for Oslo code to review
15:12:19 <bnemec> I think we'll move on then.
15:12:30 <jungleboyj> Oooh, that sounds like a good feature.  :-)
15:12:45 <bnemec> #topic Onboarding session at Summit
15:12:56 <bnemec> I got an email about this from the Foundation.
15:13:23 <bnemec> I don't think we've done Oslo onboarding sessions in the past (at least not that I've attended), but wanted to ask if people think it could be useful.
15:14:22 <bnemec> I'm happy to schedule time for it and be in the room to help.
15:14:26 <bnemec> Any thoughts?
15:14:49 <jungleboyj> bnemec:  For Cinder they have been helpful.  A way to introduce Cinder to people who want to get involved.
15:15:00 <jungleboyj> For Oslo it may be a slightly different audience.
15:15:13 <bnemec> Yeah, I'm kind of hoping maybe it would help get more people involved in Oslo.
15:15:18 <jungleboyj> Less newbies and more people who are in the community looking to better understand Oslo.
15:15:22 <jungleboyj> bnemec:  ++
15:15:45 <jungleboyj> bnemec:  Honestly, I would attend just because I don't feel like I understand all the pieces that Oslo encompasses.
15:16:00 <jungleboyj> So, I guess I think it is a good idea.
15:16:14 <kgiusti> +1 to the idea - willing to help out (assuming I get approved for travel)
15:16:17 <bnemec> Okay, I'm kind of leaning that direction too.
15:16:46 <bnemec> If nothing else it will be a good experiment.  If nobody shows up then we know that it's either not useful or needs more publicity.
15:17:01 <jungleboyj> bnemec:  I would be happy to serve as a guide in content creation.  What we have done for Cinder has been used as an example for other sessions.
15:17:04 <bnemec> Unless we've done this before and I didn't even bother to show up. :-)
15:17:15 <bnemec> jungleboyj: Cool, thanks.
15:17:16 <jungleboyj> bnemec:  :-)
15:17:31 <bnemec> #action bnemec to schedule onboarding session at summit
15:17:35 <jungleboyj> bnemec:  Can help to get it publicized through Openstack Upstream Institute.
15:17:47 <bnemec> I think they said they tend to do these right after the project update, which we're already doing anyway.
15:17:56 <jungleboyj> Cool.
15:18:00 <bnemec> So that should help.
15:18:03 <bnemec> jungleboyj: Good to know.
15:18:17 <jungleboyj> bnemec:  That is new.  They are trying to do that this time around to rope more people who are interested in.
15:18:20 <bnemec> I found Oslo to be a good place to jump in upstream since it's a collection of (mostly) smaller projects.
15:18:57 <bnemec> jungleboyj: Yeah, makes sense.
15:19:22 <bnemec> Sounds like we're all in agreement.
15:19:39 <bnemec> I'll sync with jungleboyj to come up with an agenda before then.
15:19:49 <jungleboyj> Sounds good.
15:20:08 <bnemec> #topic oslo.limit addition
15:20:18 <bnemec> lbragstad: This is relevant to your interests. :-)
15:20:55 * lbragstad lingers
15:21:06 <bnemec> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128006.html
15:21:15 <lbragstad> bnemec: it certainly is
15:21:25 <bnemec> There's a proposal to add a new Oslo library for quota management.
15:22:01 <bnemec> I don't think this will be too controversial since it's something we've wanted for about 3 years, but I wasn't entirely clear where we are in the process.
15:22:43 <bnemec> There's a policy for adding new libraries.
15:22:45 <bnemec> #link http://specs.openstack.org/openstack/oslo-specs/specs/policy/new-libraries.html
15:23:07 <bnemec> If that hasn't been done yet then we probably need to before proceeding.
15:23:18 <lbragstad> i can look into that today
15:24:24 <bnemec> lbragstad: I think your email covered at least some it already.
15:24:26 <bnemec> #link https://github.com/openstack/oslo-specs/blob/master/specs/new-library-template.rst
15:24:46 <bnemec> I saw harlowja mentioned the delimiter library that already exists.
15:24:54 <lbragstad> yeah - i saw that
15:25:10 <bnemec> I looked at it a bit this morning and I'm not sure it's a great fit for this, at least as I understand it.
15:25:28 <bnemec> It was designed to be pluggable with different backends.  I think oslo.limit is just targeting keystone?
15:25:38 <lbragstad> i know at the PTG we were just going to start with something *super* simple as the base implementation for oslo.limits
15:25:46 <lbragstad> correct
15:26:00 <bnemec> +1 to start simple
15:26:09 <lbragstad> the minimum viable product from my perspective for oslo.limit is:
15:26:20 <lbragstad> 1.) query keystone to determine the enforcement model being used
15:26:21 <bnemec> So I'm not sure we need the complexity of delimiter, and it doesn't appear to have gotten all that far in the implementation either.
15:26:40 <lbragstad> 2.) call an enforcement method with quota information from the service
15:28:06 <lbragstad> and that's it, the pattern is very similar to oslo.policy - for better or worse, I'm not sure ;)
15:28:53 <bnemec> Seems reasonable to me.
15:29:31 <lbragstad> cool
15:29:44 <bnemec> So I guess the next step is to write up the proposal email and have this discussion on the list where everyone can weigh in.
15:29:51 <lbragstad> ++
15:29:57 <lbragstad> i'll make a point to get that out today
15:30:06 <bnemec> Maybe just add it as a reply to the existing thread since there's already been a good discussion there.
15:30:18 <lbragstad> and fill out the template?
15:30:27 <bnemec> #action lbragstad to send proposal email for oslo.limit
15:30:31 <bnemec> lbragstad: Yeah
15:30:39 <lbragstad> awesome - that makes sense
15:31:22 <bnemec> Like I said, I don't anticipate a lot of resistance, but since there is an existing library we should explain why we're not using it.
15:31:30 <lbragstad> i agree
15:31:41 <bnemec> And we did agree to this process not long ago so we should use it. :-)
15:31:53 <lbragstad> yep
15:32:21 <bnemec> Okay, cool.  Sounds like we're on the same page and have a way forward.
15:32:51 <bnemec> #topic PTG wrapup
15:33:14 <bnemec> kgiusti: ansmith: There was a response to my email that the presentations still aren't accessible to (I assume) non-Red Hat folks.
15:33:26 <bnemec> Do you know if you can make those public?
15:33:40 * dhellmann slinks in very late
15:33:40 <kgiusti> bnemec: hey - the new api doc should be public
15:33:48 * bnemec didn't realize they weren't already since he as access
15:33:54 <bnemec> *has
15:34:11 <ansmith> i will check to make sure the deck on kafka driver is accessible
15:34:20 <kgiusti> bnemec: the email didn't state which links were broken...
15:34:45 <bnemec> Yeah, I'm trying to remember which ones were a problem at the PTG.
15:35:04 <bnemec> I know we projected the kafka update, so maybe that one?
15:35:46 <ansmith> yup, I never went back to fix it, will do
15:36:00 <bnemec> kgiusti: If we can confirm that kafka is accessible, then maybe we can follow up with Josh and see if there were any others.
15:36:04 <bnemec> ansmith: Thanks
15:36:27 <kgiusti> bnemec: I'll ping jharlow....
15:36:43 <kgiusti> bnemec: when he materializes.
15:37:05 <bnemec> Yeah
15:38:30 <bnemec> dhellmann: Was there anything specific you wanted to discuss about oslo.config changes to let an app detect whether a user has changed a config value?
15:41:48 <bnemec> Maybe we lost dhellmann again.
15:42:06 <bnemec> #topic Open discussion
15:42:19 <bnemec> That's it for the agenda.  Anything else to talk about?
15:43:26 * dhellmann returns
15:43:33 <dhellmann> I just need reviews on those patches
15:43:38 <dhellmann> I'd like to get them into a release soon
15:43:52 <dhellmann> bnemec: did you have questions about the release process?
15:43:56 <bnemec> Okay, my speculation was correct then.
15:44:14 <bnemec> dhellmann: Just generally what we've been doing in Oslo.  I think at one point we were doing weekly releases?
15:44:20 <dhellmann> I'm traveling this week but will try to respond to review questions
15:44:33 <dhellmann> yeah, we've been doing them weekly as long as there's something "real" in the release
15:44:36 <dhellmann> so not just for requirements updates
15:44:50 <dhellmann> or CI config changes
15:45:03 <bnemec> Yeah
15:45:13 <dhellmann> there are some tools in the releases repo for listing out all of the unreleased changes in repos owned by a given team
15:45:14 <bnemec> I think there was a tool to list all of the changes since last release in the Oslo projects?
15:45:25 <bnemec> Heh, okay.
15:45:41 <bnemec> I'll take a look at that.
15:46:01 <bnemec> We should be good to get the release train running again since Queens is out the door.
15:46:13 <dhellmann> ./tools/list_unreleased_changes.sh $(.tox/venv/bin/list-deliverables --team oslo)
15:46:29 <dhellmann> oops: ./tools/list_unreleased_changes.sh $(.tox/venv/bin/list-deliverables --team oslo -r)
15:46:45 <bnemec> Thanks, will take a look.
15:47:07 <dhellmann> let me know if you run into trouble
15:47:55 <bnemec> Will do.  I think I still remember the general release mechanism, but I may be out of date on any recent changes.
15:49:00 <dhellmann> the readme should list the commands and I can walk you through it once
15:49:04 <dhellmann> or twice
15:49:19 <dhellmann> I think I'm still signed up as the release liaison, too, fwiw
15:50:10 <bnemec> Okay, sounds good.
15:50:47 <bnemec> I will do some homework on that and follow up with any questions.
15:51:00 <bnemec> Anything else before we end the meeting?
15:51:44 <dhellmann> bnemec : http://paste.openstack.org/show/698738 should have a list of the current unreleased stuff, for reference
15:52:44 <bnemec> dhellmann: Cool, thanks
15:53:31 <bnemec> Sounds like we're about done.
15:53:37 <bnemec> Thanks for joining everyone.
15:53:55 <bnemec> #endmeeting