#openstack-oslo: oslo

Meeting started by bnemec at 15:00:29 UTC (full logs).

Meeting summary

  1. Red flags for/from liaisons (bnemec, 15:03:02)
    1. https://bugs.launchpad.net/oslo.db/+bug/1756352 (bnemec, 15:03:19)

  2. Releases for Rocky (bnemec, 15:06:25)
    1. https://review.openstack.org/#/c/552943/ (bnemec, 15:06:40)

  3. Action items from last meeting (bnemec, 15:10:07)
  4. There are 2 more changes in the series of oslo.config changes to let an app detect whether a user has changed a config value (dhellmann) (bnemec, 15:11:30)
    1. https://review.openstack.org/#/c/537400/ (bnemec, 15:11:38)
    2. https://review.openstack.org/#/c/537401/ (bnemec, 15:11:44)

  5. oslo.limit addition followup (bnemec, 15:13:52)
    1. https://review.openstack.org/552907 (bnemec, 15:14:25)
    2. ACTION: bnemec to approve oslo.limit spec (bnemec, 15:20:36)
    3. ACTION: bnemec to investigate/update new library process docs (bnemec, 15:20:52)

  6. Configuration change handling over releases (namnh) (bnemec, 15:21:58)
    1. https://review.openstack.org/#/c/520043 (bnemec, 15:22:30)
    2. https://review.openstack.org/#/c/526314 (bnemec, 15:22:36)
    3. http://lists.openstack.org/pipermail/openstack-dev/2018-March/128055.html (bnemec, 15:30:45)
    4. ACTION: review the config migration spec: https://review.openstack.org/#/c/520043/ (bnemec, 15:32:26)
    5. ACTION: namnh to update config migration testing doc (bnemec, 15:34:54)

  7. MultiConfigParser removal (bnemec, 15:36:29)
    1. https://github.com/openstack/oslo.config/blob/master/oslo_config/cfg.py#L2017 (bnemec, 15:39:01)
    2. https://github.com/openstack/oslo.config/commit/c663acebc697e92f086684b2ee87546fba57cb7d (bnemec, 15:50:13)
    3. ACTION: move MultiConfigParser to networking-cisco (bnemec, 15:50:48)

  8. Open Discussion (bnemec, 15:55:23)
    1. http://lists.openstack.org/pipermail/openstack-dev/2018-March/128352.html (dhellmann, 15:56:46)


Meeting ended at 16:01:40 UTC (full logs).

Action items

  1. bnemec to approve oslo.limit spec
  2. bnemec to investigate/update new library process docs
  3. review the config migration spec: https://review.openstack.org/#/c/520043/
  4. namnh to update config migration testing doc
  5. move MultiConfigParser to networking-cisco


Action items, by person

  1. bnemec
    1. bnemec to approve oslo.limit spec
    2. bnemec to investigate/update new library process docs
  2. namnh
    1. namnh to update config migration testing doc
  3. openstack
    1. review the config migration spec: https://review.openstack.org/#/c/520043/


People present (lines said)

  1. bnemec (112)
  2. dhellmann (34)
  3. namnh (18)
  4. lbragstad (12)
  5. jungleboyj (4)
  6. openstack (4)
  7. zzzeek (2)
  8. openstackgerrit (2)
  9. daidv (2)
  10. ansmith (1)
  11. crushil (1)
  12. kgiusti (1)
  13. e0ne (1)


Generated by MeetBot 0.1.4.