15:00:10 <bnemec> #startmeeting oslo
15:00:11 <openstack> Meeting started Mon Mar 26 15:00:10 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'oslo'
15:00:18 <bnemec> courtesy ping for amotoki, amrith, bknudson, bnemec, crushil, dansmith, dhellmann
15:00:18 <bnemec> courtesy ping for dims, dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb
15:00:18 <bnemec> courtesy ping for GheRivero, haypo, jd__, jecarey, johnsom, jungleboyj, kgiusti
15:00:18 <bnemec> courtesy ping for kragniz, lhx_, lifeless, lxsli, Nakato, ozamiatin, raildo
15:00:18 <bnemec> courtesy ping for rbradfor, redrobot, rpodolyaka, sergmelikyan, sileht, spamaps, sreshetnyak
15:00:20 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, viktors, zhiyan, zxy
15:00:22 <bnemec> courtesy ping for zzzeek
15:00:30 <kgiusti> o/
15:00:37 <jungleboyj> o/
15:00:40 <ansmith> o/
15:01:33 <gcb> o/
15:01:43 <e0ne> hi
15:02:19 <bnemec> #topic Red flags for/from liaisons
15:03:09 <jungleboyj> Don't think Cinder has anything.
15:03:34 <bnemec> I'm not aware of anything from the Oslo side either.
15:04:07 <bnemec> We can probably move on then.
15:04:25 <bnemec> #topic Releases for Rocky
15:04:56 <bnemec> I didn't do the full weekly release last week.  Will start that again this week.
15:05:31 <bnemec> I guess oslo.db was released last week to fix the requirements issue.
15:06:13 <bnemec> I'm planning to include oslo.config in the next release set too as the remained of dhellmann's config location changes have merged.
15:06:48 <bnemec> And while we're talking releases, fungi had mentioned last week that pbr hasn't been released in a long time.
15:06:55 <bnemec> I think since last summer.
15:07:37 <bnemec> There was some discussion with stephenfin about how the sphinx changes factor into that.
15:08:04 <stephenfin> bnemec: pbr is good to go as soon as those two fixes land
15:08:24 <gcb> yeah, we didn't release pbr  recently ,then we can pick up more features
15:08:27 <fungi> yeah, tat would be awesome
15:08:41 <fungi> and thanks stephenfin for jumping on the fire drill there with sphinx integration
15:08:57 <bnemec> stephenfin: https://review.openstack.org/#/c/552100 is the last thing then?
15:09:03 <stephenfin> fungi: np :)
15:09:11 <stephenfin> bnemec: Correct
15:09:29 <stephenfin> At least, until Sphinx 1.8 is released, heh
15:09:35 <bnemec> Cool, those will hopefully merge shortly.
15:09:59 <bnemec> Once those are in I will release pbr.
15:10:11 <bnemec> #action bnemec to release pbr after https://review.openstack.org/#/c/552100 merges
15:10:19 <stephenfin> Spot on. I've removed stuff so it should be a MAJOR version (4.0?)
15:10:43 <bnemec> I'll have to look at the git history, but that seems likely.
15:11:47 <bnemec> That's all I had for releases.  Anything else?
15:12:45 <bnemec> #topic Action items from last meeting
15:13:09 <bnemec> I approved the oslo.limit spec and that's been working its way through governance.
15:13:23 <bnemec> I think it merged last week?
15:13:34 <bnemec> If not it should be soon.
15:14:02 <bnemec> I did not update the new library process docs though. :-/
15:14:10 <bnemec> Will keep that on my todo list.
15:14:30 <gcb> https://review.openstack.org/#/c/552907/
15:15:26 <bnemec> Yeah, I was thinking of https://review.openstack.org/#/c/550496/ which has merged.
15:15:52 <bnemec> So we should be good proceed with oslo.limit.
15:16:12 <gcb> yeah, I saw the update in TC report :-)
15:16:42 <bnemec> I still haven't gotten to the config migration spec either.
15:17:20 <bnemec> #link https://review.openstack.org/#/c/520043/
15:18:13 <bnemec> Don't see namnh so not sure if the testing doc for that got updated.
15:18:35 <bnemec> And finally, the MultiConfigParser is no more, at least as far as Oslo is concerned.
15:19:00 <bnemec> I have a patch open with networking-cisco to move it there, but they plan to remove their use of it in Rocky anyway so they haven't accepted it yet.
15:19:21 <bnemec> #link https://review.openstack.org/554617
15:20:12 <bnemec> That's it for the action items from last week.
15:20:50 <bnemec> #topic Remove zmq driver from oslo.messaging
15:21:09 <kgiusti> yep.
15:21:22 <bnemec> We discussed this at the PTG, but because the zmq unit tests are now starting to fail in oslo.messaging we're bumping the priority on this.
15:21:34 <kgiusti> The driver hasn't had a contribution for over a year now.
15:22:04 <bnemec> And is broken as far as we can tell. :-)
15:22:05 <kgiusti> I'm writing an email to the operator's and dev's mailing list about this.
15:22:28 <kgiusti> If anyone is willing to take ownership, please step forward. :)
15:22:42 <kgiusti> but be aware: it clocks in at over 5,000 lines of code
15:22:57 <kgiusti> which is more than double the rabbit driver size
15:23:24 <bnemec> Yeah, I don't anticipate that anyone is in this meeting who cares about it, but this way it will be in the meeting notes in case anyone happens to look through them.
15:23:45 <kgiusti> If anyone comes forward we should still move it out-of-tree
15:23:58 <dhellmann> o/
15:24:14 <bnemec> I think the TLDR is that we're going to remove the zeromq driver from oslo.messaging and if anyone still needs it they should let us know ASAP.
15:24:39 <kgiusti> bnemec: don't we have to announce it as being deprecated first?
15:24:44 <bnemec> #action Anyone still using the zeromq oslo.messaging driver contact kgiusti or bnemec
15:25:02 <kgiusti> bnemec: this hasn't been done yet to my knowledge
15:25:11 <bnemec> kgiusti: It's broken and we're shutting off the tests.
15:25:20 <bnemec> At least that was my understanding of the discussion this morning.
15:25:33 <kgiusti> bnemec: agreed - we def need to shut off the tests now
15:25:49 <dhellmann> I can do either today (delete or just disable the tests) so let me know which you prefer.
15:26:12 <kgiusti> bnemec: but I thought libraries had a formal feature deprecation process?
15:26:27 <kgiusti> bnemec: not saying that it's a good idea to keep the driver around if it can't pass tests BTW
15:26:31 <bnemec> I'm a little uncomfortable removing something without deprecation, but in this case I'm not sure anyone benefits from having it there.
15:26:49 <dhellmann> if we know it doesn't work, we can't really be breaking anyone's production deployment, right?
15:27:17 <bnemec> I would think not.
15:27:23 <kgiusti> dhellmann: we know it doesn't pass tests, whether there's some restricted use case in the wild is unknown
15:27:30 <dhellmann> I suppose that's true
15:27:41 <dhellmann> ok, so just marking the tests with skips for today then?
15:27:47 <dhellmann> and announcing the impending deletion?
15:27:54 <kgiusti> dhellmann: +1 let's start there.
15:27:55 <bnemec> I'm good with that plan.
15:27:59 <dhellmann> ok
15:28:14 <dhellmann> should I mark them as skips or just delete them?
15:28:16 <dhellmann> the tests that is
15:28:38 <kgiusti> dhellmann: nuke em from orbit
15:28:43 <dhellmann> wfm
15:28:46 <kgiusti> ansmith: ?
15:28:51 <ansmith> +1
15:28:54 * bnemec prefers to take off first
15:29:06 <bnemec> No sense nuking yourself in the process. ;-)
15:29:42 <bnemec> #action dhellmann to delete zeromq tests from oslo.messaging
15:30:15 <kgiusti> #action kgiusti announce on operator's and dev ml
15:30:37 <dhellmann> are there separate zmq test jobs?
15:31:09 <kgiusti> dhellmann: yeah
15:31:28 <dhellmann> ok, I can remove those, too
15:31:47 <kgiusti> dhellmann: well - sorry there are none outside of oslo's if that's what you mean
15:32:05 <kgiusti> ansmith: we'll want to remove devstack support too, I can take that
15:32:32 <dhellmann> kgiusti : I meant any at all, and found the ones in repo, so it's to know I don't need to look elsewhere
15:33:22 <kgiusti> dhellmann: I don't know of any other projects using zmq in their gates
15:33:56 <kgiusti> dhellmann: there's just the devstack plugin, which we'll remove once the driver itself goes
15:34:34 <dhellmann> there are some legacy jobs defiined in the openstack-zuul-jobs repo
15:34:35 <bnemec> So our standard deprecation policy would say that this needs to stick around until T.
15:34:46 <dhellmann> legacy-tempest-dsvm-full-zmq
15:35:29 <dhellmann> that's used by devstack-plugin-zmq
15:35:33 <dhellmann> in project-config
15:35:45 <dhellmann> if you're going to handle the devstack parts, I can leave that to you
15:35:56 <kgiusti> dhellmann: +1
15:36:18 <openstackgerrit> Doug Hellmann proposed openstack/oslo.messaging master: add lower-constraints job  https://review.openstack.org/556066
15:36:19 <openstackgerrit> Doug Hellmann proposed openstack/oslo.messaging master: remove zmq tests  https://review.openstack.org/556561
15:36:26 <kgiusti> bnemec: bleh
15:36:32 <dhellmann> #link patch to remove zmq tests https://review.openstack.org/556561
15:36:58 <bnemec> I'm feeling like we should make an exception since we believe this is broken anyway.
15:37:19 <kgiusti> bnemec: yeah, it's not like we're going to fix anything between now and then.
15:37:19 <dhellmann> I agree. That means we need to make more noise about it, but I think we can move ahead.
15:37:29 <dhellmann> that does make me feel better about starting by just removing the tests
15:38:14 <bnemec> What about a one cycle deprecation and remove in S?
15:38:50 <kgiusti> bnemec: deprecated and unsupported, remove in S - I can live with that.
15:38:50 <dhellmann> hmm
15:38:58 <dhellmann> yeah, I can support that
15:39:08 <dhellmann> plan, that is, not driver :-)
15:39:24 <kgiusti> dhellmann: you got my hopes up ;)
15:39:26 <bnemec> Heh
15:39:43 <bnemec> kgiusti: Can you communicate that in your email then?
15:39:55 <kgiusti> bnemec: most certainly
15:40:29 <bnemec> Basically I think it looks just as bad for us to carry known-broken code that we don't plan to fix as to short-circuit the deprecation period.
15:40:49 <bnemec> So let's tear off the band-aid and get it over with.
15:40:59 <kgiusti> bnemec: +1
15:41:58 <ansmith> bnemec: agree
15:42:35 <bnemec> #action deprecate the zeromq driver in Rocky, remove it in S
15:43:15 <bnemec> Okay, sounds like we've got a plan and I think people have ample warning that this broken thing is going away.
15:43:53 <bnemec> That's it for topics.
15:43:57 <bnemec> #topic Open discussion
15:44:46 <dhellmann> I have a bunch of patches up to add jobs to run py3 unit test jobs against all of the libraries using the lower bounds of their requirements
15:44:48 <dhellmann> #link https://review.openstack.org/#/q/topic:requirements-stop-syncing+status:open
15:45:05 <dhellmann> I'm hoping those are not controversial and that we can get them approved relatively quickly
15:45:20 <bnemec> Yeah, I saw those patch bombs from over the weekend. :-)
15:45:41 <bnemec> Do we want to apply a single approver policy to those?
15:45:48 <dhellmann> wfm
15:46:19 <dhellmann> I think all of them are passing except oslo.messaging
15:46:40 <dhellmann> oh, and oslo.service
15:46:44 <dhellmann> there's something odd there
15:46:44 <bnemec> Yeah, and the regular unit tests are failing there too, IIRC.
15:49:04 <bnemec> #action Oslo cores to single approve lower-bounds tests where they are passing
15:50:12 <bnemec> I guess I should note that there are quite a few untriaged bugs in Oslo too.
15:50:14 <bnemec> #link https://bugs.launchpad.net/oslo/+bugs?search=Search&field.status=New
15:50:26 <bnemec> I started working through that on Friday and will continue this week.
15:51:09 <bnemec> Any help is welcome. :-)
15:52:22 <bnemec> A number of them can probably be closed or marked incomplete if they're very old, to request that the reporter confirm the bug is still present.
15:52:35 <bnemec> We discussed that at the PTG for oslo.messaging too.
15:53:14 <dhellmann> #info proposing kgiusti for oslo-core
15:53:15 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2018-March/128736.html
15:53:25 <bnemec> +1!
15:53:27 <dhellmann> we should discuss that on the ML
15:53:29 <kgiusti> thanks
15:53:38 <gcb> +1
15:53:52 * bnemec will respond on the list too
15:54:01 <openstackgerrit> Merged openstack-dev/pbr master: update parse test to use reliable comparison  https://review.openstack.org/555808
15:54:02 <openstackgerrit> Merged openstack-dev/pbr master: builddoc: Treat '[pbr] autodoc_tree_excludes' as a multi-line opt  https://review.openstack.org/552100
15:54:09 <bnemec> \o/ Ship it!
15:54:57 <bnemec> Actually, on that note I noticed pbr wasn't in the oslo deliverables list in the releases repo.
15:55:07 <bnemec> I'm planning to add it since that is something that falls under our purview.
15:55:23 <bnemec> #action bnemec add pbr to oslo release deliverables
15:55:47 <dhellmann> is it not on the separate list you keep? or is the team value in the deliverable file not set correctly?
15:56:32 <bnemec> dhellmann: It's actually not present in https://github.com/openstack/releases/tree/master/deliverables/rocky at all.
15:56:45 <dhellmann> bnemec : it's under _independent
15:57:07 <dhellmann> https://github.com/openstack/releases/blob/master/deliverables/_independent/pbr.yaml
15:57:11 <bnemec> dhellmann: Huh.  It didn't show up when I listed all the oslo changes.
15:57:30 <dhellmann> oh, the series defaults to the current value so it is probably being filtered out
15:57:49 <dhellmann> you might want to run "list-deliverables --series independent" and see what you get
15:57:52 <dhellmann> there may be multiple
15:58:12 <bnemec> Yeah, will try that.
15:58:14 <bnemec> #undo
15:58:15 <openstack> Removing item from minutes: #link https://github.com/openstack/releases/blob/master/deliverables/_independent/pbr.yaml
15:58:28 <bnemec> Oops, that's not what I wanted to do.
15:58:51 <bnemec> Oh well, I'll add it to my offline todo list. :-)
15:59:27 <bnemec> Okay, time's just about up.  Anything else?
16:00:05 <dhellmann> nothing here
16:00:25 <bnemec> Okay, thanks for joining everyone!
16:00:27 <bnemec> #endmeeting