15:00:41 <bnemec> #startmeeting oslo
15:00:43 <openstack> Meeting started Mon Apr  2 15:00:41 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:46 <openstack> The meeting name has been set to 'oslo'
15:00:54 <bnemec> courtesy ping for amotoki, amrith, bknudson, bnemec, dansmith, dhellmann, dims
15:00:54 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, GheRivero
15:00:54 <bnemec> courtesy ping for haypo, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:00:54 <bnemec> courtesy ping for lifeless, lxsli, ozamiatin, raildo, redrobot, rpodolyaka, sergmelikyan
15:00:54 <bnemec> courtesy ping for sileht, spamaps, sreshetnyak, stevemar, therve, thinrichs, toabctl
15:00:55 <bnemec> courtesy ping for viktors, zhiyan, zxy, zzzeek
15:01:03 <kgiusti> yo
15:01:47 * jungleboyj is on vacation
15:01:48 <kgiusti> bnemec: I didn't see ansmith in that courtesy ping list
15:02:04 <ansmith> o/
15:02:17 <namnh> o/
15:02:19 <bnemec> kgiusti: It's based on https://github.com/openstack/oslo.tools/blob/master/ping_me.py
15:02:19 <jungleboyj> Nothing to report though.
15:02:48 <kgiusti> bnemec: kk - fix it I will...
15:02:48 <ansmith> bnemec, kgiusti: I will add myself
15:03:01 <kgiusti> ansmith: thanks!
15:03:01 <bnemec> jungleboyj: Okay, thanks.  Now stop working when you're OOO. :-)
15:03:15 <bnemec> I have some cleanup to do on that list too.
15:04:15 <bnemec> #topic Red flags for/from liaisons
15:04:28 <bnemec> There were a couple of things that happened last week to be aware of.
15:04:41 <bnemec> We did a major release of pbr, for the first time in quite a while.
15:05:03 <bnemec> It's not in upper-constraints yet because we decided to hold off until after the long weekend, but it should be there soon.
15:05:29 <bnemec> If anyone notices breakage with pbr 4.0 please let us know.
15:05:52 <bnemec> Additionally, there was a new version of oslo.config that has been causing a few issues.
15:06:40 <bnemec> See the discussion on https://review.openstack.org/#/c/557012/ for details
15:07:31 <bnemec> I think we have fixes in-flight or merged for all the issues though, and obviously upper-constraints won't be updated until everything's good to go.
15:08:18 <bnemec> There was also a major oslo.messaging release, but since it was just for the removal of the pika driver no one was using it shouldn't have much impact.
15:08:32 * kgiusti crosses fingers...
15:09:07 <bnemec> I think that's it from the Oslo side.  Anything else people have seen?
15:10:19 <bnemec> #topic Releases for Rocky
15:10:34 <bnemec> As noted above, we did three major releases for widely used Oslo projects last week.
15:11:01 <bnemec> Expect another oslo.config release this week with fixes for the problems we found.
15:12:11 <bnemec> I think that's about it on the release front.  I expect to do the weekly releases once oslo.config is ready (it may be already).
15:12:17 <openstackgerrit> Seyeong Kim proposed openstack/oslo.versionedobjects master: Fixing UUID coerce function for unicode non uuid form  https://review.openstack.org/557778
15:12:28 <bnemec> #topic Action items from last meeting
15:12:36 <bnemec> We had a bunch.
15:13:00 <bnemec> bnemec to release pbr after https://review.openstack.org/#/c/552100 merges
15:13:03 <bnemec> Done
15:13:09 <bnemec> Anyone still using the zeromq oslo.messaging driver contact kgiusti or bnemec
15:13:17 <bnemec> I haven't heard anything yet.
15:13:30 <bnemec> That one was more open-ended.
15:13:31 <kgiusti> bnemec: neither have I - emailed both -dev and operators
15:13:55 <bnemec> Yeah, that took care of action item #4: http://lists.openstack.org/pipermail/openstack-dev/2018-March/128735.html
15:14:36 <bnemec> #5 was to actually deprecate the zeromq driver this cycle
15:14:56 <bnemec> That one also wasn't necessarily to be done this week, just as long as it happens in the near future.
15:15:15 * kgiusti affixes Post-It note to forehead
15:15:30 * bnemec has bad memories of post-it notes on his forehead
15:15:37 <kgiusti> :)
15:15:47 <bnemec> But that's a story for another time. :-)
15:15:58 <bnemec> I skipped action item 3: dhellmann to delete zeromq tests from oslo.messaging
15:16:05 <bnemec> Fortunately it's done.
15:16:07 <bnemec> #link https://review.openstack.org/#/c/556561/
15:16:27 <bnemec> Oslo cores to single approve lower-bounds tests where they are passing
15:16:41 <bnemec> We've been doing that, although I think there are more reviews open.
15:17:07 <bnemec> I didn't get as many reviews done last week as I would have liked.
15:17:20 <bnemec> Lots of fighting fires.
15:17:35 <bnemec> Anyway, call that one "good progress".
15:17:43 <bnemec> Finally, bnemec add pbr to oslo release deliverables
15:18:04 <bnemec> That was already done, we just needed to make sure it was included in the command we use to determine what needs a release, which is now done.
15:18:34 <bnemec> So we pretty much took care of what we needed to take care of from last week. \o/
15:19:13 <bnemec> #topic Configuration change handling over releases (namnh) https://review.openstack.org/#/c/520043 and https://review.openstack.org/#/c/526314
15:19:20 <bnemec> I saw namnh was here this week.
15:19:29 <namnh> hi
15:19:30 <bnemec> And I still owe reviews on this topic. :-/
15:19:30 <namnh> :))
15:20:02 <bnemec> Any other updates on it?
15:20:11 <namnh> i've pushed a patch set to setup environment for testing: https://review.openstack.org/#/c/549672/
15:20:21 <namnh> you can see it to setup
15:20:52 <bnemec> Cool, I think that takes care of an action item from two weeks ago. :-)
15:21:23 <namnh> Cool, hope to get your comment :))
15:21:27 <bnemec> Reviewing this is still on my todo list, I just haven't gotten to it yet.
15:21:45 <bnemec> Hopefully this week, if I can keep the interrupts to a minimum.
15:22:29 <namnh> yeah, thanks in advance
15:23:04 <bnemec> #action oslo.config reviewers look at https://review.openstack.org/#/c/520043 and associated patches
15:23:44 <bnemec> Okay, that was the only topic on the agenda for this week.
15:23:49 <bnemec> #topic Open discussion
15:24:51 <bnemec> I guess I will point out https://bugs.launchpad.net/glance/+bug/1759935 since it's related to Oslo.
15:24:52 <openstack> Launchpad bug 1759935 in Glance "Documentation build broken with openstackdocstheme 1.20.0" [Undecided,Fix released]
15:25:18 <bnemec> There was a change in openstackdocstheme that made the glance doc build blow up in pbr.
15:25:48 <bnemec> The solution was to tweak the glance eventlet monkey patching to make it compliant with the best practices.
15:25:50 <bnemec> #link http://specs.openstack.org/openstack/openstack-specs/specs/eventlet-best-practices.html#monkey-patching
15:26:33 <bnemec> Hopefully that won't cause any issues, but eventlet is a strange beast.
15:26:57 <bnemec> (I guess this could have gone under the red flags section too, but I didn't think of it)
15:27:27 <bnemec> TLDR: Follow the guidelines in http://specs.openstack.org/openstack/openstack-specs/specs/eventlet-best-practices.html#monkey-patching and you will have fewer problems with eventlet.
15:28:17 <kgiusti> bnemec: funny, I thought the first rule should be the obvious one: 'Don't'
15:28:26 <kgiusti> bnemec: just don't
15:28:28 <kgiusti> :)
15:28:59 <bnemec> kgiusti: Yeah, there was a lot of pain along that path too, unfortunately.
15:29:13 <bnemec> We had a lot of discussions at summits over the years about how to remove eventlet.
15:29:43 <bnemec> Even when we had a ton of developers available it was a hard sell though.
15:30:16 <bnemec> Concurrency is a "here be dragons" topic, and rightly so.
15:31:25 <bnemec> Okay, anything else before we end the meeting?
15:32:26 <bnemec> Going once
15:32:56 <bnemec> twice
15:33:23 <bnemec> Thanks for joining, everyone
15:33:23 <bnemec> #endmeeting