15:00:55 <bnemec> #startmeeting oslo
15:00:56 <openstack> Meeting started Mon May  7 15:00:55 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:00 <openstack> The meeting name has been set to 'oslo'
15:01:14 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:14 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:14 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:01:14 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar, therve
15:01:15 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:24 <e0ne> hi
15:01:30 <ansmith> o/
15:01:45 <kgiusti> o/
15:01:48 <jungleboyj> o/
15:03:38 <dhellmann> o/
15:03:40 <bnemec> #topic Red flags for/from liaisons
15:04:28 <bnemec> I'm not aware of anything from the Oslo side.
15:05:34 <bnemec> Seems pretty quiet, so we'll move on.
15:05:37 <bnemec> #topic Releases for Rocky
15:05:54 <jungleboyj> Nothing from Cinder.  :-)
15:06:04 <bnemec> Business as usual, except for an extra oslo.policy release last week for the multiple input/output files change.
15:06:11 <smcginnis> ./
15:06:36 <vstinner> i'm sorry to spam the meeting, but if you would like to be pay to maintain Oslo, Red Hat is looking for someone to replace me ;-) https://global-redhat.icims.com/jobs/63064/senior-software-engineer---openstack-oslo-project/job?hub=7
15:06:44 <vstinner> be paid*
15:07:11 <bnemec> #link https://global-redhat.icims.com/jobs/63064/senior-software-engineer---openstack-oslo-project/job?hub=7
15:08:06 <bnemec> vstinner: No problem, that's good to advertise.
15:08:17 <bnemec> We can always use more contributors. :-)
15:08:47 <bnemec> #topic Action items from last meeting
15:09:01 <bnemec> "bnemec to release Oslo stable branches"
15:09:08 <bnemec> Not done, but still on my list.
15:09:41 <bnemec> I wrapped up some significant non-Oslo work last week so I'm hoping to have a little more time this week.
15:09:56 <bnemec> "kgiusti remove pip-check-reqs from tox.ini"
15:10:04 <bnemec> I saw a bunch of patches.
15:10:07 <kgiusti> https://etherpad.openstack.org/p/pip_(missing|check)_reqs
15:10:20 <kgiusti> I think we're all set from the Oslo perspective
15:10:48 <kgiusti> stephenfin and tosky have jumped in too
15:10:54 <bnemec> Cool
15:11:08 <bnemec> oslo.versionedobjects has no assignee, is that an oversight?
15:11:23 <kgiusti> ? one sec
15:11:46 <kgiusti> whoopsie - missed that one
15:12:06 <kgiusti> I'll hit that up today - good catch.
15:12:28 <bnemec> That's the good thing about having a list. :-)
15:12:49 <bnemec> kgiusti: Thanks for taking care of this.
15:12:53 <kgiusti> Yep, so says my wife.
15:13:10 <bnemec> :-)
15:13:21 <kgiusti> my pleasure (removing code is so relaxing....)
15:13:37 <bnemec> "kgiusti to do a recruiting drive" <- Any bites?
15:14:08 <kgiusti> Well stephenfin and tosky bit.
15:14:25 <kgiusti> But nothing from the other affected projects.
15:16:03 <bnemec> Okay.  Hopefully some of the folks doing the other cross-project cleanup changes will jump in at some point.
15:16:21 <kgiusti> yep
15:16:40 <bnemec> It's practically free commits for anyone judged on those metrics. ;-)
15:16:50 * bnemec dangles the carrot enticingly
15:17:18 <bnemec> "investigate if anyone is using oslo.service wsgi module"
15:17:32 <bnemec> I didn't get to this either.  oslo.service is still on my todo list too though.
15:17:54 <bnemec> Definitely need to get that cleaned up.
15:18:32 <bnemec> That's it for action items from last meeting.
15:18:40 <bnemec> #topic Vancouver project update
15:18:55 <bnemec> So this starts in two weeks.
15:19:34 <bnemec> If you have anything you worked on in Queens that you'd like included in the presentation, please let me know.
15:20:08 <bnemec> Hopefully I'm aware enough of what's going on in Rocky to come up with the future list myself, but I'm happy to take reminders for that too.
15:20:37 <bnemec> I need to get together with gcb and discuss too.  I know he wanted to be involved since he was PTL last cycle.
15:20:51 <bnemec> #action bnemec to sync up with gcb about Vancouver project update
15:21:26 <bnemec> I guess I should action the other part too.
15:21:40 <kgiusti> bnemec: did you have an epad for the topics you plan to cover?  gcb would make one available for review/feedback
15:21:44 <bnemec> #action Oslo contributors to contact bnemec with any project updates they'd like included
15:22:02 <bnemec> kgiusti: Ah, good idea.
15:22:33 <kgiusti> gcb's actually... But I'm happy to take credit! :)
15:23:51 <bnemec> Okay, let's use this:
15:23:53 <bnemec> #link https://etherpad.openstack.org/p/oslo-project-update-rocky
15:24:55 <kgiusti> thanks
15:25:32 <kgiusti> got a link to the scheduled time slot?
15:26:03 <bnemec> I believe it was Wednesday.  Let me find it again.
15:26:40 <bnemec> #link https://www.openstack.org/summit/vancouver-2018/summit-schedule/events/21617/oslo-project-update
15:26:57 * bnemec notes that he needs to update his OpenStack profile
15:27:12 * bnemec also notes that his profile picture was taken in Vancouver the last time
15:27:29 <smcginnis> :)
15:27:52 <bnemec> Also a reminder that we have an onboarding session on Tuesday.
15:27:54 <bnemec> #link https://www.openstack.org/summit/vancouver-2018/summit-schedule/events/21645/oslo-project-onboarding
15:29:02 <bnemec> Okay, I think that's it for this topic.  We can circle back next week and see where it stands.
15:29:14 <bnemec> #topic Open discussion
15:30:44 <bnemec> I guess a couple of quick notes from me:
15:30:45 <bnemec> 1) I started to re-review the config migrator, but didn't quite get all the way through. Will finish it up this week.
15:30:45 <bnemec> 2) I saw some more updates on the config plugin side, haven't had a chance to look at those patches yet though.
15:34:57 <bnemec> Okay, sounds like that's it for this week.  Thanks for joining everyone.
15:35:01 <bnemec> #endmeeting