15:00:11 <bnemec> #startmeeting oslo
15:00:11 <openstack> Meeting started Mon May 14 15:00:11 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:16 <openstack> The meeting name has been set to 'oslo'
15:00:49 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:00:49 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:00:49 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:00:49 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar, therve
15:00:50 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:07 <dhellmann> o/
15:01:23 <kgiusti> o/
15:01:26 <raildo> o/
15:01:28 <ansmith> o/
15:01:49 <e0ne> hi
15:01:53 <jungleboyj> o/
15:02:27 <gcb> o/
15:02:55 <bnemec> #topic Red flags for/from liaisons
15:03:35 <jungleboyj> Nothing from Cinder right now.
15:03:48 <bnemec> Not too much from our side.  We merged a bunch of bug fixes last week that will hopefully make things better.
15:05:18 <bnemec> Okay, we'll move on then.
15:05:20 <bnemec> #topic Releases for Rocky
15:05:32 <bnemec> Just a couple last week, IIRC.
15:05:54 <bnemec> Thanks to dhellmann for doing the stable releases.  That should get us all caught up.
15:06:14 <bnemec> kgiusti: I did hold off on releasing oslo.messaging last week because I saw that the heartbeat work had only partially merged.
15:06:21 <dhellmann> bnemec : no problem
15:06:33 <bnemec> I figured it would be better to wait until that is completely done before doing the feature release.
15:06:46 <kgiusti> bnemec: right
15:06:48 <dhellmann> if someone else is interested in being trained as the release liaison, I would be happy to do the training. just let me know.
15:08:49 <bnemec> Okay, that's all I had on releases.  Expect this week's to happen today or tomorrow.
15:08:59 <bnemec> #topic Action items from last meeting
15:09:19 <bnemec> "bnemec to sync up with gcb about Vancouver project update" and "Oslo contributors to contact bnemec with any project updates they'd like included"
15:09:27 <bnemec> We ended up doing this on the etherpad.
15:09:35 <bnemec> #link https://etherpad.openstack.org/p/oslo-project-update-rocky
15:10:25 <bnemec> I made some good progress on slides for the session.  I'm hoping to send those out shortly to get some feedback.
15:10:57 <bnemec> Which dovetails nicely with the next topic.
15:11:01 <bnemec> #topic Vancouver project update
15:11:19 <bnemec> kgiusti: ansmith: Are either of you going to be there?
15:11:28 <kgiusti> I'll be there
15:11:32 <bnemec> I ask mostly because of the kafka topic.
15:11:33 <gcb> I just added two topics: policy deprecation and external-pdp
15:12:05 <bnemec> kgiusti: Okay, are you good to talk about the kafka work then?
15:12:19 <bnemec> gcb: Yep, thanks
15:12:28 <kgiusti> Sure thnig
15:12:31 <kgiusti> thing
15:12:58 <bnemec> Oh, and the RPC monitoring topic, which I may have forgotten to include in the slides...
15:13:25 <kgiusti> bnemec: if we can collaborate on the slides I can take both rpc mon and kafka
15:13:49 <kgiusti> bnemec: what slide tool are you using?
15:13:50 <bnemec> Actually it was just on a different page because it's still in-progress.
15:14:19 <bnemec> kgiusti: I'm using LibreOffice because the foundation sent out the template in PPTX (yuck).
15:14:27 <kgiusti> np - can I send you a couple of slides for inclusion?
15:14:46 <bnemec> kgiusti: Absolutely.
15:14:53 <kgiusti> bnemec: kk - will do
15:15:18 <bnemec> Thanks
15:16:11 <bnemec> I also talked to Lance about the policy-related stuff, and he's going to try to be in the room to field questions if anyone wants more specifics than I can give.
15:16:32 <gcb> bnemec: will you finish two topics in your slides I mentioned or need my input ?
15:17:11 <bnemec> gcb: I have slides for those already, so I think we're good.
15:17:23 <bnemec> They both had convenient examples that fit well on a slide. :-)
15:17:35 <gcb> bnemec: cool
15:17:55 * jungleboyj just noticed that I am listed on the Oslo On-Boarding session.
15:18:10 <bnemec> Besides details on the messaging work, I think the one thing I'm a little light on is post-Rocky work.
15:18:49 <bnemec> oslo.limit is likely to extend beyond Rocky, but I put that in the cross-project slide.
15:19:12 <bnemec> jungleboyj: That's the next topic. :-)
15:19:20 <jungleboyj> Ok.  Good.  :-)
15:19:44 <bnemec> So if anyone knows of Oslo work planned for next cycle or beyond, please let me know.
15:20:34 <dhellmann> bnemec : that config driver work may carry over
15:21:02 <bnemec> Ah, good point.
15:22:35 <bnemec> Okay, I'll make a few more tweaks and then send the slides to everyone for feedback early this week.
15:23:08 <bnemec> And before we all leave for Vancouver I'll send a final version in case I get snowed in again or something. :-)
15:23:24 <jungleboyj> :-)
15:23:49 <bnemec> Although if that happens, jungleboyj is probably stuck too. ;-)
15:24:11 <jungleboyj> :-(  Yep.  I really hope we are done with snow.
15:24:39 <bnemec> Likewise.
15:25:07 <bnemec> I think we have enough content lined up to fill our 20 minute update slot, so...
15:25:10 <bnemec> #topic Onboarding session agenda
15:25:26 <bnemec> jungleboyj: I think you mentioned that you had done these for Cinder before?
15:25:33 <jungleboyj> Yep.
15:25:40 <bnemec> And you might have a basic outline of an agenda we could follow?
15:25:51 <jungleboyj> bnemec:  Sure.
15:26:46 <bnemec> jungleboyj: Okay, can you send me that sometime this week?
15:27:00 <jungleboyj> Sure.
15:27:06 <bnemec> Cool, thanks.
15:27:12 <jungleboyj> It is basically an overview of our different repos.
15:27:19 <bnemec> #action jungleboyj to send bnemec Cinder onboarding agenda
15:27:23 <jungleboyj> Walk through of the architecture.
15:27:36 <jungleboyj> Introduce the core team members.
15:27:46 <bnemec> Yeah, I don't know that we can hit all of the Oslo repos, but maybe some highlights.
15:27:52 <jungleboyj> High level walk-through of code.
15:28:17 <jungleboyj> Yeah, I need to figure out how to slim mine down as I have half as much time this time.
15:29:00 <bnemec> Okay, we'll figure it out.
15:29:16 <bnemec> FWIW, we do have people signed up for the Oslo session.
15:30:02 <bnemec> They sent out a spreadsheet with some stats from the schedule page and at the time we had 5 people who had added it to their schedule.
15:30:21 <bnemec> Which doesn't guarantee anyone will attend, but hopefully it's a good sign that we won't be talking to ourselves. :-)
15:30:24 <jungleboyj> bnemec:  That is good.
15:30:50 <kgiusti> +1 - tho I do know a few jokes.... just in case.
15:31:19 * bnemec changes the session title to "Standup with Ken" ;-)
15:31:33 <bnemec> 2 drink minimum.
15:31:45 <kgiusti> more drinks than that - I'm not very funny.
15:32:19 <bnemec> :-)
15:32:30 <bnemec> Okay, I think we have a plan for that too.
15:32:31 <jungleboyj> :-)
15:33:41 <bnemec> I guess I should mention that the onboarding session is Tuesday at 3:30
15:33:44 <bnemec> #link https://www.openstack.org/summit/vancouver-2018/summit-schedule/events/21645/oslo-project-onboarding
15:34:26 <bnemec> And back to the previous topic the project update is Wednesday at 9:50
15:34:30 <bnemec> #link https://www.openstack.org/summit/vancouver-2018/summit-schedule/events/21617/oslo-project-update
15:34:50 <bnemec> #topic No meeting next week (or two?)
15:35:13 <bnemec> Monday I and most of you will be in Vancouver, so definitely no meeting then.
15:35:30 <jungleboyj> ++
15:35:32 <bnemec> The following Monday will be the first day back for many people, so I'm not sure it's worth holding a meeting then either.
15:36:09 <bnemec> I know I don't get back until like 10:30 PM on Friday.
15:36:28 <bnemec> At least my flight doesn't leave at 6:00 AM this time though.
15:36:54 <bnemec> So, unless someone has a burning desire to meet I'd say let's skip the next two weeks.
15:37:11 <bnemec> If something comes up we can always change that plan.
15:37:27 <kgiusti> +1
15:38:00 <bnemec> #action bnemec to send email about Oslo meeting cancellations
15:39:32 <bnemec> #topic Weekly Wayward Review
15:39:43 <bnemec> This is a new thing I want to try.
15:40:01 <bnemec> Right before we take two weeks off probably isn't the best time, but oh well.
15:40:37 <bnemec> Basically we have some very old reviews in our repos, and to start working on that backlog I'd like to pick on each week and as a group figure out what to do with it.
15:41:23 <bnemec> Currently our oldest review is:
15:41:25 <bnemec> #link https://review.openstack.org/#/c/450956/
15:41:33 <bnemec> At 410 days (!)
15:42:39 <bnemec> It's entirely unit test additions and is passing CI, so it seems like it shouldn't be too hard to review.
15:43:27 <bnemec> So maybe the way forward with it is just to get it on everyone's review queue?
15:44:48 <bnemec> I do see that some of the followup patches need some work, so maybe that's why this one stalled.
15:45:10 <bnemec> It would be nice to get it off the books if we can though.
15:45:16 <dhellmann> if it is a set of tests to show a bug exists, and the tests patch, does that mean the bug is fixed?
15:45:18 <bnemec> #action Oslo cores to review https://review.openstack.org/#/c/450956/
15:45:43 <dhellmann> or does it mean the tests are proving the library does the wrong thing?
15:45:43 <bnemec> #topic Open discussion
15:45:50 <bnemec> #undo
15:45:51 <openstack> Removing item from minutes: #topic Open discussion
15:46:43 <bnemec> Glancing through I saw some comments about wrong behavior, so I think it might be demonstrating the bug.
15:46:53 <dhellmann> ah, the tests have things that should work but don't commented out
15:46:58 <bnemec> I assume that those tests will be fixed in followups when the bug(s) are actually fixed.
15:47:14 <dhellmann> I wonder if they will, though, because dolph isn't working on openstack any more afaik
15:48:08 <bnemec> Okay, maybe that needs to be WIP'd pending a new owner for the work?
15:48:47 <dhellmann> yeah, I think we want someone to figure out what the story is and at least report back on that and maybe with a suggestion about what approach to take
15:49:29 <dhellmann> some of this might be misinterpretation of what's expected, bad docs, or actual bugs
15:50:33 <bnemec> Is here a #helpwanted meeting command?
15:51:32 <dhellmann> I don't think so :-)
15:52:00 <jungleboyj> :-)  That would be a good addition.
15:52:11 <bnemec> I guess there's already an action to review the patch, and figuring out the direction it needs to go is part of that.
15:52:32 <bnemec> This probably explains why it's been open for over a year now.
15:53:19 <dhellmann> yeah
15:53:39 <bnemec> So if anyone has an abundance of free time, feel free to take over that series.
15:54:39 <bnemec> I guess we'll revisit this next meeting too since it has an action item.  We'll see what has happened in the intervening weeks.
15:54:51 <bnemec> #topic Open discussion
15:55:05 <bnemec> A few minutes left, anything else to discuss?
15:55:39 <jungleboyj> bnemec:  I sent you a link to ne of my onboarding presentations.
15:55:56 <bnemec> jungleboyj: Great, thanks!
15:56:04 <jungleboyj> Welcome.
15:56:28 <bnemec> Oh, oops.  I actually had a couple of other things that I failed to put on the agenda.
15:56:36 <bnemec> The first was release-related.
15:56:46 <bnemec> We have some projects in Oslo that haven't been released yet in Rocky.
15:57:08 <bnemec> The release team sent out a reminder email about such projects last week.
15:57:21 <bnemec> Should we go ahead and release those?
15:57:49 <smcginnis> Do they have pending changes, or have they just been unnecessary?
15:57:53 <bnemec> This is probably a question for dhellmann
15:57:59 <smcginnis> Pending == merged
15:58:19 <bnemec> smcginnis: All the changes in those projects this cycle have been test or doc changes that don't require release.
15:58:28 <dhellmann> then it's safe to leave them
15:59:24 <bnemec> Okay, I'll leave them be then.
15:59:57 <bnemec> The other thing I wanted to mention was that we haven't actually responded to the mox removal goal yet.
16:00:15 <bnemec> That's probably going to have to wait for next meeting though since we're out of time and Summit is next week.
16:00:39 <bnemec> I'm going to leave myself an action item on that though.
16:00:50 <dhellmann> ++
16:00:52 <bnemec> #action bnemec to respond to mox removal goal
16:01:01 <dhellmann> I think our response is probably the patch to move it out of the oslo list
16:01:13 <dhellmann> assuming we're not actually using mox anywhere, of course
16:01:43 <bnemec> Yeah, I'm hoping that the work is mostly just to verify that we aren't.
16:01:57 <bnemec> But I don't know that anyone has looked.
16:02:43 <bnemec> Okay, we're over time.  Thanks for joining everyone!
16:02:45 <bnemec> #endmeeting