15:00:34 <bnemec> #startmeeting oslo
15:00:35 <openstack> Meeting started Mon Jun  4 15:00:34 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:39 <openstack> The meeting name has been set to 'oslo'
15:00:56 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:00:56 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:00:56 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:00:56 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar, therve
15:00:56 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:02 <kgiusti> o/
15:01:03 <e0ne> hi
15:01:09 <gcb> hi
15:01:10 <ansmith> o/
15:01:12 <jungleboyj> o/
15:02:25 <bnemec> #topic Red flags for/from liaisons
15:02:43 <bnemec> Nothing that immediately comes to mind from the Oslo side.
15:05:07 <bnemec> Okay, sounds like everything is quiet.
15:05:10 <bnemec> Which is good. :-)
15:05:13 <bnemec> #topic Releases
15:05:49 <bnemec> I think the major thing of note here was the oslo.messaging release last week.  It added the heartbeating functionality, so projects can start consuming that.
15:06:31 <bnemec> I was a bit late with the releases because of the Monday holiday in the US, so there may be a smaller list of them for this week.
15:07:25 <bnemec> kgiusti: Would you and/or dansmith maybe like to send something to the mailing list to announce this new feature?
15:07:34 <bnemec> I don't know how many people outside of nova and oslo know about it.
15:07:44 <bnemec> And it sounded like something that might be useful to other teams as well.
15:08:01 <kgiusti> bnemec: I certainly will, but I'd like to get the amqp1 driver working with the feature first.
15:08:17 <dansmith> bnemec: I can, but I was kinda hoping to get the support landed in nova and proven in the gate before I go asking other people to use it
15:08:17 <kgiusti> bnemec: that's the only other driver that supports RPC
15:08:33 <bnemec> Okay, that makes sense.
15:08:54 <kgiusti> bnemec: which I should be working on right now if I wasn't in oslo.messaging stable branch hell.
15:09:30 <bnemec> kgiusti: Anything you need help on?
15:09:45 <kgiusti> bnemec: yep - let's talk at the end of the meeting
15:10:37 <bnemec> kgiusti: Ack, added to the agenda.
15:10:44 <kgiusti> ty
15:11:02 <bnemec> #topic Action items from last meeting
15:11:25 <bnemec> "jungleboyj to send bnemec Cinder onboarding agenda" <- Done, and thanks.
15:11:45 <jungleboyj> bnemec:  Welcome.
15:11:57 <bnemec> "bnemec to send email about Oslo meeting cancellations" <- Also done
15:12:07 <bnemec> "Oslo cores to review https://review.openstack.org/#/c/450956/"
15:12:13 <bnemec> We actually kind of wrapped that one up in the meeting.
15:12:47 <bnemec> "bnemec to respond to mox removal goal"
15:13:06 <bnemec> I think I at least assigned myself to that one, so done-ish.
15:13:23 <bnemec> I know we've had some patches landing that are related to it as well.
15:13:36 <bnemec> And that was it for action items.
15:14:01 <bnemec> #topic pbr gate broken
15:14:19 <bnemec> This is kind of an Oslo-internal red flag, but the pbr gate is currently blocked.
15:14:30 <bnemec> All of the integration test jobs are failing due to cmd2.
15:14:58 <bnemec> I think I have a patch ready to go that will use upper-constraints to protect us against that though, so hopefully it will be unblocked by EOD.
15:15:29 <bnemec> And on a similar note...
15:15:29 <bnemec> #topic oslo.messaging stable branches
15:15:35 <bnemec> kgiusti: You're up!
15:16:00 <kgiusti> thanks - there are two patches that are not able to merge to stable/queens and stable/ocata
15:16:17 <kgiusti> the failures appear to not be related.  First queens:
15:16:28 <kgiusti> https://review.openstack.org/#/c/567124/1
15:16:58 <kgiusti> telemetry failure for rabbit: http://logs.openstack.org/24/567124/1/check/oslo.messaging-telemetry-dsvm-integration-rabbit/e7fdc7d/job-output.txt.gz#_2018-05-16_05_20_05_626882
15:17:41 <kgiusti> I think the cause is due to the latest version of heat-tempest-plugin is being used for the test - right off of HEAD - but an incompatible gabbi from u.c.txt
15:18:40 <kgiusti> If that is the case, we need to use an older version of heat-tempest-plugin, but AFAIKT that project has no queens branch...
15:18:53 <bnemec> Hmm, we probably need to bring that up with the Heat team.  I would think this affects their stable branches too, right?
15:19:26 <kgiusti> bnemec: one would think, but the way we define the zuul job may be incorrect:
15:19:50 <kgiusti> https://git.openstack.org/cgit/openstack/oslo.messaging/tree/.zuul.yaml#n195
15:20:20 <kgiusti> IIRC require-projects are always checked out from the head of the 'correct' branch
15:20:46 <kgiusti> but in any case I'll start with the heat folks and see where I get.
15:20:49 <bnemec> Yeah, but if it's a branchless project then it needs to maintain compatibility with stable branch requirements.
15:21:27 <kgiusti> OK, I'll reach out to heat on that one.
15:21:29 <bnemec> Talking to the Heat team seems like a sane first step in any case.
15:21:35 <kgiusti> +1 will do.
15:21:53 <bnemec> #action kgiusti to sync up with Heat team on heat-tempest-plugin incompatibility with stable gabbi
15:22:07 <kgiusti> The ocata issue appears to be related to sphinx + oslo.config:
15:22:33 <kgiusti> https://review.openstack.org/#/c/567121/
15:22:47 <kgiusti> http://logs.openstack.org/21/567121/1/check/build-openstack-sphinx-docs/cc3d7d6/job-output.txt.gz#_2018-05-16_12_08_03_182003
15:23:18 <kgiusti> Not sure how to tell which version of oslo.config is being used from the zuul output.
15:23:34 <kgiusti> sphinx is v 1.3.6
15:24:08 <bnemec> Hmm, we are somewhat lacking in useful logs there, aren't we?
15:24:36 <kgiusti> bnemec: welcome to my nightmare.
15:24:49 <bnemec> Does this reproduce locally?
15:25:21 <kgiusti> I've only run it via zuul but yes every time.
15:27:11 <bnemec> I'm just thinking it might be easier to debug locally than in the gate, although the gate doesn't run things exactly the same as tox necessarily. :-/
15:28:21 <bnemec> Interesting.  I get a different error locally.
15:28:23 <bnemec> sphinx.errors.ExtensionError: Could not import extension oslo_config.sphinxext (exception: cannot import name logging)
15:28:36 <bnemec> Well, let's take a look at this after the meeting.
15:28:38 <kgiusti> yep I see that too
15:28:41 <kgiusti> +1
15:29:05 <bnemec> #topic Weekly Wayward Review
15:29:46 <bnemec> #link https://review.openstack.org/#/c/511971/
15:30:29 <bnemec> I'm wondering if cliff is even supposed to be in Oslo or if it's part of the sdk now.
15:30:42 <bnemec> Although I do have +2 on the repo, which suggests Oslo.
15:32:14 <bnemec> Looks like dhellmann might be the person to talk to about that.
15:33:01 <bnemec> Maybe just WIP it since no one seems sure if this is the right approach?
15:33:16 <dhellmann> it should have been moved under sdk, but I think we left the oslo team as part of the core team
15:33:52 <dhellmann> hmm, apparently we never moved cliff over: https://governance.openstack.org/tc/reference/projects/openstacksdk.html
15:34:20 <dhellmann> ah, there it is: https://governance.openstack.org/tc/reference/projects/openstackclient.html
15:34:25 <dhellmann> not SDK, CLI
15:35:30 <bnemec> dhellmann: Okay, so I should just remove this from the Oslo review list.
15:35:58 <dhellmann> it would be nice to get some reviews there, but you don't need to track it as part of the oslo team
15:36:27 <bnemec> #action bnemec to remove cliff from Oslo review list
15:36:48 <bnemec> Yeah, the review has been open a long time so it would be nice to do something with it, whether it's technically Oslo or not.
15:38:14 <dhellmann> I imagine dtroyer has been pretty busy with StarlingX lately
15:38:43 <bnemec> Yeah
15:39:54 <bnemec> I guess this is another partial success for this topic.  We identified an action to be taken, but didn't actually close out the review. :-/
15:40:13 <bnemec> I suppose there's a reason these reviews have been open so long.
15:40:28 <bnemec> #topic Open discussion
15:40:31 <dhellmann> yeah
15:40:38 <bnemec> Anything else before we close?
15:43:13 <bnemec> Okay, thanks for joining everyone.  Talk to you next week.
15:43:16 <bnemec> #endmeeting