15:00:39 <bnemec> #startmeeting oslo
15:00:40 <openstack> Meeting started Mon Jun 25 15:00:39 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:43 <openstack> The meeting name has been set to 'oslo'
15:00:47 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:00:47 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:00:47 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:00:47 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar, therve
15:00:47 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:00:51 <dhellmann> o/
15:00:55 <stephenfin> o/
15:01:24 <kgiusti> o/
15:01:32 <ansmith> o/
15:01:55 <redrobot> \o
15:02:59 <bnemec> #topic Red flags for/from liaisons
15:03:32 <bnemec> I don't recall doing anything controversial last week.
15:04:59 <njohnston> One note - janzian has retired as the Neutron-Oslo liaison, and I have volunteered to replace him.
15:05:13 <dhellmann> welcome, njohnston!
15:05:34 <dhellmann> please make sure the CrossProjectLiaisons page in the wiki is up to date
15:05:40 <njohnston> Will do.  Thanks!
15:06:17 <bnemec> njohnston: Great!  And if you want to be pinged at the start of the meeting please propose and update to https://github.com/openstack/oslo.tools/blob/master/ping_me.py
15:06:24 <bnemec> *an
15:07:23 <bnemec> I guess on the red flags topic I will note that I ran into an issue with masakari and oslo.context: https://review.openstack.org/#/c/513520/
15:07:46 <bnemec> However, I think it's mostly due to the fact that they use user_id in their sub class and we also use it in oslo.context.
15:08:00 <bnemec> There's a note in the code that they want to remove their user_id anyway so I suspect that will be the right solution.
15:08:22 <bnemec> #topic Releases
15:08:46 <bnemec> Business as usual.  We made several releases last week, and I expect several more this week.
15:09:23 <bnemec> I would still like to get https://review.openstack.org/#/c/573447/ merged before we release oslo.log.
15:09:58 <bnemec> The first half of that merged, but it would be better to have that one too.
15:10:44 <dhellmann> I guess there's no reason to check before appending it?
15:10:56 <dhellmann> it would just reset twice, and it's only a couple of bytes, right?
15:11:00 <bnemec> dhellmann: I don't think it would hurt to have it there twice.
15:11:06 <bnemec> Yeah
15:11:16 <dhellmann> +2a
15:11:25 <bnemec> Thanks
15:11:40 <bnemec> I'll probably wait to do releases today until that merges then.
15:11:48 <dhellmann> ++
15:11:56 <bnemec> #topic Action items from last meeting
15:12:13 <bnemec> We didn't have any.
15:12:45 <bnemec> Although it's worth noting that we previously had an action item related to networkx in taskflow, and someone pushed a patch just before the meeting to address that.
15:12:55 <dhellmann> \o/
15:12:55 <bnemec> #link https://review.openstack.org/577833
15:13:02 <bnemec> We'll see what ci says about it.
15:13:18 <bnemec> But it's good progress either way.
15:13:49 <bnemec> No one off topics today either.
15:14:10 <dhellmann> I have something, we if have time
15:14:17 <bnemec> dhellmann: Sure
15:14:38 <dhellmann> I've been working on writing up the process for moving us to "python 3 first" next cycle
15:14:39 <dhellmann> #link https://review.openstack.org/#/c/575933/
15:14:57 <dhellmann> I need some repositories to test with, so I would like to start with a couple of the oslo repos
15:15:16 <dhellmann> sort of like we did with the tox.ini updates earlier this cycle
15:15:47 <bnemec> I'm good with that.
15:16:12 <bnemec> Oslo needs to be working before most of the other projects can make progress anyway.
15:16:29 <dhellmann> yeah, that's another reason for doing oslo early
15:17:24 <dhellmann> I'm waiting for one or two infra patches to land before we can start, but I will go ahead and send email to the -dev list to announce the work
15:17:55 <bnemec> So I haven't actually read that yet.  Is it a question of switching the devstack jobs to py3?
15:18:07 <bnemec> Or are we adding a py3 job in addition to the existing py2 job(s)?
15:18:43 <dhellmann> there are several changes in there and I'm rolling them all into 1 goal because of the amount of churn in the zuul configuration
15:19:08 <dhellmann> if you haven't read it, then you're a good person to give feedback on whether it explains things clearly :-)
15:19:14 <bnemec> Okay, looks like we've already done some of the steps for oslo though.
15:19:28 <dhellmann> yeah, I've done some of them, but not all
15:19:48 <dhellmann> I would like to finish at least 1 oslo repo before stein (maybe all of them if we have time)
15:20:10 <bnemec> Okay, I'll add that to my review list.
15:20:28 <bnemec> #action bnemec review https://review.openstack.org/#/c/575933
15:21:29 <dhellmann> thanks
15:22:31 <bnemec> Anyone else who wants to take a look is welcome to as well, of course. :-)
15:23:11 <bnemec> #topic Weekly Wayward Review
15:23:32 <bnemec> We actually merged a longstanding review last week.  I can't remember what it was, but I think it was the next one on the list.
15:23:34 <bnemec> So \o/
15:23:55 <bnemec> Next up is a pbr review.
15:23:55 <dhellmann> woot!
15:23:59 <bnemec> #link https://review.openstack.org/549304
15:24:31 <bnemec> Oh, that should be WIP.  It depends on a WIP patch.
15:25:42 <bnemec> And the WIP patch has some disagreement on it, so not sure we can unblock it in this meeting.
15:25:58 <bnemec> #action bnemec to WIP https://review.openstack.org/#/c/549304
15:26:12 <bnemec> That was easy. :-)
15:26:50 <bnemec> #topic Open discussion
15:27:04 <bnemec> I guess we kind of already did this, but anything else to discuss?
15:29:12 <dhellmann> what are our plans for storyboard?
15:29:49 <bnemec> I don't have any concrete ones at the moment.
15:30:10 <bnemec> I guess the first step would be to do a test import.
15:30:30 <bnemec> I don't think it's a given that it will go smoothly since I suspect we have a lot more launchpad projects than anyone else.
15:31:12 <dhellmann> we're far from the biggest any more, but a test import is definitely part of the process
15:31:23 <dhellmann> diablo_roja and fungi can help with that
15:31:36 <bnemec> Yeah, I don't think we're the biggest, but I'm not sure anyone else has as many separate lp projects.
15:31:49 <bnemec> Even tripleo manages most of their bugs under one project.
15:32:01 <dhellmann> ah
15:32:20 <bnemec> But there are other multi-lp-project projects that have migrated, so I assume that is supported.
15:32:30 <bnemec> It's more a question of scaling.
15:32:36 <dhellmann> yeah, I'm sure that's doable
15:32:39 <dhellmann> still, testing is good
15:33:36 <bnemec> Okay, I can kick off a discussion with them about trying the import.
15:33:40 <dhellmann> ++
15:33:47 <bnemec> Once we have that as a baseline we can figure out what our next steps are.
15:34:14 <bnemec> #action bnemec to contact storyboard team about doing test import of oslo projects
15:34:36 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2018-June/131787.html announce plan to use oslo for testing python 3/zuul transition steps
15:34:50 <bnemec> Cool, thanks
15:35:27 <bnemec> Anything else?
15:35:39 <dhellmann> that's it from me
15:36:15 <njohnston> nothing else here
15:38:30 <bnemec> Okay, thanks everyone for all your work and for joining the meeting!
15:38:34 <bnemec> #endmeeting