15:02:06 <bnemec> #startmeeting oslo
15:02:07 <openstack> Meeting started Mon Jul  2 15:02:06 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:08 <lbragstad> thanks
15:02:10 <openstack> The meeting name has been set to 'oslo'
15:02:15 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:02:15 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:02:15 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:02:15 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar, therve
15:02:15 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:02:27 <jungleboyj> Morning.
15:02:38 <kgiusti> o/
15:02:40 <bnemec> lbragstad: We can fast-approve that whenever it passes ci.
15:03:49 <dhellmann> o/
15:04:01 <johnsom> o/
15:04:29 <openstackgerrit> Merged openstack/futurist master: Add blueprints notes link to README  https://review.openstack.org/579075
15:04:40 <bnemec> #topic Red flags for/from liaisons
15:05:01 <bnemec> lbragstad noticed an issue with oslo.policy and the new oslotest last week.
15:05:32 <bnemec> I believe the problem was that oslotest dropped testr as a dep, so if projects don't have it explicitly in their own test-requirements then their unit tests will be broken.
15:05:51 <dhellmann> how is that a problem with oslotest?
15:05:52 <bnemec> For oslo.policy we're taking this opportunity to migrate to stestr.
15:05:58 <openstackgerrit> Merged openstack/oslo.policy master: Add blueprints and releasenotes link to README  https://review.openstack.org/579329
15:06:14 <bnemec> dhellmann: It's not, but it's something to be aware of.
15:06:18 <dhellmann> ok
15:06:40 <bnemec> Call it a yellow flag. :-)
15:06:49 <johnsom> Nothing to report from Octavia
15:07:12 <dhellmann> 2 yellow flags and the library is ejected from the game?
15:08:08 <bnemec> https://goo.gl/images/mPl4xK
15:08:50 <jungleboyj> :-)  No red flags from Cinder that I know of.
15:09:07 <bnemec> Okay, sounds like that covers it.
15:09:09 <bnemec> #topic Releases
15:09:23 <bnemec> BAU
15:09:38 <bnemec> Will do the next set of Oslo releases early this week.
15:10:27 <bnemec> #topic Action items from last meeting
15:10:37 <bnemec> "bnemec review https://review.openstack.org/#/c/575933"
15:10:45 * bnemec doesn't remember what that was
15:10:58 <bnemec> Ah, python3 first.  I did that.
15:11:09 <bnemec> "bnemec to WIP https://review.openstack.org/#/c/549304"
15:11:20 <bnemec> Also done.
15:11:31 <bnemec> "bnemec to contact storyboard team about doing test import of oslo projects"
15:11:40 <bnemec> Not done.
15:12:05 <bnemec> I got hung up on some designate stuff last week and never got around to this.  Will keep it on the list for next week.
15:12:09 <bnemec> #action bnemec to contact storyboard team about doing test import of oslo projects
15:12:25 <bnemec> And that was it.
15:12:36 <bnemec> #topic pbr Sem-Ver headers
15:12:47 <bnemec> This came up on https://review.openstack.org/#/c/561731/
15:12:49 <bnemec> #link https://review.openstack.org/#/c/561731/
15:13:33 <bnemec> fungi mentioned he's not a big fan of this feature because once a patch merges with a version bumping sem-ver tag it's impossible to undo.
15:13:48 <dhellmann> I agree
15:13:57 <bnemec> And we don't actually use it in openstack.
15:14:17 <dhellmann> I would support deprecating the automatic calculation for dev tags but retaining the calculation for an explicit tag operation like this command
15:14:23 <bnemec> However, apparently it is being used elsewhere because the submitter of the patch wants it even better integrated.
15:15:24 <bnemec> dhellmann: That sounds reasonable.
15:15:44 <bnemec> Do you want to leave that as a comment on the review?
15:15:54 <dhellmann> sure
15:16:01 <bnemec> Gaetan sounds like he might be willing to pick up that work.
15:16:48 <bnemec> #action dhellmann to comment on https://review.openstack.org/#/c/561731/
15:17:21 <bnemec> That was easier than I expected. :-)
15:17:31 <bnemec> #topic Oslo feature freeze
15:17:41 <bnemec> It's coming soon.
15:17:52 <bnemec> I believe next week sometime?
15:18:37 <bnemec> Yeah, next week is the week before final non-client release, which is when we defined the Oslo feature freeze.
15:19:17 <bnemec> So I guess features need to have landed by the end of next week or they'll have to get pushed to Stein.
15:19:39 <bnemec> I'm planning to send out an email to the list later this week to let everyone know.
15:19:50 <bnemec> #action bnemec to send mail to -dev about Oslo feature freeze
15:20:50 <bnemec> Let me know if you have any questions or concerns about this.
15:21:18 <bnemec> And that's it for topics.
15:21:20 <bnemec> #topic Weekly Wayward Review
15:21:38 <bnemec> #link https://review.openstack.org/518949
15:22:14 <bnemec> Hmm, dhellmann left comments months ago that haven't been responded to.
15:22:42 <bnemec> Maybe this should be marked WIP until those are resolved?
15:23:33 <dhellmann> I can leave a -1 in case the submitter didn't see my comments before
15:23:42 <bnemec> That might be good.
15:23:58 <bnemec> At the very least I agree with your comment on the name of the extras.
15:24:13 <bnemec> The other one the submitter needs to answer.
15:24:43 <dhellmann> ok, I left a -1 there and also commented on the pbr patch
15:24:49 <bnemec> dhellmann: Thanks
15:25:16 <bnemec> That's another longstanding review off the list \o/
15:25:26 <dhellmann> I like doing this
15:25:33 <dhellmann> I'd even say we could do 2-3 each week
15:25:44 <dhellmann> but doing at least one is a good system
15:25:45 <bnemec> I feel like it's really helped clean up our backlog.
15:25:54 <dhellmann> ++
15:26:46 <bnemec> My hope is that at some point we'll whittle it down to where we don't always even have a review that needs attention.
15:27:15 <dhellmann> good goal
15:27:39 <bnemec> We already have reviews in the oldest 15 that are only single digit days, so I feel like we're mostly keeping up.
15:27:55 <dhellmann> oh, nice, that's better than I assumed
15:28:05 <bnemec> So big thanks to everyone doing reviews for that!
15:29:01 <bnemec> I do still owe a review on the config migration patch.
15:29:09 <bnemec> #action bnemec to review config migration change
15:29:28 <bnemec> Especially with feature freeze coming up.
15:29:47 <bnemec> #topic Open discussion
15:29:59 <bnemec> Anything else this week?
15:30:35 <dhellmann> nothing from me
15:31:10 <jungleboyj> Nothing from me.
15:32:17 <stephenfin> Nope
15:33:42 <bnemec> Okay, sounds like we're done.
15:33:47 <bnemec> Thanks for joining everyone!
15:33:50 <bnemec> #endmeeting