15:00:40 <beekneemech> #startmeeting oslo
15:00:41 <openstack> Meeting started Mon Jul  9 15:00:40 2018 UTC and is due to finish in 60 minutes.  The chair is beekneemech. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:45 <openstack> The meeting name has been set to 'oslo'
15:00:51 <beekneemech> #chair bnemec
15:00:51 <openstack> Warning: Nick not in channel: bnemec
15:00:52 <openstack> Current chairs: beekneemech bnemec
15:00:59 <dhellmann> o/
15:01:00 <bnemec> Did it again. :-)
15:01:01 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:01 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:01 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:01:01 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar, therve
15:01:03 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:30 <stephenfin> o/
15:01:42 <kgiusti> o/
15:01:51 <ansmith> o/
15:02:52 <jungleboyj> o/
15:03:47 <bnemec> Oops, forgot to update my local oslo.tools.
15:04:09 <bnemec> Sorry, njohnston_.  I'll include you next week. :-)
15:04:25 <bnemec> #topic Red flags for/from liaisons
15:05:13 <jungleboyj> Nothing from Cinder.
15:06:01 <bnemec> I don't find anything in my notes from last week that seems concerning.
15:06:31 <bnemec> #topic Releases
15:06:52 <bnemec> kgiusti: I saw there was another api breaking change proposed to oslo.messaging.
15:06:58 <bnemec> Did we decide what to do with the previous one?
15:07:26 <kgiusti> bnemec: I approved the previous one - there were no meaningful uses of it according to codesearch
15:07:56 <bnemec> Okay, and I see you pushed back on the new one since it's still in use.
15:07:59 <kgiusti> bnemec: the new one I'm a bit hesitant, just given the timing and the number of references to it
15:08:09 <bnemec> Considering that, I'm inclined to agree that it should just wait until stein.
15:08:29 <bnemec> This isn't the ideal part of the cycle to be removing deprecated stuff.
15:08:40 <kgiusti> bnemec: yeah we've been dinged on doing that in the past
15:09:22 <bnemec> Okay, let's hold off on that one then.
15:09:37 <kgiusti> +1
15:09:42 <bnemec> In which case we should be good to release oslo.messaging again this week.
15:10:01 <kgiusti> yes
15:10:11 <njohnston_> thanks bnemec
15:10:19 <jungleboyj> bnemec:  ++
15:10:40 <bnemec> I think that's all I had for releases.  Expect the usual batch this week.
15:11:20 <bnemec> #topic Action items from last meeting
15:11:44 <bnemec> "bnemec to contact storyboard team about doing test import of oslo projects"
15:11:52 <bnemec> Bah, still didn't do that. :-(
15:12:10 <bnemec> "dhellmann to comment on https://review.openstack.org/#/c/561731/"
15:12:11 <bnemec> Done
15:12:20 <bnemec> "bnemec to send mail to -dev about Oslo feature freeze"
15:12:23 <bnemec> Done
15:12:29 <bnemec> "bnemec to review config migration change"
15:12:30 <bnemec> And done
15:12:51 <bnemec> So 75%.
15:13:02 <bnemec> #action bnemec to contact storyboard team about doing test import of oslo projects
15:13:06 <bnemec> Let's try that one again.
15:13:36 <bnemec> #topic Oslo feature freeze
15:13:51 <bnemec> Final reminder that it's this week.
15:14:17 * dhellmann needs to review those oslo config driver changes one more time
15:14:19 <bnemec> We freeze before everyone else so other projects have a chance to implement any new features we add before their feature freeze.
15:14:26 <bnemec> As do I.
15:14:31 <bnemec> I know we were getting close.
15:15:52 <bnemec> That was it for topics.
15:15:58 <bnemec> #topic Weekly Wayward Review
15:16:40 <bnemec> #link https://review.openstack.org/552045
15:16:49 <bnemec> This one's lbragstad's policy spec.
15:17:29 <lbragstad> o/
15:18:00 <bnemec> Ah, I see there is some question about whether we need this now.
15:18:05 <lbragstad> fwiw - i did leave a comment on that
15:18:10 <lbragstad> pointing to https://review.openstack.org/#/c/578995/
15:18:13 <lbragstad> #link https://review.openstack.org/#/c/578995/8
15:18:45 <dhellmann> I like the approach in the code patch, so we just need to get that working
15:18:50 <dhellmann> I think we can skip the spec, right?
15:19:19 <bnemec> Yeah, that sounds good to me.
15:19:24 <lbragstad> i think we can, too
15:19:49 <lbragstad> i'm investigating the failure on https://review.openstack.org/#/c/578995/
15:19:56 <lbragstad> the type check failed again
15:20:03 <lbragstad> i hope to get that passing today
15:20:22 <dhellmann> is that the thing where it needs to support the deprecated values thing from oslo.context?
15:20:54 <lbragstad> yeah...
15:21:13 <dhellmann> ok
15:21:14 <lbragstad> type checking with collections.MutableMapping failed
15:21:30 <lbragstad> http://logs.openstack.org/95/578995/8/check/legacy-tempest-dsvm-neutron-src/6634c62/logs/screen-keystone.txt.gz#_Jul_04_00_40_34_434204
15:22:31 <dhellmann> hmm
15:24:38 <dhellmann> maybe we need to make that class in oslo_context public
15:24:43 <dhellmann> we're returning it anyway
15:25:09 <lbragstad> yeah
15:25:13 <bnemec> Yeah, it seems a little weird to return a private class to callers.
15:25:31 <lbragstad> i suppose it is getting consumed by other things that are calling a public method
15:25:32 <bnemec> For one thing, private objects don't get documented.
15:25:54 <dhellmann> right on both counts
15:26:06 <dhellmann> let me play with the isinstance thing a little before we change that, though
15:26:38 <lbragstad> ok, let me know if you want to sync later dhellmann
15:27:02 <bnemec> Sounds like we have a plan to move forward anyway.
15:27:15 <bnemec> #action resolve interaction between oslo.policy and oslo.context
15:27:30 <bnemec> #topic Open discussion
15:27:36 <bnemec> Anything else before we close?
15:27:36 <dhellmann> lbragstad : isinstance is returning true for me when I instantiate a _DeprecatedPolicyValues
15:27:53 <lbragstad> hmm
15:28:10 <dhellmann> lbragstad : the logic in the if statement is wrong
15:28:58 <dhellmann> I left a comment on the patch
15:29:06 <lbragstad> checking
15:29:18 * lbragstad facepalm
15:29:19 <bnemec> Ah, that needs to be and?
15:29:25 <lbragstad> fwiw - https://review.openstack.org/#/q/status:open+project:openstack/oslo.limit+branch:master+topic:claims-implementation
15:29:28 <dhellmann> lbragstad : in fact you can pass a tuple of types as the 2nd arg to isinstance()
15:29:39 <lbragstad> for those that were interested in the oslo.limit library - i have some work up for that
15:29:40 <dhellmann> which would make that expression shorter anyway
15:29:47 <lbragstad> dhellmann: oh - nice
15:30:11 <lbragstad> i should have dug deeper into the syntax of isinstance
15:30:36 <dhellmann> oh, and since dict inherits from collections.MutableMapping you don't have to check dict separately
15:30:38 <bnemec> I love it when someone else already wrote the code I need. :-)
15:31:08 <lbragstad> yeah - this is my first stab at tinkering with context managers
15:31:37 <lbragstad> still need to handle the actual calling to keystone on __enter__ and whatnot, but those kinda lay the ground work
15:31:44 <lbragstad> s/those/those patches/
15:32:15 <bnemec> FTR, oslo.limit won't be subject to Oslo feature freeze since it hasn't been released yet.
15:32:22 <lbragstad> oh - cool
15:32:27 <bnemec> So we can continue to iterate on that for now.
15:32:32 <lbragstad> good deal...
15:32:43 <bnemec> Obviously it won't be able to be adopted by any other projects until after feature freeze, but we can make progress on our side.
15:33:11 <lbragstad> it'd be cool to have something by the end of the release that is consuming the existing unified limit work in keystone
15:33:37 <lbragstad> even if it's PoC, it should get people on the ground running if they want to adopt it in early Stein
15:34:23 <bnemec> Yep, getting new stuff in early in the cycle is always good.
15:34:53 <lbragstad> i'm trying to think of the best way to write up how to consume this
15:35:17 <bnemec> I'm guessing it will look a lot like the presentation at summit.
15:35:49 <lbragstad> #link http://specs.openstack.org/openstack/keystone-specs/specs/keystone/rocky/strict-two-level-enforcement-model.html#proposed-library-changes-consumption
15:35:53 <lbragstad> you mean ^ ?
15:36:26 <bnemec> Yeah, I think that was it.
15:36:36 <lbragstad> yeah
15:36:59 <lbragstad> i was also going to try and WIP a patch to nova that consumes it, but i'm wondering if that it too specific?
15:37:46 <bnemec> Seems like a good idea to me.
15:37:58 <lbragstad> sounds good
15:38:03 <bnemec> It's nice to have a demonstration of how something will be consumed.
15:39:19 <lbragstad> ++
15:39:45 <bnemec> Okay, anything else?
15:40:21 <jungleboyj> *crickets*
15:41:13 <bnemec> Thanks for joining everybody!
15:41:15 <bnemec> #endmeeting