15:00:29 <bnemec> #startmeeting oslo
15:00:33 <openstack> Meeting started Mon Aug 13 15:00:29 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:36 <openstack> The meeting name has been set to 'oslo'
15:00:41 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:00:41 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:00:41 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, njohnston
15:00:41 <bnemec> courtesy ping for raildo, redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar
15:00:41 <bnemec> courtesy ping for therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:00:43 <njohnston> o/
15:00:54 <redrobot> only kinda o/
15:01:12 <ansmith> o/
15:01:18 <jungleboyj> kinda here.  Have a realtor coming to take pictures of the lakehouse so I will disappear soon.
15:01:45 <bnemec> jungleboyj: Aw, are you selling it? :-/
15:02:35 <bnemec> I'm kind of expecting this to be a short meeting anyway though.
15:02:50 <bnemec> I just got back from PTO and will mostly be spending the day catching up.
15:02:59 <dhellmann> o/
15:03:33 <bnemec> #topic Red flags for/from liaisons
15:03:49 <dhellmann> bnemec : when we get to a good point in the agenda I would like to talk about the python3 goal work for a second
15:04:01 <bnemec> dhellmann: ack, I'll add it to the agenda
15:04:09 <dhellmann> sorry, I should have done that myself
15:05:08 <bnemec> Okay, not hearing any red flags so we'll move on.
15:05:13 <bnemec> #topic Releases
15:05:31 <bnemec> I obviously didn't do any last week.
15:05:48 <bnemec> I think the latest update was that some stable branches got released.
15:06:08 <jungleboyj> No redflags.
15:06:18 <bnemec> Although I only say that because I noticed a "fix included in..." email when I was skimming my email.
15:06:25 <jungleboyj> My landlord is selling it.  I bought a bigger place closer to town.
15:07:18 <bnemec> jungleboyj: Ah, didn't realize you were renting.
15:07:26 * bnemec tries to stay on topic now :-)
15:07:35 <jungleboyj> Sorry.  :-)
15:07:51 <bnemec> jungleboyj: I asked. :-)
15:08:07 <bnemec> #topic Action items from last meeting
15:08:21 <bnemec> No meeting last week and no action items from the one before that.
15:08:37 <bnemec> #topic Python 3 goal
15:08:41 <bnemec> dhellmann: You're up.
15:08:55 <dhellmann> hi!
15:09:11 <dhellmann> so, first, thanks to everyone who has been reviewing the patches to move the zuul settings into our repos
15:09:20 <dhellmann> that has been moving along very nicely
15:09:37 <dhellmann> we have a few that are failing tests, and if anyone has some time to help I could use a hand
15:09:49 <dhellmann> mostly it looks like we need to backport stestr changes to stable/rocky
15:10:04 <dhellmann> though in some cases I did find differences in behavior (oslo.log)
15:10:08 <bnemec> Yeah, I ran across a few of those while review the rocky branch changes.
15:10:11 <bnemec> *reviewing
15:10:29 <bnemec> I have reviews up for at least some of the repos.
15:10:52 <dhellmann> over the weekend I did a little bit of patch merging to get some jobs passing
15:11:05 <dhellmann> let me make a list of our open patches...
15:11:23 <dhellmann> http://paste.openstack.org/show/727932/
15:11:39 <dhellmann> those are the ones I'm tracking as part of the goal
15:12:35 <dhellmann> oh, I also submitted a bunch of new patches to add py3.6 unit test jobs
15:12:51 <dhellmann> and I'm not sure if the lib-foward-testing-python3 patches were there when you looked last, bn
15:12:52 <dhellmann> bnemec
15:13:08 <dhellmann> does anyone have any questions about any of these?
15:13:35 <dhellmann> I plan to send out a first status email tomorrow so if you have questions (or have had them and figured things out) I could put that info into the status update
15:13:36 <bnemec> So basically you need reviews on any with passing tests and fixes/reviews for any that are failing?
15:13:41 <dhellmann> yes, that's right
15:14:03 <dhellmann> we can avoid duplicating effort by leaving comments on patches to say who is going to deal with fixing it
15:14:22 <bnemec> #action Review patches listed in http://paste.openstack.org/show/727932/
15:14:31 <bnemec> Sounds like a plan.
15:14:46 <dhellmann> oh, the day after you left we had the question of whether these needed 2 cores to review. I didn't want to make that sort of decision without you around
15:14:55 <dhellmann> I should have thought to bring it up earlier :-)
15:15:14 <dhellmann> I'm comfortable with it either way, especially for the cases where we have code changes
15:15:35 <dhellmann> I mean, especially in those cases we might want 2 reviewers
15:15:57 <bnemec> Yeah, for the ones that are pure boilerplate I'd be fine with single approving.
15:16:08 <bnemec> If more changes are necessary then maybe stick with 2?
15:16:13 <dhellmann> wfm
15:16:46 <dhellmann> also, I appreciate the team going first. I was able to find and fix several bugs in my scripts as a result of having real patches to work with.
15:17:26 <dhellmann> that's all I had
15:17:56 <bnemec> Cool, thanks for the update.
15:18:03 <bnemec> I will try to take a look at that this week.
15:18:26 <dhellmann> thanks!
15:18:52 <bnemec> #topic PTG planning etherpad
15:18:56 <bnemec> #link https://etherpad.openstack.org/p/oslo-stein-ptg-planning
15:19:05 <bnemec> Just my weekly reminder that this exists.
15:19:33 <bnemec> We're within a month of the actual event so hopefully we're getting a better idea of what needs to be done in Stein.
15:19:57 <dhellmann> I wonder if moguimar wants to put anything on that list about the castellan driver work for oslo.config
15:20:48 <bnemec> Yeah, that would probably fit under the oslo.config driver next steps.
15:21:05 <bnemec> I don't know if anyone from that team will be there though.
15:21:09 <dhellmann> yeah, I don't know if any of those folks are going to be able to be there
15:21:34 <dhellmann> we have time
15:21:37 <bnemec> If we have that meeting tomorrow then maybe we can bring it up.
15:22:02 <dhellmann> ++
15:24:01 <bnemec> #topic Core team updates
15:24:10 <bnemec> Before I left there were a couple of new cores proposed on the list.
15:24:32 <bnemec> If there were no new objections since then I'll be adding them to the gerrit ACLs this week.
15:24:58 <dhellmann> ++
15:25:04 <bnemec> #action bnemec to update Gerrit ACLs with new cores
15:26:41 <bnemec> #topic Weekly Wayward Review
15:26:48 <bnemec> #link https://review.openstack.org/#/c/582203/
15:26:54 * bnemec is still avoiding the feature patches for now
15:27:24 <bnemec> dhellmann had a comment on that one that I think has been answered.
15:28:09 <dhellmann> this still feels weird, but I think I understand the reply
15:28:34 <bnemec> Yeah, it might be worth opening a bug upstream with Python?
15:29:02 <bnemec> This is kind of terrible behavior and it doesn't seem specific to oslo.log.
15:30:29 <dhellmann> the stdlib syslog handler must be doing some of the translation
15:30:36 <dhellmann> it doesn't use the syslog module
15:30:46 <dhellmann> I wonder if this is really a bug in our syslog handler
15:32:24 <dhellmann> I'm going to post some more questions on the review, because even if this is the best approach the wording isn't clear to me
15:32:45 <bnemec> ack
15:35:03 <bnemec> Okay, we'll table that one for further investigation.
15:35:08 <bnemec> #topic Open discussion
15:35:14 <bnemec> Anything else?
15:37:31 <bnemec> Looks like we're done.  Thanks for joining everyone!
15:37:32 <bnemec> #endmeeting