15:00:29 <bnemec> #startmeeting oslo
15:00:29 <openstack> Meeting started Mon Aug 20 15:00:29 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <openstack> The meeting name has been set to 'oslo'
15:00:36 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:00:36 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:00:36 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, njohnston
15:00:36 <bnemec> courtesy ping for raildo, redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar
15:00:36 <bnemec> courtesy ping for therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:00:45 <stephenfin> o/
15:00:46 <dhellmann> o/
15:00:47 <jungleboyj> o/
15:00:49 <ansmith> o/
15:00:55 <dhellmann> I guess we solved the ping/kick problem?
15:01:03 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:05 <redrobot> o/ but only kinda b/c I have another meeting happening in parallel
15:01:17 <bnemec> dhellmann: It sounds like it was only an issue if you had the Sigyn bot in your channel.
15:01:18 <kgiusti> o/
15:01:40 <dhellmann> ah
15:01:55 <bnemec> It was never a problem for this meeting, I only asked about it to try to avoid having it become one.
15:03:05 <bnemec> #topic Red flags for/from liaisons
15:04:32 <bnemec> Pretty light activity on the release front for us so there shouldn't be much in the way of new problems.
15:06:08 <bnemec> #topic Releases
15:06:45 <bnemec> I think the only noteworthy thing here is the Castellan FFE, which needs an ack from the requirements team.
15:07:34 <bnemec> #link https://review.openstack.org/592746
15:07:58 <bnemec> #topic Action items from last meeting
15:08:25 <bnemec> "Review patches listed in http://paste.openstack.org/show/727932/"
15:08:58 <bnemec> Made some progress, although I believe there are a number of those still open.
15:09:30 <bnemec> Will keep that one on the list for next week.
15:09:33 <bnemec> #action Review patches listed in http://paste.openstack.org/show/727932/
15:09:52 <bnemec> "bnemec to update Gerrit ACLs with new cores"
15:10:50 <bnemec> I got Zane added to oslo.service.  Because of the change to Moises' proposed status that got delayed until this week.
15:11:05 <bnemec> dhellmann: You were going to update the ACL for the latter?
15:11:14 <bnemec> (assuming no objections, of course)
15:13:35 <bnemec> Okay, someone will take care of that when the time comes.
15:13:55 <bnemec> #action add moguimar to core ACL after review period ends
15:14:03 <bnemec> Which I think is soon.
15:14:14 <bnemec> And that was it for action items.
15:14:28 <bnemec> #topic PTG planning etherpad
15:14:34 <bnemec> #link https://etherpad.openstack.org/p/oslo-stein-ptg-planning
15:15:16 <bnemec> I was wondering this morning if there's any common code for the upgrade status goal that should live in Oslo.
15:16:05 <bnemec> I haven't looked at the existing code in Nova though so TBD on that.
15:16:41 <bnemec> Anyway, if you have anything to discuss feel free to add it to the etherpad.  It's still pretty light right now.
15:16:54 <bnemec> #topic Berlin Project Update and Onboarding
15:17:29 <bnemec> Looking ahead, I got the request from the Foundation to let them know if we want to do a project update and onboarding session in Berlin.
15:17:49 <bnemec> I have no idea whether I'm going yet though.
15:18:58 <bnemec> So I guess this is kind of a notification to start thinking about what, if anything, we would want to include in such sessions.
15:19:18 <bnemec> Otherwise we can revisit this once travel plans are clearer.
15:19:44 <bnemec> #topic Broken repos
15:20:05 <bnemec> Doug's patch bombs have exposed the fact that some of our repos are failing ci for various reasons.
15:20:17 <bnemec> Mostly it's missing stestr migrations on the rocky branch.
15:20:49 <bnemec> #link https://review.openstack.org/587987
15:20:59 <bnemec> #link https://review.openstack.org/588046
15:21:08 <bnemec> #link https://review.openstack.org/588060
15:21:32 <bnemec> That's oslo.cache, context, and reports.
15:21:51 <bnemec> I have on my list that concurrency is also broken, but I think that was the bandit issue.
15:22:34 <bnemec> And that's fixed: https://review.openstack.org/592665
15:23:07 <bnemec> So please review the stestr migration backports to unblock those repos.
15:23:20 <bnemec> #action review stestr migration backports
15:23:56 <dhellmann> bnemec : sorry, I got pulled away, yes, I can add moguimar to the core team
15:24:11 <bnemec> dhellmann: Thanks
15:24:48 <dhellmann> I'll do that today if you think we're ready, or I can wait until a week has passed from my update email (that should be Wednesday)
15:26:59 <bnemec> I'm okay with today.  I don't anticipate any objections and if somone does strongly disagree with adding him we can always undo the change while that discussion happens.
15:28:33 <dhellmann> done
15:28:44 <bnemec> thanks
15:29:17 <bnemec> #topic Weekly Wayward Review
15:30:09 <bnemec> Since most of these are feature reviews and I'd rather avoid merging any major features until final releases are done I'm going to punt a bit on this one.
15:30:28 <bnemec> I just WIP'd a couple of patches in the list that needed it.
15:31:05 <bnemec> Once final releases are done we can look more seriously at merging features since the risk of backport pain is lower then.
15:31:10 <dhellmann> ++
15:31:35 <bnemec> #topic Open discussion
15:33:38 <bnemec> Going once...
15:33:54 <jungleboyj> bnemec: Sorry.  Got pulled away.
15:34:02 * dhellmann has nothing this week except to ask for reviews on those python3-first job patches
15:34:09 <jungleboyj> I am pretty sure I will be in Berlin.
15:34:19 <jungleboyj> Have verbal confirmation at least.
15:34:24 <jungleboyj> So, if you need help, let me know.
15:34:34 <bnemec> jungleboyj: Great, thanks!
15:34:44 <jungleboyj> bnemec:  No problem.
15:35:05 <bnemec> I'm expecting to be there, but I haven't actually talked to anyone about it yet so that's pure speculation.
15:35:15 <jungleboyj> Ok.  Sounds good.
15:35:23 * bnemec hasn't talked to his manager in about a month
15:35:53 <bnemec> dhellmann: I had an action item for that earlier.
15:36:47 <bnemec> There are a few that were blocked on broken repos too, so there is also an action item to review those fixes.
15:37:40 <dhellmann> yes, good on both counts
15:38:08 <bnemec> Okay, anything else before we wrap it up?
15:38:26 <jungleboyj> Nothing from me.  Unless you can clone me or invent a time machine.
15:39:14 <bnemec> I'm sure future me will chime in any moment...
15:40:08 <bnemec> Guess not. :-)
15:40:14 <bnemec> Thanks for joining everyone!
15:40:16 <bnemec> #endmeeting