15:01:20 <bnemec> #startmeeting oslo
15:01:22 <openstack> Meeting started Mon Aug 27 15:01:20 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:25 <openstack> The meeting name has been set to 'oslo'
15:01:38 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:38 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:38 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, njohnston
15:01:38 <bnemec> courtesy ping for raildo, redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar
15:01:38 <bnemec> courtesy ping for therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:50 <jungleboyj> o/
15:01:52 <jungleboyj> Kind of here.
15:02:09 <kgiusti> o/
15:02:19 <ansmith> o/
15:02:53 <gcb_> o/
15:03:40 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:03:50 <dhellmann> o/
15:04:21 <bnemec> #topic Red flags for/from liaisons
15:05:44 <bnemec> Nothing that I'm aware of from last week.
15:06:40 <bnemec> #topic Releases
15:06:55 <bnemec> We released castellan last week as an FFE.
15:07:07 <bnemec> Otherwise that was it.
15:07:40 <bnemec> I guess now that we're past the rc date we can start releasing stein?
15:08:24 <kgiusti> bnemec: there are a few deprecations that are due to land
15:08:38 <kgiusti> bnemec: they need to be done earlier rather than later
15:09:00 <kgiusti> I'm assuming it's ok to start that process now on master, no?
15:09:07 <bnemec> kgiusti: deprecations or removals?
15:09:26 <kgiusti> bnemec: gah - deprecated things that are due for removal, sorry
15:09:41 <kgiusti> bnemec: remove them now?
15:10:08 <openstackgerrit> Chuck Short proposed openstack/oslo.privsep master: Replace assertRaisesRegexp with assertRaisesRegex  https://review.openstack.org/596793
15:10:40 <bnemec> kgiusti: Yeah, that's good to do early.
15:11:09 <kgiusti> ok thanks
15:13:05 <bnemec> And I'll take a todo to figure out if we're good to start releasing stein versions of things.
15:13:28 <bnemec> #action bnemec check if we can release stein libraries
15:14:04 <bnemec> #topic Action items from last meeting
15:14:28 <bnemec> "Review patches listed in http://paste.openstack.org/show/727932/"
15:14:38 <bnemec> I believe we got through some of them, at least.
15:15:04 <bnemec> Have spent a lot of time chasing broken repos though.
15:15:17 <bnemec> We made progress on that too, fortunately.
15:15:29 <dhellmann> here's a new list, it's much shorter:
15:15:30 <dhellmann> #link http://paste.openstack.org/show/728832
15:15:50 <dhellmann> looks like 23 left, if I'm doing math right
15:16:25 <bnemec> Okay, thanks.
15:16:32 <bnemec> #action review patches listed in http://paste.openstack.org/show/728832/
15:17:51 <bnemec> "add moguimar to core ACL after review period ends"
15:17:54 <bnemec> Done
15:18:07 <bnemec> "review stestr migration backports"
15:18:20 <bnemec> I have one more that still needs to go in.
15:18:27 <bnemec> #link https://review.openstack.org/#/c/588060/
15:19:35 <bnemec> Oh, there's also one for taskflow.
15:19:37 <bnemec> #link https://review.openstack.org/#/c/594439/
15:20:43 <bnemec> So let's get those landed.
15:20:50 <bnemec> Otherwise that was it for action items.
15:21:29 <bnemec> #topic PTG planning etherpad
15:21:41 <bnemec> #link https://etherpad.openstack.org/p/oslo-stein-ptg-planning
15:21:46 <dhellmann> bnemec : it looks like https://review.openstack.org/#/c/594439/2 depends on a patch I rolled into another one, so it might need a rebase
15:21:52 <bnemec> This is probably the final reminder of that.
15:22:40 <bnemec> dhellmann: Those two actually work as plain backports without combining anything.
15:23:06 <dhellmann> looking at the "related changes" list, it appears to be stacked in a series?
15:23:13 <bnemec> (at least I think they were both passing)
15:23:18 <dhellmann> sorry, I didn't notice there was a literal depends-on too
15:23:46 <dhellmann> the depends-on links to a master patch
15:23:56 <dhellmann> that has been merged
15:24:04 <dhellmann> so I'm talking about https://review.openstack.org/#/c/591245/1
15:24:06 <bnemec> Oh, I should have removed that.
15:24:26 <bnemec> Although it should be a noop since it's stacked on the backport of the master patch.
15:24:50 <dhellmann> so we want that one instead of my jumbo patch?
15:25:16 <bnemec> It feels a little cleaner if we don't have to squash patches.
15:25:17 <dhellmann> I guess it does pass, so +2
15:25:28 <dhellmann> agreed
15:25:48 <bnemec> Apparently the stestr migration isn't strictly necessary for this repo, but I think it's a good thing to do anyway.
15:26:35 <bnemec> Okay, I approved the pydot backport too so that should land now.
15:26:41 <bnemec> Thanks
15:27:52 <bnemec> I think that takes care of the broken repos topic too.
15:28:05 <bnemec> There may be others, but we'll fix them as we find them.
15:28:17 <bnemec> #topic PTG team photo
15:28:22 <bnemec> Specifically, does anyone want to do one?
15:28:47 <bnemec> I don't think we have in the past for this team, but I got the email about signing up last week.
15:29:12 <dhellmann> I'll join in if we do one, but won't push folks to do it if there's not much interest
15:30:02 <bnemec> I'm not much of a picture person, so I probably won't sign us up unless someone specifically asks. :-)
15:30:06 <openstackgerrit> Merged openstack/devstack-plugin-pika master: import zuul job settings from project-config  https://review.openstack.org/588686
15:30:35 <dhellmann> maybe we can get some body doubles to stand in for us
15:32:00 <bnemec> I like that plan. :-D
15:32:54 <bnemec> Anyway, contact me if you want a team picture from the PTG and I can ask about open time slots.
15:33:04 <bnemec> #topic VMT?
15:33:15 <bnemec> This came up last week.
15:33:35 <bnemec> Apparently the Oslo projects aren't vulnerability managed by the OpenStack VMT.
15:33:48 <bnemec> I can't remember if there was a reason for that or if it was just an oversight.
15:34:06 <dhellmann> I imagine that initially they focused on the services
15:34:24 <bnemec> It _seems_ like we would want to be managed.
15:34:48 <dhellmann> I agree, if they have the capacity to do it
15:35:00 <bnemec> The services are only as secure as the libraries they use.
15:35:29 <bnemec> Okay, I'll look into whether they would be willing to take us on.
15:35:33 <dhellmann> yeah, we may just need to ask
15:35:53 <bnemec> #action bnemec to check with VMT about Oslo libraries
15:35:58 <openstackgerrit> Merged openstack/devstack-plugin-zmq master: import zuul job settings from project-config  https://review.openstack.org/595988
15:36:24 <bnemec> #topic uuidsentinel
15:37:09 <bnemec> This spawned quite the mailing list thread, so I thought I'd bring it up here in case we wanted to pull some more people into the meeting and have a more direct conversation.
15:37:48 <dhellmann> sorry for throwing a wrench in that right before taking a day off
15:38:13 <openstackgerrit> Merged openstack/devstack-plugin-pika master: import zuul job settings from project-config  https://review.openstack.org/595987
15:38:19 <dhellmann> it seems like the main feature of this thing is the simple API, so making a fixture would make it harder to use
15:38:47 <dhellmann> so we have 2 ways to handle the global
15:39:25 <dhellmann> 1. we take the class, and nova keeps the global. The benefit there is adopting it in nova wouldn't require so many updates to imports. I'm not sure how much of a real benefit that is.
15:40:03 <dhellmann> 2. we take the class and add a global. That makes it easier to document how to use it and the adoption can just import the instance from oslo.utils
15:40:22 <dhellmann> I'm not counting the idea of adding the global to sys.modules because I don't want us to do that.
15:40:49 <bnemec> I guess 1 would be like i18n, where the classes live in oslo but each project has an integration module.
15:40:55 <dhellmann> yeah
15:41:00 <dhellmann> that seems heavy for this case
15:41:08 <dhellmann> there's no special configuration to do, like in i18n
15:41:14 <bnemec> Yeah
15:42:38 <bnemec> I guess I'm more comfortable with the global if it's in oslotest so it can't accidentally be abused in production code.
15:43:32 <bnemec> Mock has this pattern too, but AIUI mock is only used for testing.
15:43:43 <bnemec> (although I've been wrong about that kind of thing before)
15:44:51 <dhellmann> ok, I guess I can go along with putting it in oslotest
15:46:08 <bnemec> I know Eric wanted it in utils because of uuidutils, but the fact that they share a name isn't a strong technical argument to me.
15:46:30 <bnemec> oslo.utils is a runtime library and this is a test module.
15:46:56 <dhellmann> I don't think we want oslotest to depend on oslo.utils, so if we reimplement this to just call the uuid module directly that should be ok
15:47:07 <bnemec> There's precedent to have test fixtures in runtime libs, but if we're not going to do this as a fixture then I'm less comfortable with it.
15:47:14 <dhellmann> yeah
15:47:22 <bnemec> Oh, that's right.  There was the dependency thing too.
15:47:39 <dhellmann> I guess we could also put it into oslo_utils.fixture
15:50:06 <dhellmann> so either a new module in oslotest or oslo_utils.fixture works for me
15:50:17 <dhellmann> I don't have a very strong opinion about either
15:50:27 <dhellmann> I would probably lean slightly towards the latter
15:51:07 <bnemec> I suppose we could add it as a fixture but also provide the global for projects that are okay with that pattern?
15:51:32 <dhellmann> oh, I meant just add the global in oslo_utils.fixture as a way to indicate that it's test code
15:52:09 <dhellmann> so take all of efried's code and put it in that module and then nova's tests can import the instance of the global from there
15:52:09 <bnemec> Yeah, I'm just thinking that if we do both then we don't force that choice on anyone.
15:52:24 <dhellmann> sure, though I can't imagine anyone using the more cumbersome API if they have the easy one
15:52:33 <openstackgerrit> Clint 'SpamapS' Byrum proposed openstack/oslo.tools master: Remove spamaps from pings  https://review.openstack.org/596828
15:52:45 <bnemec> Well, some people really dislike globals. :-)
15:52:59 <dhellmann> sure
15:53:24 <dhellmann> we could always add the fixture later if someone wants it
15:53:30 <dhellmann> or now if you do :-)
15:53:42 <openstackgerrit> Merged openstack/oslo.tools master: Remove spamaps from pings  https://review.openstack.org/596828
15:53:58 <bnemec> No, I don't feel anywhere near that strongly about it.
15:54:07 <dhellmann> I jumped in early with an opinion, but it's not very strongly held, so as long as folks are happy with the thing it's fine with me
15:54:17 <bnemec> This seems like a pretty harmless use of globals.
15:54:22 <dhellmann> yeah
15:54:35 <dhellmann> my anti-pattern detector has a hair trigger :-)
15:54:36 <bnemec> I've never really believed in absolute rules for programming.
15:54:52 <bnemec> It's a code smell for sure.
15:54:52 <SpamapS> I have one absolute rule for programming. No rules. Ever.
15:55:29 <bnemec> :-)
15:55:48 <phuongnh> :)
15:56:45 <bnemec> dhellmann: Do you want to propose that on the list then?
15:56:52 * bnemec can't remember exactly where that discussion ended up
15:57:17 <bnemec> Other than the proposal to resurrect incubator. ;-)
15:57:40 <dhellmann> so I'll propose we add eric's code to oslo_utils.fixture?
15:57:47 <openstackgerrit> Merged openstack/oslo.service master: Skips signal handling on Windows  https://review.openstack.org/593897
15:57:54 <bnemec> Yeah
15:58:00 <dhellmann> ok
15:59:24 <bnemec> #action dhellmann to respond to uuidsentinel thread
15:59:34 <bnemec> Okay, we're just about out of time
15:59:36 <bnemec> #topic Open discussion
15:59:50 <dhellmann> #link http://lists.openstack.org/pipermail/openstack-dev/2018-August/133861.html
16:00:11 <bnemec> I guess the one thing would be that next Monday is a US holiday, so I won't be around to run the meeting.
16:00:27 <bnemec> I suspect a lot of our team won't be either.
16:00:48 <dhellmann> I will be off
16:00:51 <bnemec> So I'm thinking we just cancel?
16:00:58 <dhellmann> wfm
16:01:15 <kgiusti> +1
16:01:22 <bnemec> The PTG is the next week so we'll just have to finish any last-minute scheduling asynchronously.
16:01:58 <bnemec> #action bnemec cancel oslo meeting for next week
16:02:37 <bnemec> Okay, we're over time.  Thanks for joining everyone!
16:02:39 <bnemec> #endmeeting