15:00:58 <bnemec> #startmeeting oslo
15:00:59 <openstack> Meeting started Mon Sep 24 15:00:58 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:01 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <openstack> The meeting name has been set to 'oslo'
15:01:17 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:17 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:17 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, njohnston
15:01:17 <bnemec> courtesy ping for raildo, redrobot, sileht, sreshetnyak, stephenfin, stevemar, therve
15:01:17 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:22 <e0ne> hi
15:01:23 <njohnston> o/
15:01:27 <jungleboyj> o/
15:01:31 <dhellmann> o/
15:01:38 <ansmith> o/
15:01:44 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:18 <kgiusti> o/
15:02:46 <ducnv_> o/
15:03:17 <bnemec> #topic Red flags for/from liaisons
15:03:47 <jungleboyj> Nothing exciting from me.
15:03:58 <bnemec> Lots of oslo releases went out today, so if you run into any problems let us know ASAP.
15:05:10 <dhellmann> it will probably take a while for all of the constraint updates to land
15:05:34 <bnemec> Ah, that's true.
15:06:31 <bnemec> So I guess just keep in mind that the first Oslo stein releases went out this week.
15:06:38 <bnemec> On that note,
15:06:39 <bnemec> #topic Releases
15:07:26 <bnemec> We should be back to business as usual now, so expect weekly releases of master.
15:07:55 <bnemec> Since we just released all the things, I may hold off this week until we can get oslo.messaging ready for its major release.
15:08:13 <bnemec> I think there were still one or two patches pending for that.
15:08:34 <kgiusti> bnemec: there are two, but I think they can go in now
15:08:57 <kgiusti> bnemec: I've reached out to the two remaining projects - no response
15:09:04 <bnemec> kgiusti: Yeah, that was my recollection as well.
15:09:11 <bnemec> The tacker patch merged, so IMHO we're good to go.
15:09:20 <bnemec> It doesn't look like the other two are going to merge anytime soon.
15:09:49 <kgiusti> bnemec: yeah, I'm going to approve the outstanding two o.m. patches unless anyone disagrees
15:10:41 <bnemec> kgiusti: Nope, good with me. I only held off last week to give the tacker patch a little time to settle.
15:11:14 <bnemec> Not sure what I was expecting to happen, but I guess it was a little grace time to find any potential problems with it before we do the removal.
15:11:46 <bnemec> Anyway, I'm good with merging the last removal.
15:11:56 <kgiusti> bnemec: kk stay tuned....
15:12:19 <bnemec> kgiusti: That was it though, right? Nothing else we should wait on that you know of?
15:12:54 <kgiusti> bnemec: that's the last of the outstanding removals IIRC
15:13:12 <kgiusti> bnemec: so go for it.
15:13:24 <bnemec> Okay, as soon as that merges I'll do releases for the week then.
15:14:32 <bnemec> #topic Action items from last meeting
15:14:41 <bnemec> "kgiusti to contact tacker team about removing transport_url"
15:14:47 <bnemec> Done, as discussed above
15:14:52 <bnemec> "kgiusti to send message to openstack-dev for meteos and daisycloud about transport_url"
15:14:54 <bnemec> Likewise
15:14:59 <bnemec> "review https://review.openstack.org/#/c/561731"
15:15:02 * bnemec clicks
15:15:20 <bnemec> Ah, done. Good. :-)
15:15:50 <bnemec> That was it for action items.
15:16:00 <bnemec> " oslo.upgradecheck core list"
15:16:21 <bnemec> The governance patch merged last week, but I still don't seem to be able to populate the core list for the new project.
15:16:35 <dhellmann> bnemec : you probably need to ask the infra team to add you to the existing group
15:16:43 <dhellmann> that's a manual step from someone with gerrit admin rights
15:17:17 <dhellmann> yeah, https://review.openstack.org/#/admin/groups/1946,members is empty
15:17:22 <bnemec> dhellmann: Ah, okay. I probably need to go back to the new project guide. That's probably the next documented step. :-)
15:17:32 <dhellmann> probably :-)
15:17:58 <dhellmann> I also propose we add mriedeman to that group
15:18:04 <bnemec> This was kind of a heads up that I'm aware it needs to be taken care of and I'll get on it this week.
15:18:07 <bnemec> dhellmann: Agreed.
15:18:23 <dhellmann> he's the goal champion, after all :-)
15:18:28 <bnemec> I was planning to do that in an EAFP fashion.
15:19:11 <bnemec> Plus he wrote most of the actual code in the repo. ;-)
15:19:35 <dhellmann> that also
15:20:08 <bnemec> #action bnemec to add mriedem to oslo.upgradecheck core list when possible
15:20:22 <bnemec> #action bnemec to follow up on populating oslo.upgradecheck core group
15:20:37 <bnemec> #topic Storyboard
15:20:45 <bnemec> #link https://storyboard-dev.openstack.org/#!/project_group/oslo
15:20:51 <bnemec> Our test import is done.
15:21:21 <bnemec> I have some questions after looking it over. I don't know if anyone else has had a chance to try it out yet.
15:21:48 <bnemec> My questions may be more for the storyboard team than here, but I'm happy to discuss it more if anyone wants.
15:23:27 <jungleboyj> bnemec:  What are the questions.  I have been investigating SB for a little bit.
15:23:47 <bnemec> And please do take the test import for a spin to make sure we aren't hitting any weird edge cases with our 40 projects. :-)
15:24:01 <bnemec> jungleboyj: I noticed that we have fewer stories open than we had bugs in launchpad.
15:24:03 <bnemec> That was one.
15:24:21 <bnemec> Also, it looks like we lost all prioritization?
15:24:46 <bnemec> I think we're supposed to use tags for that now, so is there some way to map lp prio to tags?
15:25:04 <bnemec> Or maybe I just haven't found the correct view yet.
15:25:11 <jungleboyj> Intersting on the missing bugs.  I thought it should be a 1 to 1 mapping there.
15:25:29 <jungleboyj> So, perhaps that is something to take up with diablo_rojo if you can figure out what went missing.
15:25:39 <jungleboyj> There is no concept of prioritization in LP.
15:25:42 <bnemec> That's what I was expecting, but it's possible there was some de-duping that happened if, say, two oslo projects were on the same bug.
15:25:56 <jungleboyj> bnemec:  Oh, that is possible.
15:25:59 <bnemec> Maybe lp counts that as two bugs and storyboard only counts it once.
15:26:27 <jungleboyj> There were complaints at the PTG about no prioritization but it isn't a concept that Storyboard uses.
15:26:42 <jungleboyj> So, if you want to prioritize you will need to come up with a system to use tags to do so.
15:27:06 <bnemec> Yeah, which I'm okay with doing, but I don't want to manually apply it to 266 stories if I can help it.
15:27:27 <dhellmann> the intent is to use a worklist to manage priority ordering
15:27:31 <dhellmann> or tags, as jungleboyj says
15:27:53 <jungleboyj> What I am planning to do for Cinder is to start by writing documentation as to how we will use storyboard as our design process and then mock it up before we actually start using it.
15:27:54 <dhellmann> although that's up for discussion again since some downstream consumers want to have some sort of field on the story
15:28:27 <jungleboyj> As we discussed it we discovered we have a lot of room for improvement and going to try to fix things now.
15:28:43 <jungleboyj> dhellmann:  ++ and you can use the tags to create the priority lists.
15:29:05 <dhellmann> true
15:29:10 <bnemec> Yeah, so I think this may be partially a question of me learning how this is intended to work.
15:29:25 <jungleboyj> bnemec:  ++ and deciding how you want to use it.
15:29:25 <bnemec> I just spent a cycle triaging 100+ bugs, so I'd rather not have that work go to waste. ;-)
15:29:44 <dhellmann> it might be worth starting a thread on the mailing list about the priority thing again, because we now have at least 3 teams working around that behavior
15:30:03 <jungleboyj> I spent a lot of time at the ptg talking to TheJulia about how they are and aren't using it and spent time with the SB team trying to better understand.
15:30:45 <jungleboyj> dhellmann:  Perhaps.  It seems like they address things based on the amount of need.  :-)
15:31:01 <dhellmann> they're a small team, like everyone else
15:31:14 <jungleboyj> dhellmann:  Yeah.  That is true.
15:31:14 <dhellmann> in this case I think there may be a need to convince them that this is actually something people do use
15:31:31 <dhellmann> that was not the impression early on when SB was being designed
15:31:31 <jungleboyj> bnemec:  You aren't alone.  tbarron and I are working through this and helping each other somewhat.
15:32:02 <bnemec> I guess it's fair to point out that so far priority has been a write once, read never field for me.
15:32:11 <bnemec> But that's only because I was focused on triaging, not fixing.
15:32:22 <bnemec> I was hoping to get to the latter this cycle. :-)
15:32:22 <jungleboyj> dhellmann:  I think some of this is generational.  That team is more used to Trello and Jira versus tradition bug tracking and prioritization.  :-)
15:32:34 <dhellmann> possibly
15:33:09 <jungleboyj> We haven't used priority so much so I am less concerned about that.
15:33:25 <bnemec> Sounds like we definitely need a broader discussion on this, anyway.
15:33:35 <bnemec> #action send mail to list about storyboard priorities
15:33:54 <bnemec> #action bnemec send mail to list about disparity between story count and bug count
15:34:47 <dhellmann> mordred : this feels like something we should not set, if the PyPA folks are updating twine in advance of breaking changes to the API
15:34:52 <dhellmann> oops, wrong window
15:35:15 <jungleboyj> bnemec:  Sounds good.
15:35:25 <bnemec> #topic  Castellan 1.0?
15:35:33 <bnemec> I meant to bring this up during the releases topic, but I forgot.
15:35:48 <bnemec> dhellmann: mentioned that we should probably do this on the release review.
15:36:18 <bnemec> I guess we need to sync with the barbican team on this?
15:36:29 <bnemec> (that probably shouldn't be a ?)
15:37:02 <bnemec> So maybe this is another one we need to take to the list.
15:37:51 <bnemec> Look at us being a good example of using the mailing list. :-)
15:38:47 <dhellmann> ++
15:39:11 <bnemec> Okay
15:39:11 <bnemec> #action send mail about castellan 1.0
15:40:01 <bnemec> #topic Weekly Wayward Review
15:40:11 <bnemec> #link https://review.openstack.org/#/c/520043/
15:40:34 <bnemec> Since the implementation of this is about done, we should really decide what to do with the spec.
15:41:19 <dhellmann> does the spec match the implementation? :-)
15:41:35 <bnemec> It appears to be a bit out of date. We aren't using a separate mapping file anymore.
15:42:23 <ducnv_> yes, we using machine readable config now
15:43:18 <bnemec> The many to one mapping is still an outstanding question, so maybe that could be split into separate spec.
15:43:34 <bnemec> Or we could just hash it out on the review, since that's sort of an implementation detail.
15:44:02 <bnemec> I guess we deferred the dynamic group behavior too?
15:44:35 <dhellmann> I think we deferred all of the hard stuff, yes
15:45:16 <bnemec> That's probably handled by the warning on non-existent options.
15:45:36 <bnemec> The dynamic group options will get dumped out when the tool runs and people will have to migrate those manually for now.
15:46:27 <bnemec> I guess that would have been a valid argument for keeping missing options in the output file. :-/
15:46:32 <bnemec> Which I -1'd.
15:46:41 <bnemec> We can change that behavior later if we want though.
15:47:38 <bnemec> ducnv_: Can you update that spec to reflect the current design?
15:47:56 <ducnv_> yes, I will
15:48:02 <bnemec> We should probably have something we can point at when going to the other projects to ask them to implement the mapping features.
15:50:47 <ducnv_> so what should we do?
15:50:54 <bnemec> #action ducnv_ to update config migrator spec
15:51:05 <bnemec> ducnv_: I left some comments on the review about things that need to be updated.
15:51:16 <bnemec> It may not be a complete list, but it's what I noticed reading through it quickly here.
15:52:06 <ducnv_> i've seen, I will add docs for migrator tool soon.
15:52:43 <ducnv_> for the follow up patch (https://review.openstack.org/#/c/603060/2), do you have any comment about logic of code.
15:53:11 <bnemec> ducnv_: I have not had a chance to look at that yet.
15:54:28 <bnemec> #topic Open discussion
15:54:30 <ducnv_> bnemec ok, np
15:54:58 <bnemec> We should probably get moguimar into the ping list.
15:55:00 <dhellmann> fyi, we had some issues with the release jobs so while the releases worked the constraint updates and announcements weren't sent
15:55:02 <dhellmann> we're working on that
15:55:49 <bnemec> dhellmann: Sounds good. Is there anything we need to do once that's fixed?
15:55:59 <dhellmann> no
15:56:42 <bnemec> Cool. I like problems that solve themselves. :-)
15:56:44 <bnemec> (sort of)
15:58:18 <bnemec> #action add moguimar to ping list
15:58:59 <bnemec> That's all I've got. Anything else in the last two minutes?
15:59:11 <bnemec> Make that one minute
16:00:27 <bnemec> Okay, thanks for joining everyone!
16:00:29 <bnemec> #endmeeting