15:00:47 <bnemec> #startmeeting oslo
15:00:48 <openstack> Meeting started Mon Oct  1 15:00:47 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:51 <openstack> The meeting name has been set to 'oslo'
15:01:05 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:05 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:05 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, moguimar
15:01:05 <bnemec> courtesy ping for njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin, stevemar
15:01:05 <bnemec> courtesy ping for therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:13 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:14 <moguimar> o/
15:01:30 <njohnston> o/
15:01:30 <phuongnh> o/
15:01:41 <ducnv> o/
15:01:42 <moguimar> bnemec: is this meeting weekly at this time?
15:01:45 <kgiusti> o/
15:01:47 <moguimar> gotta put it to my callendar
15:01:58 <moguimar> calendar*
15:02:00 <bnemec> moguimar: Yes
15:02:03 <moguimar> good
15:02:06 <ansmith> o/
15:03:52 <bnemec> #topic Red flags for/from liaisons
15:04:06 <jungleboyj> Nothing from me.
15:04:07 <bnemec> Nothing on our end.
15:04:38 <bnemec> Well, there's a major release of oslo.messaging that will happen this week.
15:04:54 <bnemec> But I think we've addressed all of the projects so that shouldn't be disruptive.
15:05:04 <kgiusti> +1
15:05:07 <njohnston> nothing here
15:05:41 <bnemec> Okay, thanks.
15:05:42 <bnemec> #topic Releases
15:05:54 <bnemec> As noted above, oslo.messaging is the notable one.
15:06:21 <bnemec> I ended up not doing releases last week so there will be several others as well.
15:06:43 <bnemec> Also, castellan 1.0.
15:06:47 <bnemec> #link https://review.openstack.org/#/c/606108/
15:07:17 <bnemec> If you have any objections to castellan going 1.0 please voice them now.
15:08:16 <bnemec> #topic Action items from last meeting
15:08:34 <bnemec> Two about the oslo.upgradecheck core list. Both are done.
15:08:50 <bnemec> "send mail to list about storyboard priorities"
15:08:51 <bnemec> Done
15:08:56 <bnemec> "bnemec send mail to list about disparity between story count and bug count"
15:09:00 <bnemec> Also done, and resolved.
15:09:30 <bnemec> One or two projects were omitted from the import, and some stories weren't showing up in the list I was looking at.
15:09:38 <bnemec> "send mail about castellan 1.0"
15:09:41 <bnemec> Done
15:09:46 <bnemec> "ducnv_ to update config migrator spec"
15:09:54 <bnemec> Done. Sorry I haven't looked at it yet. :-/
15:10:06 <bnemec> "add moguimar to ping list"
15:10:13 <bnemec> There was a review, not sure it merged yet.
15:10:23 <bnemec> It's in my local copy of oslo.tools though so it's effectively done. :-)
15:10:30 <moguimar> =D
15:11:31 <bnemec> #topic  Berlin Project Update and Onboarding
15:11:49 <bnemec> If we're going to do this we need to respond no later than a week from now.
15:12:04 <moguimar> I'm going to Berlin
15:12:08 <bnemec> Unfortunately, I still don't know whether I'm going and it seems to be leaning "no".
15:12:43 <moguimar> I'm getting my ticket today
15:13:30 <bnemec> I'm assuming dhellmann is also going, so do you two want to do the project update and/or onboarding?
15:13:37 <bnemec> Assuming we can even still get a slot.
15:14:52 <moguimar> it will be my first summit, so I'm kinda blank on how things happen there
15:15:19 * jungleboyj is planning to do it for Cinder again.
15:15:27 <bnemec> Yeah, we'd probably want Doug to lead it.
15:15:30 * dhellmann slinks in late
15:15:31 <jungleboyj> Can plan to join your seesion as well.
15:16:07 <dhellmann> do we still have the old slide deck for that from last time?
15:16:21 <bnemec> dhellmann: Yeah, I can pass that along.
15:16:47 <dhellmann> ok, moguimar are you up for helping out with the presentation?
15:17:02 <moguimar> yep
15:17:11 <dhellmann> it's mostly talking about what we do and what the libs are iirc
15:17:18 <bnemec> Yeah
15:17:19 <dhellmann> and answering questions of course
15:18:01 <phuongnh> :)
15:18:02 <dhellmann> so what needs to happen to set that up?
15:18:07 <bnemec> Okay, I'll request a project update slot.
15:18:09 <dhellmann> ok
15:18:17 <bnemec> Do we also want to do another onboarding?
15:18:49 <dhellmann> moguimar : maybe you can talk about the config driver stuff during the project update
15:18:57 <moguimar> cool
15:18:57 <dhellmann> we'll need to make a list of other things we want to talk about, too
15:19:08 <dhellmann> bnemec : have we seen much value from those?
15:19:15 <bnemec> I can start an etherpad to solicit update topics.
15:19:18 <dhellmann> ++
15:19:28 <dhellmann> I think the project update is probably good enough
15:19:38 <bnemec> dhellmann: We've only done the one. I'm not sure whether it actually gained us any contributors.
15:19:45 <bnemec> Okay, works for me.
15:20:10 <bnemec> #action bnemec to request project update slot
15:20:17 <bnemec> #action bnemec to start etherpad for project update topics
15:20:33 <bnemec> #action bnemec to send dhellmann slides from previous project update
15:21:20 <dhellmann> send them to moguimar too so he can see what he's signing up for :-)
15:21:28 <bnemec> Will do. :-)
15:21:51 <bnemec> #topic  Storyboard
15:22:01 <bnemec> There was a bunch of discussion about this last week.
15:22:17 <bnemec> As I mentioned, I think we resolved the disparity in bug/story counts.
15:22:31 <bnemec> There's still an ongoing discussiong about how to deal with priority in storyboard.
15:23:21 <dhellmann> the storyboard api is pretty easy to use from python, so if we wanted to do something like use tags for that we could roll our own post-migration script to add tags
15:23:25 <dhellmann> we just need the input data
15:23:32 <dhellmann> and the script, of course
15:23:35 <bnemec> I would like to have _some_ method of maintaining our existing priority for lp bugs, whether that's a dedicated field or just a set of tags.
15:23:57 <bnemec> Yeah, I think Kendall mentioned that the data gets migrated, it just isn't exposed in the web ui?
15:24:07 <dhellmann> the priority setting?
15:24:21 <bnemec> I thought so.
15:24:21 <dhellmann> if that's the case it's even easier
15:24:35 <dhellmann> query storyboard, iterate over the results, make the change
15:24:58 <dhellmann> there's some example code in the goal-tools repo that creates stories, boards, etc. and it adds tags, too
15:25:38 <bnemec> #link http://lists.openstack.org/pipermail/openstack-dev/2018-September/135111.html
15:25:46 <dhellmann> #link http://git.openstack.org/cgit/openstack/goal-tools/tree/goal_tools/import_goal.py
15:26:19 <bnemec> Ah, specifically https://github.com/openstack-infra/storyboard/blob/master/storyboard/migrate/launchpad/writer.py#L270
15:26:55 <dhellmann> so then the only question is whether that field comes back as part of the data when you ask for details about a story
15:27:15 <dhellmann> if it does, it would be easy enough to write a priority-to-tags.py that only needed to be run against storyboard itself
15:27:54 <dhellmann> who wants to learn more about the storyboard api? :-)
15:27:54 <bnemec> Yeah, it looks like that's actually on tasks, not stories themselves.
15:28:16 <bnemec> But I guess that makes sense since each project gets a task and each project in lp had its own priority.
15:29:37 <dhellmann> yeah
15:31:03 <dhellmann> is the test import data still in storyboard-dev?
15:31:06 <dhellmann> I'm not finding it
15:31:13 <bnemec> I can put it on my todo list, but it's rather long already so it's anybody's guess when it will get done.
15:31:17 <dhellmann> oh, nm, user error
15:31:37 <bnemec> Yeah, https://storyboard-dev.openstack.org/#!/project_group/oslo
15:32:16 <bnemec> Although they suggested using https://storyboard-dev.openstack.org/#!/story/list?status=active&project_group_id=74 instead
15:32:33 <bnemec> Apparently the project group view isn't heavily used.
15:32:41 <bnemec> It's also a bit broken right now.
15:33:25 <dhellmann> yeah, I just needed 1
15:33:32 <dhellmann> I can confirm that we can read the priority values out of the API
15:34:10 <dhellmann> so we could do the thing where we set tags like priority-oslo-medium
15:34:29 <bnemec> Yeah.
15:34:36 <bnemec> And you can create worklists from tags, right?
15:34:39 <dhellmann> although tags are on the story right now, not the task, so that's not ideal
15:34:42 <dhellmann> you can, yes
15:35:15 <bnemec> Since the tag is oslo-specific, it's probably okay to have it on the story.
15:35:56 <bnemec> #action investigate writing a script to automatically tag stories with migrated priority
15:36:03 * bnemec leaves that unassigned on purpose
15:36:15 <bnemec> Whoever gets to it first gets a cookie. ;-)
15:36:51 <dhellmann> see https://storyboard-dev.openstack.org/#!/story/1789351 for an example
15:37:24 <dhellmann> http://paste.openstack.org/show/731178/ is the script that did that
15:37:41 <dhellmann> and I can show someone how to set up the config file you need
15:37:49 <dhellmann> with the sb credentials
15:40:45 <bnemec> Okay, so our path forward here is to automate the priority -> tag transition.
15:41:10 <bnemec> I'm trying to remember if there was anything else that needed resolution.
15:41:56 <bnemec> I guess not from me. The other two things I had noted are either resolved or not blockers.
15:43:50 <bnemec> Okay, that was it for one-off topics.
15:43:53 <bnemec> #topic Weekly Wayward Review
15:45:20 <bnemec> There are a few specs that are in need of review, but I think they're already on everyone's list.
15:45:22 <bnemec> So...
15:45:24 <bnemec> #link https://review.openstack.org/#/c/581541/
15:45:54 <dhellmann> I thought the qa team owned hacking
15:46:08 <dhellmann> +2a anyay
15:46:11 <dhellmann> anyway
15:46:15 <bnemec> At one point we set up a separate core team for hacking, I think.
15:46:34 <dhellmann> ah
15:47:24 <bnemec> I never removed it from the project list because I was less likely to forget it that way. :-)
15:47:45 <dhellmann> heh
15:48:53 <bnemec> But it doesn't include oslo-core, so I guess it probably shouldn't be there.
15:49:02 <bnemec> The active core list is actually rather short at this point. :-/
15:49:33 <bnemec> Not sure how much activity is going on in hacking anyway though.
15:50:49 <bnemec> Anyway, I need to do more reviews this week.
15:51:08 <bnemec> I've been kind of distracted with other stuff lately and slacking on that.
15:51:17 <bnemec> #topic Open discussion
15:52:06 <phuongnh> bnemec: please help us to review updated config migrator spec when you have time
15:52:25 <bnemec> phuongnh: Yep, it's on my list.
15:52:33 <phuongnh> thanks
15:52:34 <dhellmann> same
15:52:45 <phuongnh> thank dhellmann
15:53:40 <bnemec> phuongnh: Note that there is a -1 on the spec already.
15:54:02 <bnemec> I haven't looked closely, but it sounds like at least some of the comments should be addressed.
15:55:19 <phuongnh> thanks, if it is reasonable, please place agree comment and ducnv will update them soon.
15:55:24 <ducnv> oh, yes, I will do that
15:55:52 <phuongnh> ducnv: thanks
15:55:58 <bnemec> Sounds good.
15:56:03 <bnemec> Anything else?
15:56:14 <phuongnh> that is all for me
15:56:26 <ducnv> nothing from me
15:58:05 <bnemec> Okay, thanks for joining everyone!
15:58:07 <bnemec> #endmeeting