15:00:29 <bnemec> #startmeeting oslo
15:00:31 <openstack> Meeting started Mon Oct 8 15:00:29 2018 UTC and is due to finish in 60 minutes. The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:35 <openstack> The meeting name has been set to 'oslo'
15:00:42 <ajo> o/
15:00:50 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:00:50 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:00:50 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, moguimar
15:00:50 <bnemec> courtesy ping for njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin, stevemar
15:00:51 <bnemec> courtesy ping for therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:00:55 <dhellmann> o/
15:01:03 <redrobot> o/
15:01:05 <gcb_> o/
15:01:05 <johnsom> o/
15:01:06 <ansmith> o/
15:01:11 <raildo> o_
15:01:11 <moguimar> o/
15:01:13 <stephenfin> o/
15:01:24 <kgiusti> o/
15:01:33 <jungleboyj> o/
15:02:04 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:12 <bnemec> #topic Red flags for/from liaisons
15:02:34 <bnemec> Major release of oslo.messaging last week.
15:02:35 <johnsom> Nothing to report from the Octavia team
15:02:37 <jungleboyj> Nothing from me.
15:03:00 <bnemec> I don't think it should affect anyone, but it's something to keep in mind.
15:03:26 <bnemec> Oh, actually sileht found a significant bug in it.
15:03:29 <ducnv_> o/
15:03:30 <bnemec> Let me find the link.
15:04:03 <bnemec> https://github.com/openstack/oslo.messaging/commit/172cfb33f3ee207531a9e82fbc8293d24009a256
15:04:33 <bnemec> It will only affect you if you aren't explicitly setting a transport, which I suspect is usually not the case.
15:04:46 <bnemec> But obviously it is sometimes.
15:05:54 <johnsom> Thanks for the heads up. We are calling out the transport, but it's always nice to have this information should things go sideways.
15:06:25 <bnemec> It's fixed and should get released as part of the usual bunch of releases this week too.
15:06:37 <bnemec> Otherwise I think that's it.
15:06:48 <bnemec> #topic Releases
15:07:00 <bnemec> Business as usual.
15:07:47 <bnemec> #topic Action items from last meeting
15:08:08 <bnemec> "bnemec to request project update slot"
15:08:12 <bnemec> Done, but...
15:08:37 <bnemec> Because of the uncertainty around my travel plans I waited too long.
15:09:07 <bnemec> So unless some projects drop out we aren't going to have a normal project update slot. :-(
15:09:26 <dhellmann> ah, bummer
15:09:45 <bnemec> I was thinking we should look into whether we could do a lightning talk or something.
15:10:00 <jungleboyj> bnemec: Bummer.
15:10:00 <bnemec> It might not be as formal, but at least we could get the information out there.
15:10:03 <dhellmann> we should try to get moguimar a lightning talk slot
15:10:11 <dhellmann> at the very least, that's a big new feature for folks to know is coming
15:10:20 <bnemec> Yeah, agreed.
15:10:38 * dhellmann looks around the room for someone else he can volunteer to do something
15:11:05 <moguimar> o/
15:11:12 <moguimar> I can do lightning talk on drivers
15:11:22 <bnemec> I've never done a lighting talk, so I'm not sure when that all gets scheduled.
15:11:29 <bnemec> It's usually closer to summit though, right?
15:11:37 * bnemec doesn't want to drop the ball again
15:11:52 <dhellmann> you should get in touch with ttx and/or diablo_rojo about it now to make sure
15:12:38 <bnemec> Okay, will do.
15:12:47 <bnemec> I can verify that we didn't get an official update timeslot too.
15:13:02 <bnemec> #action bnemec to look into lightning talk for oslo.config drivers
15:13:03 <gcb_> ttx or diablo_rojo is the right people
15:13:30 <dhellmann> they will at least know who you really need to talk to
15:14:41 <bnemec> So, lesson learned. Request the timeslot early and we can always back out if nobody can do it.
15:14:53 <bnemec> "bnemec to start etherpad for project update topics"
15:14:57 <bnemec> Obsoleted by the previous topic.
15:15:09 <bnemec> But will do if we still get a session.
15:15:18 <bnemec> "bnemec to send dhellmann slides from previous project update"
15:15:20 <bnemec> Ditto.
15:15:41 <bnemec> Except that I can do the slides now since it turns out I am going to be in Berlin.
15:15:56 <bnemec> "investigate writing a script to automatically tag stories with migrated priority"
15:16:02 <bnemec> Still not done to my knowledge.
15:16:21 <dhellmann> I started something on that
15:16:32 <dhellmann> it's pretty hacky and I hit a bug in the SB API that I wasn't able to figure out
15:16:48 <dhellmann> I forgot about putting it in a repo somewhere
15:16:53 <dhellmann> I can put it in oslo.tools maybe?
15:16:54 <bnemec> Okay, cool (the started part, not the bug part).
15:17:04 <dhellmann> that's not a good long term home, but it would let someone else take over the script
15:17:05 <bnemec> That seems like a reasonable place for it.
15:18:42 <bnemec> #action dhellmann to put story tagging code in a repo (oslo.tools?)
15:19:25 <bnemec> That was it for action items.
15:19:46 <bnemec> I think that covers the storyboard topic I still had on the agenda too.
15:19:53 <bnemec> #topic os-log-merger
15:20:06 <bnemec> #link https://review.openstack.org/#/c/607142
15:20:09 <ajo> hi o/
15:20:20 <ajo> exactly, and
15:20:21 <bnemec> There was a proposal to add this as a formal project.
15:20:23 <ajo> #link https://wiki.openstack.org/wiki/OsLogMerger
15:20:42 <bnemec> A question that came up was whether it should be under the oslo umbrella.
15:21:25 <ajo> bnemec: Exactly, although it's not a library itself, and I didn't know if it'd have a place under oslo
15:21:50 <ajo> it's a tool to help openstack developers and operators
15:22:08 <ajo> I started it around 3 years ago and I haven't publicized it much.
15:22:19 <dhellmann> what does it do?
15:22:22 <bnemec> We certainly have common logging bits in Oslo, but I'm trying to think whether we have much in the way of standalone tools like this.
15:22:55 <ajo> So, the purpose of the tool is to take the logs of several openstack (and non openstack services)
15:23:12 <ajo> and merge them together in a single output, ordered by timestamp
15:23:12 <bnemec> "os-log-merger is an OpenStack project which produces tools to help debugging openstack logs by aggregation. "
15:23:17 <bnemec> quoth the wiki :-)
15:23:20 <ajo> hehe
15:23:40 <ajo> it auto-detects the type of log
15:24:06 <ajo> Neutron jobs use it to aggregate functional log outputs, and send the aggregation to logstash/kibana
15:24:08 <ajo> but,
15:24:51 <ajo> When you have lots of services (sometimes replicated across nodes) which interact to each other, it becomes a pain to trace a request, or whats happening under the hood (post-mortem)
15:25:15 <ajo> osprofiler for example, helps with that if you prepare your environment, setup the services for a profiling session, etc
15:25:26 <ajo> but if you just have the logs, it's not possible
15:25:54 <ajo> https://pypi.org/project/os-log-merger/ < -- search for "Level 3"
15:26:00 <ajo> there is no anchor, sorry :)
15:27:29 <ajo> My purpose with submiting it to governance (or oslo) is maximizing utility, making other projects more aware of it's existance, and eventually getting more contributions to make it better.
15:27:39 <ajo> any questions?
15:28:05 <ajo> So the question remains, does it make sense to you folks?
15:28:36 <bnemec> "It should work as long as the logs are based on oslo logger output."
15:28:36 <bnemec> ^seems like an argument to have this in oslo.
15:29:01 <ajo> bnemec: what do you mean "the logs are based on oslo logger output"?
15:29:17 <bnemec> ajo: I'm quoting from the pypi description. :-)
15:29:53 <ajo> bnemec: oh, that comment is obsolete, now it supports other formats too (so we're able to merge more system logs together with oslo logger output) :)
15:30:03 <ajo> oslo log :)
15:30:06 <bnemec> Ah, okay.
15:30:24 * ajo sends a review to fix that :)
15:30:29 <dhellmann> how many people are contributing to it?
15:31:13 <ajo> dhellmann: not a lot, I believe we have been around 4-5 maximum, I can ask git for more precise number
15:31:23 <bnemec> There are three listed on the wiki right now.
15:31:30 <dhellmann> how many are *active*?
15:31:45 <dhellmann> I don't know about adopting something that isn't maintained
15:31:51 <dhellmann> we have a lot of those sorts of things already
15:32:05 <ajo> 3-4
15:32:20 <ajo> dhellmann: I understand the concern, of course :)
15:33:24 <ajo> it's been slow during 3 years, there's room for lots of improvement. And greater visibility should help with having more capacity to develop it
15:34:19 <dhellmann> bnemec : that tagging script is in https://review.openstack.org/608707
15:34:33 <bnemec> dhellmann: Thanks
15:34:44 <dhellmann> I'm also a bit concerned that this is stretching our mission statement, which has to do with common libraries
15:35:00 <gcb_> we have check list for adopting an oslo project or not, let me find the URL
15:35:01 <dhellmann> I feel like folks suggested bringing it to Oslo because it didn't fit anywhere else :-/
15:35:36 <dhellmann> I think it's probably a useful tool, I just feel like it might be better served in an ops tools SIG or project team
15:35:44 <ajo> yeah, true, and because creating a whole governance project just for this, seemed an overkill I guess
15:35:58 <dhellmann> possibly, yeah
15:36:25 <gcb_> http://specs.openstack.org/openstack/oslo-specs/specs/policy/new-libraries.html
15:36:29 <bnemec> Are there other ops tools that we could put under the same governance umbrella as this?
15:36:45 <ajo> dhellmann: what do you mean "ops tools SIG or project team", creating a new project with such purpose?
15:36:50 <dhellmann> ajo : yes
15:36:59 <dhellmann> bnemec : who owns os-purge?
15:37:13 <ajo> ok, that could make a lot of sense, I suspect there are other tools in existence which could be willing to join
15:37:21 <bnemec> I have no idea, but that would be a good one too.
15:37:36 <dhellmann> gcb_ : I think the fact that that document only talks about libraries is pretty significant
15:37:50 <bnemec> And it would be nice to make that an official thing since I know a lot of operators want it.
15:37:51 <ajo> yeah
15:38:04 <dhellmann> bnemec : yeah, the public cloud group expressed some interest in os-purge-like features recently
15:39:16 <ajo> I'm fine with going the ops tools team path.... that makes sense considering the purpose of the oslo project
15:39:27 <ajo> if we o the ops-tools patch, any advice dhellmann?
15:39:33 <gcb_> dhellmann, yeah, do you mean https://pypi.org/project/ospurge/ /
15:39:33 <ajo> may be we can talk about that off-meeting
15:39:37 <ajo> don't want to hold everybody
15:39:39 <dhellmann> gcb_ : yes
15:39:54 <bnemec> Yeah, that feels like a better fit than Oslo for this.
15:40:20 <dhellmann> ajo : maybe a good next step is to propose creating a group like that on the mailing list(s)?
15:40:29 <dhellmann> the structure could be a lot like oslo, with separate review teams on each repo and 1 core team across them all if folks are more comfortable with that
15:40:45 <dhellmann> and a sig feels like it's lower effort than a project team
15:40:57 <ajo> dhellmann: how does a SIG work?
15:41:16 <dhellmann> https://governance.openstack.org/sigs/
15:41:21 <ajo> thanks
15:41:33 <dhellmann> the process to create one is at the very bottom there
15:41:39 <ajo> dhellmann: I may have some more questions, if you have time off meeting, no need to hold everybody
15:41:44 <ajo> thanks a lot
15:41:59 <dhellmann> and I can help you find a guide to set it up if you get some positive responses
15:42:03 <dhellmann> ajo : sure
15:42:19 <dhellmann> we could move to #openstack-tc after this meeting
15:42:25 <ajo> ack
15:42:51 <bnemec> Okay, good discussion. Thanks everyone.
15:43:05 <bnemec> That was it for topics.
15:43:07 <bnemec> #topic Weekly Wayward Review
15:44:10 <bnemec> There's the config migrator one, but I think that one's already being actively worked.
15:44:17 <bnemec> So, let's do this one:
15:44:19 <bnemec> #link https://review.openstack.org/583524
15:45:11 <bnemec> I suspect that one lingered because of the discussion over how the message was formatted.
15:46:18 <bnemec> I guess Doug +2'd the first patch set, so maybe this already has consensus.
15:46:23 * bnemec looks what changed from 1 to 2.
15:46:48 <dhellmann> was it just rebased?
15:46:55 <bnemec> Ah, nothing.
15:47:00 <bnemec> Yeah, must have been.
15:48:08 <bnemec> Okay, sent it.
15:48:18 <dhellmann> yeah, we can clean that up
15:49:38 <bnemec> There's also a fairly simple followup to that one: https://review.openstack.org/#/c/583525/3
15:49:51 <bnemec> The only negative comment so far was in regard to the commit message.
15:50:00 <bnemec> And that was addressed, I believe.
15:50:10 <openstackgerrit> Doug Hellmann proposed openstack/oslo.config master: avoid trailing space in sphinxext log output https://review.openstack.org/608717
15:50:16 <dhellmann> fixed ^^
15:50:52 <bnemec> +2
15:50:56 <bnemec> Thanks
15:51:45 <stephenfin> I have a few
15:51:54 <stephenfin> assuming wayward means "good but needs review"
15:52:14 <dhellmann> lingering, yeah
15:52:18 <bnemec> It's mostly grabbing our oldest review without a -1 and figuring out how to proceed.
15:52:31 <stephenfin> These two would be good https://review.openstack.org/583957 https://review.openstack.org/594222
15:52:34 <bnemec> We just knocked out two of yours. :-)
15:52:41 <stephenfin> Oh, awesome
15:53:02 * stephenfin loves it when things happen without him having to do a thing :)
15:53:37 <stephenfin> Of those two I shared, the latter one's the one I care about. The other one? Meh, nice-to-have at most
15:54:07 <bnemec> Ah, yes. I was looking at that one before the meeting.
15:54:57 <dhellmann> lgtm
15:55:08 <stephenfin> (y) Ta
15:56:47 <bnemec> Okay, three down. Very good. :-)
15:56:51 <bnemec> #topic Open discussion
15:57:03 <stephenfin> I have an item for this: backports
15:57:40 <stephenfin> I mentioned it here earlier today, but we've a couple of open patches against Ocata and Pike and I'm not sure what the policy around accepting them is
15:58:01 <stephenfin> ...especially with extended-maintenance now a thing (for Ocata)
15:58:34 <stephenfin> (If there are docs on this somewhere, please tell me where to go RTFM :))
15:59:00 <dhellmann> those branches are still open for stable backports, aren't they?
15:59:15 <bnemec> stephenfin: I think any bug fixes that would have been appropriate during the maintained phase are still appropriate in EM.
15:59:30 <bnemec> We just don't produce releases anymore.
15:59:34 <bnemec> https://docs.openstack.org/project-team-guide/stable-branches.html#maintenance-phases
15:59:42 <dhellmann> I guess ocata is EM but the others are stable: https://releases.openstack.org
15:59:54 <stephenfin> OK, so that brings me to the second part of my question: what's considered appropriate in that case?
16:00:14 <bnemec> https://docs.openstack.org/project-team-guide/stable-branches.html#appropriate-fixes
16:00:29 <dhellmann> https://docs.openstack.org/project-team-guide/stable-branches.html#extended-maintenance
16:00:30 <stephenfin> nova's policy is the last release gets all bug backports, the second last release only gets security/data loss potential backports, and the third last release got nothing
16:00:31 <dhellmann> heh
16:00:40 <dhellmann> oh, we don't get that picky
16:00:55 <dhellmann> send it all back as far as people want to deal with fixing broken gate jobs
16:01:38 <bnemec> +1
16:01:45 <stephenfin> OK, I wasn't sure about that point. I owe kgiusti/dmueller an apology, in that case
16:01:48 <stephenfin> Thanks for the info
16:02:10 <kgiusti> stephenfin: np
16:02:48 <bnemec> Okay, we're two minutes over time.
16:02:48 * kgiusti can't recall what exactly needs an apology, but likes stephenfin enough to forgive practically anything
16:03:04 <bnemec> Feel free to continue discussions in the regular channel.
16:03:08 <bnemec> Thanks for joining everyone!
16:03:12 <dhellmann> o/
16:03:12 <bnemec> #endmeeting