15:01:25 <beekneemech> #startmeeting oslo
15:01:26 <openstack> Meeting started Mon Oct 15 15:01:25 2018 UTC and is due to finish in 60 minutes.  The chair is beekneemech. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:29 <openstack> The meeting name has been set to 'oslo'
15:01:34 <beekneemech> #chair bnemec
15:01:34 <openstack> Warning: Nick not in channel: bnemec
15:01:35 <openstack> Current chairs: beekneemech bnemec
15:01:42 <bnemec> Oops
15:01:48 <redrobot> o/
15:02:00 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:02:00 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:02:00 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, moguimar
15:02:00 <bnemec> courtesy ping for njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin, stevemar
15:02:00 <bnemec> courtesy ping for therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:02:12 <redrobot> \o
15:02:17 <kgiusti> o/
15:02:18 <jungleboyj> o/
15:02:20 <ansmith> o/
15:02:21 <ducnv_> o/
15:02:31 <stephenfin> o/
15:02:52 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:04:05 <bnemec> #topic Red flags for/from liaisons
15:04:42 <bnemec> We released a new oslo.messaging which hopefully addresses the issue from last week.
15:06:17 <bnemec> #topic Releases
15:06:40 <bnemec> Mostly business as usual.
15:07:00 <bnemec> I believe we had a removal in pbr so we'll need a major release for that.
15:07:20 <bnemec> I did want to ask if there is anything else we should wait on.
15:07:51 <jungleboyj> I think we got beyond the issues we had from the messaging release last week.
15:09:22 <bnemec> I don't see any other major changes on https://review.openstack.org/#/q/project:openstack-dev/pbr+status:open so I'll probably go ahead and release that this week.
15:09:53 <bnemec> If you have any objections let me know ASAP.
15:10:02 <bnemec> jungleboyj: Thanks
15:10:11 <bnemec> #topic Action items from last meeting
15:10:35 <bnemec> "bnemec to look into lightning talk for oslo.config drivers"
15:10:58 <bnemec> Sent an email to Kendall, but I haven't heard back yet.
15:11:06 <bnemec> I'll follow up again this week.
15:11:18 <bnemec> #action bnemec to follow up on oslo.config lightning talk
15:11:29 <bnemec> "dhellmann to put story tagging code in a repo (oslo.tools?)"
15:11:43 <bnemec> I believe that was actually done during last meeting.
15:12:34 <bnemec> #link https://review.openstack.org/608707
15:12:38 <bnemec> That one ^
15:13:01 <bnemec> That was it for action items.
15:13:17 <bnemec> No new one-off topics either.
15:13:26 <bnemec> #topic Weekly Wayward Review
15:14:04 * cdent comes out of hiding
15:14:11 <bnemec> #link https://review.openstack.org/#/c/593566/
15:14:38 <bnemec> I actually left some comments on that because I don't understand what it's trying to fix.
15:15:05 <bnemec> Maybe I should have just -1'd to draw attention to it.
15:16:08 <stephenfin> bnemec: I got distracted, but there are three patches I'd like to see go into pbr before we cut https://review.openstack.org/#/c/607895/ https://review.openstack.org/#/c/602761/ https://review.openstack.org/#/c/587204/
15:17:47 * bnemec looks
15:20:10 <bnemec> Okay, I approved the first two. I'll take a look at the third one after the meeting.
15:20:17 <stephenfin> \o/
15:20:46 <bnemec> None of those will require major version bumps though, so worst case scenario is that they end up in a feature release next week.
15:21:24 <stephenfin> True true
15:21:25 <bnemec> We don't actually branch for every major release, although now that I think about it maybe we should.
15:22:09 <bnemec> It would be very awkward to do a bugfix on a major release that only existed in the middle of a cycle.
15:23:48 <bnemec> stephenfin: Any thoughts on https://review.openstack.org/#/c/593566 ?
15:25:07 <stephenfin> bnemec: It's a weird one, which is why I haven't said anything
15:25:26 <stephenfin> On one hand, I see where they're coming from. I've always found it odd that we install all dependencies for something like the pep8 targets which don't need those. It's technically correct
15:26:15 <stephenfin> On the flipside, pretty much everyone else is doing it that way at the moment and it's nice for things to work the same across projects.
15:26:44 <bnemec> We're still doing that though, and I think we do need it even for pep8. It does import all of the code so if anything is missing it will blow up.
15:27:09 <bnemec> IIRC anyway.
15:27:09 <stephenfin> Hmm, does it import it? I didn't think it did
15:27:47 <stephenfin> Assuming it doesn't, that's another optimization Dirk can make
15:28:09 <stephenfin> But yeah, I can go either way. Was pretty much waiting on you to jump first :)
15:28:24 <stephenfin> (though the very last thing we want though is a flood of "Remove flake8 from test-requirements" patches...)
15:28:25 <bnemec> It would be easy to test. Just remove the "{[testenv]deps}" from that review.
15:28:33 * stephenfin goes to check
15:29:19 <cdent> before the meeting expires I'd lik to invite some review on https://review.openstack.org/#/c/585850/ (config in env) as I managed to get it caught up with comments
15:29:40 <stephenfin> bnemec: I'll check. If it works, I say let ask for that change then let it in. They've submitted a few good reviews so no point being a stickler on noddy stuff
15:30:43 <bnemec> stephenfin: Fair enough. I do feel like I'm splitting hairs here, but I don't understand the change and I'm generally not comfortable +2'ing things that I don't understand.
15:31:16 <bnemec> cdent: Yeah, and did you have some time off coming up?
15:31:44 <openstackgerrit> Merged openstack/oslo.messaging master: Using pip as a python module  https://review.openstack.org/610462
15:31:46 <cdent> bnemec: It was last week. I had said that if somebody needed to adopt the changes while I was gone, that was okay, but now I'm back.
15:32:54 <bnemec> cdent: Ah, oops. I'll try to get to that again this week.
15:33:05 <cdent> thanks
15:33:27 <bnemec> #action stephenfin to test removing everything except flake8 from pep8 venv for https://review.openstack.org/#/c/593566
15:33:27 <stephenfin> cdent: worth noting that dhellmann is now on vacation so hopefully there's nothing hinging on him
15:33:32 <stephenfin> at least I think so
15:33:41 <bnemec> Yeah, he's out for a couple of weeks.
15:33:46 <cdent> ah, right, thanks
15:33:53 <stephenfin> bnemec: Yeah, that works fine
15:34:35 <bnemec> I think Doug's comment on the env config review was something that could be done as a followup, so it shouldn't block anything.
15:35:32 <bnemec> #topic Open discussion
15:35:49 <bnemec> We're basically having open discussion already anyway. :-)
15:36:02 <bnemec> So anything else before we end?
15:36:14 <ducnv_> hi Ben, could you help me review this patch https://review.openstack.org/#/c/603060/9 when you have time.
15:37:08 <bnemec> ducnv_: Yeah, that's also on my list.
15:37:22 <ducnv_> For 2 basic cases, I hope it will be completed soon :)
15:37:48 <ducnv_> bnemec, thank in advance
15:38:01 <bnemec> I think we're getting close. I believe I've +2'd everything in the series up to that point.
15:38:38 <ducnv_> great!!
15:39:25 <bnemec> Anything else?
15:39:38 <openstackgerrit> Hervé Beraud proposed openstack/oslo.tools master: Add hberaud to ping list  https://review.openstack.org/610620
15:39:58 <openstackgerrit> Sean McGinnis proposed openstack/sphinx-feature-classification master: Handle ConfigParser.readfp deprecation  https://review.openstack.org/610621
15:40:38 <smcginnis> Anyone aware of an update somewhere that could be causing - TypeError("functools.partial(<function synchronized at 0x7f149783e0d0>, lock_file_prefix='cinder-') is not a module, class, method, or function.",)
15:41:15 <openstackgerrit> Merged openstack/oslo.tools master: Add hberaud to ping list  https://review.openstack.org/610620
15:41:34 <bnemec> I don't think we've changed anything in oslo.concurrency as of late.
15:42:14 <smcginnis> Yeah, didn't see anything recently released. Probably something in an external library.
15:42:35 <smcginnis> Just noticed it causing doc job failures in Cinder this morning.
15:43:01 <bnemec> No releases of fasteners recently either.
15:43:13 <stephenfin> smcginnis: Got a sample fail?
15:43:37 <smcginnis> stephenfin: Right now, if you check out openstack/cinder master and run tox -e docs it fails.
15:44:00 <smcginnis> Trying to figure out exactly where to see what could be the cause of it.
15:45:04 <smcginnis> Looks like I have some app.info calls to clean up too.
15:45:47 * stephenfin goes to test
15:47:53 <bnemec> Yeah, it's not obvious to me what is wrong there. Let's discuss it further after the meeting.
15:48:13 <stephenfin> (y)
15:49:16 <bnemec> Okay, going to wrap it up then. Thanks for joining everyone!
15:49:19 <bnemec> #endmeeting