15:00:49 <bnemec> #startmeeting oslo
15:00:49 <openstack> Meeting started Mon Oct 29 15:00:49 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <openstack> The meeting name has been set to 'oslo'
15:01:07 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:07 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:07 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, moguimar
15:01:07 <bnemec> courtesy ping for njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin, stevemar
15:01:08 <bnemec> courtesy ping for therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:20 <kgiusti> o/
15:01:22 <jungleboyj> o/  Kind of here.
15:01:27 <phuongnh> o/
15:01:34 <jungleboyj> bnemec:  Congrats on being an IBMer again.
15:01:44 <phuongnh> :)
15:01:49 <bnemec> jungleboyj: Yeah...
15:03:20 <ducnv_> o/
15:03:21 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:03:30 <bnemec> #topic Red flags for/from liaisons
15:04:00 <jungleboyj> Nothing from Cinder.
15:04:49 <bnemec> As I mentioned in my email I was travelling last week, but I don't recall hearing about any major issues.
15:06:12 <bnemec> #topic Releases
15:06:17 <njohnston> o/
15:06:40 <bnemec> Releases happend last week as normal. Expect more of the same this week.
15:07:22 <bnemec> #topic Action items from last meeting
15:07:32 <bnemec> "bnemec to follow up on oslo.config lightning talk"
15:08:03 <bnemec> I did hear back from Kendall and the appropriate people are aware of our request.
15:08:33 <bnemec> I have another topic related to this for later, but this one is done.
15:08:42 <bnemec> "stephenfin to test removing everything except flake8 from pep8 venv for https://review.openstack.org/#/c/593566"
15:08:52 <bnemec> I believe he did this and commented on the review, so done.
15:09:11 <bnemec> And that was it.
15:09:31 <bnemec> #topic Project Update Video?
15:09:54 <bnemec> Since we didn't get an official project update slot, I was thinking maybe we could jump on a video chat and record our own.
15:10:22 <bnemec> We'd lose the in-person feedback, but at least the information would be out there.
15:11:18 <bnemec> There's quite a bit going on in Oslo right now that I think people would be interested in, so I'd like to have a bit more than an unrecorded lightning talk about it.
15:12:32 <bnemec> Worst case scenario would be that I just record a YouTube video of me yammering for 20 minutes, but ideally it would be good if the people who worked on stuff could talk about it.
15:13:21 <dhellmann> o/
15:14:05 <bnemec> So I just wanted to throw this out there and see if anyone else was interested. If so, please let me know ASAP.
15:14:05 <dhellmann> ++ for letting folks talk about their work
15:14:31 <bnemec> I'd ideally like to get this done before Summit so we can socialize it there.
15:15:39 <bnemec> I will send an email to the list asking for topics too.
15:15:46 <bnemec> #action bnemec send email about project update video
15:16:39 <bnemec> #topic Weekly Spotlight?
15:17:09 <bnemec> On a sort of related note, I was thinking it might be good if we highlighted some Oslo bits in a weekly-ish blog or something.
15:17:24 <bnemec> One of the questions that came up in Vancouver was how to know what's available in Oslo.
15:17:33 <bnemec> I'm thinking this might go a long way toward addressing that.
15:17:39 <dhellmann> I like that
15:17:58 <bnemec> dhellmann: You were doing something similar for Python, right?
15:18:11 <dhellmann> you mean https://pymotw.com/3/?
15:18:23 <bnemec> Yeah
15:18:48 <dhellmann> yeah, that's a lot of examples of using stdlib modules
15:19:05 <dhellmann> it would be good to have examples of using oslo libs, if that's what you have in mind
15:19:37 <bnemec> Yeah, I was thinking pick a module, talk about what's available in it, show some examples of using it.
15:19:45 <dhellmann> ++
15:20:01 <dhellmann> did you have a tool in mind?
15:20:17 <bnemec> No, I'm currently still in the idea stage with this. :-)
15:20:31 <dhellmann> ok, well +1 to the idea
15:21:28 <bnemec> Okay, I will try to dig a little deeper if I get a chance.
15:21:35 <bnemec> dhellmann: What did you use for pymotw?
15:21:52 <dhellmann> a combination of sphinx and wordpress
15:22:12 <dhellmann> wordpress supports scheduling posts in advance, which let me write more than one at a time
15:22:27 <dhellmann> the foundation has a wordpress blog already and we might be able to use that
15:23:15 <dhellmann> if we add the tutorials to the relevant lib docs, then the blog post just needs to be an introduction with a link
15:23:19 <bnemec> Okay, I can look into that.
15:24:08 <dhellmann> michael stills wrote some posts about using privsep that would be good to repurpose, and jaosorior has some recent ones on policy, too
15:24:18 <bnemec> Yeah, that's a good point. A lot of this probably belongs in the docs anyway.
15:24:43 <dhellmann> docs for findability and blog for putting it out in front of folks
15:25:50 <jaosorior> o/
15:27:20 <bnemec> #action bnemec to investigate oslomotw
15:27:50 <bnemec> #topic Weekly Wayward Review
15:28:45 <bnemec> The flake8 one from last week is still out there, but hasn't gotten a response yet.
15:28:51 <bnemec> So we'll do the next one.
15:28:53 <bnemec> #link https://review.openstack.org/600266
15:29:34 <bnemec> lbragstad: ^
15:30:01 * lbragstad lingers
15:30:02 <bnemec> Maybe it should be WIP'd pending the outcome of the Nova POC?
15:30:36 <lbragstad> yeah... i saw jaypipes start a thread on that last week
15:31:01 <lbragstad> sounds like he's getting close to starting on it?
15:31:31 <bnemec> lbragstad: So do we want to go ahead and merge the oslo.limit patches or wait for that?
15:32:11 <lbragstad> i certainly don't want to cause interface churn even if it is marked as experimental
15:32:26 <lbragstad> want me to see if i can get jay to weigh in on that approach?
15:32:41 <lbragstad> before merging it?
15:32:53 <bnemec> Sure, that would be good.
15:33:04 <lbragstad> ok - i'll see if i can get that done today or tomorrow
15:33:15 <lbragstad> if i can't we can just merge it and follow up later
15:33:57 <bnemec> Okay, we can circle back next week and if there's been no change we can merge it (assuming another Oslo core is okay with it).
15:34:04 <lbragstad> ++ sounds good
15:34:26 <bnemec> #action lbragstad to ping jaypipes about oslo.limit API
15:36:02 <bnemec> Since that doesn't remove any reviews from our queue, I will point out this relatively little one that's been pending for a while:
15:36:02 <bnemec> #link https://review.openstack.org/#/c/602185/
15:36:46 <bnemec> It's just removing the doc references to the _LE, _LI, etc. translation functions.
15:38:19 <dhellmann> bnemec : should that commit message say "should not be using the log-oriented marker functions"?
15:39:00 <bnemec> dhellmann: The negation is the No at the start of the sentence.
15:39:12 <dhellmann> ah, I read that too quickly
15:39:34 <dhellmann> lgtm, though I agree with stephenfin's nits
15:39:38 <bnemec> But it might read easier if it got moved to be "should not".
15:40:24 <bnemec> Yeah, I'm not sure how common _C and _P are, and I don't recall the purpose behind them so I kind of deferred all of that.
15:40:37 <bnemec> Maybe it would be a good topic for MOTW. :-)
15:40:41 <dhellmann> I think _P was for plural and _C was for count
15:42:56 <bnemec> #topic Open discussion
15:43:08 <bnemec> Anything else before we close?
15:44:18 <bnemec> Welcome back dhellmann. Hope your PTO was relaxing. :-)
15:44:30 <dhellmann> yes, very, thanks!
15:46:23 <bnemec> Okay, looks like that's it for this week. Thanks for joining!
15:46:25 <bnemec> #endmeeting