15:00:30 <bnemec> #startmeeting oslo
15:00:31 <openstack> Meeting started Mon Dec 17 15:00:30 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:35 <openstack> The meeting name has been set to 'oslo'
15:00:52 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:00:52 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:00:52 <bnemec> courtesy ping for hberaud, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:00:52 <bnemec> courtesy ping for moguimar, njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin
15:00:53 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:00:57 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:09 <moguimar> o/
15:01:10 <redrobot> \o-ish
15:01:12 <hberaud> o/
15:01:17 <ansmith> o/
15:02:43 <kgiusti> o/
15:03:02 <moguimar> bnemec: how do I feed the agenda?
15:03:12 <moguimar> if I want to put someting there
15:03:17 <bnemec> moguimar: Just edit the wiki page I linked above.
15:03:28 <bnemec> You should have access with your launchpad credentials.
15:03:41 <bnemec> The same ones as for gerrit.
15:04:15 <bnemec> #topic Red flags for/from liaisons
15:04:52 <bnemec> The tooz test jobs are broken with recent versions of grpcio.
15:05:10 <bnemec> I imagine that means there are problems in production use as well.
15:05:16 <bnemec> This is for the etcd3 driver only.
15:05:43 <bnemec> #link https://bugs.launchpad.net/python-tooz/+bug/1808046
15:05:45 <openstack> Launchpad bug 1808046 in tooz "etcd3 driver failing with "Deadline Exceeded"" [Critical,In progress] - Assigned to Ben Nemec (bnemec)
15:06:15 <moguimar> done
15:06:23 <bnemec> We're working on capping the version in g-r and an issue has been opened with the grpc folks.
15:07:57 <bnemec> I think that's it from the oslo side.
15:08:04 <bnemec> Any other issues we should know about?
15:08:06 <hberaud> I also want to speak about the migrator topics https://review.openstack.org/#/q/status:open+project:openstack/oslo.config+branch:master+topic:migrator
15:08:37 <bnemec> Yeah, that's on the agenda. We'll get there.
15:09:43 <hberaud> to raise the priority if possible, I've made some review on it and submit changes, do someone can take a look?
15:09:52 <hberaud> bnemec: ack
15:10:11 <bnemec> #topic Releases
15:10:22 <bnemec> Business as usual last week and this week.
15:10:52 <bnemec> There likely won't be any releases over the holidays however.
15:11:23 <bnemec> Which shouldn't be an enormous problem since I doubt there will be a lot of changes merging during that time either. :-)
15:11:48 <bnemec> #topic Action items from last meeting
15:12:02 <bnemec> "dhellmann to re-review https://review.openstack.org/#/c/593556/"
15:12:07 <bnemec> He did. Thanks Doug.
15:12:16 <bnemec> And that was it for action items.
15:12:38 <bnemec> #topic [RFE] Configuration mapping tool for upgrade
15:12:45 <bnemec> #link https://review.openstack.org/#/q/status:open+project:openstack/oslo.config+branch:master+topic:migrator
15:13:11 <bnemec> So the problem with this is that all of the folks that were working on it seem to have disappeared.
15:13:21 <bnemec> Which concerns me from a long-term maintenance perspective.
15:14:05 <bnemec> In addition, this feature requires some coordination with other projects to adopt fully.
15:14:36 <hberaud> bnemec: which projects we need to coordinate?
15:14:38 <bnemec> People need to use the mapping when changing values from release to release, and someone needs to drive that cross-project work.
15:14:50 <openstackgerrit> Merged openstack/oslosphinx master: Replacing the HTTP protocal with HTTPS in layout.html  https://review.openstack.org/625218
15:14:56 <hberaud> bnemec: I can start a ML thread to manage this
15:15:18 <bnemec> hberaud: That would be good.
15:15:27 <hberaud> bnemec: ack
15:15:42 <bnemec> To be honest, I'm a little dubious of the value of the tool. I'm not sure how many people are manually writing OpenStack configs in the first place.
15:15:59 <bnemec> And if you're using puppet/ansible/chef/etc. to manage your config then they handle upgrades.
15:16:20 <bnemec> But I guess we can discuss this further on the list.
15:16:21 <hberaud> ok
15:16:45 <bnemec> Thanks for bringing it up.
15:17:01 <hberaud> bnemec: yeah I think it's can be a good approach to choose if we move forward on it
15:17:11 <hberaud> bnemec: my pleasure
15:17:16 * jungleboyj walks in late
15:17:21 <bnemec> #action hberaud to send email to openstack-discuss about oslo.config migrator
15:17:34 * bnemec give jungleboyj the stink-eye :-P
15:17:47 * jungleboyj looks sheepish
15:18:27 <bnemec> As if I'd ever be on time for a Monday morning meeting that I wasn't chairing. :-)
15:18:30 <bnemec> #topic Reviews: oslo.policy: Add ability for policy-checker to read configuration
15:18:38 <bnemec> #link https://review.openstack.org/#/c/625038/3
15:18:44 <bnemec> #link https://review.openstack.org/#/c/616659/7
15:18:54 <moguimar> just wanted to bring those reviews up
15:19:16 <moguimar> jaosorior was working on it and I suggested using oslo.config instead of argparse+configparser
15:19:35 <moguimar> then he asked me to take it over as he is in PTO
15:19:50 <bnemec> I know I'm subscribed to those. I saw some discussion around the design of the code.
15:19:54 <bnemec> Are you just looking for more input?
15:19:59 <moguimar> yep
15:20:17 <moguimar> input/validation
15:20:29 <bnemec> Okay, I'll try to take a closer look this week.
15:20:45 <bnemec> You might also ping some of the keystone folks as they have interest in oslo.policy as well.
15:21:03 <moguimar> ok, thanks Ben
15:21:40 <bnemec> #action bnemec to look at oslo policy checker reviews
15:22:02 <bnemec> I really need to take a closer look at the pluggable policy spec too. :-/
15:22:33 <bnemec> I'm guessing that won't get in until 2019 at this point though.
15:22:39 <moguimar> #action moguimar to ping keystone folks for the oslo.policy change
15:22:53 <moguimar> I think jaosorior won't be back til 2019 too
15:23:12 <bnemec> And that leads us neatly into our next topic:
15:23:14 <bnemec> #topic No meetings next two weeks
15:23:33 <bnemec> It's that time of year when everyone is out for holiday breaks.
15:23:35 * dhellmann slinks in later
15:23:48 <jungleboyj> Wow, how did I beat dhellmann  :-)
15:24:02 <bnemec> I'm around for the rest of this week, but then I'll be out for the year too.
15:24:17 <bnemec> I think many of our Oslo cores are in the same boat.
15:25:53 <bnemec> So, to sum up, no meetings the next two weeks, mostly likely no releases after this week, and also likely much reduced review activity until 2019.
15:26:13 <bnemec> I'll send an email to the list just for completeness.
15:26:18 <moguimar> this is my last week too
15:26:31 <bnemec> #action bnemec to send mail to openstack-discuss about EOY plans.
15:27:31 <bnemec> Okay, that was it for topics.
15:27:33 <bnemec> #topic Weekly Wayward Review
15:29:13 <bnemec> I'm going to skip a couple of feature reviews because we probably can't resolve those here.
15:29:14 <bnemec> #link https://review.openstack.org/#/c/616605/
15:29:37 <bnemec> That one's had some discussion already and I think it's ready to go.
15:32:38 <bnemec> dhellmann: This one's probably you too since you were -1 before.
15:32:55 <dhellmann> I'll put that on my queue for this week
15:33:01 <dhellmann> today is going to be busy
15:33:14 <dhellmann> if someone else looks at it and thinks it's ok, that's fine with me
15:33:39 <bnemec> Okay, thanks.
15:33:59 <bnemec> #topic Open discussion
15:34:05 <bnemec> Anything else this week?
15:34:09 <hberaud> do someone can take a look to the workflow validation of this one please? => https://review.openstack.org/#/c/618482/
15:36:25 <moguimar> Ill put that one in my review list hberaud
15:36:44 <hberaud> moguimar: thx :)
15:37:30 <hberaud> dhellmann: I put this one on my review list => https://review.openstack.org/#/c/616605/
15:37:59 <bnemec> Thanks guys.
15:39:19 <moguimar> o/
15:39:34 <hberaud> o/
15:41:11 <bnemec> Okay, sounds like we're done.
15:41:19 <bnemec> Thanks for joining everyone and see you in 2019!
15:41:20 <dhellmann> o/
15:41:27 <hberaud> see you!
15:41:33 <bnemec> #endmeeting