15:00:54 <bnemec> #startmeeting oslo
15:00:55 <openstack> Meeting started Mon Jan 14 15:00:54 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:58 <openstack> The meeting name has been set to 'oslo'
15:00:59 <moguimar> o/
15:01:12 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:12 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:12 <bnemec> courtesy ping for hberaud, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:01:12 <bnemec> courtesy ping for moguimar, njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin
15:01:12 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:22 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:55 <ansmith> o/
15:03:04 <kgiusti> o/
15:03:53 <bnemec> #topic Red flags for/from liaisons
15:04:06 <bnemec> Still dealing with the fallout from parallel privsep.
15:04:11 <njohnston> o/
15:04:23 <bnemec> Fixed the neutron functional test failures, but now there's another one in neutron-fwaas.
15:04:41 <bnemec> Still investigating that one.
15:04:56 <bnemec> #link https://bugs.launchpad.net/neutron/+bug/1811506
15:04:58 <openstack> Launchpad bug 1811506 in neutron "neutron-fwaas-dsvm-functional tests failing with oslo.privsep 1.31" [Critical,In progress] - Assigned to Ben Nemec (bnemec)
15:05:02 <bnemec> For those playing along at home.
15:05:35 <njohnston> thanks for all your work on that bnemec
15:06:13 <amotoki> bnemec: I saw your patch but I am not sure it is different from my test patch. neutron changes resolved most but I still see one failure.
15:06:32 <bnemec> amotoki: Yeah, I didn't look at the test names carefully enough.
15:06:39 <bnemec> That won't fix the last failure.
15:06:49 <bnemec> Sorry for the noise.
15:06:55 <amotoki> bnemec: no worries
15:07:12 * jungleboyj sneaks in late.
15:07:13 <amotoki> I am suffering  how to debug privsep functions...
15:07:51 <amotoki> good news is it can be reproduced easily in our local devstack env
15:08:00 <bnemec> amotoki: Log messages from the privileged function _should_ get propagated back to the caller.
15:08:34 <bnemec> It's probably not relevant here, but I also did a blog post about my debugging of the ctypes issue.
15:08:35 <bnemec> #link http://blog.nemebean.com/content/debugging-segfault-osloprivsep
15:10:19 <bnemec> Anyway, more investigation needed.
15:10:38 <bnemec> #topic Releases
15:11:13 <bnemec> Should be business as usual. Expect the weekly releases to happen soon.
15:11:53 <bnemec> #topic Action items from last meeting
15:12:09 <bnemec> "moguimar to sync with jaosorior on policy config change"
15:12:14 <bnemec> I believe that was done.
15:12:23 <bnemec> Now I need to revisit that review.
15:12:47 <bnemec> "bnemec to respond again to config migrator thread"
15:12:51 <bnemec> Done
15:13:12 <bnemec> The outcome was that we abandoned that patch series pending someone else wanting the feature.
15:13:30 <bnemec> "bnemec to request space at Denver PTG III"
15:13:32 <bnemec> Done
15:13:39 <bnemec> "moguimar to review https://review.openstack.org/#/c/620686/"
15:13:52 <bnemec> Done, thanks
15:14:07 <bnemec> And that was it for action items.
15:15:31 <moguimar> and thanks for reviewing the castellan driver bnemec
15:15:36 <bnemec> I could swear I had something I wanted to add to the agenda, but I apparently didn't and can't remember what it was. :-)
15:15:45 <bnemec> moguimar: np
15:16:32 <bnemec> #topic Weekly Wayward Review
15:17:00 <bnemec> #link https://review.openstack.org/623244
15:17:04 <bnemec> Easy one this week.
15:18:11 <bnemec> Just a two line change with a unit test to cover it.
15:18:44 <kgiusti> bnemec: approved
15:18:55 <bnemec> kgiusti: Thanks!
15:18:57 <moguimar> lgtm
15:19:05 <bnemec> That does it for our regular agenda.
15:19:07 <bnemec> #topic Open discussion
15:19:46 <kgiusti> I've got a problem reproducing a bug reported against oslo.messaging pike
15:19:55 <kgiusti> https://bugs.launchpad.net/oslo.messaging/+bug/1800957
15:19:56 <openstack> Launchpad bug 1800957 in oslo.messaging "Upgrading to pike version causes rabbit timeouts with ssl" [Undecided,Confirmed] - Assigned to Ken Giusti (kgiusti)
15:20:09 <kgiusti> For the life of me I cannot reproduce it
15:20:47 <kgiusti> A user has gone so far as to offer up their reproducer - alas WFM
15:21:14 <kgiusti> if anyone has spare cycles (HA!) and can try to repo this I would be forever in debt...
15:21:56 <bnemec> That sounds fun. :-)
15:22:16 <kgiusti> yep hard to fix something that I can't break
15:23:24 <bnemec> Doesn't sound too terrible to set up the environment.
15:23:29 <kgiusti> Someone went as far as to identify a possible commit, but that change fixes a valid threading issue
15:23:31 <bnemec> I'll try to give it a shot.
15:23:51 <kgiusti> bnemec: my hero... LMK what happens
15:25:08 <bnemec> #action bnemec to try to reproduce https://bugs.launchpad.net/oslo.messaging/+bug/1800957
15:25:10 <openstack> Launchpad bug 1800957 in oslo.messaging "Upgrading to pike version causes rabbit timeouts with ssl" [Undecided,Confirmed] - Assigned to Ken Giusti (kgiusti)
15:25:35 <bnemec> #action investigate https://bugs.launchpad.net/neutron/+bug/1811506
15:25:36 <openstack> Launchpad bug 1811506 in neutron "neutron-fwaas-dsvm-functional tests failing with oslo.privsep 1.31" [Critical,In progress] - Assigned to Ben Nemec (bnemec)
15:25:56 <bnemec> So many bugs.
15:25:59 <bnemec> Happy Monday! :-)
15:26:15 <bnemec> Okay, anything else?
15:27:01 <jungleboyj> One announcement.
15:27:14 <bnemec> jungleboyj: has the floor
15:27:27 <jungleboyj> For anyone in Raleigh the first week of February we are going to be doing a mid-cycle.
15:27:42 <jungleboyj> If there is anyone who wants to come be a fly on the wall, feel free to join us.
15:28:11 <jungleboyj> #link https://etherpad.openstack.org/p/cinder-stein-mid-cycle-planning
15:28:20 <jungleboyj> The etherpad has details.
15:28:39 <bnemec> Cool, sounds good.
15:28:46 * bnemec will be in Florida that week
15:29:06 <jungleboyj> bnemec:  Nice.  Hopefully we have good weather in that part of the world.
15:29:33 <bnemec> jungleboyj: Most likely that will be the week we finally get snow. ;-)
15:30:04 <jungleboyj> Yeah, that was what happened to me last year, but the snow was in Raleigh.  :-(
15:30:29 <bnemec> Well, fingers crossed.
15:30:39 <jungleboyj> :-)
15:31:56 <bnemec> Any other open discussion topics?
15:34:05 <bnemec> Okay, thanks for joining everyone!
15:34:08 <bnemec> Until next week.
15:34:11 <bnemec> #endmeeting