15:01:14 <bnemec> #startmeeting oslo
15:01:15 <openstack> Meeting started Mon Jan 21 15:01:14 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:18 <openstack> The meeting name has been set to 'oslo'
15:01:27 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:27 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:27 <bnemec> courtesy ping for hberaud, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:01:27 <bnemec> courtesy ping for moguimar, njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin
15:01:27 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:32 <e0ne> hi
15:01:36 <hberaud> o/
15:01:36 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:53 <ansmith> o/
15:02:07 <moguimar> o/
15:03:59 <bnemec> #topic Red flags for/from liaisons
15:04:12 <bnemec> The big one remains parallel privsep.
15:04:40 <bnemec> We've been chasing down bugs in Neutron and related projects.
15:05:15 <bnemec> I think we've managed to find fixes or workarounds for all of the known issues, but I think there is some more discussion to be had.
15:05:52 <bnemec> But I have a topic later for that, so unless anyone has any new red flags we can move on.
15:05:52 <kgiusti> o/
15:06:35 <bnemec> #topic Releases
15:06:57 <bnemec> Nothing major to report here.
15:07:15 <bnemec> I think the stable branches should all be released at this point.
15:07:18 <hberaud> can you take a look to this one => https://review.openstack.org/#/c/631594/
15:07:48 <hberaud> fixing an error introduced by this one => https://review.openstack.org/#/c/631276/
15:07:52 <jungleboyj> Helping my Son's class. So not on today.
15:08:15 <bnemec> jungleboyj: Ack
15:09:25 <bnemec> hberaud: Done. I'll try to remember to exclude that one when I do weekly releases.
15:09:39 <hberaud> bnemec: ack thx
15:10:13 <bnemec> hberaud: Also, I highly recommend using the new-release command to make these changes. It automatically fills in the hash so you don't have to worry about stuff like this.
15:10:24 <hberaud> bnemec: ack
15:10:25 <bnemec> tox -e venv -- new-release stein [project name] [type of release]
15:10:37 <hberaud> bnemec: really usefull
15:11:08 <bnemec> Although it's also worth noting that unless something is extremely critical it usually isn't necessary to request a one-off release.
15:11:19 <bnemec> Everything with new changes gets released weekly in Oslo.
15:11:26 <hberaud> bnemec: ack
15:12:19 <bnemec> Okay, that should do it for releases.
15:12:21 <bnemec> #topic Action items from last meeting
15:12:50 <bnemec> "bnemec to try to reproduce https://bugs.launchpad.net/oslo.messaging/+bug/1800957"
15:12:51 <openstack> Launchpad bug 1800957 in oslo.messaging "Upgrading to pike version causes rabbit timeouts with ssl" [High,Confirmed] - Assigned to Ken Giusti (kgiusti)
15:12:55 <bnemec> Tried and failed.
15:13:12 <bnemec> So I think we can confirm that the reproducer isn't 100% there.
15:13:38 <bnemec> There's ongoing discussion on the bug so hopefully we can make progress.
15:13:49 <bnemec> "investigate https://bugs.launchpad.net/neutron/+bug/1811506"
15:13:50 <openstack> Launchpad bug 1811506 in neutron "neutron-fwaas-dsvm-functional tests failing with oslo.privsep 1.31" [Critical,In progress] - Assigned to Akihiro Motoki (amotoki)
15:14:08 <bnemec> Also done.
15:14:27 <bnemec> Turned out there was an issue with how the test was checking the network namespace when it was run in threads.
15:14:35 <kgiusti> update: one of the upstream reporters indicated the problem occurs more frequently at higher thread counts
15:14:50 <kgiusti> I'll retry today
15:14:52 <bnemec> I sent an email to the list and there's a patch up from amotoki to fix the problem.
15:14:59 <openstackgerrit> Moisés Guimarães proposed openstack/oslo.policy master: Add ability for policy-checker to read configuration  https://review.openstack.org/616659
15:15:27 <bnemec> kgiusti: Does that relate to the reproducer or just to running in actual environments?
15:15:40 <kgiusti> reproducer
15:15:48 <kgiusti> using the simulator
15:17:11 <bnemec> kgiusti: Okay, let me know if you still can't reproduce it. I can try again in my environment.
15:17:25 <kgiusti> bnemec: will do thanks
15:17:51 <bnemec> #action kgiusti to try to reproduce https://bugs.launchpad.net/oslo.messaging/+bug/1800957 with higher thread count
15:17:52 <openstack> Launchpad bug 1800957 in oslo.messaging "Upgrading to pike version causes rabbit timeouts with ssl" [High,Confirmed] - Assigned to Ken Giusti (kgiusti)
15:18:31 <bnemec> #topic Privsep and code that forks
15:18:42 <bnemec> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001831.html
15:19:07 <bnemec> In case anyone didn't see the email thread, I wanted to mention this here too.
15:19:46 <bnemec> It's a fairly significant problem with threaded privsep and some of the privileged code in projects.
15:21:33 <bnemec> I guess I don't have anything more to add at this point, so feel free to provide input on the list.
15:21:49 <bnemec> #topic Weekly Wayward Review
15:22:42 <bnemec> #link https://review.openstack.org/#/c/597290/
15:22:58 <moguimar> I just updated this one to remove merge conflicts.
15:23:02 <moguimar> #link https://review.openstack.org/#/c/616659/
15:23:07 <bnemec> Fairly simple pbr change.
15:24:36 <moguimar> +2
15:25:02 <moguimar> I liked the "arequirement>=1.0"
15:25:50 <moguimar> also tests if what was supposed to stay there is actually there after the parsing
15:27:32 <bnemec> moguimar: Thanks. I left a couple of comments on yours.
15:28:36 <bnemec> If stephenfin doesn't revisit that one this week I'll probably go ahead and merge it since he was +2 before, and I just added the reno he asked for.
15:28:51 <bnemec> #topic Open discussion
15:29:02 <bnemec> Anything else today?
15:31:26 <bnemec> Okay, thanks for joining everyone!
15:31:29 <bnemec> #endmeeting