15:06:05 <bnemec> #startmeeting oslo
15:06:06 <openstack> Meeting started Mon Feb 18 15:06:05 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:06:10 <openstack> The meeting name has been set to 'oslo'
15:06:13 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:06:13 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:06:13 <bnemec> courtesy ping for hberaud, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:06:13 <bnemec> courtesy ping for moguimar, njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin
15:06:13 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:06:16 <moguimar> o/
15:06:19 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:07:33 <ansmith> o/
15:07:56 <kgiusti> o/
15:08:22 <moguimar> Ben, quick question, the Barbican guys asked when is the next castellan comming out. Where can I find info about Oslo releases and schedule?
15:09:22 <bnemec> moguimar: Oslo releases everything with changes weekly.
15:09:31 <bnemec> However, I should double-check that Castellan is in our list.
15:10:00 <bnemec> We ran into a situation recently with pycadf (I think) where it wasn't in the oslo list because it was owned by the keystone team in the releases repo.
15:10:27 <bnemec> It's possible Castellan is owned by Barbican and doesn't show up in my list.
15:10:47 <bnemec> Nope, it's Oslo: https://github.com/openstack/releases/blob/master/deliverables/stein/castellan.yaml
15:10:53 <bnemec> And was released about a month ago.
15:11:16 <bnemec> I assume there haven't been any substantial changes since then.
15:11:26 <bnemec> #topic Releases
15:11:37 <bnemec> Since we're already discussing this topic. :-)
15:13:09 <bnemec> Oh crud, I missed that castellan had new changes to release because they were showing up as October commits.
15:13:34 <bnemec> The more recent changes were just test and doc changes.
15:14:18 <bnemec> moguimar: Looks like I dropped the ball. I'll get Castellan released this week.
15:14:30 <bnemec> #action bnemec to release castellan
15:15:08 <bnemec> And of course I'll do the regular set of releases too.
15:15:17 <bnemec> Anything else on releases?
15:15:44 <moguimar> not on my end
15:16:48 <bnemec> #topic Red flags for/from liaisons
15:16:59 <bnemec> Back to your regularly scheduled topic. :-)
15:17:09 <bnemec> Not sure we have any liaisons here today though.
15:18:26 <bnemec> Okay moving on then.
15:18:39 <bnemec> I don't think there was anything to report on our side either.
15:18:43 <bnemec> #topic Action items from last meeting
15:18:57 <bnemec> "Investigate adding main thread execution to privsep"
15:19:06 <bnemec> I haven't had a chance to look into this yet.
15:19:13 <bnemec> "bnemec to update openstack-discuss about privsep/fork issue"
15:19:19 <bnemec> However, this is done, so the plan is on the record.
15:19:55 <bnemec> If anyone has free cycles and wants to look into this, please feel free.
15:20:10 <bnemec> "moguimar to take over https://review.openstack.org/579186"
15:20:16 <bnemec> I saw discussion on this, so calling it done.
15:20:20 <moguimar> working on it
15:20:26 <moguimar> not done =P
15:20:29 <bnemec> Cool.
15:20:37 <bnemec> Well, you're working on it, so the action item is done. :-P
15:20:48 <moguimar> ah, ok
15:21:03 <bnemec> I'm all about checking the done boxes in the meeting. :-)
15:21:21 <bnemec> And that was it for action items.
15:21:32 <bnemec> #topic Oslo Feature Freeze Feb. 22
15:21:54 <bnemec> Per https://releases.openstack.org/stein/schedule.html
15:22:18 <bnemec> Oslo feature freeze is this week. Any features after Friday will require an FFE.
15:22:51 <bnemec> I'll send email to the list about this since we're earlier with feature freeze than any other projects.
15:23:03 <bnemec> #action bnemec send email to openstack-discuss about Oslo feature freeze
15:24:14 <bnemec> I guess that's it. If you have feature patches open that you want in this cycle, make sure they merge by Friday!
15:24:19 <bnemec> #topic Technical vision evaluation
15:24:35 <bnemec> We need to do this.
15:24:58 <bnemec> I mean to do more homework on it before this meeting, but unfortunately didn't get a chance. :-/
15:25:24 <bnemec> For details on this, see:
15:25:26 <bnemec> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-January/001417.html
15:25:50 <bnemec> My thought is that since Oslo doesn't have one main source repo, we just put this in our policies section in the specs repo.
15:26:33 <bnemec> I realize it doesn't quite fit there, but unless someone has a better option I think we should go with it.
15:27:17 <bnemec> I'm not sure how much we'll have to do since I'm pretty sure they added a bullet point to the vision doc specifically to address Oslo.
15:27:43 <bnemec> So unless we're doing something wrong, we should already be in alignment.
15:28:24 <bnemec> If that's the case then writing the bullet points should be easy, but I'd like to at least do the evaluation so I can reply "Done" to the ML thread. :-)
15:28:36 * bnemec notices a theme for this week's meeting
15:29:44 <bnemec> #action Oslo team perform technical vision evaluation
15:30:02 <bnemec> We'll see if that gets done by next week, but hopefully.
15:30:14 <moguimar> bnemec: you remind me of the monday.com add on youtube
15:30:15 <bnemec> #topic Messaging singleton for get_transport_url
15:30:25 <bnemec> moguimar: lol
15:30:40 <bnemec> I mean, that's pretty much the life of a PTL.
15:30:56 <bnemec> It's basically a project management position.
15:31:05 <bnemec> If you're lucky you also get to write code once in a while. ;-)
15:31:38 <bnemec> kgiusti: ansmith: Hey, we had a question from eandersson about https://review.openstack.org/#/c/636428
15:31:52 <bnemec> Apparently octavia was having issues with a huge number of rabbit connections piling up.
15:32:10 <bnemec> He was wondering if get_transport_url should be a singleton.
15:32:58 <kgiusti> bnemec: sorry I've been MIA last week (blame europe)
15:33:04 <johnsom> Yes, I don’t have all of the details there, so didn’t raise it earlier.
15:33:17 <bnemec> kgiusti: Yeah, no worries. I was in the same boat a couple of weeks ago. :-)
15:33:39 <bnemec> Not literally in a boat, you understand. I flew there.
15:33:47 <johnsom> The docs for oslo messaging don’t even mention the close method on the transport.
15:33:48 * bnemec dodges rotten fruit
15:33:54 <kgiusti> bnemec: several projects do their own singleton-ish wrapper under the covers
15:34:13 <bnemec> Yeah, I think that's what eandersson is proposing in that patch.
15:34:31 <bnemec> Should we document that as a best practice?
15:34:37 <johnsom> What I don’t know is why they didn’t close when they went out of scope
15:35:05 <kgiusti> bnemec: documenting that would be a good idea yes.
15:35:19 <kgiusti> bnemec: there
15:35:56 <bnemec> kgiusti: Okay, sounds good. If we can somehow avoid this bad behavior on the Oslo side that would be even better.
15:35:58 <kgiusti> bnemec: oops - the TCP connection per transport is only implied
15:36:17 <bnemec> Not sure we can cache it on the library side though since it's generated from a conf object and a url.
15:36:40 <kgiusti> bnemec: one sec...
15:38:49 <bnemec> We don't necessarily need to resolve this now.
15:38:59 <kgiusti> bnemec: can't find the specific code but impl_rabbit uses dedicated conns for some reason
15:39:11 <kgiusti> bnemec: which also blows up the # of connections
15:39:14 <bnemec> I just wanted to bring it up since I know next to nothing about messaging and was completely unhelpful on this issue. :-)
15:39:15 <kgiusti> bnemec: np.
15:39:27 <kgiusti> bnemec: I'll look into it
15:39:45 <bnemec> kgiusti: Great, thanks!
15:40:08 <bnemec> #action kgiusti to investigate connection explosion related to get_transport_url
15:40:51 <bnemec> That was it for topics. Let's see which review we can check off this list...
15:40:53 <bnemec> #topic Weekly Wayward Review
15:41:22 <bnemec> #link https://review.openstack.org/#/c/624509/
15:41:40 <bnemec> Pretty simple one.
15:42:02 <bnemec> This was causing some spurious unit test failures for me at one point.
15:44:26 <bnemec> Oh crud, I never added a test for that.
15:44:48 <bnemec> Okay, never mind. I'll WIP that patch until I can add tests.
15:45:35 <bnemec> Well, that gets it out of the review queue at least. :-)
15:45:42 <bnemec> #topic Open discussion
15:45:56 <bnemec> Anything else before we end the meeting for this week?
15:46:29 <moguimar> I accidentally ran into kgiusti last week =P
15:46:57 <bnemec> moguimar: I hope you didn't hurt him. :-P
15:47:01 <moguimar> he was spawning in every room I walked into at the office
15:47:12 <kgiusti> moguimar: don't tell my wife....
15:47:14 <bnemec> Hax!
15:47:20 <moguimar> xD
15:47:20 <bnemec> lol
15:47:33 <bnemec> kgiusti: went a very different direction with spawning than I did.
15:48:19 <kgiusti> bnemec: sorry
15:49:08 <bnemec> kgiusti: Not at all, yours was better anyway. :-)
15:50:20 <moguimar> I was able to introduce him to the best facilities we have at the Brno office
15:50:43 <bnemec> You mean Pegas? ;-)
15:51:20 <kgiusti> moguimar: the facilities were impressive, but not as impressive as the local brew - it's literally cheaper than water!
15:51:29 * bnemec 's mouth still waters thinking about those ribs
15:52:17 <moguimar> on my second visit to Prague, for PyCon CZ, my friends from Brazil asked me if beer was realy cheaper than water
15:52:41 <moguimar> I said:  ¯\_(ツ)_/¯
15:52:48 <moguimar> I didn't buy any water there
15:52:54 <bnemec> lol
15:54:06 <bnemec> moguimar: BTW, I don't know if you have any interest in https://review.openstack.org/#/c/614224/ but it's going to be affected by feature freeze.
15:54:08 <moguimar> but IIRC there is a law that says there should be a non alcoholic drink in the menu cheaper than the alcoholic ones
15:54:52 <moguimar> I'll let jaosorior know about that
15:55:25 <jaosorior> I didn't get much momentum for it
15:55:30 <jaosorior> so I guess it'll have to wait
15:55:51 <bnemec> Sorry about that. I should have looked at it before last week.
15:57:48 <bnemec> Oh, we had a spec open for this too: https://review.openstack.org/#/c/578719/
15:59:03 <bnemec> Okay, there's a bunch of discussion around this that probably still needs to be resolved, so I guess this isn't likely to land this cycle.
15:59:11 <bnemec> And we're just about out of time.
15:59:17 <bnemec> Thanks for joining everyone!
15:59:21 <bnemec> #endmeeting