15:22:45 <bnemec> #startmeeting oslo
15:22:46 <openstack> Meeting started Mon Feb 25 15:22:45 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:22:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:22:49 <openstack> The meeting name has been set to 'oslo'
15:23:05 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:23:05 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:23:05 <bnemec> courtesy ping for hberaud, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:23:05 <bnemec> courtesy ping for moguimar, njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin
15:23:05 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:23:08 <moguimar> o/
15:23:11 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:23:19 <hberaud> o/
15:23:22 <kgiusti> o/
15:23:23 <bnemec> Apologies for being late. I forgot that my appointment this morning overlapped this meeting.
15:23:28 <ansmith> o/
15:23:29 <jungleboyj> o/
15:23:33 <dhellmann> o/
15:23:49 <jungleboyj> bnemec:  Were you able to get to your appointment?
15:24:07 <bnemec> jungleboyj: Days like today are why I have a 4x4 truck. :-)
15:24:19 <bnemec> But yeah, it's post-snowpocalyptic out there.
15:24:20 <stephenfin> o/
15:24:30 <bnemec> Abandoned cars everywhere and stuff.
15:24:35 <jungleboyj> :-)  I have just decided not to tempt fate and am hiding at home.
15:24:40 <jungleboyj> bnemec:  I heard that.
15:25:10 <bnemec> Yeah, it figures that the one day I have to go out is today. :-)
15:25:27 <bnemec> #topic Red flags for/from liaisons
15:25:34 <bnemec> Other than red flag wind warnings. :-)
15:26:16 <jungleboyj> Nothing from Cinder.
15:26:48 <bnemec> I guess from our side, there's the amqp 2.4.1 bump.
15:27:06 <bnemec> If you're running oslo.messaging with ssl to rabbit, you very much want amqp 2.4.1.
15:27:19 <bnemec> That goes back to pike, but we can't backport the requirements change.
15:27:51 <bnemec> We'll be release noting it too, but I'm trying to publicize the change as much as possible.
15:28:06 <bnemec> Also, oslo.cache is currently broken, but I think it's unit tests only.
15:28:26 <bnemec> I'll be taking a look at hberaud's change to fix that today.
15:28:30 <hberaud> yeah due to https://github.com/sqlalchemy/dogpile.cache/commit/7e8d9b0a2eb552adb6734c8570c63eb6ea2e3a7a
15:28:34 <bnemec> #action bnemec to look at hberaud's oslo.cache fix
15:28:48 <bnemec> Anyone else is welcome to also.
15:28:59 <hberaud> my fix is under WIP yet
15:29:35 <hberaud> but I know why the problem occure
15:29:52 <bnemec> Okay, so more to do there, and keep that in mind if you're trying to get a patch in to oslo.cache.
15:30:13 <bnemec> Although we're past feature freeze, so that's less likely.
15:30:58 <bnemec> I know we had the python 3 bug in that library too, which we'll need to discuss once we unblock the gate.
15:31:41 <bnemec> Okay, lots of red flags this week, actually. :-/
15:32:01 <bnemec> #topic Releases
15:32:14 <bnemec> Will do the normal releases today.
15:32:31 <bnemec> Ideally this will be the last set with any feature releases this cycle.
15:32:50 <bnemec> Although we may have to make an exception for the oslo.cache bug, but we'll cross that bridge when we come to it.
15:33:18 <bnemec> moguimar: I believe the new castellan should be released now.
15:33:26 <moguimar> ok, thanks bnemec
15:33:30 <bnemec> I know you the barbican team was asking about that last week.
15:33:35 <bnemec> s/you//
15:34:16 <bnemec> #topic Action items from last meeting
15:34:25 <bnemec> Speaking of which...
15:34:26 <bnemec> "bnemec to release castellan"
15:34:28 <bnemec> Done
15:34:33 <bnemec> "bnemec send email to openstack-discuss about Oslo feature freeze"
15:34:35 <bnemec> Done
15:34:41 <bnemec> "Oslo team perform technical vision evaluation"
15:34:45 <bnemec> Not done. :-(
15:35:13 <bnemec> I'll leave it on my todo list though.
15:35:21 <bnemec> "kgiusti to investigate connection explosion related to get_transport_url"
15:35:55 <kgiusti> bnemec: it was recommended to adopt the singleton pattern used by other projects
15:36:19 <bnemec> kgiusti: Okay, did we have documentation of that?
15:36:31 <kgiusti> bnemec: nope.
15:36:43 <kgiusti> bnemec: #action kgiusti document singleton pattern
15:37:08 <kgiusti> #action kgiusti document singleton pattern
15:37:10 <kgiusti> ?
15:37:23 <bnemec> That should do it.
15:37:33 <bnemec> Not sure whether the bot will have picked up the one addressed to me.
15:37:38 <bnemec> kgiusti: Thanks
15:37:46 <kgiusti> bnemec: we should consider integrating that pattern into the library itself
15:37:58 <kgiusti> bnemec: for train
15:38:03 <bnemec> Yep, that would be a good followup.
15:38:54 <bnemec> That was it for action items from last week.
15:39:10 <bnemec> #topic Oslo Feature Freeze
15:39:21 <bnemec> We're now officially in feature freeze for Oslo.
15:39:57 <bnemec> As I mentioned, hopefully the releases I submit today will be the last feature ones for the cycle.
15:40:10 <bnemec> But we can discuss FFE's as needed.
15:40:57 <bnemec> So in general, cores please don't merge anything feature-y without discussing it with me first.
15:41:22 <bnemec> If we merge a feature without an FFE it will just block releasing that library.
15:42:02 <bnemec> I think we have an experienced enough core team that we shouldn't need to procedural -2 everything.
15:42:20 <bnemec> At least that's my hope because I'd rather not spend the time to do that. :-)
15:42:38 <jungleboyj> You get a -2 and you get a -2!
15:42:48 <bnemec> Everyone gets a -2!
15:42:58 <jungleboyj> Yay!
15:43:49 <bnemec> The other topics on the agenda were addressed last week, so I think that's it for those.
15:43:54 <bnemec> #topic Weekly Wayward Review
15:43:57 <moguimar> I think this is the first feature freeze I'm seeing from a closer distance
15:44:12 <moguimar> so we should hold +2 and +w?
15:45:23 <bnemec> moguimar: +2 is okay, but don't +w anything that would trigger a feature release.
15:45:30 * bnemec grabs a link to the release criteria...
15:45:35 <moguimar> ok
15:46:08 <bnemec> #link https://releases.openstack.org/reference/using.html#using-new-release-command
15:46:28 <bnemec> In general we follow semver, but that provides a short description of each release type that I find useful.
15:46:53 <bnemec> For wayward reviews, we obviously have a more limited set because of feature freeze.
15:46:59 <bnemec> But I think we can probably do this one:
15:47:01 <bnemec> #link https://releases.openstack.org/reference/using.html#using-new-release-command
15:47:04 <bnemec> Bleh.
15:47:12 <bnemec> #link https://review.openstack.org/#/c/625372
15:48:13 <bnemec> Oh, I see stephenfin asked for a reno on that.
15:49:07 <bnemec> hberaud: Since you already kind of adopted that one, would you be able to write a reno?
15:49:40 <hberaud> bnemec: yeah
15:49:52 <bnemec> hberaud: Great, thanks!
15:49:57 <moguimar> does it needs a release note?
15:50:22 * moguimar wrote his first release note on openstack last week =D
15:50:43 <moguimar> castellan folks made me do it
15:50:52 <bnemec> I would think that either a reno or lp bug would be good for discoverability.
15:51:11 <bnemec> I don't know that our git commit messages are SEO'd especially well. :-)
15:51:58 <bnemec> I personally wouldn't require both.
15:51:59 <moguimar> +1 for the lp
15:52:31 <bnemec> stephenfin was the one who asked, so maybe he can weigh in too.
15:52:49 * stephenfin checks
15:53:05 <hberaud> I'll create the lp
15:53:25 <stephenfin> It doesn't need a reno, but for a user facing tool like this it is mighty helpful
15:53:38 <hberaud> stephenfin: +1
15:54:06 <stephenfin> Helps with discoverability of these issues (user: "why is X happening", user -> Google)
15:54:58 <bnemec> Yeah
15:55:19 <bnemec> The reno could be pretty brief since it can reference the lp for details.
15:57:23 <bnemec> Okay, I marked that one WIP. That should get cleared when a new patch set is pushed so we'll know to look again.
15:57:42 <bnemec> #topic Open discussion
15:57:52 <bnemec> Anything else for this week?
15:58:01 <moguimar> yep
15:58:25 <moguimar> I was checking open changes and found this one
15:58:27 <moguimar> https://review.openstack.org/#/c/610111
15:58:46 <moguimar> so it basically updates .zuul.d/project.yaml and tox.ini
15:59:22 <moguimar> the current state of project.yaml tests py35 py36 and py37
15:59:46 <moguimar> do we have any best practices for that cross projects?
15:59:55 <johnsom> Sorry I missed the liaison section, but wanted to follow up on the oslo.service /yappi issue we had.
16:00:01 <moguimar> like, when are we suposed to add py38 and frop 35?
16:00:37 <bnemec> moguimar: We may need to discuss this on the list again. I looked when I approved all of the py37 changes last week, and the previous conclusion was that we would drop py35 and add py37 this cycle.
16:00:44 <bnemec> But I'm not clear that we ever actually dropped py35.
16:00:45 <moguimar> and is it better to keep the tox.ini one in the lower one (3.5) until it gets deprecated to make it fail fast during dev?
16:00:53 <johnsom> I think it is all resolved now, but that oslo.service release broke all of our live test gates. Luckily I was able to reach the yappi developer and he was willing to cut a new release of yappi with the fix.
16:01:10 <bnemec> And I'm idly tempted to say we should wait to drop things until next cycle.
16:01:34 <moguimar> I like having the last 3 versions as it is right now
16:01:43 <bnemec> I guess dropping py35 is pretty safe since it isn't going to break the gate, but I think we should clarify our support stance.
16:02:13 <bnemec> johnsom: Yeah, that's weird. I would have expected a problem like that to get caught in the gate since it happened on installation of the lib.
16:02:48 <moguimar> ok, I'll create some WIP on that and we can push it forward
16:02:51 <johnsom> Yeah, me too. Not sure what the magic combination was that triggered it for DIB installs
16:04:44 <gsantomaggio> I am looking how Open Stack does use RabbitMQ,
16:04:44 <gsantomaggio> I found this HA policy:
16:04:44 <gsantomaggio> https://git.openstack.org/cgit/openstack/openstack-ansible-rabbitmq_server/tree/defaults/main.yml#n154
16:04:44 <gsantomaggio> If I am not wrong, open stack does not use the autodelete queues anymore.
16:04:44 <gsantomaggio> It works using queues with TTL, right?
16:04:45 <gsantomaggio> So, this policy should be changed from '^(?!amq\.).*'  to '^(?!reply_\.).*'
16:04:45 <gsantomaggio> What do you think?
16:04:48 <bnemec> moguimar: Sounds good. Let me find the mailing list thread where this was first discussed. I think we should probably reopen that.
16:05:38 <moguimar> ok
16:06:03 <kgiusti> gsantomaggio: quite possibly - let me take a look
16:06:29 <bnemec> johnsom: Weirdly, it never broke our gate. I see passing test jobs that used .99: http://logs.openstack.org/88/637688/1/check/openstack-tox-py36/0b4045f/job-output.txt.gz#_2019-02-20_00_50_27_988954
16:06:43 <gsantomaggio> @kgiusti thanks
16:07:01 <bnemec> Maybe dib does something different with the encoding that tripped up the pip install?
16:07:43 <johnsom> bnemec Agreed. They had a bug and patch for it already. No idea how/what caused it to fail to install. It was a xenial image, nothing special.
16:08:10 <bnemec> Oh, that's right. Someone else actually reported it first.
16:08:50 <bnemec> moguimar: Okay, this actually goes back to the openstack-dev days: http://lists.openstack.org/pipermail/openstack-dev/2018-October/135626.html
16:09:47 <bnemec> #action moguimar to follow up on status of py35 in the gate
16:10:02 <moguimar> thanks
16:10:18 <bnemec> johnsom: Do you have any proposed actions to take to avoid this in the future?
16:11:01 <openstackgerrit> Hervé Beraud proposed openstack-dev/pbr master: Resolve ``ValueError`` when mapping value contains a literal ``=``.  https://review.openstack.org/625372
16:11:10 <johnsom> bnemec I would if I knew what the trigger was, but I don't. They py2 and 3 gates should have caught it.
16:12:04 <bnemec> johnsom: Well, at least now we have a known-working version so we can add version exclusions if it happens again.
16:12:40 <johnsom> Yeah, it's fixed and released on the yappi side. I have added the blacklist on yappi in g-r, so we should be good.
16:13:48 <bnemec> #action kgiusti and gsantomaggio to investigate OSA rabbitmq_policies
16:14:11 <bnemec> I think that covers all of the topics so far in open discussion.
16:14:35 <bnemec> I'll take this opportunity to note that anyone can add items to the agenda, so if you have something to discuss please feel free. :-)
16:15:10 <bnemec> Anything else before we end?
16:15:36 <moguimar> not on my end
16:15:54 <gsantomaggio> Nope :)!
16:17:08 <bnemec> Thanks for joining everyone!
16:17:08 <bnemec> Should be back to normal schedule next week.
16:17:11 <bnemec> #endmeeting