15:01:31 <bnemec> #startmeeting oslo
15:01:32 <openstack> Meeting started Mon Mar 18 15:01:31 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:35 <openstack> The meeting name has been set to 'oslo'
15:01:54 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:54 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:54 <bnemec> courtesy ping for hberaud, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:01:54 <bnemec> courtesy ping for moguimar, njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin
15:01:54 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:02:01 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:14 <hberaud> o/
15:02:22 <kgiusti> o/
15:02:52 <johnsom> o/
15:03:20 <ansmith> o/
15:04:00 <moguimar> o/
15:04:22 <bnemec> #topic Red flags for/from liaisons
15:04:48 <johnsom> Nothing to report from Octavia
15:05:15 <moguimar> Nothing from Barbican :)
15:06:00 <bnemec> I will note that Nova folks were investigating an issue last week with how oslo.service handles SIGHUP.
15:07:01 <bnemec> #link https://review.openstack.org/#/c/641907/
15:07:23 <moguimar> also a friend from ironic said he'll poke me about Oslo.messaging
15:07:38 <moguimar> who should I forward him to?
15:08:04 <moguimar> or where is the best place to start learning about Oslo.messaging?
15:09:14 <bnemec> moguimar: kgiusti and ansmith are our main messaging cores.
15:09:48 <bnemec> I know pretty much nothing about messaging. :-)
15:10:08 <bnemec> My main contribution ever to the messaging code got removed with the qpid driver.
15:10:41 <kgiusti> moguimar: I can put it back if you'd like
15:11:12 <kgiusti> moguimar: are the oslo.service issues related to messaging?
15:11:25 <bnemec> kgiusti: Not really.
15:11:54 <bnemec> It's related to RPC messages getting lost on SIGHUP, but I don't think it's anything wrong with messaging.
15:12:10 <bnemec> Just some mismatched expectations about what happens when a SIGHUP is received.
15:13:03 <bnemec> Looks like there has been some discussion on the review I linked above.
15:13:05 <kgiusti> bnemec: I personally expect chaos, but I'm a glass half full kinda guy
15:13:35 <bnemec> kgiusti: I think your expectations have been met. :-)
15:14:11 <kgiusti> bnemec: then ship it!
15:14:22 <bnemec> Anyway, sounds like that's pretty much it for red flags. We can keep discussing after the meeting.
15:14:31 <bnemec> kgiusti: Done!
15:14:37 * bnemec looks at all the stable branch reviews above
15:14:48 <bnemec> #topic Releases
15:14:52 <bnemec> Speaking of...
15:15:06 <bnemec> No master releases again last week as we were still in feature freeze.
15:15:21 <bnemec> I did release rocky and queens versions of a couple of libraries that had changes backported.
15:15:44 <bnemec> No Pike releases, which is fine since I think that's going extended maintenance soon (now?).
15:16:27 <bnemec> I don't anticipate any master releases yet this week since to my knowledge nothing should have merged that needs release yet.
15:17:29 <bnemec> That should be it for releases. We'll get back to normal next week, most likely.
15:17:32 <bnemec> #topic Action items from last meeting
15:17:39 <bnemec> "bnemec to release stable branches"
15:17:40 <bnemec> Done
15:17:47 <bnemec> "bnemec to survey Oslo projects for legacy jobs"
15:17:59 <bnemec> Sort of done.
15:18:19 <bnemec> I decided it probably wasn't worth the time to go through every Oslo project's zuul config.
15:18:42 <bnemec> I think we're mostly off legacy jobs anyway, so we'll play whack-a-mole with any failures that happen as a result of the bionic migration.
15:19:10 <bnemec> Speaking of which...
15:19:15 <bnemec> #topic Bionic Migration Complete
15:19:25 <bnemec> That was it for action items, BTW.
15:19:40 <bnemec> Legacy jobs were migrated to Bionic last week.
15:19:57 <bnemec> If you see any failures in legacy jobs that appear to be distro-related let us know.
15:20:14 <bnemec> Worst case scenario we make them non-voting until they can be fixed.
15:20:45 <bnemec> Which is another reason I didn't spend too much time tracking them down ahead of time.
15:21:07 <bnemec> Hopefully no actions from this, but keep an eye out for failures.
15:21:16 <bnemec> #topic Oslo cycle-highlights
15:21:41 <bnemec> We're supposed to add our cycle highlights to the releases repo soon.
15:22:12 <bnemec> I haven't really gone through the history for this release yet, but I have a couple of things I thought we'd want included:
15:22:18 <bnemec> 1) Castellan oslo.config driver
15:22:26 <bnemec> 2) Oslo.config validator
15:22:44 <bnemec> Those are two things people have been asking for for a long time so it would be good to get them included in the marketing material.
15:22:53 <bnemec> They're also user-facing things, which a lot of our work isn't.
15:23:09 <bnemec> If you have any other ideas for things we should include, please let me know ASAP.
15:23:52 <bnemec> Oh, maybe the env var driver too?
15:24:02 <openstackgerrit> Merged openstack/oslo.config stable/stein: Update .gitreview for stable/stein  https://review.openstack.org/644052
15:24:06 <bnemec> Anyway, give it some thought if you can.
15:24:22 <bnemec> #topic  Stein branches open, feature freeze complete
15:24:32 <bnemec> Thanks for that timely reminder, openstackgerrit.
15:24:58 <bnemec> stable/stein branches have obviously been created, which means master is open for feature development again.
15:25:18 <bnemec> Maybe don't merge anything _too_ crazy until the final release has been cut in case we need to backport a major bugfix.
15:26:17 <bnemec> Also, I believe in the past we've single-approved these bot-proposed branch changes.
15:26:26 <bnemec> Let's keep doing that.
15:26:39 <bnemec> #action Oslo cores to single-approve bot-proposed new branch changes
15:27:03 <bnemec> I'll shoot an email to the list for cores who aren't here.
15:27:15 <bnemec> #action bnemec to email openstack-discuss about stein single-approval
15:28:31 <bnemec> That's it for topics.
15:28:34 <bnemec> #topic Weekly Wayward Review
15:29:03 <bnemec> #link https://review.openstack.org/#/c/597612
15:29:37 <bnemec> Oh, oops: "Cannot Merge"
15:29:42 <bnemec> Apparently that one needs a rebase.
15:29:50 <bnemec> I'll get that taken care of shortly.
15:30:01 <bnemec> #action bnemec to rebase https://review.openstack.org/#/c/597612
15:30:33 <bnemec> Check that one off the list.
15:30:37 <bnemec> #topic Open discussion
15:30:44 <bnemec> Anything else this week?
15:32:34 <bnemec> Going once...
15:32:39 <bnemec> twice...
15:32:51 <bnemec> Done. Thanks for joining everyone!
15:32:56 <bnemec> #endmeeting