15:01:38 <bnemec> #startmeeting oslo
15:01:39 <openstack> Meeting started Mon Mar 25 15:01:38 2019 UTC and is due to finish in 60 minutes. The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:42 <openstack> The meeting name has been set to 'oslo'
15:01:45 <bnemec> moguimar: Yes. :-)
15:02:15 <moguimar> you were just waiting, weren't you?
15:02:16 <moguimar> xD
15:02:24 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:02:24 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:02:24 <bnemec> courtesy ping for hberaud, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:02:24 <bnemec> courtesy ping for moguimar, njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin
15:02:24 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:02:32 <redrobot> \o
15:02:36 <moguimar> o/
15:02:38 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:57 <hberaud> o/
15:03:02 <ansmith> o/
15:03:44 <bnemec> #topic Red flags for/from liaisons
15:03:51 <kgiusti> o/
15:04:05 <bnemec> We discovered an issue last week with oslo.db and postgresql 10.
15:04:35 <bnemec> Specifically that our old psycopg2 minimum version couldn't be installed with pgsql 10.
15:05:08 <bnemec> We've merged fixes for that to master and stable/stein.
15:05:21 <bnemec> I don't know that we can fix the older branches since that would require a feature release.
15:05:46 <bnemec> I'll be submitting the stein release request right after the meeting since that needs to happen before master.
15:07:00 <bnemec> Any other red flags?
15:08:10 <moguimar> none from barbican
15:08:15 <njohnston> o/
15:08:29 <njohnston> none from neutron
15:08:36 <bnemec> Cool, thanks
15:08:38 <bnemec> #topic Releases
15:08:48 <bnemec> As I noted, the priority is to get oslo.db for stein released.
15:09:09 <bnemec> Given that situation, I think I'm going to hold off on releasing master of any of the other libs until the stein release is final.
15:09:29 <bnemec> If we find any other critical blockers like this I don't want to be stuck because we already did the train feature version bump.
15:09:57 <bnemec> If, for some reason, you desperately need a release of master for a library let me know.
15:10:16 <bnemec> I don't expect that to be the case though since everyone should be working on the stein release.
15:10:41 <bnemec> #topic Action items from last meeting
15:10:48 <bnemec> "Oslo cores to single-approve bot-proposed new branch changes"
15:10:55 <bnemec> Done. Thanks stephenfin.
15:11:00 <bnemec> "bnemec to email openstack-discuss about stein single-approval"
15:11:01 <bnemec> Done.
15:11:08 <bnemec> "bnemec to rebase https://review.openstack.org/#/c/597612"
15:11:18 <bnemec> Done, but I think it already needed another one. Did I do that?
15:11:27 <bnemec> No.
15:11:47 <bnemec> #action bnemec to rebase https://review.openstack.org/#/c/597612
15:11:51 <bnemec> It goes back on the list then. :-)
15:12:05 <bnemec> That was it for action items.
15:13:00 <bnemec> #topic Technical Vision Evaluation
15:13:12 <bnemec> Not much to say here, other than it turns out we don't need to do this.
15:13:33 <bnemec> Shared libraries are explicitly excluded from the technical vision document, so basically our evaluation is "Not applicable".
15:13:53 <bnemec> I had mentioned this in a past meeting so I wanted to wrap it up.
15:14:16 <bnemec> The only other topic I had was the oslo.db issue, which we covered in the red flags section.
15:14:32 <moguimar> I put a new topic in the list
15:14:43 <moguimar> OpenStack.org -> opendev.org
15:14:54 <bnemec> Wow, that must have been during the meeting. :-)
15:14:57 <bnemec> #topic openstack.org -> opendev.org
15:15:03 <moguimar> got an email about that last week
15:15:06 <bnemec> I saw a bunch of patches related to this.
15:15:21 <bnemec> A bunch have already merged.
15:15:24 <moguimar> the patches I've seen so far was git: -> https:
15:15:30 <moguimar> to facilitate the change
15:15:53 <moguimar> then eventually we'll have to do OpenStack -> OpenDev
15:16:03 <bnemec> Yeah, I think that's probably necessary because the new thing doesn't support git:// addresses?
15:16:09 <moguimar> yep
15:16:21 <moguimar> that's what the commit say
15:16:31 <bnemec> So obviously we need to get all of those patches merged soon-ish.
15:16:43 <moguimar> so should we single approve them as well?
15:16:48 <bnemec> Yes, please.
15:17:03 <moguimar> 👍
15:17:12 <bnemec> #action Oslo cores to single approve git -> https patches
15:17:49 <bnemec> It looks like people already are, so I'll spare everyone the mailing list post this time around.
15:18:04 <bnemec> Anything else about this?
15:18:56 <moguimar> not for now I guess
15:19:15 <bnemec> Okay, thanks for bringing it up.
15:19:17 <bnemec> #topic Weekly Wayward Review
15:20:10 <bnemec> #link https://review.openstack.org/#/c/636998/
15:20:26 <bnemec> Not too worried about backport conflicts with that one. :-)
15:20:49 <bnemec> I skipped over a few old reviews that seemed to make non-trivial changes.
15:21:11 <bnemec> Until stein is out the door I don't want to merge anything that would make backporting a critical bug fix problematic.
15:21:38 <moguimar> +2
15:21:49 <bnemec> And since we already had a critical bug it's not just a hypothetical concern. :-)
15:22:06 <bnemec> moguimar: Thanks
15:23:58 <bnemec> #topic Open discussion
15:24:07 <bnemec> Anything else for this week?
15:24:22 <moguimar> I have a question about the weekly agenda
15:24:38 <moguimar> when can I add new items for next meeting?
15:25:39 <hberaud> is it possible to merge this one => https://review.openstack.org/618506 ?
15:26:06 <moguimar> I would be nice to have the date for next meeting in the agenda, so we know if the items already there are for the next meeting or from the last one
15:26:22 <bnemec> hberaud: Yeah, I'll revisit that one today.
15:26:28 <moguimar> so if one finds the previous date, can update it to the next week and clear the items
15:26:36 <bnemec> moguimar: Feel free to add items any time.
15:26:54 <bnemec> I _generally_ can remember what we've already discussed and just skip any leftovers.
15:26:59 <hberaud> bnemec: thanks
15:27:19 <moguimar> ok
15:27:28 <bnemec> And I never just arbitrarily clear the entire list.
15:28:00 <bnemec> So if something gets added to last week's list I'm not going to wipe it out just because the list was out of date.
15:28:40 <bnemec> Basically my policy on this is "trust the meeting chair to do the right thing". :-)
15:29:34 <bnemec> Anything else?
15:29:39 <moguimar> not on my end
15:31:03 <bnemec> Okay, thanks for joining everyone!
15:31:06 <bnemec> #endmeeting