15:01:02 <bnemec> #startmeeting oslo
15:01:03 <openstack> Meeting started Mon Apr 1 15:01:02 2019 UTC and is due to finish in 60 minutes. The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:06 <openstack> The meeting name has been set to 'oslo'
15:01:26 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dims, dougwig
15:01:26 <bnemec> courtesy ping for e0ne, electrocucaracha, garyk, gcb, haypo, hberaud, jd__
15:01:26 <bnemec> courtesy ping for johnsom, jungleboyj, kgiusti, kragniz, lhx_, moguimar, njohnston
15:01:27 <bnemec> courtesy ping for raildo, redrobot, sileht, sreshetnyak, stephenfin, stevemar, therve
15:01:27 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:28 <bnemec> To be added or removed from the ping list, please submit a patch to http://git.openstack.org/cgit/openstack/oslo.tools/tree/ping_me.py
15:01:34 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:35 <hberaud> o/
15:01:45 <jungleboyj> o/
15:02:06 <kgiusti> o/
15:02:06 <johnsom> o/
15:02:11 <redrobot> \o
15:02:14 <stephenfin> o/
15:02:43 <openstackgerrit> Dan Smith proposed openstack/oslo.tools master: Remove dansmith from ping_me.py https://review.openstack.org/649056
15:02:53 <bnemec> Just FYI, this will be my last Oslo meeting. I won the lottery and am retiring to a tropical island in the Caribbean.
15:02:54 * dansmith chuckles
15:02:59 <bnemec> (someone had to)
15:03:46 <jungleboyj> He he.
15:04:15 <njohnston> o/
15:04:20 * bnemec should have merged the unrolling patch before adding the instructions for the ping list.
15:04:22 <hberaud> tropical island... strange choice
15:04:29 <bnemec> Now they're all going to merge conflict.
15:05:02 <bnemec> hberaud: I happen to like the ocean, despite my distinctly non-oceanic current location. :-)
15:05:17 <bnemec> #topic Red flags for/from liaisons
15:05:34 <bnemec> The big thing from last week was that oslosphinx is no longer working.
15:05:34 <jungleboyj> Nothing that I am aware of from Cinder.
15:05:50 <johnsom> Nothing from Octavia
15:05:55 <bnemec> Which _shouldn't_ be a problem since that project has been retired for years, but quite a few projects are still using it.
15:05:57 <openstackgerrit> Merged openstack/oslo.tools master: Include add/remove info in ping script output https://review.openstack.org/647535
15:05:59 <openstackgerrit> Merged openstack/oslo.tools master: Unroll the ping list https://review.openstack.org/647536
15:06:00 <openstackgerrit> Merged openstack/oslo.tools master: Remove flaper87 from ping list https://review.openstack.org/647537
15:06:02 <hberaud> bnemec: I hope you'll love it
15:06:07 <bnemec> Including a couple of oslo projects, unfortunately.
15:06:58 <bnemec> stephenfin sent a message to openstack-discuss about the oslosphinx thing.
15:07:01 * bnemec finds the link
15:07:22 <bnemec> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-March/004368.html
15:07:39 <bnemec> If you have any questions about this, I recommend asking him.
15:07:50 <bnemec> I will answer what I can, but he's the docs expert.
15:07:54 <stephenfin> I need to work through the retirement process for the repo itself. I'll probably wait til the end of the week for that
15:08:10 <bnemec> stephenfin: Sounds good, thanks.
15:09:50 <bnemec> I guess the only other thing we ran into last week was that oslo.db's lower-constraints didn't work with postgresql 10.
15:10:43 <bnemec> Not sure that would affect most people, but FYI in case you're still running an older version of psycopg.
15:10:56 <bnemec> #topic Releases
15:11:16 <bnemec> We released oslo.db for stein last week.
15:11:32 <bnemec> Which is noteworthy because it was a feature release on a stable branch.
15:11:49 <bnemec> But it was needed to fix the issue I just mentioned (changing requirements forces a feature release).
15:12:13 <bnemec> Because of that problem, I've been holding off on doing any other master releases in case we happen to run into a similar situation with another library.
15:12:39 <bnemec> I'd rather not get into a situation where we released master and can't fix something in stein as a result.
15:14:33 <bnemec> Will still be holding off on releases for this week, but we'll get everything released soon since I think this is release week for Stein.
15:14:48 <bnemec> At least I assume it is since the release update email last week was R-1. :-)
15:15:00 <bnemec> #topic Action items from last meeting
15:15:20 <bnemec> "bnemec to rebase https://review.openstack.org/#/c/597612"
15:15:41 <bnemec> Done
15:15:52 <bnemec> Finally went a week without merge conflicting that one. :-)
15:16:08 <bnemec> "Oslo cores to single approve git -> https patches"
15:16:16 <bnemec> I believe that's pretty much done.
15:16:42 <bnemec> There might be a few that ran into ci failures that are still open, but I saw a lot of them merge last week.
15:16:59 <bnemec> And that was it for action items.
15:17:13 <bnemec> #topic PTG Schedule
15:17:19 <bnemec> #link https://www.openstack.org/ptg#tab_schedule
15:17:26 <bnemec> FYI for anyone who didn't see this on the list.
15:17:39 <bnemec> Oslo has a day, but split over two days.
15:17:45 <bnemec> Friday afternoon and Saturday morning.
15:18:20 <bnemec> If anyone is flying out Friday night please let me know so we can get your topics discussed in the Friday session.
15:18:33 <bnemec> I've heard a fair number of people are doing that.
15:19:37 <bnemec> #topic PTG Team Photo
15:20:07 <bnemec> We haven't actually done one of these since I've been PTL because I'm camera-shy, but if anyone wants to do a team photo let me know. :-)
15:20:47 <bnemec> We're a pretty small team so it shouldn't be too hard to get us all together at once.
15:21:07 <bnemec> That was it for the agenda this week.
15:21:08 <bnemec> #topic Weekly Wayward Review
15:21:54 <bnemec> #link https://review.openstack.org/#/c/597612/
15:22:11 <bnemec> And kgiusti already approved it so that's it for this topic. :-)
15:22:18 <kgiusti> :D
15:22:38 <hberaud> can you take a look for the workflow part on it please => https://review.openstack.org/645203
15:23:51 <bnemec> hberaud: I'll take a look after the meeting. Seems like it should be fine though.
15:24:04 <hberaud> bnemec: thanks
15:24:10 <bnemec> #topic PTG Topics
15:24:25 <bnemec> I guess I should have mentioned this earlier, but a reminder that there is an etherpad for PTG topics.
15:24:27 <bnemec> #link https://etherpad.openstack.org/p/oslo-train-topics
15:24:38 <bnemec> If you have anything to discuss face-to-face, please add it there.
15:25:04 <johnsom> Has there been any talk of adding etcd as a backend for TaskFlow? I.e. an alternative to zookeeper/redis?
15:25:38 <bnemec> johnsom: There's hasn't been a lot of taskflow talk, period. :-/
15:25:43 <johnsom> Etcd is a “base service” so it might be nice to have that as an option.
15:25:58 <bnemec> Agreed.
15:26:11 <johnsom> Ok.
15:26:15 <bnemec> Is taskflow using tooz to talk to the backend?
15:26:21 <bnemec> If so, it might already work.
15:27:22 <johnsom> I don’t think that got done.
15:27:27 <johnsom> Not sure though
15:27:36 <bnemec> Okay
15:27:38 <openstackgerrit> Stephen Finucane proposed openstack/oslosphinx master: Retire oslosphinx https://review.openstack.org/649070
15:27:44 * bnemec doesn't know much about taskflow
15:28:17 <bnemec> Last I heard, there was some talk about moving it out of openstack, but I don't think anything ever came of it.
15:28:33 <johnsom> Right, I remember that too
15:28:35 <bnemec> We had also discussed keeping it where it is, but adopting a single +2 policy since there are so few contributors.
15:29:28 <johnsom> We are looking at taking the next step and enabling jobboard, so I was curious about the state of etcd support.
15:29:43 <bnemec> For now, I would say it's in maintenance mode. We'll keep it working, but nobody is doing feature development that I'm aware of.
15:30:04 <johnsom> Yeah, that was my feeling as well.
15:30:30 <bnemec> #topic Open discussion
15:30:46 <bnemec> I guess we're kind of there already, but if anyone has topics to discuss before we close, now is the time.
15:32:14 <bnemec> #action bnemec to review https://review.openstack.org/645203
15:32:51 <bnemec> Alright, looks like we're done.
15:32:55 <bnemec> Thanks for joining everyone!
15:32:58 <bnemec> #endmeeting