15:02:08 <bnemec> #startmeeting oslo
15:02:09 <openstack> Meeting started Mon Apr 15 15:02:08 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:12 <openstack> The meeting name has been set to 'oslo'
15:02:29 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dims, dougwig
15:02:29 <bnemec> courtesy ping for e0ne, electrocucaracha, garyk, gcb, haypo, hberaud, jd__
15:02:29 <bnemec> courtesy ping for johnsom, jungleboyj, kgiusti, kragniz, lhx_, moguimar, njohnston
15:02:29 <bnemec> courtesy ping for raildo, redrobot, sileht, sreshetnyak, stephenfin, stevemar, therve
15:02:31 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:02:33 <bnemec> To be added or removed from the ping list, please submit a patch to http://git.openstack.org/cgit/openstack/oslo.tools/tree/ping_me.py
15:02:36 <johnsom> o/
15:02:37 <dansmith> now wait a damn second
15:02:37 <e0ne> hi
15:02:37 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:37 <hberaud> o/
15:02:55 <dansmith> bnemec: I removed myself from said list :)
15:02:55 <bnemec> dansmith: Sorry, forgot to pull. :-(
15:02:58 <dansmith> hah, okay
15:03:00 <jungleboyj> o/
15:03:08 <bnemec> Won't happen again. :-)
15:03:13 <ansmith> o/
15:03:56 <kgiusti> o/
15:04:32 <bnemec> #topic Red flags for/from liaisons
15:04:45 <bnemec> I just got back from PTO so I have no idea what's going on.
15:04:52 <bnemec> I guess that's a red flag. ;-)
15:04:55 <johnsom> I have made a number of patches to sphinx-feature-classification as Octavia  is going to start using it.
15:05:04 <johnsom> #link https://review.openstack.org/#/q/project:openstack/sphinx-feature-classification+owner:%22Michael+Johnson+%253Cjohnsomor%2540gmail.com%253E%22
15:05:30 * jungleboyj is in the same boat as bnemec
15:05:43 <johnsom> These have an initial +2, we would love to see those merged and hopefully a release soon-ish as we are going to be using it heavily soon.
15:06:47 <bnemec> johnsom: Cool, at a glance they look pretty simple so hopefully we can get them in quickly.
15:06:56 <johnsom> +1
15:07:35 <johnsom> Eric posted a cinder patch to test, it is linked in one of the patch comments.
15:07:41 <bnemec> We haven't released anything for a couple of weeks so I guess I wouldn't expect a lot of red flags.
15:07:52 <bnemec> Sounds good, thanks.
15:08:16 <johnsom> Otherwise I have no other red flags to report this week.
15:08:47 <bnemec> #topic Releases
15:09:09 <bnemec> As noted, we haven't been doing releases in the interest of keeping things quiet during the end-of-release time period.
15:09:34 <bnemec> Now that Train is out of the station we'll get back to our regular weekly schedule.
15:10:15 <bnemec> I'll try to get to that today, but no promises.
15:10:41 <bnemec> #topic Action items from last meeting
15:11:02 <bnemec> "bnemec to review https://review.openstack.org/645203"
15:11:46 <bnemec> Oops, I didn't do that. Fortunately Zane and Ken did.
15:11:49 <bnemec> Thanks guys!
15:12:08 <kgiusti> welcome back :D
15:12:36 <hberaud> :)
15:12:38 <bnemec> Thanks. :-)
15:12:50 <bnemec> That was the only action item.
15:12:58 <bnemec> #topic Project Update
15:13:21 <bnemec> We're doing the usual project update session in Denver.
15:13:27 <bnemec> #link https://www.openstack.org/summit/denver-2019/summit-schedule/events/23720/oslo-project-update
15:13:48 <bnemec> Looks like it's Wednesday at 11:40 AM.
15:14:20 <bnemec> If you have things you want covered in that talk, please add them to the appropriate section of https://etherpad.openstack.org/p/oslo-train-topics
15:14:49 <bnemec> The first topic is the project update list. I have it split into completed and future items.
15:15:57 <bnemec> I'll probably be putting together the presentation later this week or early next week, so don't dawdle if you want to add anything.
15:16:25 <bnemec> Doesn't need to have a ton of detail, that's obviously not going to be the final content of the presentation. It's just notes so I don't miss anything.
15:17:07 <bnemec> #topic PTG Schedule
15:17:13 <bnemec> #link https://www.openstack.org/ptg#tab_schedule
15:17:30 <bnemec> Another reminder too of the Oslo schedule for the PTG.
15:17:49 <bnemec> Friday afternoon into Saturday morning.
15:18:29 <bnemec> If you're leaving Friday night and have something to discuss, make sure I know that so we can put it early on the schedule.
15:19:10 <bnemec> I would imagine we'll get through everything Friday afternoon, but if anything does bleed over into Saturday we need everyone to be present to make any progress. :-)
15:19:58 <bnemec> #topic Weekly Wayward Review
15:20:54 <bnemec> #link https://review.openstack.org/#/c/633053/
15:21:30 <bnemec> Should be a noop functionally, just an optimization.
15:22:11 <bnemec> Albeit an optimization to concurrent code, which is always a bit tricky.
15:22:56 <bnemec> However, thanks to all the bugs we had in this code recently we have pretty solid test coverage of it. :-)
15:25:43 <bnemec> stephenfin: You had looked at https://review.openstack.org/#/c/633053/ previously. Could you revisit it when you get a chance?
15:25:54 <stephenfin> I can
15:26:04 <stephenfin> (Though not today, I'm afraid :()
15:27:03 <bnemec> Good enough for me.
15:27:15 <bnemec> #action stephenfin (or any other core) to review https://review.openstack.org/#/c/633053/
15:27:23 <bnemec> #topic Open discussion
15:27:29 <bnemec> Anything else this week?
15:30:06 <bnemec> Alright, enjoy your 30 minutes back.
15:30:10 <bnemec> Thanks for joining everyone!
15:30:13 <bnemec> #endmeeting