15:01:46 <bnemec> #startmeeting oslo
15:01:47 <openstack> Meeting started Mon Apr 22 15:01:46 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:50 <openstack> The meeting name has been set to 'oslo'
15:02:09 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dims, dougwig, e0ne
15:02:09 <bnemec> courtesy ping for electrocucaracha, garyk, gcb, haypo, hberaud, jd__, johnsom
15:02:09 <bnemec> courtesy ping for jungleboyj, kgiusti, kragniz, lhx_, moguimar, njohnston, raildo
15:02:09 <bnemec> courtesy ping for redrobot, sileht, sreshetnyak, stephenfin, stevemar, therve, thinrichs
15:02:09 <bnemec> courtesy ping for toabctl, zhiyan, zxy, zzzeek
15:02:11 <bnemec> To be added or removed from the ping list, please submit a patch to http://git.openstack.org/cgit/openstack/oslo.tools/tree/ping_me.py
15:02:12 <openstackgerrit> Merged openstack/oslo.log master: Added cmdline information into fluentFormatter event message  https://review.opendev.org/648393
15:02:21 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:27 <kgiusti> o/
15:02:29 <jungleboyj> O/
15:02:45 <johnsom> o/
15:02:45 <njohnston> o/
15:04:24 <bnemec> #topic Red flags for/from liaisons
15:04:51 <jungleboyj> Nothing from Cinder.
15:04:58 <johnsom> No red flags.
15:05:01 <ansmith_> o/
15:05:02 <bnemec> Nothing much on our side. I never did do releases last week so there shouldn't be much new going on.
15:05:31 <bnemec> I guess the one exception would be the issue Nova is investigating, but it's not clear what caused the breakage.
15:05:37 <bnemec> #link https://bugs.launchpad.net/nova/+bug/1825435
15:05:38 <openstack> Launchpad bug 1825435 in OpenStack Compute (nova) "TestRPC unit tests intermittently fail with "'>' not supported between instances of 'NoneType' and 'datetime.datetime'" - maybe due to "Fatal Python error: Cannot recover from stack overflow."" [High,Confirmed]
15:06:07 <bnemec> It doesn't appear to be an Oslo problem, but investigation is ongoing.
15:06:28 <bnemec> If you're seeing stack overflows when looking up oslo.config values then you may be hitting that too.
15:07:04 <bnemec> #topic Releases
15:07:24 <bnemec> I will go do them right away after the meeting.
15:07:32 <bnemec> They didn't get done last week because reasons. :-)
15:07:58 <johnsom> +1
15:08:38 <bnemec> #topic Action items from last meeting
15:08:45 <bnemec> "stephenfin (or any other core) to review https://review.openstack.org/#/c/633053/"
15:08:51 <bnemec> Done. Thanks, Stephen.
15:09:00 <bnemec> And that was it.
15:09:34 <bnemec> #topic Project Update
15:09:55 <bnemec> I started working on the slides last week. If you have anything you want covered let me know ASAP.
15:10:28 <bnemec> You can find a list of topics that I've included already at https://etherpad.openstack.org/p/oslo-train-topics
15:11:13 <bnemec> That's also the place to add any PTG topics you want discussed. I'll be trying to come up with a tentative schedule this week.
15:11:35 <bnemec> I expect it will change once we start actually having discussions, but it will be a place to start.
15:13:26 <bnemec> #topic Weekly Wayward Review
15:13:29 <bnemec> #link https://review.opendev.org/#/c/638248/
15:14:36 <kgiusti> bnemec's home for wayward reviews!
15:15:22 <bnemec> Much like every parent with a 25 year old still living at home, my goal is for them to move out as soon as possible. ;-)
15:15:41 <kgiusti> :D
15:15:46 <bnemec> Unfortunately I'm not sure we have any other cores in the meeting this week. :-/
15:16:09 <ansmith_> bnemec: I  will take a look ^^
15:16:35 <bnemec> Oh, hey ansmith_ :-)
15:16:53 <bnemec> I only looked for o/'s above the first topic. :-)
15:17:09 <bnemec> #action ansmith_ to review https://review.opendev.org/#/c/638248
15:17:33 <bnemec> Thanks
15:17:35 <bnemec> #topic Open discussion
15:17:47 <bnemec> Anything else?
15:17:55 <johnsom> In oslo.messaging, why can't we requeue when using the RPCServer? It appears to auto-ack always.
15:18:31 <kgiusti> johnsom: yeah the re-queue api only applies to notifications
15:19:08 <kgiusti> johnsom: I supposed nobody has asked for that for rpc (until now :)
15:19:16 <johnsom> That is what I saw as well. I was just wondering why we don't have the same option with the RPCs.
15:19:45 <kgiusti> johnsom: pre-dates my knowledgebase... anyone else?
15:20:46 <bnemec> No idea. I suspect that pre-dates anyone who is still working on oslo.messaging.
15:21:16 <bnemec> We could take a look at the git blame for the code and see if there's anything in the commit message about it being applicable only to notifications.
15:21:25 <johnsom> Ok, if there isn't a reason it might be something I will be looking into. I think we can use that functionality on Octavia. Can't commit that I'm going to do it yet however.
15:22:12 <bnemec> Sounds good.
15:22:13 <kgiusti> johnsom: let me know if you need any help
15:22:32 <kgiusti> and speaking of messaging: http://lists.openstack.org/pipermail/openstack-discuss/2019-April/005305.html
15:22:33 <bnemec> It's entirely possible this is one of those things where someone scratched their itch and didn't care if it worked for notifications.
15:22:35 <johnsom> kgiusti Thanks
15:23:39 <kgiusti> TL;DR some folks are experiencing weird connection failures to rabbitmq
15:23:42 <bnemec> Oh, eventlet.
15:23:59 <kgiusti> bingo!
15:24:05 <bnemec> Right? That was the thread where eventlet wasn't playing nicesly with WSGI.
15:24:08 <bnemec> *nicely
15:24:42 <bnemec> I wonder if we should add that to the eventlet best practices doc.
15:24:49 <bnemec> "Don't mix eventlet and WSGI"
15:25:01 <bnemec> It's basically combining multiple concurrency mechanisms.
15:25:08 <kgiusti> yep - michele is investigating reports in mistral and perhaps ironic...
15:25:21 <bnemec> Which I realize doesn't solve the immediate problem(s).
15:25:45 <bnemec> I'm surprised no one ran into this before. I think Nova was doing this back in Rocky too.
15:26:22 <kgiusti> I'll keep an eye on it.
15:26:54 <bnemec> Cool. If there's anything I can do to help let me know.
15:27:00 <ansmith_> johnsom, kgiusti: regarding re-queue, i believe difference is that with rpc, message is ack'ed prior to dispatch where with notify, message ack follows dispatch
15:27:21 <bnemec> It sounded like Michele was investigating so I decided to leave it in his capable hands. :-)
15:27:40 <kgiusti> Indeed
15:28:19 <bnemec> So I guess that's another red flag.
15:28:24 <kgiusti> ansmith_: good point - ack on rcv.... never liked that
15:28:24 * bnemec blames the long weekend
15:28:36 <johnsom> ansmith_ Not sure I follow (not that familiar with the oslo messaging code yet).
15:28:49 <johnsom> This is the offending code I think: https://github.com/openstack/oslo.messaging/blob/master/oslo_messaging/rpc/server.py#L159
15:28:56 <johnsom> #link https://github.com/openstack/oslo.messaging/blob/master/oslo_messaging/rpc/server.py#L159
15:29:18 <kgiusti> johnsom: that's it.
15:30:02 <bnemec> Interesting that the TODO says we should remove that...
15:30:18 <johnsom> It seems like the endpoint should be able to return requeue like in notifications.
15:30:59 <kgiusti> johnsom: the return value from the rpc handler is application data which is sent back in the reply
15:31:51 <bnemec> Okay, let's continue this discussion, but I'm going to end the meeting if no one else has anything that needs attention.
15:31:53 <kgiusti> johnsom: the client rpc api is essentially a function call.   We'd need to add a new behavior - perhaps have the handler throw a new type of exception
15:31:55 <johnsom> We aren't sending data back, but yes, that could complicate things
15:32:08 <bnemec> Oh, and there will be no meeting next week due to Summit/PTG.
15:32:22 <bnemec> #action bnemec to send email about meeting cancellation.
15:32:50 <bnemec> I may cancel the meeting after too since it will be the first day back.
15:34:33 <bnemec> Okay, I think that's it.
15:34:52 <bnemec> Thanks for joining everyone! See some of you next week.
15:34:56 <bnemec> #endmeeting