15:01:02 <bnemec> #startmeeting oslo
15:01:02 <openstack> Meeting started Mon May 20 15:01:02 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:05 <openstack> The meeting name has been set to 'oslo'
15:01:24 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dims, dougwig, e0ne
15:01:24 <bnemec> courtesy ping for electrocucaracha, garyk, gcb, haypo, hberaud, jd__, johnsom
15:01:24 <bnemec> courtesy ping for jungleboyj, kgiusti, kragniz, lhx_, moguimar, njohnston, raildo
15:01:24 <bnemec> courtesy ping for redrobot, sileht, sreshetnyak, stephenfin, stevemar, therve, thinrichs
15:01:24 <bnemec> courtesy ping for toabctl, zhiyan, zxy, zzzeek
15:01:34 <hberaud> o/
15:01:39 <jungleboyj> Yay Courtesy ping.
15:01:45 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:53 <stephenfin> o/
15:01:55 <jungleboyj> Though this now conflicts with the Ironic meeting that I am also supposed to be in.
15:02:05 <bnemec> :-(
15:02:49 <jungleboyj> :-)
15:02:55 <jungleboyj> I am just too popular.  ;-)
15:03:00 <ansmith> o/
15:03:05 <kgiusti> o/
15:03:17 <bnemec> jungleboyj: There are worse problems to have. :-)
15:03:28 <jungleboyj> Indeed.
15:03:46 <bnemec> #topic Red flags for/from liaisons
15:03:58 <jungleboyj> Nothing from Cinder.
15:04:18 <moguimar> o/
15:04:49 <moguimar> nothing from Barbican
15:05:08 <bnemec> Oslo spent most of last week dealing with the fallout of bandit/sphinx, so we didn't have much opportunity to break things (more). :-)
15:06:14 <bnemec> That's probably it for this topic based on the attendees.
15:06:16 <bnemec> #topic Releases
15:06:42 <jungleboyj> :-)
15:06:44 <bnemec> I didn't end up doing master releases last week because I was waiting on a Stein release that needed to bump the minor version.
15:07:06 <bnemec> That merged now, so I'll get the master release change updated with anything new.
15:07:58 <bnemec> There was a one-off release of oslo.serialization to deal with something that broke in PyYAML 5.1.
15:09:03 <bnemec> On a release-related note, I let the releases team know that hberaud is now our release liaison, so if there are releases needed and I'm not available he's your man.
15:09:07 <hberaud> I'll take a look
15:09:30 <hberaud> (on the pyyaml stuff)
15:09:57 <bnemec> hberaud: It's fixed. I just released it separately because it was blocking packaging of the library for Train.
15:10:05 <hberaud> oh ok
15:10:25 <bnemec> #link https://review.opendev.org/#/c/656813/
15:10:49 <bnemec> I think that's it for releases.
15:10:51 <bnemec> #topic Action items from last meeting
15:11:08 <bnemec> "bnemec to contact release team about new Oslo liaison"
15:11:09 <bnemec> Done
15:11:16 <bnemec> "bnemec to send email to list about courtesy pings"
15:11:22 <bnemec> Done, and we'll discuss that in a moment.
15:11:28 <jungleboyj> He he he.
15:11:31 <bnemec> "push cap, uncap patches to projects blocked by bandit"
15:11:42 <bnemec> Done, huge thanks to everyone who helped out!
15:11:54 <bnemec> "bnemec to send email about bandit plans"
15:11:56 <bnemec> Done
15:12:05 <bnemec> "bnemec and hberaud to sort out sphinx requirements"
15:12:06 <bnemec> Done
15:12:16 <bnemec> "hberaud to investigate pbr unit test flakiness"
15:12:26 <bnemec> I think this is still WIP.
15:12:37 <bnemec> There's actually a new problem with the pbr tests that I hadn't noticed yet last week.
15:12:57 <bnemec> The pbr-installation-devstack jobs are failing consistently now. We'll need to fix that before we can unblock pbr.
15:13:02 <hberaud> yeah, have you seen my latest comments about? https://review.opendev.org/659546
15:13:06 <bnemec> So that's actually a higher priority than the flaky unit tests.
15:13:18 <bnemec> hberaud: No, I hadn't.
15:13:45 <bnemec> Ah, fun.
15:14:06 <bnemec> hberaud: So do we need to make sure everyone has their networkx dependency updated then?
15:14:44 <hberaud> https://review.opendev.org/#/q/status:open+topic:cap-networkx
15:14:57 <hberaud> I've sent a bunch of fix for networkx
15:15:35 <hberaud> but the project in error in pbr devstack seem to ok with networkx...
15:16:10 <gsantomaggio> I hope to work on this https://review.opendev.org/#/c/659078/ this week( if I won't have other problems ), I'd like to have the feature for the next release
15:16:14 <bnemec> Okay, thanks for looking into it.
15:16:25 <bnemec> We'll keep plugging away to unblock pbr.
15:16:34 <bnemec> To wrap up this topic:
15:16:34 <bnemec> "hberaud to review https://review.opendev.org/#/c/618569/"
15:16:39 <bnemec> Done, thanks.
15:18:03 <bnemec> gsantomaggio: Okay, I see kgiusti has been looking at that too. I'm sure we can get it ready soon.
15:18:17 <bnemec> #topic Courtesy pings
15:18:33 <moguimar> love them
15:18:45 <bnemec> So there was definite resistance to getting rid of these completely.
15:19:21 <bnemec> We had a discussion about this in the Cinder meeting last week too, and I think we came up with a plan that should be acceptable.
15:19:40 <jungleboyj> moguimar:  ++
15:19:52 <bnemec> My current thought is that we clear the ping list at the start of each cycle and require everyone to re-subscribe.
15:20:09 <jungleboyj> bnemec:  ++
15:20:11 <bnemec> That way nobody ends up getting pinged just because they hadn't remembered to remove their name.
15:20:23 <jungleboyj> Opt-In
15:20:32 <bnemec> I'm also thinking I may do away with the oslo.tools ping script and just move the list to the meeting agenda directly.
15:20:41 <moguimar> maybe save those who 'o/' last meeting
15:20:53 <bnemec> We really don't need Oslo core approval for someone to add or remove themselves from the list.
15:21:22 <moguimar> that's true
15:21:27 <moguimar> ++ to the agenda
15:21:28 <bnemec> moguimar: One of the basic tenets of the ping list was that it needs to be explicitly opt-in though.
15:21:48 <bnemec> I don't want to add anyone who didn't specifically ask for it.
15:22:00 <moguimar> I see
15:22:07 <bnemec> Maybe with the exception of the active Oslo cores. I'm probably going to seed the list with all of you. :-)
15:22:24 <bnemec> Although maybe not. I'll have to think about that some more.
15:22:35 <moguimar> I couldn't be more happy about that
15:23:06 <jungleboyj> bnemec:  I think that approach is good.  I know I will never remember this meeting on a Monday morning otherwise.
15:23:09 <moguimar> or maybe I could xD
15:23:18 <bnemec> In the meantime, I'll continue to use the existing ping list for the next week or two so people have a chance to get subscribed to the agenda list.
15:23:36 <moguimar> ok
15:23:36 <bnemec> And I'll send an email to the list to let everyone know about our plan.
15:23:48 <bnemec> It'll probably be a new thread so it doesn't get lost in the existing discussion.
15:24:02 <bnemec> #action bnemec to email openstack-discuss about ping list
15:24:56 <bnemec> For context, the existing discussion is here:
15:24:56 <bnemec> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006235.html
15:25:02 <jungleboyj> Sounds like a good plan.
15:25:15 <gsantomaggio> for who is interested I am publishing a set of commands I usually use to filter/sort data in RMQ using command line:
15:25:15 <gsantomaggio> https://github.com/Gsantomaggio/rabbitmq-utils/blob/master/command_line_tools/command_line_tools
15:25:56 <bnemec> Okay, keep an eye out for that email and respond if there's anything that concerns you.
15:25:58 <kgiusti> +1 - indeed helpful
15:26:34 <bnemec> gsantomaggio: Cool, thanks. Maybe we should include a link to that from the oslo.messaging docs somewhere?
15:27:03 <bnemec> Okay, next topic...
15:27:06 <bnemec> #topic Bandit cap
15:27:11 <gsantomaggio> I will
15:27:24 <bnemec> gsantomaggio: Sounds good, thanks.
15:27:41 <bnemec> So last week we agreed to push a two patch series to each repo, one to cap bandit, and one to uncap.
15:27:57 <bnemec> However, it was pointed out that usually we leave linters capped so new releases don't break us.
15:28:10 <bnemec> When we want a newer version of the linter we just bump the cap appropriately and fix any new issues.
15:28:28 <bnemec> Which raises the question of whether we even want to keep the uncap patches.
15:29:03 <bnemec> I'm kind of leaning toward no, myself.
15:29:19 <bnemec> I'm not sure why we didn't cap bandit in the first place, but I suspect it was an oversight.
15:29:31 <bnemec> But if anyone has more context on that I'd love to hear it.
15:31:20 <bnemec> Unless someone objects, I'm going to propose that we abandon the uncap patches and just leave bandit capped for the time being.
15:31:45 <hberaud> +1
15:31:50 <bnemec> Once again, I'll email the list before doing anything.
15:32:02 <bnemec> #action bnemec to email list about abandoning bandit uncap patches
15:32:38 <bnemec> That's it for topics.
15:32:41 <bnemec> #topic Weekly Wayward Review
15:33:17 <bnemec> #link https://review.opendev.org/#/c/647492/
15:33:51 <bnemec> I'm not sure I fully understand what's going on there, but based on my googling it seems like this is a good fix for the problem.
15:34:10 <bnemec> I realize we can't merge pbr patches right now, but it would be nice to get a second +2 on it so it's ready to go when ci is unblocked.
15:35:10 <moguimar> what about that single company approval thread?
15:35:16 <bnemec> The good news is it's a simple patch too.
15:35:58 <moguimar> and how many cores per company do we have right now?
15:35:59 <bnemec> moguimar: It's not really relevant to us. We have exactly one active core who's not from Red Hat right now.
15:36:28 <bnemec> And he's only around to periodically clear out the needs approval list, AFAICT.
15:36:45 <bnemec> Basically we don't have enough company diversity to have a meaningful policy on this.
15:36:56 <moguimar> ack
15:37:21 <bnemec> Which is pretty much what I said in http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006054.html :-)
15:37:48 <bnemec> Do we have anyone who can take a look at https://review.opendev.org/#/c/647492/ ?
15:38:25 <bnemec> If it helps, maybe I can provide a link to the discussion of the problem that I was looking at.
15:40:01 <moguimar> +2
15:40:20 <bnemec> moguimar: Awesome, thanks!
15:40:53 <bnemec> hberaud: Feel free to approve that once pbr ci is working again.
15:41:01 <bnemec> If someone else doesn't get to it first, of course.
15:41:07 <bnemec> #topic Open discussion
15:41:09 <hberaud> bnemec: ack
15:41:12 <moguimar> I got a poster approved for EuroPython on Oslo.Config, Castellan and HashiCorp Vault. So I'm feeling positive about finding some time to fix/polish the docs and examples.
15:41:13 <bnemec> Anything else this week?
15:41:24 <bnemec> moguimar: Nice
15:41:43 <moguimar> a talk on the same topic in in the waiting list
15:41:51 <bnemec> Definitely good to socialize that feature since people have been asking about it for so long.
15:41:56 <moguimar> quite hard to get a slot for EuroPython
15:42:02 <moguimar> as a talk
15:42:15 <bnemec> I imagine.
15:42:44 <bnemec> moguimar: You had assigned yourself the bug about the docs for the driver being in a private module, right?
15:42:47 <moguimar> internal jokes say that it was because I couldn't attend to it in 2017 and had to cancel my talk xD
15:43:16 <moguimar> I think I have it in my plate
15:43:17 <bnemec> I'm sure that happens semi-regularly, which is why they have a waiting list.
15:43:33 <bnemec> Okay, cool.
15:44:04 <bnemec> Other topics before I give you 15 minutes back?
15:44:11 <moguimar> not on my end
15:46:18 <bnemec> Okay, good meeting. Thanks everyone!
15:46:20 <bnemec> #endmeeting