15:00:51 <bnemec> #startmeeting oslo
15:00:52 <openstack> Meeting started Mon Jun  3 15:00:51 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:55 <openstack> The meeting name has been set to 'oslo'
15:01:54 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dims, dougwig, e0ne
15:01:54 <bnemec> courtesy ping for electrocucaracha, garyk, gcb, haypo, hberaud, jd__, johnsom
15:01:54 <bnemec> courtesy ping for jungleboyj, kgiusti, kragniz, lhx_, moguimar, njohnston, raildo
15:01:54 <bnemec> courtesy ping for redrobot, sileht, sreshetnyak, stephenfin, stevemar, therve, thinrichs
15:01:55 <bnemec> courtesy ping for toabctl, zhiyan, zxy, zzzeek
15:01:57 <bnemec> If you want to continue receiving courtesy pings, please see http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006431.html
15:02:04 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:10 <redrobot> \o
15:02:16 <johnsom> o/
15:02:25 <bnemec> I will continue to use the existing ping list next week, but after that we'll be switching to the list in the agenda.
15:02:27 <moguimar> hey
15:02:28 <jungleboyj> Multi-tasking.
15:02:29 <jungleboyj> o/
15:02:35 <moguimar> On a training today
15:02:44 <bnemec> moguimar: Ack
15:02:45 <moguimar> any hot topic for me?
15:02:57 <moguimar> otherwise I'll read the logs tomorrow
15:03:21 <bnemec> moguimar: Nothing specific. I see you're already in the new ping list so that's probably the main thing.
15:03:29 <moguimar> redrobot can take the Barbican Liaison hat
15:03:31 * redrobot looks for ping list in Agenda
15:03:40 <kgiusti> o/
15:03:49 <redrobot> moguimar, 👍
15:04:18 * redrobot doesn't find ping list in agenda, only https://github.com/openstack/oslo.tools/blob/master/ping_me.py
15:04:43 <bnemec> redrobot: https://wiki.openstack.org/wiki/Meetings/Oslo under Agenda Template
15:05:11 <redrobot> bnemec, ack, thanks! :D
15:05:45 <bnemec> #topic Red flags for/from liaisons
15:05:57 <bnemec> I guess the new ping list is the primary thing.
15:06:05 <johnsom> Nothing here
15:06:12 <jungleboyj> Nothing from Cinder.
15:06:35 <bnemec> #action liaisons who want to continue receiving courtesy pings need to update the ping list on the meeting agenda wiki page
15:07:06 <redrobot> No red flags from Barbican.
15:07:07 <bnemec> I linked this earlier, but if you want more discussion of why/what we're doing, see http://lists.openstack.org/pipermail/openstack-discuss/2019-May/006431.html
15:08:25 <bnemec> redrobot: Thanks for updating the wiki page. I completely missed that the ping script was still there.
15:08:38 <redrobot> bnemec, 👍
15:09:09 <bnemec> Doesn't sound like there's anything pressing in terms of red flags.
15:09:15 <bnemec> #topic Releases
15:09:54 <bnemec> Got master and queens released last week. A little late, but everything's out there now.
15:10:22 <bnemec> I'll look at what needs to be released again this week, as usual.
15:11:22 <bnemec> Don't think I have anything else on releases.
15:11:23 <bnemec> #topic Action items from last meeting
15:11:33 <bnemec> "bnemec to email openstack-discuss about ping list"
15:11:35 <bnemec> Done
15:11:42 <bnemec> "bnemec to email list about abandoning bandit uncap patches"
15:11:43 <bnemec> Done
15:11:54 <bnemec> And that was it.
15:12:27 <bnemec> We already talked about courtesy pings, so I'll move on to the next topic.
15:12:32 <bnemec> #topic Bandit cap
15:12:50 <bnemec> We got this taken care of on master, but I've seen a few backports going in.
15:13:13 <bnemec> We probably need to get all of these backported to all of the affected branches, unfortunately. :-/
15:13:56 <bnemec> Alternatively we can just do the backports on-demand as we find backports that are blocked.
15:14:24 <bnemec> That saves us work up front, but it does mean that backports in oslo libs are likely to be a two step process in a lot of cases, which is not great.
15:15:55 <bnemec> If anyone has thoughts about this please let me know.
15:17:25 <bnemec> I guess may be we can just backport the patches listed in https://ethercalc.openstack.org/ml1qj9xrnyfg
15:18:33 <bnemec> Unless someone objects, I propose that we backport those patches back to queens.
15:18:44 <bnemec> Let's not do the em branches for now.
15:19:04 <bnemec> If someone wants to merge something there they can do the backport themselves.
15:19:20 <bnemec> #action backport bandit cap patches
15:19:35 <bnemec> I'll also send a followup email about this.
15:19:44 <bnemec> #action bnemec send email about backporting bandit caps
15:20:40 <bnemec> That was the only other topic I wanted to discuss this week.
15:20:44 <bnemec> #topic Weekly Wayward Review
15:21:39 <bnemec> #link https://review.opendev.org/#/c/647904/
15:21:56 <bnemec> This is my config validator patch to allow users to ignore certain groups.
15:22:19 <bnemec> This is to allow the tool to be used with projects that have dynamic groups, where the group name may not match what is in the sample config data.
15:22:42 <bnemec> Pretty simple change.
15:23:02 <bnemec> Has a +1 from hberaud|gone before he was core, so we can consider that a +2 now.
15:23:21 <bnemec> I'm not sure we have any other Oslo cores here today though. :-/
15:25:16 <bnemec> I guess I'll just action the Oslo cores on this.
15:25:26 <bnemec> #action Oslo cores to review https://review.opendev.org/#/c/647904/
15:25:37 <kgiusti> bnemec: shouldn't that be "99.99%"?   Just sayin' :)
15:25:39 <bnemec> Let's see if any of them read the meeting minutes. ;-)
15:26:02 <bnemec> kgiusti: Like I said, citation needed. :-P
15:27:21 <bnemec> #topic Open discussion
15:27:25 <bnemec> Anything else this week?
15:30:11 <bnemec> Doesn't look like it. Thanks for joining everyone!
15:30:12 <bnemec> #endmeeting