15:01:10 <bnemec> #startmeeting oslo
15:01:11 <openstack> Meeting started Mon Jun 10 15:01:10 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:15 <openstack> The meeting name has been set to 'oslo'
15:01:21 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dims, dougwig, e0ne
15:01:21 <bnemec> courtesy ping for electrocucaracha, garyk, gcb, haypo, hberaud, jd__, johnsom
15:01:21 <bnemec> courtesy ping for jungleboyj, kgiusti, kragniz, lhx_, moguimar, njohnston, raildo
15:01:21 <bnemec> courtesy ping for redrobot, sileht, sreshetnyak, stephenfin, stevemar, therve, thinrichs
15:01:23 <bnemec> courtesy ping for toabctl, zhiyan, zxy, zzzeek
15:01:36 <johnsom> o/
15:01:36 <bnemec> REMINDER: This is the final week the old ping list will be used.
15:01:42 <moguimar> o/
15:01:50 <kgiusti> o/
15:01:51 <ansmith_> o/
15:01:54 <bnemec> If you want to continue receiving courtesy pings, please add yourself to the list in the agenda template.
15:01:58 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:00 <redrobot> \o
15:03:36 <bnemec> #topic Red flags for/from liaisons
15:03:46 <johnsom> Nothing from Octavia
15:03:58 <jungleboyj> Nothing from Cinder.
15:04:15 <bnemec> I don't think we have anything to bring up from the Oslo side.
15:04:24 <bnemec> I spent most of last week unblocking pbr ci, but that shouldn't affect anyone else.
15:04:42 <bnemec> Unless it allows us to merge a broken pbr patch, I guess. ;-)
15:06:10 <bnemec> Okay, sounds like that's it for this topic.
15:06:13 <bnemec> #topic Releases
15:06:38 <bnemec> tooz is proposed for release to allow the uncapping of grpcio in g-r.
15:06:52 <bnemec> I may hold off on doing the other weekly releases until we can get some of the pbr fixes merged.
15:07:28 <bnemec> Hopefully that will happen more quickly now. If not, I'll go ahead with the releases anyway.
15:08:05 <bnemec> I don't have anything else about releases, so...
15:08:07 <bnemec> #topic Action items from last meeting
15:08:35 <bnemec> "liaisons who want to continue receiving courtesy pings need to update the ping list on the meeting agenda wiki page"
15:08:49 <bnemec> This is an ongoing one, but we'll call it done.
15:08:56 <bnemec> "backport bandit cap patches"
15:09:07 <bnemec> Not done, but this is a topic for later.
15:09:15 <bnemec> "bnemec send email about backporting bandit caps"
15:09:19 <bnemec> That part was done.
15:09:26 <bnemec> "Oslo cores to review https://review.opendev.org/#/c/647904/"
15:09:41 <bnemec> Done, thanks
15:10:04 <bnemec> And that's it for action items.
15:10:12 <bnemec> #topic Courtesy pings
15:10:35 <bnemec> As I mentioned earlier, this is the final reminder to add yourself to the ping list in the agenda if you want to keep receiving courtesy pings.
15:10:49 <bnemec> After this week I will no longer be using the oslo.tools ping list.
15:11:04 <bnemec> #action liaisons who want to continue receiving courtesy pings need to update the ping list on the meeting agenda wiki page
15:11:23 * stephenfin lurks
15:11:45 <bnemec> At this point hopefully nothing else needs to be said on this topic. If you have questions let me know and I can direct you to the previous discussions.
15:12:26 <bnemec> #topic Bandit cap on stable branches
15:12:54 <bnemec> I brought this up last week and there was some discussion on the mailing list since then.
15:13:41 <bnemec> Given that it would be a lot of patches to backport and we don't tend to have a lot of backport activity, I'm kind of inclined to just wait until bandit releases 1.6.1.
15:14:14 <bnemec> I realize that leaves us open to future breakages on the stable branches, but we've gotten away with it for this long.
15:14:44 <moguimar> I've seen somewhere else
15:14:47 <bnemec> Of course we can always do spot backports if we find that we need to.
15:14:58 <moguimar> versions pinned and bots submitting update patches
15:15:07 <moguimar> when new versions are out
15:15:45 <bnemec> moguimar: That sounds like global-requirements and its upper-constraints file.
15:16:07 <bnemec> Unfortunately linters aren't covered by that because projects are expected to move forward with linter versions as they're ready.
15:16:31 <bnemec> We don't want to force a big bang update to a new version of a linter that will block a lot of projects.
15:17:09 <bnemec> And to be clear, I'm not looking to block backporting of bandit caps. I'm just saying that I'm not going to spend the time to do them.
15:18:23 <bnemec> So if anyone wants to take that on, the columns exist in https://ethercalc.openstack.org/ml1qj9xrnyfg to track the patches.
15:19:37 <bnemec> Okay, that was it for topics this week.
15:19:39 <bnemec> #topic Weekly Wayward Review
15:20:26 <bnemec> #link https://review.opendev.org/#/c/642932/
15:20:49 <bnemec> It's been over a month since my last comment on that review, so I think I'm just going to mark it WIP until I get an answer.
15:21:03 <bnemec> I'd rather avoid adding any new features to rootwrap if we can help it.
15:22:46 <bnemec> Okay, that's done.
15:22:50 <bnemec> #topic Open discussion
15:23:01 <bnemec> Anything else this week?
15:23:16 <moguimar> Who is going to EuroPython?
15:23:39 * bnemec is not
15:24:09 <moguimar> I'll have a poster on oslo.config + castellan + vault
15:25:12 <bnemec> Cool!
15:29:02 <bnemec> Looks like that's it for this week.
15:29:10 <bnemec> Thanks for joining, everyone!
15:29:13 <bnemec> #endmeeting