15:00:27 <bnemec> #startmeeting oslo
15:00:29 <openstack> Meeting started Mon Jun 17 15:00:27 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:32 <openstack> The meeting name has been set to 'oslo'
15:00:34 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, kgiusti, redrobot, stephenfin, johnsom
15:00:34 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:43 <hberaud> o/
15:00:47 <johnsom> o/
15:00:50 <jungleboyj> o/
15:00:50 <moguimar> o/
15:01:11 <bnemec> First week of the new ping list. Hope nobody missed the transition. :-)
15:02:19 <ansmith> o/
15:02:37 <jungleboyj> :-)
15:03:28 <bnemec> #topic Red flags for/from liaisons
15:03:37 <moguimar> none from Barbican
15:03:55 <johnsom> Nothing from Octavia team
15:04:04 <kgiusti> o/
15:04:08 <moguimar> although redrobot asked last week about feature freeze dates
15:04:37 <jungleboyj> Nothing from Cinder.  :-)
15:04:43 <bnemec> moguimar: Oslo-specific dates are on the releases page: https://releases.openstack.org/train/schedule.html
15:04:56 <moguimar> ack
15:05:18 <bnemec> We only have feature freeze since we don't really do spec freeze or anything like that.
15:05:28 <bnemec> Lately we don't really do specs, period. ;-)
15:05:57 <bnemec> I have nothing in my notes as far as red flags from the Oslo side either.
15:06:12 <bnemec> #topic Releases
15:06:25 <bnemec> I think the big news here is that pbr with the utf-8 description fix got merged last week.
15:06:45 <bnemec> I need to reply to that mailing list thread and have everyone who was affected verify that it fixed the problem.
15:07:05 <bnemec> #action bnemec reply to unicode project description thread
15:07:34 <bnemec> Otherwise expect the usual set of releases this week.
15:07:44 <bnemec> #topic Action items from last meeting
15:08:06 <bnemec> "liaisons who want to continue receiving courtesy pings need to update the ping list on the meeting agenda wiki page"
15:08:16 <bnemec> That was the only one, and hopefully it's done.
15:08:26 <johnsom> Some of us are here, so success! lol
15:08:32 <hberaud> lol
15:08:35 <bnemec> \o/
15:09:11 <bnemec> I should look for where we document that for liaisons and get it updated.
15:09:19 <bnemec> And also retire the script in oslo.tools.
15:09:33 <bnemec> #action bnemec update liaison documentation with new ping list details
15:09:45 <bnemec> #action bnemec retire courtesy ping script in oslo.tools
15:10:49 <bnemec> #topic Kafka functional tests
15:10:59 <bnemec> While we have ansmith, I wanted to discuss this a bit.
15:11:23 <bnemec> Currently the kafka functional tests are blocked because the kafka archive we were downloading got removed.
15:12:06 <bnemec> I have a patch up to fix the download location without changing the version, but it seems to be a bit flaky: https://review.opendev.org/#/c/664275/
15:12:43 <bnemec> There's also ansmith's patch that bumps the version, but that seems to be passing even less: https://review.opendev.org/#/c/653825/
15:13:05 <kgiusti> bnemec: I don't think apache will be cool with that - tried that with qpid-proton awhile ago.  much pain
15:13:32 <ansmith> bnemec: +1 to changing to pull from archive, the functional tests have been flaky on and off, mostly on
15:13:37 <kgiusti> bnemec: I've also tried pulling from github - even worse
15:14:02 <bnemec> kgiusti: Where do they want us to pull from?
15:14:12 <bnemec> ansmith: Okay, so this isn't a new thing.
15:14:47 <bnemec> Do you want to do this in two steps (download from archive, bump version) or just go with your patch?
15:15:19 <kgiusti> bnemec: not that we can't pull from it - but if it happens frequently enuff we may be blocked (that's what happened to me)
15:15:21 <ansmith> why don't we do it in two steps, take your patch for the switch to pull from archive, meanwhile i will focus on getting more instight into func test issues
15:15:49 <ansmith> kgiusti: switching from dist to archive should unblock
15:15:57 <hberaud> +1 for 2 steps
15:15:58 <bnemec> ansmith: Okay, sounds good.
15:16:07 <kgiusti> ansmith: https://archive.apache.org/dist/
15:16:13 <bnemec> Maybe we can run it that way for a while and see if we run into rate-limiting from apache.
15:16:18 <kgiusti> ansmith: +1
15:16:52 <bnemec> Oh, so maybe we should pick a different mirror?
15:17:29 <bnemec> Per the "Please do not download from apache.org! If you are currently at apache.org and would like to browse, please visit a nearby mirror site instead."
15:18:20 <bnemec> I'll update my patch to point at a mirror instead of apache.org directly.
15:18:21 <kgiusti> bnemec: ansmith: one aspect of a mirror (or any site not under our control) is that we don't control when images are removed/updated
15:18:34 <openstackgerrit> Lance Bragstad proposed openstack/oslo.limit master: Remove ProjectClaim object from oslo.limit  https://review.opendev.org/665708
15:18:34 <bnemec> #action bnemec to point kafka functional test patch at apache mirror
15:18:35 <openstackgerrit> Lance Bragstad proposed openstack/oslo.limit master: Remove verification functionality  https://review.opendev.org/665709
15:18:36 <openstackgerrit> Lance Bragstad proposed openstack/oslo.limit master: Remove __enter__ and __exit__ methods from Enforcer  https://review.opendev.org/665710
15:18:37 <openstackgerrit> Lance Bragstad proposed openstack/oslo.limit master: Add skeleton enforce() method to Enforcer  https://review.opendev.org/665711
15:19:07 <bnemec> Yay for progress on oslo.limit. Now back to your regularly scheduled meeting. :-)
15:19:39 <bnemec> kgiusti: It looked like they had some pretty old releases in the archive though, and hopefully the mirrors are actually mirrors and not subsets.
15:20:03 <kgiusti> bnemec: + mirror - worth a try
15:20:09 <kgiusti> bnemec: +1 that is
15:20:31 <bnemec> Okay cool.
15:20:45 <bnemec> #agreed switch kafka functional tests to an apache archive mirror
15:21:24 <bnemec> That's all I had for topics this week.
15:21:25 <bnemec> #topic Weekly Wayward Review
15:22:32 <bnemec> #link https://review.opendev.org/648727
15:22:51 <bnemec> This is a pbr fix that can probably merge now that ci is more stable.
15:23:01 <hberaud> +1
15:23:04 <bnemec> But I have to admit I haven't looked at it yet because of the pbr ci instability.
15:23:55 <bnemec> And it's a bunch of regexes so it probably isn't a quick review. ;-)
15:24:05 <bnemec> But lots of unit test cases, so ++ for that.
15:25:51 <bnemec> wow, that's an old bug
15:26:00 <hberaud> yeah
15:26:29 <moguimar> will put it into my list
15:27:49 <bnemec> Yeah, it's going to take me a minute to wrap my head around the regexes. Let's try to get this reviewed this week.
15:27:59 <bnemec> #action Cores to review https://review.opendev.org/648727
15:28:14 <bnemec> And non-cores of course. :-)
15:28:27 <bnemec> #topic Open discussion
15:28:33 <bnemec> Anything else this week?
15:29:06 <hberaud> I continue to work on the oslo.messaging rabbit driver heartbeat issue on my side
15:29:25 <bnemec> hberaud: The native thread thing?
15:29:30 <bnemec> I saw kgiusti had commented on that.
15:29:51 <bnemec> But I was distracted by other stuff late last week so I haven't looked closely.
15:29:51 <hberaud> Yeah. I've inspect the complete stack from nova-puppet to the driver initialization
15:29:52 <kgiusti> kgiusti: yep - Mr "Debby Downer" at your service...
15:30:16 <hberaud> I will publish my analyze and my POC soon
15:30:25 <kgiusti> hberaud: +1
15:30:31 <bnemec> Sounds good, thanks
15:30:31 <hberaud> and after that we will discuss about that
15:30:58 <bnemec> Feel free to add it to the meeting agenda once it's ready.
15:31:11 <bnemec> Or we can discuss it ad-hoc if we can get everyone together some other time.
15:31:15 <hberaud> ack
15:31:25 <hberaud> good idea
15:32:38 <bnemec> Oh, I need to sync up with mnaser about the oslo.service reload thing too.
15:33:38 <bnemec> I'm wondering if we want to just merge the fix and rely on OSA ci to verify that it's working.
15:33:52 <bnemec> Since the actual functional code changes were fairly minimal, but writing tests was going to be more of a hassle.
15:34:15 <bnemec> And it would be nice to get that in sooner rather than later so we aren't merging a big, potentially breaking change right at the end of the cycle.
15:34:43 <bnemec> #action bnemec to follow up on oslo.service reload bug
15:35:13 <hberaud> which bug?
15:35:53 <bnemec> #link https://review.opendev.org/#/c/641907/
15:35:58 <bnemec> hberaud: That patch^
15:36:01 <hberaud> ty
15:37:30 <bnemec> Wow, I included this in the PTG wrapup but provided no useful information about it. :-(
15:38:30 <bnemec> Fortunately I think the conclusion we came to was basically to address the comments on the review and then go with it.
15:38:40 <bnemec> Anyway, hopefully more on that next week.
15:38:44 <bnemec> Anything else for this week?
15:39:54 <moguimar> not on my end
15:41:12 <hberaud> not for me
15:41:35 <bnemec> Okay, thanks for joining everyone!
15:41:37 <bnemec> #endmeeting