15:01:01 <bnemec> #startmeeting oslo
15:01:01 <openstack> Meeting started Mon Jul  1 15:01:01 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:01 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, kgiusti, redrobot, stephenfin, johnsom
15:01:01 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:04 <openstack> The meeting name has been set to 'oslo'
15:01:09 <hberaud> o/
15:01:13 <jungleboyj> o/
15:01:35 <ansmith> o/
15:01:39 <johnsom> o/
15:02:41 <kgiusti> o/
15:03:25 <bnemec> #topic Red flags for/from liaisons
15:04:03 <jungleboyj> Nothing from Cinder.
15:04:51 <bnemec> I don't have anything on my list from last week, so I don't think there were any major disasters to note. :-)
15:06:29 <johnsom> Nothing from Octavia team
15:07:03 <bnemec> #topic Releases
15:07:12 <bnemec> Nothing to report.
15:07:21 <bnemec> I never actually got around to doing them last week. :-(
15:07:41 <bnemec> I will try to get that taken care of right away today.
15:07:59 <bnemec> I don't want things to release late this week since it's going to be a long weekend for a lot of folks in the US.
15:08:33 <bnemec> #topic Action items from last meeting
15:08:51 <bnemec> "kgiusti and bnemec to review rabbit heartbeat changes"
15:08:57 * moguimar shows up late
15:09:23 <kgiusti> https://review.opendev.org/#/c/663074/
15:09:49 <bnemec> I dropped the ball on this too. :-(
15:09:58 <kgiusti> I'm good with ^^^ - pretty simple
15:10:29 <kgiusti> hberaud: does that change make mod_wsgi happy?
15:10:32 <bnemec> Cool, sounds good.
15:10:38 <hberaud> kgiusti: yep
15:10:54 <kgiusti> hberaud: ship it!
15:11:01 <bnemec> I'll try to get back to this. I've had some very frustrating downstream stuff going on that has been eating up a lot of time/brainpower.
15:11:33 <bnemec> #action bnemec to review https://review.opendev.org/#/c/663074/
15:14:00 <bnemec> Oh, ugh, we're using the unpatched threading module?
15:14:12 <bnemec> Here be dragons.
15:14:39 <bnemec> Okay, don't need to spend everyone's time with me looking at the review though.
15:14:54 <bnemec> The only topic I had on the list is something I didn't address again, so we'll skip it.
15:15:02 <bnemec> #topic Weekly Wayward Review
15:15:15 <bnemec> #link https://review.opendev.org/648165
15:15:30 <bnemec> This one is relatively simple.
15:15:50 <bnemec> It's basically the start of a blacklist for the config validator that contains opt groups we know don't work well.
15:16:17 <bnemec> In this case keystone_authtoken because they do some crazy runtime opt generation that doesn't play nicely with offline validation.
15:19:46 <bnemec> kgiusti and moguimar: ^Since you're the two oslo cores here that aren't already on that review. :-)
15:20:55 * bnemec just remembered another topic that should be mentioned
15:21:00 <bnemec> I'll do that after this.
15:22:36 <kgiusti> no longer wayward....
15:22:45 <bnemec> kgiusti: Thanks!
15:23:09 <bnemec> #topic Shanghai CFP
15:23:32 <bnemec> Just a heads up for anyone who hasn't already seen this, the CFP closes soon.
15:24:03 <bnemec> Specifically July 2nd.
15:24:26 <bnemec> I submitted a talk about the tools Oslo provides to help operators.
15:25:08 <bnemec> If it's accepted (and I even go to Shanghai) I plan to demonstrate stuff like the castellan driver, config validator, and the oslo.policy CLI tools.
15:26:51 <bnemec> So make sure you get your talks submitted by tomorrow if you want to do one.
15:26:57 <bnemec> That's all I had to say on this.
15:27:01 <bnemec> #topic Open discussion
15:27:06 <bnemec> Anything else?
15:27:09 * jungleboyj is having a hard time getting Cinder people to say they are going to Shanghai.
15:27:41 <hberaud> we risk to facing some pypi issue during deployments => https://github.com/pypa/warehouse/issues/5890
15:27:59 <hberaud> (FYI)
15:29:33 <hberaud> pypi folks have reintroduce some deactivated checks on deployment and so one check related to the long_description syntaxe check (render rst, markdown)
15:30:22 <moguimar> not on my end
15:30:34 <bnemec> I think we use all RST for our READMEs so hopefully that won't affect us.
15:30:45 <bnemec> I can't remember whether we validate that README.rst is valid though.
15:30:53 <bnemec> I guess we'll find out when we try to release. :-)
15:30:59 <hberaud> I currently doing some checks on your oslo side
15:31:04 <bnemec> hberaud: Thanks for the heads up.
15:31:11 <bnemec> Sounds good.
15:32:13 <bnemec> Anything else before I give you all half an hour back?
15:32:45 <bnemec> #action hberaud add checks for README.rst validity
15:32:52 <bnemec> Just to make it official. :-)
15:33:05 <hberaud> bnemec: ack
15:34:19 <bnemec> Okay, sounds like we're done. Thanks for joining, everyone!
15:34:22 <bnemec> #endmeeting