15:01:06 <bnemec> #startmeeting oslo
15:01:06 <openstack> Meeting started Mon Jul 15 15:01:06 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:07 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, kgiusti, redrobot, stephenfin, johnsom
15:01:07 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:10 <openstack> The meeting name has been set to 'oslo'
15:01:16 <njohnston> o/
15:01:17 <hberaud> o/
15:02:05 <jungleboyj> o/
15:04:31 <bnemec> #topic Red flags for/from liaisons
15:04:41 <bnemec> Nothing that I know of from the Oslo side.
15:05:03 <njohnston> nothing I am aware of in Neutron country
15:05:37 <jungleboyj> Nothing from Cinder.
15:07:04 <stephenfin> Nothing from nova that I've heard about, fwiw
15:07:25 <bnemec> Cool, thanks everyone
15:07:30 <bnemec> #topic Releases
15:07:57 <bnemec> I forgot to do these last week, which means it makes sense that nothing broke. :-)
15:08:21 <bnemec> I'll try to get them out today.
15:09:06 <bnemec> I saw the mandatory change merged in oslo.messaging, so I think we're ready to release that?
15:09:10 <bnemec> gsantomaggio: ^
15:09:28 <bnemec> No kgiusti today. :-/
15:09:55 <bnemec> I can ping later too before I propose the releases.
15:10:44 <bnemec> #topic Action items from last meeting
15:10:45 <hberaud> I think it's ready for a release but yep ask before
15:10:54 <gsantomaggio> @bnemec  Mandatory is ready for Client side, and I think we can release with these feature.
15:11:18 <bnemec> Sounds good, thanks hberaud and gsantomaggio.
15:11:26 <bnemec> Just one action item from last week:
15:11:30 <bnemec> "hberaud add checks for README.rst validity"
15:11:35 <gsantomaggio> I am working also for mandatory in `RPCServer` will release asap
15:12:06 <hberaud> bnemec: done. everything is ok we don't need to add something
15:12:21 <bnemec> hberaud: My favorite kind of outcome. :-)
15:12:28 <hberaud> :)
15:13:19 <bnemec> #topic PTG Planning
15:13:37 <bnemec> As you've probably seen, they're starting planning for the PTG.
15:14:08 <bnemec> The Foundation wants to know which teams will need space, so we need to try to figure out if we will have anyone attending.
15:14:21 <bnemec> The due date is August 11th.
15:14:52 <bnemec> Since that's a weekend the practical date is actually the 9th, I guess.
15:15:28 <bnemec> I don't know if I'm going yet, and I realize most others probably don't either.
15:15:59 <bnemec> I'll probably go ahead and create a planning etherpad like some of the other teams have done.
15:16:05 <bnemec> #action bnemec to create PTG planning etherpad
15:17:24 <bnemec> If you know that you're definitely _not_ going, that will be helpful to know as well.
15:18:18 <bnemec> And of course if you know of something that we should discuss in person feel free to make a note of that too.
15:18:36 <bnemec> I think that's about it for the PTG. Watch for an email with the etherpad link.
15:19:07 <jungleboyj> One thing to keep in mind is the fact that there may be new people from China that attend that we haven't seen in the past.
15:19:19 * jungleboyj is hoping that will make things more productive for Cinder.
15:20:04 <bnemec> Yeah, that's a good point.
15:20:13 <jungleboyj> *fingers crossed*
15:20:33 <bnemec> Although if none of our active cores are there it might still be a problem. :-)
15:20:49 <jungleboyj> True.  I know I am going to have to be there.  :-)
15:20:55 <stephenfin> I'm almost certain to be there, fwiw
15:21:12 * njohnston is going to sit this one out
15:21:12 <stephenfin> (Given that I'm in Japan the previous two weeks, it'd be silly not to go)
15:21:25 <jungleboyj> :-)
15:21:27 <bnemec> Heh, that's convenient. :-)
15:22:05 <hberaud> me too (not for the japan part :p )
15:22:22 <bnemec> Then I guess I can probably request at least half a day so there's a specific time for people to find us.
15:22:22 <stephenfin> Would have been more convenient if I'd checked PTG/Summit dates _before_ booking my return flights, but ¯\_(ツ)_/¯
15:22:54 <bnemec> Generally speaking, we've gotten through our formal topics in half a day anyway.
15:23:58 <bnemec> I still don't know if I'm going (I haven't gone to two of the three APAC summits), but it sounds like we will have representation either way.
15:25:02 <bnemec> #topic Weekly Wayward Review
15:25:21 <bnemec> #link https://review.opendev.org/#/c/650915
15:26:38 <bnemec> Looks like a fairly simple osprofiler review.
15:30:27 <bnemec> And lgtm. Just need another +2.
15:34:11 <bnemec> Okay, I'll just action this one. Hopefully we can get it merged this week.
15:34:16 <bnemec> #action Oslo cores to review https://review.opendev.org/#/c/650915
15:34:28 <bnemec> #topic Open discussion
15:34:35 <bnemec> Anything else this week?
15:36:05 <hberaud> (network issue, sorry, maybe I missing something)
15:36:24 <bnemec> hberaud: Looking for reviews on https://review.opendev.org/#/c/650915
15:36:39 <hberaud> bnemec: thanks
15:37:19 <hberaud> bnemec: I'll take a look
15:37:43 <bnemec> hberaud: Thanks
15:37:54 <bnemec> Other than that we're in open discussion.
15:38:24 <hberaud> can someone take a look to https://review.opendev.org/#/c/648727/ too?
15:39:22 <hberaud> else concerning the oslo.messaging heartbeat issue, kguisti asked to move this feature as an experimental feature (https://review.opendev.org/#/c/663074/)
15:39:54 <hberaud> I've made the necessary changes (for the optional part)
15:40:06 <hberaud> bnemec: what do you think about?
15:40:42 <hberaud> bnemec: in the past you asked to avoid to introduce the optional mode
15:41:26 <hberaud> bnemec: so I'm interesting by your point of view too
15:41:52 <hberaud> s/interesting/interested/
15:42:29 <bnemec> hberaud: I know I had initially requested that we just do the right thing always and not make it configurable, but since it's not 100% clear what that is I'd be okay with making it optional for testing.
15:42:46 <bnemec> I guess the main thing would be to mark it very explicitly as experimental, probably in the opt help string.
15:42:55 <hberaud> bnemec: okay nice
15:43:03 <bnemec> That's on my todo list, so I'll try to get to it this week.
15:43:36 <hberaud> bnemec: yeah it's already tagged "experimental" in the help string
15:43:43 <bnemec> Cool
15:43:51 <hberaud> bnemec: thx
15:45:35 <bnemec> Anything else?
15:46:03 <hberaud> not on my side
15:46:28 <gsantomaggio> nope :)!
15:48:28 <bnemec> Okay, I'm going to action some of the things we discussed and then end the meeting then.
15:48:34 <bnemec> #action Oslo cores to review https://review.opendev.org/#/c/648727/
15:48:41 <bnemec> #action bnemec to review https://review.opendev.org/#/c/663074/
15:48:52 <bnemec> And that's it. Thanks for joining everyone!
15:48:54 <bnemec> #endmeeting