15:00:48 <bnemec> #startmeeting oslo
15:00:48 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, kgiusti, redrobot, stephenfin, johnsom
15:00:48 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:49 <openstack> Meeting started Mon Aug 12 15:00:48 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:52 <openstack> The meeting name has been set to 'oslo'
15:00:59 <hberaud> o/
15:01:02 <jungleboyj> o/
15:03:57 <bnemec> Okay, light attendance today. Might be a quick one. :-)
15:04:05 <bnemec> #topic Red flags for/from liaisons
15:04:27 <jungleboyj> Nothing from Cinder.
15:04:54 <bnemec> Nothing from the Oslo side either.
15:04:58 <bnemec> #topic Releases
15:05:41 <bnemec> Not much to report.
15:05:41 <bnemec> We released a new oslo.policy that allows disabling the deprecation warnings in unit tests to eliminate some log spam in Keystone.
15:06:00 <bnemec> That'll probably be relevant for other projects as they start to migrate to scope types and such.
15:06:41 <bnemec> Also a major version bump for oslo.messaging, but that should have minimal impact. It was just removing support for a behavior that we dropped a while back.
15:07:00 <bnemec> #topic Action items from last meeting
15:07:17 <bnemec> bnemec review https://review.opendev.org/#/c/663074/
15:07:33 <bnemec> Yes I did.
15:07:43 <bnemec> And that was it for action items.
15:08:11 <bnemec> #topic py37 failures
15:08:34 <bnemec> As part of the train unit tests community goal, it turns out we have some failing py37 tests.
15:09:01 <bnemec> Specifically oslo.log and castellan. I think I fixed the oslo.db ones on Friday, but that hasn't merged yet so we'll see.
15:09:34 <openstackgerrit> Merged openstack/oslo.i18n master: Move doc related modules to doc/requirements.txt  https://review.opendev.org/669418
15:10:03 <bnemec> Any help with those would be appreciated. I know the oslo.log one looked kind of tricky. I haven't looked at Castellan yet.
15:10:48 <bnemec> #action Get py37 tests passing on oslo.log and castellan repos
15:11:00 <hberaud> If I've spare I'll take a look but I'm not sure to find time...
15:11:37 <bnemec> Maybe I'll open bugs for those so we can write down any findings somewhere.
15:11:46 <bnemec> #action bnemec to open bugs for py37 test failures
15:11:51 <hberaud> good idea
15:13:02 <bnemec> #topic PTG
15:13:09 <bnemec> #link https://etherpad.openstack.org/p/oslo-shanghai-topics
15:13:50 <bnemec> I did request a half day of PTG space in Shanghai. That's down from the full day I've requested in the past, but I think that's fine. We've been done in half a day or less every time anyway.
15:14:21 <bnemec> And it sounds like we won't actually have a room, but a table in a shared space so if there are popup discussions we'll just find a different table. :-)
15:15:19 <bnemec> On a related note, I had a talk accepted for the Summit to demo some operator-facing Oslo tools.
15:15:38 <bnemec> #link https://www.openstack.org/summit/shanghai-2019/summit-schedule/events/23978/demo-of-oslo-tools-that-make-life-easier-for-operators
15:15:50 <bnemec> You can see the list of things I'm planning to cover there.
15:16:06 <bnemec> Basically oslo.config and oslo.policy, but if you can think of anything else that might be good, let me know.
15:17:12 <bnemec> #topic Weekly Wayward Review
15:18:31 <bnemec> #link https://review.opendev.org/#/c/660339/
15:18:45 <bnemec> This isn't strictly the oldest one, but it's one I think we can polish off right now.
15:18:53 <bnemec> hberaud: Would you be able to approve that?
15:19:23 <hberaud> bnemec: sure
15:20:18 <bnemec> Cool, thanks
15:20:42 <bnemec> #topic Open discussion
15:20:52 <bnemec> That was it for the agenda. Anything else this week?
15:21:15 <hberaud> I'll be on PTO from this wednesday and the 2 following weeks included
15:21:42 <hberaud> I'll be back at the begining of september
15:21:48 <hberaud> (FYI)
15:21:53 <bnemec> Sounds good. Enjoy your time off!
15:22:08 <hberaud> ty :)
15:24:48 <bnemec> Okay, sounds like that's it. Thanks for joining!
15:24:50 <bnemec> #endmeeting