15:02:34 <bnemec> #startmeeting oslo
15:02:34 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, kgiusti, redrobot, stephenfin, johnsom
15:02:34 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:02:35 <openstack> Meeting started Mon Aug 19 15:02:34 2019 UTC and is due to finish in 60 minutes. The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:39 <openstack> The meeting name has been set to 'oslo'
15:02:42 <njohnston_> o/
15:02:49 <bnemec> Dang, I am missing all of my meeting notifications today.
15:02:49 <moguimar> o/
15:02:53 <bnemec> moguimar: Thanks for the reminder.
15:02:58 <moguimar> no biggie
15:02:58 <kgiusti> o/
15:03:07 <ansmith_> o/
15:03:22 <johnsom> o/
15:03:58 <bnemec> Hey kgiusti, while I've got you here, any idea why the amqp opts are in the rabbit group instead of the amqp one? https://opendev.org/openstack/oslo.messaging/src/branch/master/oslo_messaging/opts.py#L45
15:04:34 * kgiusti looks...
15:05:21 <kgiusti> bnemec: legacy
15:05:52 <kgiusti> bnemec: those options are queue lifetime configuration options - used to apply to qpid and rabbitmq
15:06:25 <kgiusti> bnemec: since they're no longer universal to all drivers they can be moved into imp_rabbit
15:06:50 <bnemec> kgiusti: Okay, thanks. I was looking at them for a discussion earlier and was surprised by that.
15:06:58 <bnemec> #topic Red flags for/from liaisons
15:07:07 <bnemec> Back to your regularly scheduled meeting agenda...
15:07:23 <johnsom> Nothing from the Octavia team
15:07:28 <njohnston> nothing I am aware of in Neutron land
15:07:29 <moguimar> nothing from Oslo
15:07:33 <moguimar> oops
15:07:35 <moguimar> Barbican xD
15:07:37 <johnsom> lol
15:07:49 <moguimar> that's what happens when you're the middle man xD
15:08:04 <bnemec> :-)
15:08:24 <bnemec> I don't see anything from the Oslo side either, so you were right both times. :-)
15:08:38 <bnemec> #topic Releases
15:09:11 <bnemec> I think the only one last week was oslo.messaging. That review hasn't merged yet though.
15:09:35 <bnemec> When it does, this will be the first release with the heartbeat native thread option.
15:10:24 <bnemec> Which I think is mostly interesting to Nova, but if you're having trouble with messaging heartbeats in an environment that combines eventlet and wsgi, that may help you.
15:10:34 <kgiusti> bnemec: is it waiting on https://review.opendev.org/#/c/661314/ ?
15:11:01 <bnemec> kgiusti: No, although we should probably update the spec to reflect what we did.
15:11:18 <bnemec> Unfortunately Herve is out for a couple of weeks here so it may be a while.
15:11:43 <bnemec> Just waiting on https://review.opendev.org/#/c/676425/ to merge.
15:12:11 <kgiusti> bnemec: ack - gotcha
15:12:35 <gsantomaggio> Hi all,
15:12:35 <gsantomaggio> This week I should have time to work on https://review.opendev.org/#/c/672073/
15:13:17 <kgiusti> yay gsantomaggio in 'da room!
15:14:22 <gsantomaggio> 😀
15:14:29 <bnemec> Okay, sounds good. I've only been vaguely following that review.
15:15:05 <bnemec> #topic Action items from last meeting
15:15:16 <bnemec> "Get py37 tests passing on oslo.log and castellan repos"
15:15:21 <bnemec> Done
15:15:32 <bnemec> oslo.log in particular was rather "fun" to figure out.
15:16:08 <bnemec> "bnemec to open bugs for py37 test failures"
15:16:18 <bnemec> Also done, although one of them already had a bug open for it.
15:16:30 <bnemec> That was it for action items last week.
15:16:42 <bnemec> #topic Feature freeze
15:17:05 <bnemec> This is just a heads up, Oslo feature freeze is coming up in a couple of weeks.
15:17:41 <bnemec> After the 30th any feature work will require an exception.
15:18:20 <bnemec> #link https://releases.openstack.org/train/schedule.html
15:18:30 <bnemec> The Oslo schedule is always available on ^
15:19:13 <bnemec> #topic PTG
15:19:23 <bnemec> #link https://etherpad.openstack.org/p/oslo-shanghai-topics
15:19:36 <bnemec> Also another reminder about the PTG etherpad.
15:19:57 <bnemec> I also wanted to note that I had a talk accepted for the summit to demonstrate some of the operator-facing tools in Oslo.
15:20:11 <bnemec> moguimar: I was planning to include the castellan config driver, FYI.
15:20:20 <bnemec> I might be pinging you for help setting up a demo environment for that.
15:21:11 <bnemec> Also planning to cover the config validator and various policy tools since those are relatively recent additions.
15:22:19 <bnemec> #link https://www.openstack.org/summit/shanghai-2019/summit-schedule/events/23978/demo-of-oslo-tools-that-make-life-easier-for-operators
15:22:42 <bnemec> If you have anything else that you think I should cover there let me know ASAP.
15:23:11 <bnemec> I'm not sure how long it will take to get through all of those, so we'll see how in-depth I can go.
15:23:40 <bnemec> #topic oslo.config - rst to plaintext
15:24:03 <bnemec> moguimar: Was this you?
15:25:41 <moguimar> yep
15:25:57 <moguimar> I was poked about this patch
15:26:32 <moguimar> do we still need it
15:26:34 <moguimar> ?
15:27:13 <bnemec> I guess the question is whether stephenfin is going to pursue the rst config opt descriptions change.
15:27:14 <moguimar> I was poked here
15:27:17 <moguimar> https://review.opendev.org/#/c/650935
15:27:26 <moguimar> is stephenfin around?
15:27:28 <stephenfin> ENOTIME
15:27:34 <stephenfin> I can do it, but not until M3
15:27:39 <stephenfin> i.e. not for Train
15:28:00 <bnemec> So it's probably safe to abandon that for now. It can be revived if/when that work goes forward.
15:28:06 * stephenfin needs to do some reading up on docutils internal
15:28:11 <stephenfin> Yeah, that would be best
15:28:18 <moguimar> ok
15:28:20 <bnemec> And the requirements change doesn't block someone working on the feature, it just can't merge until the requirements are in.
15:28:36 <stephenfin> indeed
15:29:02 <moguimar> so we abandon the oslo patch and do what with the requirements one?
15:29:04 <bnemec> #agreed abandon the rst2txt requirements review pending further progress on the feature
15:29:17 <bnemec> moguimar: I would abandon the requirements patch and maybe WIP the oslo one.
15:29:21 <moguimar> ok
15:29:27 <moguimar> I'll abandon it then
15:29:50 <bnemec> Sounds good, thanks.
15:30:48 <bnemec> Okay, that was it for the agenda.
15:30:51 <bnemec> #topic Weekly Wayward Review
15:32:00 <bnemec> #link https://review.opendev.org/#/c/658675/
15:32:17 <bnemec> That's the oldest one, and I think maybe it should be WIP based on the latest discussion.
15:33:28 <bnemec> I'm not sure how much desire there is to pursue that one either. There was some interest around it at one point, but it kind of tapered off as we looked into it further.
15:34:22 <bnemec> Okay, that's done.
15:34:32 <bnemec> It might still be nice to get that in though, if anyone wants to take it over.
15:34:45 <bnemec> I'm not sure if Doug will have time to revisit it at this point.
15:35:13 <bnemec> #topic Open discussion
15:35:22 <bnemec> Anything else this week?
15:35:48 <johnsom> I want to raise awareness to this patch proposed by the Octavia team for Taskflow:
15:35:51 <johnsom> #link https://review.opendev.org/#/c/675388/
15:36:38 <johnsom> We are starting to heavily use the retry mechanisms of Taskflow and have found that one of the "status history" tables quickly overflows on mysql. It's a pretty simple fix.
15:37:10 <bnemec> Heh, I looked at that and went "wait, we have db migrations in taskflow?!"
15:37:53 <johnsom> Yeah, for certain usage paterns.
15:40:23 <bnemec> johnsom: Okay, approved.
15:40:31 <johnsom> Cool, thanks!
15:41:54 <bnemec> Anything else?
15:44:08 <bnemec> Looks like we're done. Thanks for joining, everyone!
15:44:11 <bnemec> #endmeeting