15:00:45 <bnemec> #startmeeting oslo
15:00:45 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, kgiusti, redrobot, stephenfin, johnsom
15:00:45 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:46 <openstack> Meeting started Mon Aug 26 15:00:45 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:49 <openstack> The meeting name has been set to 'oslo'
15:00:55 <moguimar> o/
15:01:04 <johnsom> o/
15:01:13 <ansmith> o/
15:01:16 <redrobot> 👋
15:03:13 <bnemec> I can't tell what that is. :-)
15:03:25 <bnemec> #topic Red flags for/from liaisons
15:03:48 <johnsom> redrobot and his fancy emojis
15:04:05 <johnsom> Nothing from the Octavia team this week
15:04:13 <moguimar> Nothing from Barbican
15:04:16 <bnemec> I don't think there were any major issues last week.
15:04:27 <bnemec> One thing to be aware of is that I'm hoping to get https://review.opendev.org/641907 merged soon.
15:04:40 <bnemec> That will change the behavior of oslo.service on SIGHUP if you use mutable config.
15:05:14 <openstackgerrit> Merged openstack/oslo.messaging master: Add the mandatory flag for direct send  https://review.opendev.org/672073
15:05:32 <bnemec> Basically it will make it work the way it was always supposed to, but it is a pretty significant change in behavior.
15:06:00 <bnemec> So if you see any issues in the near future, keep that in mind.
15:06:25 <bnemec> That should be it for this topic.
15:06:27 <bnemec> #topic Releases
15:06:46 <gsantomaggio> 👋
15:06:47 <bnemec> I didn't actually propose any last week because the one from the previous week hadn't merged yet.
15:07:26 <bnemec> It has now though, so I'll get them proposed early this week.
15:08:18 <bnemec> #topic Action items from last meeting
15:08:27 <bnemec> There were no action items last week.
15:08:49 <gsantomaggio> I finished ( for the moment ) mandatory stuff:
15:08:49 <gsantomaggio> https://blueprints.launchpad.net/oslo.messaging/+spec/transport-options
15:08:49 <gsantomaggio> Client and server side
15:08:54 <bnemec> There was an agreement to abandon https://review.opendev.org/#/c/650935 which I see was done.
15:09:43 <moguimar> yep
15:09:45 <bnemec> gsantomaggio: Yep, I see that just merged.
15:09:59 <bnemec> Speaking of which...
15:10:08 <bnemec> #action bnemec add gsantomaggio to oslo.messaging core list
15:10:20 <gsantomaggio> thank you
15:10:54 <bnemec> #topic Feature freeze
15:11:00 <bnemec> #link https://releases.openstack.org/train/schedule.html
15:11:09 <bnemec> Be aware, this is the last week to merge features without an exception.
15:11:31 <bnemec> After Friday, any feature patches will require a feature freeze exception from me.
15:12:53 <bnemec> I guess I don't have anything else to say about that. Just reminding everyone.
15:13:13 <bnemec> I also don't have anything new to say about the PTG so I'm going to skip that one this week.
15:13:18 <bnemec> #topic  Lazy translation
15:13:45 <bnemec> This came up last week because there was a patch to Keystone fixing it.
15:14:16 <bnemec> I wanted to mention it because there was previously a question as to whether anyone was using lazy translation and if we could just drop it.
15:14:35 <bnemec> The fact that someone noticed it wasn't working means they are using it though.
15:15:00 <bnemec> So I'm proposing that we do keep it.
15:15:06 <bnemec> Hopefully not a controversial position. :-)
15:15:46 <bnemec> It does add a bit of complexity developers need to know about, but it hasn't been a huge maintenance burden thus far.
15:16:28 <bnemec> That's all I had. I mostly wanted to get this on the record so hopefully we don't forget the next time this question comes up. :-)
15:16:39 <bnemec> #topic  oslo.service sighup change
15:17:29 <bnemec> I mentioned this earlier, but I want to point out https://review.opendev.org/641907 again.
15:17:33 <bnemec> #link https://review.opendev.org/641907
15:17:46 <bnemec> So it shows up fancy in the meeting notes. :-)
15:18:13 <bnemec> It fixes a pretty significant bug in the mutable config functionality.
15:18:44 <bnemec> And I would like to get it merged ASAP so we have some time before release to exercise it.
15:20:10 <bnemec> Zane has +2'd it and Eric verified that it does partially fix the Nova SIGHUP behavior (another patch is needed to oslo.privsep).
15:20:35 <bnemec> The latest patch set was just a commit message change to remove a bug that it doesn't actually fix.
15:20:53 <bnemec> Anyway, would appreciate another oslo core taking a look at that so we can get it merged.
15:21:43 <bnemec> And that's it for topics.
15:21:44 <bnemec> #topic Weekly Wayward Review
15:23:38 <bnemec> Herve has a question on https://review.opendev.org/#/c/649629/ so I'm going to skip that.
15:24:11 <bnemec> I think https://review.opendev.org/#/c/662830 is good to go, but I'd still like a sanity check from the keystone team on that.
15:24:26 <bnemec> I'll take an action to follow up with them about that.
15:24:37 <bnemec> #action bnemec to ask keystone team about https://review.opendev.org/#/c/662830
15:26:39 <bnemec> Okay, the next oldest are all WIP oslo.limit patches, so I think we're in pretty good shape here.
15:27:00 <bnemec> I'll just leave it at the action to follow up on the castellan token patch.
15:27:11 <bnemec> moguimar: ^That might be of interest to you too.
15:27:33 <redrobot> 👀
15:27:50 <moguimar> ok, will add me and redrobot
15:27:58 <bnemec> Cool, thanks.
15:28:40 <bnemec> #topic Open discussion
15:28:46 <bnemec> Anything else this week?
15:30:53 <moguimar> not on my end
15:33:06 <bnemec> Okay, that'll do it then.
15:33:12 <bnemec> Thanks for joining, everyone!
15:33:15 <bnemec> #endmeeting