15:00:26 <bnemec> #startmeeting oslo
15:00:26 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, kgiusti, redrobot, stephenfin, johnsom
15:00:26 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:00:26 <openstack> Meeting started Mon Sep  9 15:00:26 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <openstack> The meeting name has been set to 'oslo'
15:00:32 <hberaud> o/
15:00:35 <moguimar> o/
15:00:39 <jungleboyj> o/
15:00:40 <johnsom> o/
15:01:36 <ansmith> o/
15:02:36 <bnemec> #topic Red flags for/from liaisons
15:02:38 <kgiusti> o/
15:02:50 <johnsom> Nothing to raise from Octavia team
15:03:24 <moguimar> Nothing from Oslo
15:03:27 <moguimar> oops
15:03:29 <moguimar> barbican
15:03:36 <bnemec> moguimar: :-)
15:03:38 <moguimar> :facepalm:
15:04:02 <bnemec> The one major thing to note from the Oslo side is that we have merged the sighup fix so that services won't be completely restarted when using mutable config.
15:04:14 <bnemec> If you see any weird behavior as a result please let us know ASAP.
15:04:32 <jungleboyj> nothing from Cinder
15:05:43 <bnemec> Okay, sounds like we're good.
15:05:44 <bnemec> #topic Releases
15:06:10 <jungleboyj> \o/
15:06:28 <bnemec> We're in feature freeze, so releases from here on out should be bugfix only, unless an FFE is granted.
15:07:34 <bnemec> Also note that I released all the things last week. We need to do that so when branches are cut they include all of the doc and test changes we normally don't release.
15:08:27 <bnemec> Otherwise I would expect release activity to slow down a bit here as we come to the end of the cycle.
15:09:03 <bnemec> I think that's all I've got.
15:09:09 <bnemec> #topic Action items from last meeting
15:09:17 <bnemec> "bnemec add gsantomaggio to oslo.messaging core list"
15:09:20 <bnemec> Done. \o/
15:09:43 <gsantomaggio> @bnemec thank you
15:10:08 <bnemec> My pleasure. :-)
15:10:18 <bnemec> "bnemec to ask keystone team about https://review.opendev.org/#/c/662830"
15:10:50 <bnemec> Pretty sure I did that, but still haven't heard anything back.
15:11:20 <bnemec> At this point I'm inclined to just go ahead and merge it.
15:11:33 <moguimar> lbragstad: ^
15:11:36 <bnemec> Since it's a bug fix we could do that now. I'm not sure how high priority this is though.
15:12:06 <moguimar> bnemec: lbragstad and I are working in the same DFG now
15:12:32 <bnemec> Handy. :-)
15:12:37 <moguimar> yep
15:13:15 <lbragstad> i can take a look at that today if needed
15:13:26 <bnemec> The other thing is that since this is a bugfix we could wait until next cycle and backport it.
15:14:27 <bnemec> lbragstad: I'm mostly just looking for a sanity check that this isn't horribly violating any keystone expectations of how tokens get used.
15:15:06 <lbragstad> bnemec cool - that sounds good
15:16:09 <bnemec> Okay, we'll wait for lbragstad's input on that one then.
15:16:37 <bnemec> #topic Feature freeze
15:17:00 <bnemec> I mentioned it earlier, but we're in feature freeze now, both for Oslo and non-client libs.
15:17:32 <bnemec> That means nobody should merge any patches that would require a feature release from now until we branch stable/train.
15:18:13 <bnemec> Unless an FFE has been granted, and at this point I think we'd need approval from both me and the release team since we're out of the Oslo-specific freeze period.
15:18:46 <bnemec> On a related note...
15:18:49 <bnemec> #topic Deprecation of oslo.i18n Message.translate function
15:19:17 <bnemec> A bug was pointed out on the mailing list a couple of weeks ago that there was an issue with the Message.translate function.
15:19:33 <bnemec> It turns out we shadowed a unicode built-in function in our Message subclass.
15:20:13 <bnemec> That causes problems when we pass a Message object as a unicode to external libraries that try to use it as a non-i18n call.
15:20:45 <bnemec> I have a two-part fix up for this, starting at https://review.opendev.org/#/c/679092/
15:21:04 <bnemec> The first one we can merge because it's exclusively a bug fix.
15:21:25 <bnemec> The followup is more of a question because it deprecates the existing function.
15:21:27 <bnemec> #link https://review.opendev.org/#/c/679321/1
15:21:47 <bnemec> However, I would like to ask for an FFE to get that in this cycle so we can do the removal ASAP.
15:22:04 <bnemec> If we wait til next cycle we'll have to wait an extra cycle before removing it, per our deprecation policy.
15:22:38 <bnemec> It's a pretty low risk thing since we don't document calling that function directly. Translation is supposed to happen via the i18n.translate module-level function.
15:23:19 <bnemec> I don't see any deprecation warnings logged in the tempest jobs on the patch, so I don't think any of the projects we're testing with call it directly.
15:24:48 <bnemec> So I wanted to bring this up for two reasons: 1) To get another core to look at that so we can have it ready to merge if we get an FFE
15:24:48 <bnemec> 2) To see if anyone has any objections to me asking for an FFE on it
15:26:11 <bnemec> If I hear no objections during the meeting I'll probably go ahead and take it to the list.
15:27:13 <bnemec> Okay, moving on then.
15:27:18 <bnemec> #topic PTG/Forum
15:27:26 <bnemec> #link https://etherpad.openstack.org/p/oslo-shanghai-topics
15:27:45 <bnemec> Forum session proposals are now open.
15:28:15 <gsantomaggio> can't go :(
15:28:22 <bnemec> I don't have any topics planned, but if anyone has anything that they think would benefit from a broad discussion at the Forum please feel free to submit and add to the etherpad.
15:28:28 <moguimar> bnemec: feel free to ping me for the castellan demo
15:28:34 <bnemec> There's a lot of that going around. :-/
15:28:52 <bnemec> moguimar: Cool, I was planning on that. :-)
15:30:24 <bnemec> I don't have a lot else to say on that, other than to always keep in mind that if you run across anything you think would benefit from discussion at the PTG, please add it to the etherpad too.
15:30:39 <bnemec> #topic Cycle highlights
15:30:54 <bnemec> Now that we're coming to the end of the cycle, it's time for cycle highlights.
15:31:13 <bnemec> I believe there was an email to the ML about this, but basically it's some marketing bullet points for each project.
15:31:47 <bnemec> We don't always have them for Oslo because a lot of our work is not user-facing, so it's not terribly marketable.
15:32:18 <bnemec> However, if you worked on anything this cycle that you think should show up in the OpenStack marketing materials please let me know ASAP.
15:32:26 <bnemec> Oslo-related of course. ;-)
15:33:20 <moguimar> was castellan driver this or last cycle?
15:34:59 <bnemec> Last cycle, I believe.
15:35:10 <bnemec> I'm pretty sure I included it in the cycle highlights last time.
15:36:08 <bnemec> For reference, here's the cycle highlights from last time:
15:36:10 <bnemec> #link https://review.opendev.org/#/c/645019
15:36:24 <bnemec> Basically all config-related.
15:38:49 <bnemec> #topic Weekly Wayward Review
15:39:35 <bnemec> This one catches my eye:
15:39:36 <bnemec> #link https://review.opendev.org/#/c/672781/
15:40:14 <bnemec> It's a kind of important fix since it results in broken rules in the generated policy.
15:40:54 <bnemec> lbragstad: I'm thinking I might go ahead and +2 since we've both reviewed each other's changes, and I only touched the tests.
15:41:41 <bnemec> And maybe that will get cmurphy's attention. I hesitate to ping her since I don't know if she's caught up from PTO yet.
15:42:09 <moguimar> bnemec: I can review it tomorrow morning
15:42:21 <bnemec> moguimar: Sounds good, thanks.
15:42:50 <bnemec> #action moguimar to review https://review.opendev.org/#/c/672781/
15:43:39 <bnemec> Alright, we'll call that good. At some point here I'll probably stop doing the wayward review section until ussuri opens up since we don't want to be forcing patches in late in the cycle.
15:43:43 <bnemec> #topic Open discussion
15:43:48 <bnemec> Anything else this week?
15:44:33 <moguimar> not on my end
15:44:48 <lbragstad> thanks moguimar
15:47:13 <bnemec> Okay, let's give everyone 13 minutes back. Thanks for joining!
15:47:16 <bnemec> #endmeeting