15:01:01 <bnemec> #startmeeting oslo
15:01:01 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot
15:01:01 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:02 <openstack> Meeting started Mon Oct 28 15:01:01 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:06 <openstack> The meeting name has been set to 'oslo'
15:01:23 <johnsom> o/
15:01:59 <jungleboyj> Kind of here.
15:02:03 <bcafarel> o/
15:02:24 <kgiusti> o/
15:04:07 <bnemec> #topic Red flags for/from liaisons
15:04:27 <jungleboyj> Nothing from Cinder.
15:04:36 <johnsom> Nothing from Octavia.
15:04:51 <bcafarel> Nothing from Neutron. (trying to respect alignment)
15:05:01 <bnemec> :-)
15:05:50 <bnemec> Nothing much happened on the Oslo side, for reasons which I will get into in the next topic.
15:06:29 <bnemec> #topic Releases
15:06:39 <openstackgerrit> Merged openstack/futurist master: Switch to Ussuri jobs  https://review.opendev.org/689907
15:06:40 <openstackgerrit> Merged openstack/futurist master: Bump the openstackdocstheme extension to 1.20  https://review.opendev.org/688074
15:06:49 <bnemec> I didn't end up being able to do master releases last week because the ussuri deliverables weren't in the release repo yet.
15:07:41 <bnemec> I did check our queens branches in preparation for that release going to extended maintenance, but there was nothing that needed to be released.
15:09:04 <bnemec> No action items from last week, so we'll skip that topic.
15:09:22 <bnemec> #topic PTG/Summit
15:09:46 <bnemec> It's next week, so at this point I'm just trying to get all of my ducks in a row.
15:10:14 <bnemec> I sent out the project update slides to a number of people for review last week.
15:10:30 <bnemec> This week I'll be recording a version of the presentation since they aren't going to be recording the live one.
15:10:43 <bnemec> If you think of anything that should be included let me know ASAP.
15:11:51 <bnemec> I don't know how many people are going to be there, so I'm not sure how much discussion we'll actually get done at the PTG.
15:12:16 <bnemec> I know Keystone is doing a virtual PTG for the same reason, so maybe we should think about doing the same.
15:12:57 <bnemec> We'll see how much gets accomplished in Shanghai, and then maybe afterward we can schedule something.
15:13:18 <bnemec> On a related note:
15:13:18 <bnemec> #topic No meeting next week
15:13:36 <bnemec> Since I and a lot of other folks will be in Shanghai next week, we won't have a meeting.
15:13:42 <bnemec> I'm sure you're all heartbroken. :-)
15:14:34 <bnemec> That's it for topics this week.
15:14:42 <bnemec> #topic Weekly Wayward Review
15:14:50 <bnemec> #link https://review.opendev.org/#/c/675373/
15:15:09 <bnemec> I foolishly ran a backup job on the VM that hosts my stats page, so I'm working off old data here.
15:15:27 <bnemec> This is a trivial patch that we should be able to merge.
15:15:46 <bnemec> kgiusti: I guess you're the only oslo core here this week, if you wouldn't mind doing the honors.
15:16:05 <kgiusti> bnemec: I'd be happy to...
15:16:23 <bnemec> Thanks!
15:17:02 <bnemec> #topic Open discussion
15:17:15 <bnemec> That's it for the regular agenda. Anything else before we make this a short meeting?
15:17:43 <kgiusti> yep - messaging centric:
15:17:52 <kgiusti> https://review.opendev.org/#/q/topic:nats-python+(status:open+OR+status:merged)
15:18:08 <bnemec> Ah, I saw those.
15:18:11 <kgiusti> Akira is proposing a new driver - one based on NATS
15:18:20 <kgiusti> Thoughts?
15:18:29 <bnemec> What are the odds that we can maintain another driver at this point?
15:18:43 <kgiusti> Realistically - unlikely.
15:19:10 <kgiusti> Unless Akira is willing to follow the guidance we've set up awhile ago
15:19:42 <kgiusti> Where they're commited to supporting it (and there are at least 2 active devs doing so)
15:19:42 <bnemec> That was kind of my thought as well.
15:20:24 <kgiusti> In any case we've done these things via feature branches - not on mainline
15:20:41 <bnemec> At this point I think basically our entire messaging team has been pulled off to work on other things, so we don't have a lot of spare capacity in that area.
15:21:42 <kgiusti> right - I can reach out to Akira and discuss this further.
15:22:05 <bnemec> Okay, that sounds like the way to go.
15:22:14 <kgiusti> I was just wondering what was the driver of this effort - if anyone on the team was aware of the backstory.
15:22:30 <openstackgerrit> Merged openstack/sphinx-feature-classification master: Remove pypy from default env list  https://review.opendev.org/675373
15:23:36 <kgiusti> Ah - Akira72 are you working on the NATS driver?
15:23:45 <bnemec> Fortuitous timing. :-)
15:25:44 <openstackgerrit> Merged openstack/oslo.concurrency master: Switch to Ussuri jobs  https://review.opendev.org/690841
15:25:58 <kgiusti> I can follow up in the review otherwise
15:26:17 <kgiusti> Akira7216: ping
15:26:53 <Akira7216> hi, all
15:27:01 <bnemec> o/ Akira7216
15:27:10 <kgiusti> Hi Akira7216
15:27:19 <Akira7216> Sorry, i just joined now.
15:27:41 <kgiusti> We were discussing the proposed NATS driver: prohttps://review.opendev.org/#/q/topic:nats-python+(status:open+OR+status:merged)
15:27:56 <Akira7216> yes, I'm developing it.
15:28:08 <openstackgerrit> Merged openstack/oslo.rootwrap master: Bump the openstackdocstheme extension to 1.20  https://review.opendev.org/688244
15:28:23 <kgiusti> Can you give us a little background on the use-case?
15:28:46 <Akira7216> ok.
15:29:55 <Akira7216> At Japanese OpenStack Opsworkshop, we discussed RabbitMQ ops.
15:30:38 <Akira7216> One of the major problems is clustering.
15:31:56 <Akira7216> A member said that the best practice is non clustering.
15:33:16 <Akira7216> So, I've tried to create a new driver. for oslo.messaging.
15:34:02 <Akira7216> It works fine with nov and cinder.
15:34:49 <kgiusti> Akira7216: is this driver an alternative to RabbitMQ?
15:35:23 <Akira7216> Yes. It works with NATS messaging system.
15:35:43 <kgiusti> Akira7216: understood.
15:35:53 <Akira7216> No need to use RabbitMQ.
15:36:34 <kgiusti> Akira7216: In general there's a lot of work to get a new driver accepted upstream
15:36:47 <kgiusti> Akira7216: and most of that work is support.
15:37:06 <Akira7216> yes, I know.
15:37:45 <kgiusti> Akira7216: so the team has a policy to ensure there are folks who can fill the additional support needs: https://docs.openstack.org/oslo.messaging/latest/contributor/supported-messaging-drivers.html#policy
15:38:39 <Akira7216> Yes.
15:39:21 <kgiusti> Akira7216: So before a driver can be upstreamed there has to be a blueprint describing the intent and need for the new driver
15:39:51 <kgiusti> Akira7216: the blueprint is the first step.
15:40:18 <Akira7216> Sorry, I just started writing it.
15:41:03 <bnemec> Akira7216: Do you think you will be able to meet the requirements kgiusti linked?
15:41:04 <kgiusti> Akira7216: no worries - I didn't want you to get too far along with the implementation before the team can consider all the other factors involved.
15:41:56 <kgiusti> Akira7216: to be honest the oslo.messaging team is pretty bare boned at this point - keeping up with the existing drivers keeps the team pretty busy.
15:44:36 <bnemec> kgiusti: Do we have a spec template for new drivers or is this freeform?
15:45:17 <kgiusti> bnemec: we should use one of the existing blueprints as an example - maybe Kafka
15:46:06 <kgiusti> Akira7216: I'll follow up on your code review with more detail
15:46:10 <bnemec> kgiusti: Sounds good. Can you send a link to Akira7216?
15:46:14 <bnemec> Perfect, thanks.
15:46:32 <bnemec> #action kgiusti to followup with Akira7216 about NATS driver for oslo.messaging
15:47:53 <Akira7216> Thank you. I'll fill the spec and put it by the next week
15:48:07 <bnemec> Akira7216: Great, thanks!
15:48:28 <bnemec> One other thing I want to mention that I forgot to cover earlier: Please don't merge any py27 removal patches in Oslo yet.
15:48:39 <bnemec> I see some have been proposed, but we can't stop gating on py27 until everyone else does.
15:49:00 <bnemec> This is going to need to be carefully coordinated so we don't break consumers of Oslo.
15:49:15 <bnemec> I'll send an email to the list as well since most of our cores aren't here to see this.
15:49:28 <bnemec> #action Oslo cores to NOT merge py27 removal patches yet
15:49:43 <bnemec> #action bnemec send email to list about py27 plan for Oslo
15:50:09 <bnemec> Okay, this ended up being a much longer meeting than I expected. :-)
15:50:14 <bnemec> Anything else before we close?
15:53:24 <bnemec> Alright, thanks for joining, everyone who is still here! :-)
15:53:27 <bnemec> #endmeeting